maxima-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. # -*- mode: rpm-spec -*-
  2. # By default, this spec file will generate RPMs for Clisp and SBCL.
  3. # This can be changed by modifying the variables below.
  4. %define enable_clisp 0
  5. %define enable_sbcl 1
  6. # Inhibit automatic compressing of info files. Compressed info
  7. # files break maxima's internal help.
  8. %define __spec_install_post /bin/true
  9. Summary: Maxima Symbolic Computation Program
  10. Summary(ja): 数式処理プログラム Maxima
  11. Name: maxima
  12. Version: 5.42.2
  13. Release: 1%{?_dist_release}
  14. License: GPL
  15. Group: Applications/Engineering
  16. URL: http://maxima.sourceforge.net
  17. Source0: %{name}-%{version}.tar.gz
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. # Requires: maxima_exec = %{version}-%{release}
  20. %if %{enable_clisp}
  21. BuildRequires: clisp
  22. Requires: clisp
  23. %endif
  24. %if %{enable_sbcl}
  25. BuildRequires: sbcl
  26. Requires: sbcl
  27. %endif
  28. BuildRequires: texinfo
  29. Requires(post): /sbin/install-info
  30. Requires(preun): /sbin/install-info
  31. Obsoletes: %{name}-exec-clisp
  32. Obsoletes: %{name}-exec-sbcl
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. Maxima is a full symbolic computation program. It is full featured
  37. doing symbolic manipulation of polynomials, matrices, rational
  38. functions, integration, Todd-coxeter, graphing, bigfloats. It has a
  39. symbolic debugger source level debugger for maxima code. Maxima is
  40. based on the original Macsyma developed at MIT in the 1970's. It is
  41. quite reliable, and has good garbage collection, and no memory leaks.
  42. It comes with hundreds of self tests.
  43. #'
  44. %description -l ja
  45. Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
  46. 有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
  47. も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
  48. ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
  49. Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
  50. ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
  51. 信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
  52. %if %{enable_sbcl}
  53. SBCLではコマンドライン履歴を使用することができません。
  54. コマンドライン履歴を使用する場合には rlwrap パッケージを
  55. インストールして、
  56. rlwrap maxima
  57. のように起動して下さい。
  58. %endif
  59. %package xmaxima
  60. Summary: Tcl/Tk interface to Maxima
  61. Summary(ja): Maxima 用 Tcl/Tk インターフェース
  62. Group: Applications/Engineering
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: tk > 8.1
  65. Provides: xmaxima
  66. %description xmaxima
  67. Tcl/Tk interface to Maxima.
  68. %prep
  69. %setup -q
  70. %{configure} \
  71. %if %{enable_clisp}
  72. --enable-clisp \
  73. %endif
  74. %if %{enable_sbcl}
  75. --enable-sbcl \
  76. %endif
  77. ;
  78. %build
  79. %{__make} %{?_smp_mflags}
  80. %install
  81. %{__rm} -rf %{buildroot}
  82. %{makeinstall}
  83. %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
  84. %post
  85. /sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
  86. %preun
  87. if [ "$1" = 0 ]; then
  88. /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
  89. fi
  90. %clean
  91. %{__rm} -rf %{buildroot}
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
  95. %{_bindir}/maxima
  96. %{_bindir}/rmaxima
  97. %dir %{_libdir}/maxima/%{version}
  98. %if %{enable_clisp}
  99. %{_libdir}/maxima/%{version}/binary-clisp
  100. %endif
  101. %if %{enable_sbcl}
  102. %{_libdir}/maxima/%{version}/binary-sbcl
  103. %endif
  104. %{_libexecdir}/maxima/%{version}
  105. %{_datadir}/applications/xmaxima.desktop
  106. %{_datadir}/bash-completion/completions/*
  107. %{_datadir}/pixmaps/*
  108. %{_datadir}/maxima/%{version}
  109. %{_datadir}/mime/packages/*
  110. %{_mandir}/man1/*
  111. %{_infodir}/*
  112. %files xmaxima
  113. %{_bindir}/xmaxima
  114. %changelog
  115. * Tue Jan 29 2019 Toshiaki Ara <ara_t@384.jp> 5.42.2-1
  116. - new upstream release
  117. * Thu Dec 06 2018 Toshiaki Ara <ara_t@384.jp> 5.42.1-1
  118. - new upstream release
  119. * Fri Jun 01 2018 Toshiaki Ara <ara_t@384.jp> 5.41.0-2
  120. - rebuild with sbcl-1.4.8
  121. * Wed Nov 01 2017 Toshiaki Ara <ara_t@384.jp> 5.41.0-1
  122. - new upstream release
  123. * Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-2
  124. - delete maxima-exec-{clisp,sbcl} subpackages
  125. - add Vendor and Distribution
  126. * Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-1
  127. - New upstream release
  128. - add build option (SBCL)
  129. - delete build options (GCL and CMUCL)
  130. * Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
  131. - update to 5.36.1
  132. - add BuildRequires: texinfo
  133. * Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
  134. - rebuild with Vine6 environment
  135. * Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
  136. - rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
  137. * Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
  138. - new upstream release
  139. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
  140. - applied new versioning policy, spec in utf-8
  141. * Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
  142. - New upstream release
  143. - Change Group
  144. * Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
  145. - Japanese Summary and description by rpmSpecTranslate project
  146. * Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
  147. - New upstream release (for diff() bug fix)
  148. - Tidy up spec file
  149. * Sun Feb 1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
  150. - Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
  151. * Sat Aug 2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
  152. - Add exec-clisp BuildPreReq clisp
  153. - Add xmaxima Requires tk > 8.1
  154. - Remove xmaxima-olderTcl patch
  155. * Fri Jun 6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
  156. - Rebuild for clisp-2.29-0vl1
  157. * Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
  158. - Enable clisp only, disable cmucl and gcl
  159. - Add xmaxima-olderTcl patch (for tclversion older than 8.1)
  160. - Remove %{_infodir}/dir file
  161. * Sat Jan 4 2003 James Amundson <amundson@fnal.gov>
  162. - Added doc files
  163. - Added explicit clisp version
  164. - Added conditional to postun
  165. - Renamed exec_* packages to exec-*
  166. - Use rpm macros instead of hard-coded paths
  167. - Thanks to Rex Dieter for helpful suggestions
  168. * Sun Sep 8 2002 James Amundson <amundson@fnal.gov>
  169. - Initial build.