faac-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198
  1. %define name faac
  2. %define version 1.28
  3. %define release 9%{?_dist_release}
  4. %define enable_libmp4v2_external 1
  5. Summary: Reference encoder and encoding library for MPEG2/4 AAC
  6. Summary(ja): MPEG2/4 AAC 用のリファレンスエンコーダ及びエンコードライブラリ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
  11. Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
  12. ## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
  13. Patch1: mp4v2-strcasestr-vine.diff
  14. ## this patch is based on http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=64908ea587e0ad04fb69e452446f6e13d2c664f3
  15. Patch2: mp4v2-2.0.0.patch
  16. License: LGPLv2+
  17. Group: Applications/Multimedia
  18. URL: http://www.audiocoding.com/
  19. BuildRequires: nkf
  20. BuildRequires: autoconf, automake, libtool, gcc-c++
  21. %if %{enable_libmp4v2_external}
  22. BuildRequires: libmp4v2-devel
  23. %endif
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. %description
  26. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  27. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  28. multichannel and gapless encoding.
  29. %description -l ja
  30. FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP, Main/Low Complexity object types, Main/LOW MPEG-2 object types をサポートしています.またマルチチャンネルやギャップレスエンコーディングもサポートしています.
  31. %package devel
  32. Summary: Development libraries of the FAAC AAC encoder
  33. Summary(ja): FAAC AAC エンコーダの開発用ライブラリ
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}
  36. %description devel
  37. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  38. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  39. multichannel and gapless encoding.
  40. This package contains development files and documentation for libfaac.
  41. %if !%{enable_libmp4v2_external}
  42. %package -n libmp4v2
  43. Summary: Library for working with files using the mp4 container format
  44. Group: System Environment/Libraries
  45. %description -n libmp4v2
  46. The libmp4v2 library provides an abstraction layer for working with files
  47. using the mp4 container format. This library is developed by mpeg4ip project
  48. and is an exact copy of the library distributed in the mpeg4ip package.
  49. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  50. %package -n libmp4v2-devel
  51. Summary: Development files for the mp4v2 library
  52. Group: Development/Libraries
  53. Requires: libmp4v2 = %{version}-%{release}
  54. %description -n libmp4v2-devel
  55. The libmp4v2 library provides an abstraction layer for working with files
  56. using the mp4 container format. This library is developed by mpeg4ip project
  57. and is an exact copy of the library distributed in the mpeg4ip package.
  58. This package contains development files for libmp4v2.
  59. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  60. %endif
  61. %prep
  62. %setup -q
  63. #find . -type f -print|xargs nkf --unix --overwrite
  64. %if %{enable_libmp4v2_external}
  65. %patch0 -p1 -b .mp4v2
  66. %patch1 -p1 -b .strcasestr
  67. %patch2 -p0 -b .mp4v2-2.0.0
  68. #touch -r configure.in.mp4v2 configure.in
  69. %endif
  70. # # avoid to append the string "2005-02-02" to the tag Requires:
  71. # chmod 644 ChangeLog
  72. # # modify configure.in to escape error
  73. # %__mv configure.in configure.in.org
  74. # %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
  75. %build
  76. sh bootstrap
  77. %configure \
  78. --disable-static \
  79. %if !%{enable_libmp4v2_external}
  80. --with-mp4v2
  81. %endif
  82. %{__make} %{?_smp_mflags}
  83. %install
  84. %{__rm} -rf %{buildroot}
  85. %{__make} install DESTDIR=%{buildroot}
  86. %clean
  87. %{__rm} -rf %{buildroot}
  88. %post
  89. /sbin/ldconfig 2>/dev/null
  90. %postun
  91. /sbin/ldconfig 2>/dev/null
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
  95. %{_bindir}/*
  96. %{_libdir}/*.so.*
  97. %{_mandir}/man1/%{name}*
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %exclude %{_libdir}/*.la
  101. %{_libdir}/*.so
  102. %{_includedir}/*.h
  103. %if !%{enable_libmp4v2_external}
  104. %files -n libmp4v2
  105. %defattr(-,root,root,-)
  106. %{_libdir}/libmp4v2.so.*
  107. %files -n libmp4v2-devel
  108. %defattr(-,root,root,-)
  109. %{_libdir}/libmp4v2.so
  110. %{_libdir}/libmp4v2.a
  111. %endif
  112. %changelog
  113. * Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-9
  114. - added Patch2 for building with libmp4v2 2.0.0
  115. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
  116. - s/self-build-libmp4v2/libmp4v2/
  117. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
  118. - change release to sync with self-build-faac
  119. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
  120. - applied mp4v2-strcasestr.diff from lauchpad
  121. - fixed wrong declaration of strcasestr() in mpeg4ip.h
  122. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
  123. - rebuilt with mp4v2 v1.9.1
  124. - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
  125. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
  126. - change release to sync with self-build-faac
  127. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
  128. - added BuildRequires: nkf
  129. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
  130. - change release to sync with self-build-faac
  131. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
  132. - new upstream release
  133. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
  134. - fixed Summary: , %%description
  135. - removed internal mp4v2
  136. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
  137. - new upstream release
  138. - added --disable-static in %%configure
  139. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
  140. - spec in utf8
  141. - remove *.la
  142. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
  143. - apply new versioning policy
  144. * Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
  145. - initial build
  146. ### end of file