self-build-faac-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %define pkgname faac
  2. %define name self-build-%{pkgname}
  3. %define version 1.28
  4. %define release 9%{?_dist_release}
  5. %define enable_libmp4v2_external 1
  6. %define sourceurl0 http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source10: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
  14. Source11: mp4v2-strcasestr-vine.diff
  15. Source12: mp4v2-2.0.0.patch
  16. License: LGPLv2+
  17. Group: Restricted Software
  18. Requires(post): self-build-setup >= 0.9.9
  19. # (build)requies of target package.
  20. Requires(post): nkf
  21. Requires(post): autoconf, automake, libtool, gcc-c++
  22. %if %{enable_libmp4v2_external}
  23. Requires(post): libmp4v2-devel
  24. %endif
  25. BuildArch: noarch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. Packager: munepi
  28. %description
  29. FAAC is an AAC audio encoder. It currently supports MPEG-4
  30. LTP, MAIN and LOW COMPLEXITY object types and MAIN and LOW
  31. MPEG-2 object types. It also supports multichannel and
  32. gapless encoding.
  33. %if !%{enable_libmp4v2_external}
  34. The libmp4v2 library provides an abstraction layer for
  35. working with files using the mp4 container format. This
  36. library is developed by mpeg4ip project and is an exact copy
  37. of the library distributed in the mpeg4ip package.
  38. %endif
  39. If you install this package, it automatically downloads
  40. source code, compile it, and create
  41. rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
  42. And the created rpm packages are automatically installed
  43. if installation is executed by apt-get command or synaptic
  44. package manager.
  45. [Note]
  46. This package requires many other packages to compile
  47. targetsoftware. So it consume more disk space than usual.
  48. Also installation takes logner time because of compilation.
  49. (This will take a few minutes to quarter or half of an hour,
  50. depends on building environment)
  51. [About self-build package]
  52. For some kind of software, distributing of binary package
  53. may viorate the patent or law. Therefore we chose self-build
  54. packge, create binary package on your machine, for such kind
  55. of softwares instead of distributing binary package.
  56. Please obey the national law when you use the created binary
  57. packages. And if you want to use the softwares using patented
  58. thechnology, it may be required to get a permission, make an
  59. agreement or purchas a license. Please consider it with your
  60. purpose or way of use and take appropriate action.
  61. %description -l ja
  62. FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP,
  63. Main/Low Complexity object types, Main/LOW MPEG-2 object
  64. types をサポートしています.またマルチチャンネルやギャップ
  65. レスエンコーディングもサポートしています.
  66. %if !%{enable_libmp4v2_external}
  67. libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
  68. ルで動作するものに対して抽象レイヤーを提供します.このライブ
  69. ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
  70. ケージに分散されているライブラリの完全なコピーです.
  71. %endif
  72. このパッケージをインストールすると、自動的にソースコードを
  73. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  74. と libmp4v2-%{version} の rpm パッケージを作成します。
  75. また apt-get コマンドや synaptic パッケージマネージャから実行
  76. した場合は、作成された rpm パッケージのインストールも自動的に
  77. 行います。
  78. [注意]
  79. コンパイルに必要な多くの関連パッケージを要求するので通常より
  80. ディスクの領域を多く消費します。
  81. またインストール時にコンパイルを行うため、通常より時間がかか
  82. る場合があります。(環境にもよりますが数分から数十分程度)
  83. [self-build パッケージについて]
  84. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  85. 違反する可能性があるものがあります。その為、このような問題が
  86. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  87. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  88. ジという方法を採っています。
  89. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  90. アのライセンス、および利用する国の各種法令に従ってください。
  91. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  92. センスの購入などが必要となる場合がありますので、利用する目的
  93. や形態に応じて各自で判断し適切な対応を取ってください。
  94. %prep
  95. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  96. %install
  97. %{__rm} -rf ${RPM_BUILD_ROOT}
  98. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  99. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  100. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  101. %{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  102. %{__install} -m 644 %{SOURCE12} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  103. %clean
  104. %{__rm} -rf ${RPM_BUILD_ROOT}
  105. %posttrans
  106. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 25000
  107. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  108. %{pkgname}-devel-%{version}-%{release}
  109. %files
  110. %defattr(-,root,root)
  111. %{_datadir}/%{name}
  112. %changelog
  113. * Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-9
  114. - added Source12 for building with libmp4v2 2.0.0
  115. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
  116. - s/self-build-libmp4v2/libmp4v2/
  117. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
  118. - renamed %%{Source0} to faac-vl.spec
  119. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
  120. - applied mp4v2-strcasestr.diff from lauchpad
  121. - fixed wrong declaration of strcasestr() in mpeg4ip.h
  122. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
  123. - rebuilt with mp4v2 v1.9.1
  124. - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
  125. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
  126. - applied a progress bar to show approximately building time
  127. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
  128. - added Requires(post): nkf
  129. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
  130. - added BuildArch: noarch
  131. - avoided to execute self-build-rpm.sh on RPM transaction
  132. - moved %%post actions to %%posttrans
  133. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
  134. - new upstream release
  135. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
  136. - fixed Summary: , %%description
  137. - removed internal mp4v2
  138. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
  139. - new upstream release
  140. - added PreReq: self-build-libmp4v2
  141. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
  142. - spec in utf8
  143. - remove *.la
  144. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
  145. - run pre-allocate-rpm.sh in %%post
  146. - set PreReq: self-build-setup >= 0.8
  147. - apply new versioning policy
  148. * Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
  149. - initial build
  150. ### end of file