self-build-ffmpeg-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %global gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) ; \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
  5. /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
  6. %global x264_postinstall \
  7. x264_postinstall_sh=$(mktemp) ; \
  8. rpm -q --scripts self-build-x264 | \
  9. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
  10. /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
  11. %global pkgname ffmpeg
  12. %global name self-build-%{pkgname}
  13. %global major_version 2.8
  14. %global version %{major_version}.7
  15. #% define svndate 20110326
  16. %global release 3%{?svndate:.%svndate}%{?_dist_release}
  17. %global sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  18. %global with_faac 1
  19. %global with_vaapi 1
  20. %global with_libvpx 1
  21. #% define enable_avconv 1
  22. Summary: Package to automatically build %{pkgname} rpm package
  23. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  24. Name: %{name}
  25. Version: %{version}
  26. Release: %{release}
  27. Source0: %{pkgname}-vl.spec
  28. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  29. License: GPLv2+
  30. Group: Restricted Software
  31. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  32. Obsoletes: self-build-ffmpeg < %{version}
  33. Requires(post): self-build-setup >= 0.9.9
  34. #Requires(post): subversion
  35. # (build)requies of target package.
  36. Requires(post): bzip2-devel
  37. Requires(post): celt-devel
  38. ##Requires(post): dirac-devel
  39. Requires(post): freetype2-devel
  40. Requires(post): gnutls-devel
  41. Requires(post): gsm-devel
  42. Requires(post): imlib2-devel
  43. Requires(post): libdc1394-devel
  44. Requires(post): libogg-devel
  45. Requires(post): libass-devel
  46. %{!?_without_cdio:Requires(post): libcdio-devel}
  47. %{!?_without_cdio:Requires: libcdio-paranoia-devel}
  48. #libcrystalhd is currently broken
  49. %{?_with_crystalhd:Requires(post): libcrystalhd-devel}
  50. Requires(post): libraw1394-devel
  51. Requires(post): librtmp-devel >= 2.3
  52. Requires(post): libtheora-devel
  53. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  54. Requires(post): libvdpau-devel
  55. Requires(post): libvorbis-devel
  56. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.7}
  57. Requires(post): libXvMC-devel
  58. %{?_with_opencore_amr:Requires(post): opencore-amr-devel vo-amrwbenc-devel}
  59. %{!?_without_openal:Requires(post): openal-soft-devel}
  60. %{?_with_opencv:Requires(post): opencv-devel}
  61. %{?_with_openjpeg:Requires(post): openjpeg-devel}
  62. ##Requires(post): schroedinger-devel
  63. Requires(post): SDL-devel
  64. Requires(post): speex-devel
  65. ##Requires(post): texi2html
  66. Requires(post): zlib-devel
  67. Requires(post): libogg-devel
  68. Requires(post): yasm
  69. Requires(post): a52dec-devel
  70. Requires(post): lame-devel
  71. # Requires(post): self-build-a52dec
  72. Requires(post): self-build-faac
  73. Requires(post): self-build-faad2
  74. # Requires(post): self-build-lame
  75. Requires(post): self-build-libdca
  76. Requires(post): self-build-x264 >= 0.142
  77. Requires(post): self-build-x265 >= 1.4
  78. Requires(post): self-build-xvidcore
  79. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  80. BuildArch: noarch
  81. Packager: munepi
  82. %description
  83. FFMpeg is a complete and free Internet live audio and video
  84. broadcasting solution for Linux/Unix. It also includes a
  85. digital VCR. It can encode in real time in many formats
  86. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  87. real, mjpeg, and flash.
  88. If you install this package, it automaticaly downloads source
  89. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  90. And the created rpm packages are automatically installed
  91. if installation is executed by apt-get command or synaptic
  92. package manager.
  93. [Note]
  94. This package requires many other packages to compile
  95. target software. So it consume more disk space than usual.
  96. Also installation takes longer time because of compilation.
  97. (This will take a few minutes to quarter or half of an hour,
  98. depends on building environment)
  99. [About self-build package]
  100. For some kind of software, distributing of binary package
  101. may viorate the patent or law. Therefore we chose self-build
  102. packge, create binary package on your machine, for such kind
  103. of softwares instead of distributing binary package.
  104. Please obey the national law when you use the created binary
  105. packages. And if you want to use the softwares using patented
  106. thechnology, it may be required to get a permission, make an
  107. agreement or purchas a license. Please consider it with your
  108. purpose or way of use and take appropriate action.
  109. %description -l ja
  110. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  111. ブオーティオ・ビデオブロードキャスティングソリューションです.
  112. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  113. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  114. 多様なフォーマットをリアルタイムにエンコードすることができます.
  115. このパッケージをインストールすると、自動的にソースコードを
  116. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  117. の rpm パッケージを作成します。
  118. また apt-get コマンドや synaptic パッケージマネージャから実行
  119. した場合は、作成された rpm パッケージのインストールも自動的に
  120. 行います。
  121. [注意]
  122. コンパイルに必要な多くの関連パッケージを要求するので通常より
  123. ディスクの領域を多く消費します。
  124. またインストール時にコンパイルを行うため、通常より時間がかか
  125. る場合があります。(環境にもよりますが数分から数十分程度)
  126. [self-build パッケージについて]
  127. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  128. 違反する可能性があるものがあります。その為、このような問題が
  129. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  130. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  131. ジという方法を採っています。
  132. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  133. アのライセンス、および利用する国の各種法令に従ってください。
  134. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  135. センスの購入などが必要となる場合がありますので、利用する目的
  136. や形態に応じて各自で判断し適切な対応を取ってください。
  137. %prep
  138. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  139. %install
  140. %{__rm} -rf ${RPM_BUILD_ROOT}
  141. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  142. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  143. %clean
  144. %{__rm} -rf ${RPM_BUILD_ROOT}
  145. %posttrans
  146. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 93000
  147. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  148. %{pkgname}-libs-%{version}-%{release} \
  149. %{pkgname}-devel-%{version}-%{release}
  150. ## Rebuild gpac with ffmpeg-devel
  151. # set locale
  152. case $LANG in
  153. ja*)LOCALE=ja ;;
  154. *) LOCALE=C ;;
  155. esac
  156. Rebuild_gpac_C(){
  157. echo -n " "
  158. echo "Rebuild gpac with ffmpeg-devel"
  159. }
  160. Rebuild_gpac_ja(){
  161. echo -n " "
  162. echo "ffmpeg-devel で gpac をリビルドします。"
  163. }
  164. Rebuild_gpac_$LOCALE
  165. %{gpac_postinstall}
  166. ## Rebuild x264 with ffmpeg-devel
  167. # set locale
  168. case $LANG in
  169. ja*)LOCALE=ja ;;
  170. *) LOCALE=C ;;
  171. esac
  172. Rebuild_x264_C(){
  173. echo -n " "
  174. echo "Rebuild x264 with ffmpeg-devel"
  175. }
  176. Rebuild_x264_ja(){
  177. echo -n " "
  178. echo "ffmpeg-devel で x264 をリビルドします。"
  179. }
  180. Rebuild_x264_$LOCALE
  181. %{x264_postinstall}
  182. %files
  183. %defattr(-,root,root)
  184. %{_datadir}/%{name}
  185. %changelog
  186. * Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 2.8.6-3
  187. - change BR: self-build-{a52dec,lame} to {a52dec,lame}-devel
  188. * Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 2.8.6-2
  189. - rebuild
  190. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  191. - rebuild with libcdio-0.93
  192. * Mon Feb 15 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.6-1
  193. - new upstream release
  194. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.5-1
  195. - new upstream release
  196. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-2
  197. - rebuild with gnutils-3.4.7
  198. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.7.1-1
  199. - new upstream release
  200. * Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.3-1
  201. - new upstream release
  202. * Mon Apr 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.2-1
  203. - new upstream release
  204. * Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6.1-1
  205. - new upstream release
  206. * Mon Mar 9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.6-1
  207. - new upstream release
  208. * Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.4-1
  209. - new upstream release
  210. * Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.3-1
  211. - new upstream release
  212. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
  213. - new upstream release
  214. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-2
  215. - add BuildRequires: libcdio-paranoia-devel
  216. * Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  217. - new upstream release
  218. * Fri Oct 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
  219. - new upstream release
  220. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
  221. - new upstream release
  222. - added %%{x264_postinstall} in %%post
  223. * Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
  224. - new upstream release
  225. - added man pages
  226. - added Source10: ffmpeg-1.2.1-doc.tar.xz
  227. * Thu Apr 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  228. - new upstream release
  229. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  230. - new upstream release
  231. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  232. - libvpx >= 0.9.7
  233. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  234. - new upstream release /x264-0.129
  235. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  236. - new upstream release
  237. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  238. - new upstream release
  239. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  240. - new upstream release
  241. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  242. - new upstream release
  243. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  244. - new upstream release
  245. - enable CELT decoding via libcelt
  246. - enable FreeType support
  247. - drop faad2 support (dropped upstream)
  248. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  249. - added BuildArch: noarch
  250. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  251. - new upstream release
  252. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  253. - new upstream release
  254. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  255. - required latest x264 build
  256. - added BuildRequires: librtmp-devel >= 2.3
  257. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  258. - new upstream release
  259. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  260. - unpacked source archives
  261. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  262. - fixed some dependencies
  263. - Requires(post): libva-devel
  264. - Requires(post): libvpx-devel >= 0.9.1
  265. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  266. - new upstream release
  267. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  268. - bumped version to pre-0.6
  269. - updated source snapshot 20100410
  270. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  271. - fixed self-build log size
  272. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  273. - added ffprobe.1.gz
  274. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  275. - updated source snapshot 20100401
  276. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  277. - renamed %%{Source0} to ffmpeg-vl.spec
  278. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  279. - updated source snapshot 20100216
  280. - rebuild with recent x264-devel
  281. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  282. - added BuildRequires: libvdpau-devel
  283. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  284. - dropped BuildArch: noarch
  285. - added ffmpeg.1, ffplay.1, ffserver.1
  286. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  287. - avoided to execute self-build-rpm.sh on RPM transaction
  288. - moved %%post actions to %%posttrans
  289. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  290. - added BuildArch: noarch
  291. - added ffmpeg-0.5-disable-texi2html.patch
  292. - dropped PreReq: texi2html
  293. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  294. - added %%{gpac_postinstall} in %%post
  295. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  296. - corrected release number
  297. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  298. - new upstream release
  299. - added PreReq:
  300. - speex-devel
  301. - bzip2-devel
  302. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  303. - change release to sync with ffmpeg
  304. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  305. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  306. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  307. - 20090202 snapshot
  308. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  309. - 20090110 snapshot
  310. - dropped some patches
  311. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  312. - source updated (r15488)
  313. - fixed License: GPLv2+
  314. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  315. - added BuildRequires: yasm (only %%ix86)
  316. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  317. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  318. - spec in utf8
  319. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  320. - run pre-allocate-rpm.sh in %%post
  321. - set PreReq: self-build-setup >= 0.8
  322. - change release number
  323. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  324. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  325. include Source1 in the binary package.
  326. - drop "Source100: ffmpeg-vine.patch".
  327. - drop "PreReq: subversion".
  328. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  329. - build with new versioning policy
  330. - change to use svn export from svn checkout on post install
  331. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  332. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  333. - For all pre-required package that is provied by self-build,
  334. changed to its self-build package
  335. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  336. - initial build for Vine Linux 4.2
  337. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  338. ### end of file