gpac-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383
  1. #% global svndate 20111217
  2. %define with_static 1
  3. Name: gpac
  4. Summary: MPEG-4 multimedia framework
  5. Version: 0.8.0
  6. Release: 1%{?svndate:.svn%svndate}%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://gpac.sourceforge.net/
  10. Source0: https://github.com/gpac/gpac/archive/v%{version}.tar.gz
  11. #Source0: gpac-%{svndate}.tar.bz2
  12. #Source9: gpac-snapshot-vine.sh
  13. # Patch2: gpac-0.4.6-amr.patch
  14. Patch3: gpac-compatibility-openssl-1.1.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. Obsoletes: %{name} < %{version}, %{name}-libs < %{version}
  17. Obsoletes: %{name}-devel < %{version}
  18. Obsoletes: %{name}-devel-static < %{version}
  19. Requires: %{name}-libs = %{version}-%{release}
  20. BuildRequires: ImageMagick
  21. BuildRequires: SDL-devel
  22. BuildRequires: librsvg2-devel >= 2.5.0
  23. BuildRequires: libGLU-devel
  24. BuildRequires: freeglut-devel
  25. BuildRequires: freetype2-devel >= 2.1.4
  26. BuildRequires: libjpeg-devel
  27. BuildRequires: libpng-devel >= 1.2.5
  28. BuildRequires: libxml2-devel
  29. BuildRequires: openssl-devel
  30. #BuildRequires: openjpeg-devel
  31. BuildRequires: pulseaudio-libs-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: libogg-devel libvorbis-devel libtheora-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libXpm-devel
  36. BuildRequires: libXv-devel
  37. #BuildRequires: wxGTK-devel
  38. %{?_with_mozilla:BuildRequires: gecko-devel}
  39. #BuildRequires: doxygen
  40. BuildRequires: desktop-file-utils
  41. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  42. # *-devel packages provided by other self-build-* should only be listed
  43. # in self-build-%{name}.spec as PreReq.
  44. ##BuildRequires: a52dec-devel
  45. #BuildRequires: faad2-devel
  46. #BuildRequires: libmad-devel
  47. #BuildRequires: xvidcore-devel >= 1.0.0
  48. ##BuildRequires: ffmpeg-devel
  49. %description
  50. GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
  51. from scratch in ANSI C. The original development goal is to provide a clean,
  52. small and flexible alternative to the MPEG-4 Systems reference software.
  53. GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
  54. X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
  55. MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
  56. for MP4 and 3GPP(2) files and many tools for scene descriptions
  57. (MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
  58. %package libs
  59. Summary: Library for %{name}
  60. Group: System Environment/Libraries
  61. %description libs
  62. The %{name}-libs package contains library for %{name}.
  63. %package devel
  64. Summary: Development libraries and files for %{name}
  65. Group: Development/Libraries
  66. Requires: %{name}-libs = %{version}-%{release}
  67. %description devel
  68. Development libraries and files for gpac.
  69. %if %{with_static}
  70. %package devel-static
  71. Summary: Development libraries and files for %{name}
  72. Group: Development/Libraries
  73. Requires: %{name}-devel = %{version}-%{release}
  74. %description devel-static
  75. Static library for gpac.
  76. %endif
  77. %prep
  78. %setup -q
  79. ## remove extra_libs directory
  80. %__rm -rf extra_libs
  81. # %patch2 -p1 -b .amr
  82. # %patch3 -p1 -b .openssl-1.1
  83. ## kwizart - enable dynamic mode - hardcoded with patch2
  84. # define SONAME number from the first number of gpac version.
  85. #define soname libgpac.so.0
  86. #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
  87. # Fix encoding warnings
  88. %__cp -p Changelog Changelog.origine
  89. iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
  90. touch -r Changelog.origine Changelog
  91. %__rm -rf Changelog.origine
  92. %__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
  93. iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine > doc/ipmpx_syntax.bt
  94. touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
  95. %__rm -rf doc/ipmpx_syntax.bt.origine
  96. # executable ./configure
  97. chmod +x configure
  98. %build
  99. %configure \
  100. --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
  101. --X11-path=%{_prefix} \
  102. --libdir=%{_lib} \
  103. --disable-oss-audio \
  104. --disable-static \
  105. --use-js=no \
  106. \
  107. --disable-wx \
  108. ;
  109. #Avoid mess with setup.h
  110. %__cp -p config.h include/gpac
  111. # Parallele build will fail
  112. %__make all
  113. %__make sggen
  114. # ## kwizart - build doxygen doc for devel
  115. # pushd doc
  116. # doxygen
  117. # popd
  118. %install
  119. %__rm -rf $RPM_BUILD_ROOT
  120. %__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
  121. #Install generated sggen binaries
  122. #MPEG4 SVG X3D
  123. for b in MPEG4 X3D; do
  124. pushd applications/generators/${b}
  125. %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
  126. popd
  127. done
  128. #config.h like but not only
  129. #Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
  130. %__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
  131. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
  132. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
  133. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
  134. %__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
  135. rm -rf %{buildroot}%{_includedir}/win{32,ce}
  136. %clean
  137. %__rm -rf $RPM_BUILD_ROOT
  138. %post libs -p /sbin/ldconfig
  139. %postun libs -p /sbin/ldconfig
  140. %files
  141. %defattr(-,root,root,-)
  142. %doc AUTHORS BUGS Changelog COPYING README.md TODO
  143. %{_bindir}/MP4*
  144. %{_bindir}/*Gen
  145. %{_datadir}/gpac/
  146. %{_mandir}/man1/*.1.*
  147. %files libs
  148. %defattr(-,root,root)
  149. %{_libdir}/libgpac.so.*
  150. %{_libdir}/gpac/
  151. %files devel
  152. %doc doc/CODING_STYLE doc/ipmpx_syntax.bt
  153. %defattr(-,root,root)
  154. %{_includedir}/gpac/
  155. %{_libdir}/libgpac.so
  156. %if %{with_static}
  157. %files devel-static
  158. %defattr(-,root,root,-)
  159. %{_libdir}/libgpac_static.a
  160. %else
  161. %exclude %{_libdir}/libgpac_static.a
  162. %endif
  163. %changelog
  164. * Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 0.8.0-1
  165. - new upstream release
  166. - change BR: self-build-a52dec to a52dec-devel
  167. * Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 0.7.1-1
  168. - new upstream release
  169. - add Patch3 for compatibility with openssl-1.1
  170. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-4
  171. - rebuild
  172. * Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-3
  173. - rebuilt
  174. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
  175. - rebuilt
  176. * Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
  177. - new upstream release
  178. - remove Patch1 (gpac-0.5.0-libdir.patch)
  179. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
  180. - rebuilt
  181. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
  182. - remove BuildRequires: xmlrpc-epi-devel
  183. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
  184. - added Obsoletes: %{name} < %{version} and so on.
  185. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
  186. - rebuild
  187. * Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
  188. - new upstream release
  189. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
  190. - rebuild
  191. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
  192. - update snapshot svn20111217
  193. - removed upstreamed/obsolated patches
  194. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
  195. - rebuilt with internal openjpeg
  196. - added --use-openjpeg=local in configure options
  197. - added --enable-pic in configure options
  198. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
  199. - rebuild
  200. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
  201. - removed doxygen support
  202. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
  203. - change release to sync with self-build-gpac
  204. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
  205. - rebuild
  206. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
  207. - added --use-js=no in configure
  208. - added devel-static subpackage
  209. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
  210. - change release to sync with self-build-gpac
  211. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
  212. - change release to sync with self-build-gpac
  213. * Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
  214. - applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
  215. - corrected default %%defattr
  216. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
  217. - dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
  218. - rebuilt with ffmpeg-devel by self-build-ffmpeg
  219. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
  220. - initial build based on RPM Fusion
  221. - without Osmo4 and its plugins for Mozilla browsers
  222. - added --disable-wx in configure options
  223. - included %%{_libdir}/libgpac_static.a in devel subpackage
  224. * Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
  225. - Fix -devel doc timestamp which leads to multilib conflict
  226. ( RPM Fusion #270 )
  227. * Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
  228. - Fix for ppc64
  229. * Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
  230. - Update to 0.4.5 (final)
  231. - Drop upstreamed patches - Rewrite some
  232. - Add More BR.
  233. - Conditionalize --with mozilla amr
  234. * Mon Sep 8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
  235. - Fix for Large File Support (was livna #2075 )
  236. * Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
  237. - Enable devel-static
  238. - Conditionalize Osmo4 (buggy).
  239. - Clean the spec
  240. * Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
  241. - Update to 20080217.
  242. - Split libs.
  243. - Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
  244. - Add openjpeg-devel missing BR
  245. - Static patching instead of dyn patch when possible.
  246. - Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
  247. - Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
  248. - Exclude static lib
  249. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
  250. - Use %%{smp_mflags}
  251. - Oops, we're actually 0.4.5
  252. - Fix gpac so filenames
  253. - Only install nposmozilla when %%{with_firefox} is set
  254. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
  255. - Update to 20080211cvs
  256. - Disable osmozilla, doesn't build with xulrunner
  257. - Fix builds with gcc 4.3
  258. * Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
  259. - Rebuild for rawhide
  260. * Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
  261. - Update to v4.4
  262. * Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
  263. - Update to cvs 20070526
  264. - Enable conditional build ( 3gpp firefox )
  265. * Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
  266. - Update to cvs 20070411
  267. * Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
  268. - Update to 20061208
  269. - Uses firefox-devel (since fc6!)
  270. - Drop tutorial
  271. - Use version-DEV-date with libgpac.so
  272. - Disabled osmozilla
  273. - Fix soname
  274. - Enabled gprof
  275. * Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
  276. - gpac snapshot.sh
  277. - Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
  278. - TODO: - no-soname make option for libgpac.so
  279. - static lib in devel - needed ?
  280. - osmozilla - xpt link problem.
  281. - Osmo4: segmentation fault on exit.
  282. - MP4Client: segmentation fault on launch.
  283. - The program 'Osmo4' received an X Window System error:
  284. "The error was 'BadMatch (invalid parameter attributes)'.
  285. (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
  286. - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
  287. * Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
  288. - Update to 0.4.2cvs20061017
  289. - Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
  290. - Enable mozilla plugin: osmozilla.
  291. - Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
  292. - Provide documentation html in doc .
  293. - Provide tutorial from http://www.wildamerica.com/pages/Marty.html
  294. - Various corrections.
  295. * Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
  296. - lib64 fixes
  297. * Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
  298. - initial package