self-build-gstreamer1-plugins-ugly-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. %define pkgname gstreamer1-plugins-ugly
  2. %define major 1.0
  3. %define _gst_ver 1.8.2
  4. %define _gstpb_ver 1.8.2
  5. %define version 1.8.2
  6. %define release 2%{?_dist_release}
  7. %define sourceurl http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
  8. Summary: Package to automatically build %{pkgname} rpm package
  9. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  10. Name: self-build-%{pkgname}
  11. Version: %{version}
  12. Release: %{release}
  13. Source0: %{pkgname}-vl.spec
  14. License: LGPLv2+
  15. Group: Restricted Software
  16. Requires(post): self-build-setup >= 0.9.9
  17. # (build)requies of target package.
  18. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  19. Requires(post): gstreamer1-devel >= %{_gst_ver}
  20. Requires(post): gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  21. #Requires(post): gtk-doc >= 1.3
  22. Requires(post): python >= 2.1, python-pyxml
  23. Requires(post): glib2-devel >= 2.6
  24. Requires(post): twolame-devel
  25. Requires(post): liboil-devel >= 0.3.0
  26. Requires(post): libcdio-devel >= 0.82
  27. Requires(post): libdvdread-devel
  28. Requires(post): PyXML
  29. Requires(post): self-build-libmad >= 0.15
  30. Requires(post): libid3tag-devel >= 0.15
  31. Requires(post): libmpeg2-devel
  32. Requires(post): a52dec-devel
  33. Requires(post): lame-devel
  34. Requires(post): self-build-ffmpeg
  35. Requires(post): self-build-x264
  36. Requires(post): self-build-libmad
  37. Obsoletes: gstreamer1-plugins-ugly < %{version}-%{release}
  38. BuildArch: noarch
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  40. Packager: Takemikaduchi
  41. %description
  42. gstreamer1-plugins-ugly is a set of ugly plugins for Gstreamer
  43. streaming-media framework.
  44. If you install this package, it automaticaly downloads source
  45. code, compile it, and create rpm packages of
  46. %{pkgname}-%{version}.
  47. And the created rpm packages are automatically installed
  48. if installation is executed by apt-get command or synaptic
  49. package manager.
  50. [Note]
  51. This package requires many other packages to compile
  52. targetsoftware. So it consume more disk space than usual.
  53. Also installation takes logner time because of compilation.
  54. (This will take a few minutes to quarter or half of an hour,
  55. depends on building environment)
  56. [About self-build package]
  57. For some kind of software, distributing of binary package
  58. may viorate the patent or law. Therefore we chose self-build
  59. packge, create binary package on your machine, for such kind
  60. of softwares instead of distributing binary package.
  61. Please obey the national law when you use the created binary
  62. packages. And if you want to use the softwares using patented
  63. thechnology, it may be required to get a permission, make an
  64. agreement or purchas a license. Please consider it with your
  65. purpose or way of use and take appropriate action.
  66. %description -l ja
  67. gstreamer1-plugins-ugly は GStreamer ストリーミングメディア
  68. フレームワーク用 ugly プラグイン集です。
  69. このパッケージをインストールすると、自動的にソースコードを
  70. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  71. の rpm パッケージを作成します。
  72. また apt-get コマンドや synaptic パッケージマネージャから実行
  73. した場合は、作成された rpm パッケージのインストールも自動的に
  74. 行います。
  75. [注意]
  76. コンパイルに必要な多くの関連パッケージを要求するので通常より
  77. ディスクの領域を多く消費します。
  78. またインストール時にコンパイルを行うため、通常より時間がかか
  79. る場合があります。(環境にもよりますが数分から数十分程度)
  80. [self-build パッケージについて]
  81. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  82. 違反する可能性があるものがあります。その為、このような問題が
  83. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  84. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  85. ジという方法を採っています。
  86. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  87. アのライセンス、および利用する国の各種法令に従ってください。
  88. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  89. センスの購入などが必要となる場合がありますので、利用する目的
  90. や形態に応じて各自で判断し適切な対応を取ってください。
  91. %prep
  92. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  93. %install
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %clean
  98. %{__rm} -rf ${RPM_BUILD_ROOT}
  99. %posttrans
  100. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
  101. %files
  102. %defattr(-,root,root)
  103. %{_datadir}/%{name}
  104. %changelog
  105. * Thu Oct 10 2019 Toshiaki Ara <ara_t@384.jp> 1.8.2-2
  106. - change BR: self-build-{a52dec,lame,libmpeg2} to {a52dec,lame,libmpeg2}-devel
  107. * Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  108. - new upstream release
  109. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
  110. - rebuild with libcdio-0.93
  111. * Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  112. - new upstream release
  113. * Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
  114. - new upstream release
  115. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  116. - new upstream release
  117. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  118. - new upstream release
  119. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
  120. - new upstream release
  121. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
  122. - new upstream release
  123. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  124. - new upstream release
  125. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
  126. - rebuild with libcdio-0.92
  127. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  128. - new upstream release
  129. * Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  130. - new upstream release
  131. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  132. - new upstream release
  133. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  134. - new upstream release
  135. * Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  136. - new upstream release
  137. * Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  138. - new upstream release
  139. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
  140. - new upstream release
  141. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  142. - new upstream release
  143. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  144. - new upstream release
  145. * Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  146. - new upstream release
  147. * Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  148. - new upstream release
  149. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  150. - new upstream release
  151. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  152. - new upstream release
  153. - rename package
  154. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
  155. - new upstream relase
  156. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
  157. - new upstream relase
  158. - built with new x264
  159. - License: LGPLv2+
  160. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  161. - new upstream relase
  162. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  163. - new upstream relase
  164. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  165. - new upstream relase
  166. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  167. - new upstream relase
  168. - renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
  169. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  170. - new upstream relase
  171. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  172. - new upstream relase
  173. - added Requires(post): self-build-libmpeg2
  174. - enable mpeg2dec with libmpeg2-devel in %%configure
  175. - check version between original spec and self-build spec in %%prep
  176. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  177. - avoided to execute self-build-rpm.sh on RPM transaction
  178. - moved %%post actions to %%posttrans
  179. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  180. - added BuildArch: noarch
  181. - dropped PreReq: gtk-doc >= 1.3
  182. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  183. - new upstream relase
  184. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  185. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  186. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  187. - new upstream relase
  188. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  189. - initial build for Vine Linux.