self-build-lame-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. %define pkgname lame
  2. %define name self-build-%{pkgname}
  3. %define version 3.99.5
  4. %define release 2%{?_dist_release}
  5. #% define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
  6. %define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source101: lame-noexecstack.patch
  14. Source110: lame-3.99-libs-termcap.patch
  15. License: GPLv2+
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 1.0.0
  18. # (build)requies of target package.
  19. %{?enable_brhist:Requires(post): ncurses}
  20. %{?enable_brhist:Requires(post): ncurses-devel}
  21. Requires(post): gtk+
  22. Requires(post): gtk+-devel
  23. Requires(post): nasm
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. Lame is an open source developing mp3 encoder.
  29. If you install this package, it automaticaly downloads source
  30. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  31. And the created rpm packages are automatically installed
  32. if installation is executed by apt-get command or synaptic
  33. package manager.
  34. [Note]
  35. This package requires many other packages to compile
  36. targetsoftware. So it consume more disk space than usual.
  37. Also installation takes logner time because of compilation.
  38. (This will take a few minutes to quarter or half of an hour,
  39. depends on building environment)
  40. [About self-build package]
  41. For some kind of software, distributing of binary package
  42. may viorate the patent or law. Therefore we chose self-build
  43. packge, create binary package on your machine, for such kind
  44. of softwares instead of distributing binary package.
  45. Please obey the national law when you use the created binary
  46. packages. And if you want to use the softwares using patented
  47. thechnology, it may be required to get a permission, make an
  48. agreement or purchas a license. Please consider it with your
  49. purpose or way of use and take appropriate action.
  50. %description -l ja
  51. lame はオープンソースで開発されている mp3 エンコーダです。
  52. このパッケージをインストールすると、自動的にソースコードを
  53. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  54. パッケージを作成します。
  55. また apt-get コマンドや synaptic パッケージマネージャから実行
  56. した場合は、作成された rpm パッケージのインストールも自動的に
  57. 行います。
  58. [注意]
  59. コンパイルに必要な多くの関連パッケージを要求するので通常より
  60. ディスクの領域を多く消費します。
  61. またインストール時にコンパイルを行うため、通常より時間がかか
  62. る場合があります。(環境にもよりますが数分から数十分程度)
  63. [self-build パッケージについて]
  64. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  65. 違反する可能性があるものがあります。その為、このような問題が
  66. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  67. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  68. ジという方法を採っています。
  69. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  70. アのライセンス、および利用する国の各種法令に従ってください。
  71. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  72. センスの購入などが必要となる場合がありますので、利用する目的
  73. や形態に応じて各自で判断し適切な対応を取ってください。
  74. %prep
  75. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  76. %install
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %{__install} -m 644 %{SOURCE101} %{SOURCE110} \
  81. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %posttrans
  85. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 61000
  86. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  87. %{pkgname}-mp3x-%{version}-%{release} \
  88. %{pkgname}-devel-%{version}-%{release}
  89. %files
  90. %defattr(-,root,root)
  91. %{_datadir}/%{name}
  92. %changelog
  93. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.99.5-2
  94. - fix lame-vl.spec for i686
  95. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.99.5
  96. - new upstream release
  97. * Sun Sep 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.4-2
  98. - added BuildArch: noarch
  99. - disable the VBR bitrate histgrum feature
  100. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.4-1
  101. - new upstream release
  102. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.3-1
  103. - new upstream release
  104. - renamed %%{Source0} to lame-vl.spec
  105. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-2
  106. - rebuilt to add signature
  107. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-1
  108. - new upstream release
  109. * Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-5
  110. - dropped BuildArch: noarch
  111. (because if BuildArch: noarch, %%ifarch is invalid)
  112. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-4
  113. - added BuildArch: noarch
  114. - avoided to execute self-build-rpm.sh on RPM transaction
  115. - moved %%post actions to %%posttrans
  116. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-3
  117. - spec in utf8
  118. - remove *.la
  119. * Wed May 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-2
  120. - change %%{__make} option to -j1 in Source0 <BTS:VineLinux:611>
  121. - remove trailing /* in %%files <BTS:VineLinux:622>
  122. * Sat May 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-1
  123. - run pre-allocate-rpm.sh in %%post
  124. - set PreReq: self-build-setup >= 0.8
  125. - apply new versioning policy
  126. * Thu Nov 01 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl3
  127. - update description about self-build package
  128. * Mon Oct 22 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl2
  129. - unset BuildArch: noarch
  130. * Thu Oct 18 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl1
  131. - initial build for Vine Linux
  132. (using same version number of target software)