mjpegtools-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. # -*- coding: utf-8-unix -*-
  2. Name: mjpegtools
  3. Version: 2.1.0
  4. Release: 1%{?_dist_release}
  5. Summary: Tools to manipulate MPEG data
  6. Summary(ja): MPEG データを操作するツール集
  7. Group: Applications/Multimedia
  8. License: GPLv2
  9. URL: http://mjpeg.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
  11. Patch0: mjpegtools-2.1.0-sdl-cflags.patch
  12. Patch1: mjpegtools-2.1.0-no_format.patch
  13. Patch2: mjpegtools-2.1.0-pic.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
  16. BuildRequires: libjpeg-devel
  17. BuildRequires: nasm
  18. BuildRequires: libdv-devel
  19. BuildRequires: SDL-devel >= 1.1.3
  20. BuildRequires: SDL_gfx-devel
  21. #BuildRequires: libquicktime-devel >= 0.9.8
  22. #BuildRequires: self-build-libquicktime >= 0.9.8
  23. BuildRequires: libpng-devel
  24. BuildRequires: gtk2-devel >= 2.4.0
  25. # mencoder for lav2avi.sh
  26. #Requires: mencoder
  27. #Requires: self-build-mplayer
  28. # ffmpeg main package, y4mscaler and which for anytovcd.sh
  29. #Requires: ffmpeg
  30. #Requires: self-build-ffmpeg
  31. #Requires: y4mscaler
  32. Requires: which
  33. Requires(post): /sbin/install-info
  34. Requires(preun): /sbin/install-info
  35. %description
  36. The mjpeg programs are a set of tools that can do recording of videos
  37. and playback, simple cut-and-paste editing and the MPEG compression of
  38. audio and video under Linux.
  39. %description -l ja
  40. mjpegtools は、Linux 上でビデオ録画や再生、
  41. 簡単なカット&ペーストの編集、オーディオやビデオの MPEG 圧縮ができる
  42. ツール集です。
  43. %package devel
  44. Summary: Development files for mjpegtools libraries
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: pkgconfig
  48. %description devel
  49. The mjpeg programs are a set of tools that can do recording of videos
  50. and playback, simple cut-and-paste editing and the MPEG compression of
  51. audio and video under Linux. This package contains development files
  52. for building applications that use mjpegtools libraries.
  53. %prep
  54. %setup -q
  55. %patch0 -p1 -b .sdl
  56. %patch1 -p1 -b .format
  57. %patch2 -p0 -b .fpic
  58. %__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
  59. %__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
  60. for f in docs/yuvfps.1 ; do
  61. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  62. done
  63. %build
  64. %configure --disable-dependency-tracking --disable-static
  65. %__make # %{?_smp_mflags}
  66. %install
  67. %__rm -rf $RPM_BUILD_ROOT
  68. %__make install DESTDIR=$RPM_BUILD_ROOT
  69. %__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
  70. # too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
  71. %__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
  72. %clean
  73. %__rm -rf $RPM_BUILD_ROOT
  74. %post
  75. /sbin/ldconfig
  76. /sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  77. %postun
  78. /sbin/ldconfig
  79. %preun
  80. [ $1 -eq 0 ] && \
  81. /sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
  85. %{_bindir}/*
  86. %{_mandir}/man1/*.1*
  87. %{_mandir}/man5/yuv4mpeg.5*
  88. %{_infodir}/mjpeg-howto.info*
  89. ## gui
  90. %doc README.glav
  91. %{_bindir}/glav
  92. # lavplay and yuvplay won't save -libs/console util users from X11 and SDL
  93. # dependencies as long as liblavplay is in -libs, but they're inherently
  94. # GUI tools -> include them here
  95. %{_bindir}/lavplay
  96. %{_bindir}/y4mhist
  97. %{_bindir}/yuvplay
  98. %{_mandir}/man1/lavplay.1*
  99. %{_mandir}/man1/yuvplay.1*
  100. ## libs
  101. %{_libdir}/lib*.so.*
  102. %files devel
  103. %defattr(-,root,root,-)
  104. %{_includedir}/%{name}
  105. %{_libdir}/lib*.so
  106. %{_libdir}/pkgconfig/%{name}.pc
  107. %{_includedir}/%{name}/*lav*.h
  108. %{_libdir}/liblav*.so
  109. %changelog
  110. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
  111. - new upstream release
  112. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-4
  113. - added Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
  114. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
  115. - rebuild
  116. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
  117. - rebuild
  118. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  119. - new upstream release
  120. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  121. - new upstream release
  122. * Fri Sep 3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
  123. - Fix a memleak which is causing issues for LiVES
  124. * Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
  125. - Update to upstream 1.9.0 final release
  126. * Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
  127. - rebuild for new F11 features
  128. * Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
  129. - initial build
  130. * Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
  131. - Release bump for rpmfusion
  132. - Sync with freshrpms (no changes)
  133. * Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
  134. - Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
  135. * Tue Dec 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
  136. - 1.9.0rc3.
  137. * Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
  138. - Requires: which
  139. * Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
  140. - License: GPLv2
  141. * Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
  142. - Rebuild.
  143. * Fri Jun 8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
  144. - 1.9.0rc2.
  145. * Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
  146. - Split GUI utilities into -gui subpackage.
  147. - Don't ship mpegtranscode, it's broken/outdated.
  148. - Require mencoder for lav2avi.sh.
  149. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
  150. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  151. * Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
  152. - Specfile cleanup.
  153. * Sun Jun 4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
  154. - Get rid of undefined non-weak symbols in liblav*.
  155. - Apply upstream fix for compiling with libquicktime 0.9.8.
  156. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  157. - switch to new release field
  158. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  159. - add dist
  160. * Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
  161. - Include license text in -libs, it can be installed without the main package.
  162. - Convert yuvfps man page to UTF-8.
  163. - Fix -devel Group tag.
  164. * Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
  165. - Added patch to compile with gcc 4.1
  166. - Dropped 0 Epoch
  167. * Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
  168. - 1.8.0.
  169. * Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
  170. - 1.6.3-rc3, Altivec fixes applied upstream.
  171. * Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
  172. - 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
  173. - Fix Altivec build, kudos to upstream.
  174. * Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
  175. - 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
  176. * Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
  177. - PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
  178. * Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
  179. - Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
  180. - Require pkgconfig in -devel.
  181. * Wed Feb 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
  182. - Add corrected -fPIC tweak from Thorsten.
  183. * Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
  184. - Include PNG input support.
  185. - Remove no-op $RPM_OPT_FLAGS setting from %%build.
  186. - Remove bogus optimization settings from configure script.
  187. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
  188. - CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
  189. option --with-pic is not enough
  190. * Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
  191. - Disabling static libraries building
  192. * Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
  193. - Include quicktime support.
  194. - Apply patch from ALT Linux to fix info pages, fix typo in %%post.
  195. - Require /sbin/install-info.
  196. - Add "--without static" rpmbuild option to work around an issue with FC3 strip
  197. - Always enable SIMD accelerations, CPU capabilities detected at runtime.
  198. - Always disable use of cmov.
  199. * Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
  200. - Added patch to fix gcc3.4 build
  201. - Detected race condition in Makefiles (disabling _smp_mflags use)
  202. - Added info files & scriptlets
  203. - Dropped patch0 and patch1
  204. * Tue Jun 8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
  205. - Updated to 1.6.2
  206. * Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
  207. - Removed comment after scriptlets
  208. * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
  209. - buildroot -> RPM_BUILD_ROOT
  210. * Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
  211. - Applied upstream patches to fix build on gcc3.3 systems
  212. * Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
  213. - Now test arch for configure options (from Ville)
  214. - Removed ImageMagick-devel BuildRequires
  215. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
  216. - Added missing BuildRequires
  217. - Added post/postun scriplets for libs package
  218. * Wed Apr 23 2003 Dams <anvil[AT]livna.org>
  219. - Initial build.