self-build-mjpegtools-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. %define pkgname mjpegtools
  2. %define name self-build-%{pkgname}
  3. %define version 2.1.0
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. Source100: mjpegtools-2.1.0-sdl-cflags.patch
  13. Source101: mjpegtools-2.1.0-no_format.patch
  14. Source102: mjpegtools-2.1.0-pic.patch
  15. License: GPLv2+
  16. Group: Restricted Software
  17. Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
  18. Obsoletes: self-build-mjpegtools < %{version}-%{release}
  19. # Requires(posttrans) not yet implemented. So we use (post) instead.
  20. Requires(post): self-build-setup >= 0.9.0
  21. Requires(post): libjpeg-devel
  22. Requires(post): nasm
  23. Requires(post): libdv-devel
  24. Requires(post): SDL-devel >= 1.1.3
  25. Requires(post): SDL_gfx-devel
  26. Requires(post): self-build-libquicktime >= 1.2.0
  27. Requires(post): libpng-devel
  28. Requires(post): gtk2-devel >= 2.4.0
  29. Requires(post): self-build-mplayer >= 1.1
  30. Requires(post): self-build-ffmpeg >= 1.1.0
  31. #Requires(post): y4mscaler
  32. Requires: which
  33. Requires(post): /sbin/install-info
  34. Requires(preun): /sbin/install-info
  35. BuildArch: noarch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. Packager: munepi
  38. %description
  39. The mjpeg programs are a set of tools that can do recording of videos
  40. and playback, simple cut-and-paste editing and the MPEG compression of
  41. audio and video under Linux.
  42. If you install this package, it automaticaly downloads source
  43. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  44. And the created rpm packages are automatically installed
  45. if installation is executed by apt-get command or synaptic
  46. package manager.
  47. [Note]
  48. This package requires many other packages to compile
  49. targetsoftware. So it consume more disk space than usual.
  50. Also installation takes logner time because of compilation.
  51. (This will take a few minutes to quarter or half of an hour,
  52. depends on building environment)
  53. [About self-build package]
  54. For some kind of software, distributing of binary package
  55. may viorate the patent or law. Therefore we chose self-build
  56. packge, create binary package on your machine, for such kind
  57. of softwares instead of distributing binary package.
  58. Please obey the national law when you use the created binary
  59. packages. And if you want to use the softwares using patented
  60. thechnology, it may be required to get a permission, make an
  61. agreement or purchas a license. Please consider it with your
  62. purpose or way of use and take appropriate action.
  63. %description -l ja
  64. mjpegtools は、Linux 上で
  65. ビデオ録画や再生、
  66. 簡単なカット&ペーストの編集、
  67. オーディオやビデオの MPEG 圧縮
  68. ができるツール集です。
  69. このパッケージをインストールすると、自動的にソースコードを
  70. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  71. の rpm パッケージを作成します。
  72. また apt-get コマンドや synaptic パッケージマネージャから実行
  73. した場合は、作成された rpm パッケージのインストールも自動的に
  74. 行います。
  75. [注意]
  76. コンパイルに必要な多くの関連パッケージを要求するので通常より
  77. ディスクの領域を多く消費します。
  78. またインストール時にコンパイルを行うため、通常より時間がかか
  79. る場合があります。(環境にもよりますが数分から数十分程度)
  80. [self-build パッケージについて]
  81. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  82. 違反する可能性があるものがあります。その為、このような問題が
  83. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  84. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  85. ジという方法を採っています。
  86. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  87. アのライセンス、および利用する国の各種法令に従ってください。
  88. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  89. センスの購入などが必要となる場合がありますので、利用する目的
  90. や形態に応じて各自で判断し適切な対応を取ってください。
  91. %prep
  92. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  93. %install
  94. %{__rm} -rf ${RPM_BUILD_ROOT}
  95. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  97. %{__install} -m 644 %{SOURCE100} %{SOURCE101} %{SOURCE102} \
  98. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  99. %clean
  100. %{__rm} -rf ${RPM_BUILD_ROOT}
  101. %posttrans
  102. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 172000
  103. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  104. %{pkgname}-devel-%{version}-%{release}
  105. %files
  106. %defattr(-,root,root)
  107. %{_datadir}/%{name}/*
  108. %changelog
  109. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
  110. - new upstream release
  111. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-4
  112. - added Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
  113. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
  114. - rebuild
  115. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
  116. - rebuild
  117. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  118. - new upstream release
  119. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
  120. - initial build
  121. ### end of file