openssl096-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456
  1. %define soversion 2
  2. Summary: Secure Sockets Layer Toolkit
  3. Name: openssl096
  4. Version: 0.9.6m
  5. Release: 1%{?_dist_release}
  6. Source: openssl-engine-%{version}.tar.gz
  7. Source1: hobble-openssl
  8. Source2: Makefile.certificate
  9. Source3: ca-bundle.crt
  10. Source4: RHNS-CA-CERT
  11. Source5: make-dummy-cert
  12. Source6: openssl.pc
  13. Patch0: openssl-0.9.6m-rpm.patch
  14. Patch1: openssl-0.9.5a-64.patch
  15. Patch2: openssl-0.9.5a-defaults.patch
  16. Patch3: openssl-0.9.5a-ia64.patch
  17. Patch4: openssl-0.9.6g-glibc.patch
  18. Patch5: openssl-0.9.6g-soversion.patch
  19. # security fix
  20. Patch106: openssl-CAN-2005-2969.patch
  21. Patch107: openssl-0.9.7d-CVE-2006-4339.patch
  22. Patch108: openssl-engine-0.9.6b-cve-2006-2940.patch
  23. Patch109: openssl-0.9.6b-cve-2006-3738.patch
  24. Patch110: openssl-0.9.8b-cve-2006-4343.patch
  25. Patch120: openssl-0.9.6m_CVE-2007-3108.patch
  26. Patch130: openssl-0.9.6m_CVE-2007-5135.patch
  27. Patch140: openssl-0.9.6m_CVE-2006-4339.patch
  28. License: BSDish
  29. Group: System Environment/Libraries
  30. URL: http://www.openssl.org/
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. BuildPreReq: perl, sed
  33. Requires: mktemp
  34. Distribution: Vine Linux
  35. Vendor: Project Vine
  36. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  37. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  38. %description
  39. The OpenSSL certificate management tool and the shared libraries that
  40. provide various cryptographic algorithms and protocols.
  41. %package devel
  42. Summary: OpenSSL libraries and development headers.
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The static libraries and include files needed to compile apps
  47. with support for various the cryptographic algorithms and protocols
  48. supported by OpenSSL.
  49. Patches for many networking apps can be found at:
  50. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  51. %package perl
  52. Summary: OpenSSL scripts which require Perl.
  53. Group: Applications/Internet
  54. Requires: perl
  55. Requires: %{name} = %{version}-%{release}
  56. %description perl
  57. Perl scripts provided with OpenSSL for converting certificates and keys
  58. from other formats to those used by OpenSSL.
  59. %prep
  60. %setup -q -n openssl-engine-%{version}
  61. #%{SOURCE1}
  62. %patch0 -p1 -b .redhat
  63. %patch1 -p1 -b .64
  64. %patch2 -p1 -b .defaults
  65. %patch3 -p1 -b .ia64
  66. %patch4 -p1 -b .glibc
  67. %patch5 -p1 -b .soversion
  68. # security fix
  69. %patch106 -p0 -b .CAN-2005-2969
  70. %patch107 -p1 -b .CVE-2006-4339
  71. %patch108 -p1 -b .CVE-2006-2940
  72. %patch109 -p1 -b .CVE-2006-3738
  73. %patch110 -p0 -b .CVE-2006-4343
  74. %patch120 -p0 -b .CVE-2007-3108
  75. %patch130 -p1 -b .CVE-2007-5135
  76. %patch140 -p1 -b .CVE-2006-4339
  77. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  78. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  79. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  80. chmod 644 doc/ssleay.txt
  81. # Link the configuration header to the one we're going to make.
  82. ln -sf ../../crypto/opensslconf.h include/openssl/
  83. %build
  84. PATH=${PATH}:${PWD}/bin
  85. TOPDIR=${PWD}
  86. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  87. # Figure out which flags we want to use. Can't use assembler because it's
  88. # not lowest-common-denominator in most cases.
  89. perl util/perlpath.pl `dirname %{__perl}`
  90. %ifarch %ix86
  91. sslarch=linux-elf
  92. sslflags="no-asm 386"
  93. %endif
  94. %ifarch sparc
  95. sslarch=linux-sparcv9
  96. sslflags=no-asm
  97. %endif
  98. %ifarch ia64
  99. sslarch=linux-ia64
  100. sslflags=no-asm
  101. %endif
  102. %ifarch alpha
  103. sslarch=alpha-gcc
  104. sslflags=no-asm
  105. %endif
  106. %ifarch s390
  107. sslarch=linux-s390
  108. %endif
  109. %ifarch s390x
  110. sslarch=linux-s390x
  111. %endif
  112. %ifarch mipsel
  113. sslarch=linux-mips
  114. sslflags=no-asm
  115. %endif
  116. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  117. # usable on all platforms. The Configure script already knows to use -fPIC and
  118. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  119. ./config --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} shared
  120. make all build-shared
  121. # Generate hashes for the included certs.
  122. make rehash build-shared
  123. # Verify that what was compiled actually works.
  124. make -C test apps tests
  125. # Relink the main binary to get it dynamically linked.
  126. rm apps/openssl
  127. make all build-shared
  128. %install
  129. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  130. # Install OpenSSL.
  131. install -d $RPM_BUILD_ROOT{/lib,%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
  132. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  133. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  134. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{solibbase} $RPM_BUILD_ROOT/lib/
  135. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  136. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  137. rename so.%{solibbase} so.%{version} $RPM_BUILD_ROOT/lib/*.so.%{solibbase}
  138. for lib in $RPM_BUILD_ROOT/lib/*.so.%{version} ; do
  139. chmod 755 ${lib}
  140. ln -s -f ../../lib/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  141. ln -s -f ../../lib/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`.%{soversion}
  142. done
  143. %clean
  144. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  145. %files
  146. %defattr(-,root,root)
  147. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  148. %doc doc/README doc/c-indentation.el doc/openssl.txt
  149. %doc doc/openssl_button.html doc/openssl_button.gif
  150. %doc doc/ssleay.txt
  151. %attr(0755,root,root) /lib/*.so.%{version}
  152. %post -p /sbin/ldconfig
  153. %postun -p /sbin/ldconfig
  154. %changelog
  155. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6m-1vl5
  156. - applied new versioning policy
  157. * Tue Oct 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  158. - 0.9.6m-0vl5
  159. - add patch120 for fix CVE-2007-3108 (Montgomery:BN_from_montgomery())
  160. - add patch130 for fix CVE-2007-5135
  161. - add patch140 for fix CVE-2006-4339 (RSA key with exponent 3)
  162. * Fri Sep 29 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  163. - 0.9.6m-0vl4
  164. - add Patch108 for fix CVE-2006-2940
  165. - add Patch109 for fix CVE-2006-3738
  166. - add Patch110 for fix CVE-2006-4343
  167. - change patch No. (patch6 -> 106, patch7 -> 107)
  168. * Mon Sep 11 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  169. - 0.9.6m-0vl3
  170. - add patch7 for fix CVE-2006-4339
  171. * Sat Jul 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6m-0vl2
  172. - rebuilt for VineSeed
  173. * Thu Oct 13 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  174. - 0.9.6m-0vl1.1
  175. - add patch6 for fix CAN-2005-2969
  176. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  177. - new upstream release
  178. - SECURITY fix.
  179. - http://www.openssl.org/news/secadv_20040317.txt
  180. - build as compatibility package
  181. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  182. - new upstream release
  183. - [Security fix]
  184. - Vulnerabilities in ASN.1 parsing
  185. http://www.openssl.org/news/secadv_20030930.txt
  186. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  187. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  188. - add openssl.pc for pkgconfig
  189. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  190. - New upstream version
  191. - dropped patch10, 11
  192. -- merged upstream version
  193. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  194. - rebuild for VineSeed
  195. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  196. - [Security Fix]
  197. - Timing-based attacks on RSA keys
  198. http://www.openssl.org/news/secadv_20030317.txt
  199. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  200. http://www.openssl.org/news/secadv_20030317.txt
  201. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  202. - new upstream release 0.9.6i
  203. - [Security Fix]
  204. - build for Vine Linux 2.6 errata
  205. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  206. - new upstream release 0.9.6h
  207. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  208. - new upstream release 0.9.6g
  209. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  210. - SECURITY: CAN-2002-0659 fixed
  211. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  212. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  213. - update asn patch to fix accidental reversal of a logic check
  214. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  215. - update asn patch to reduce chance that compiler optimization will remove
  216. one of the added tests
  217. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  218. - rebuild
  219. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  220. - add patch to fix ASN.1 vulnerabilities
  221. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  222. - rename spec file name
  223. - SECURITY: CA-2002-23 fixed
  224. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  225. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  226. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  227. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  228. - added ${PATH} in LD_LIBRARY_PATH
  229. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  230. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  231. - remove --no-<cipher>
  232. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  233. - add Patch10 for mipsel shared ( Configure )
  234. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  235. - build for Vine Linux
  236. - use openssl-engine-0.9.6b.tar.gz
  237. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  238. - update to 0.9.6b
  239. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  240. - move .so symlinks back to %%{_libdir}
  241. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  242. - move shared libraries to /lib (#38410)
  243. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  244. - switch to engine code base
  245. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  246. - add a script for creating dummy certificates
  247. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  248. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  249. - add s390x support
  250. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  251. - change two memcpy() calls to memmove()
  252. - don't define L_ENDIAN on alpha
  253. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  254. - make subpackages depend on the main package
  255. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  256. - adjust the hobble script to not disturb symlinks in include/ (fix from
  257. Joe Orton)
  258. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  259. - drop the m2crypo patch we weren't using
  260. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  261. - configure using "shared" as well
  262. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  263. - update to 0.9.6a
  264. - use the build-shared target to build shared libraries
  265. - bump the soversion to 2 because we're no longer compatible with
  266. our 0.9.5a packages or our 0.9.6 packages
  267. - drop the patch for making rsatest a no-op when rsa null support is used
  268. - put all man pages into <section>ssl instead of <section>
  269. - break the m2crypto modules into a separate package
  270. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  271. - use BN_LLONG on s390
  272. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  273. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  274. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  275. - move c_rehash to the perl subpackage, because it's a perl script now
  276. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  277. - update to 0.9.6
  278. - enable MD2
  279. - use the libcrypto.so and libssl.so targets to build shared libs with
  280. - bump the soversion to 1 because we're no longer compatible with any of
  281. the various 0.9.5a packages circulating around, which provide lib*.so.0
  282. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  283. - change hobble-openssl for disabling MD2 again
  284. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  285. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  286. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  287. apps built against a version of the library without it
  288. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  289. - disable some inline assembly, which on x86 is Pentium-specific
  290. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  291. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  292. - fix s390 patch
  293. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  294. - added support s390
  295. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  296. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  297. - add the CA.pl man page to the perl subpackage
  298. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  299. - always build with -mcpu=ev5 on alpha
  300. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  301. - add a symlink from cert.pem to ca-bundle.crt
  302. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  303. - add a ca-bundle file for packages like Samba to reference for CA certificates
  304. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  305. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  306. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  307. - add unzip as a buildprereq (#17662)
  308. - update m2crypto to 0.05-snap4
  309. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  310. - fix some issues in building when it's not installed
  311. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  312. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  313. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  314. - add Richard Henderson's patch for BN on ia64
  315. - clean up the changelog
  316. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  317. - fix the building of python modules without openssl-devel already installed
  318. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  319. - byte-compile python extensions without the build-root
  320. - adjust the makefile to not remove temporary files (like .key files when
  321. building .csr files) by marking them as .PRECIOUS
  322. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  323. - break out python extensions into a subpackage
  324. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  325. - tweak the makefile some more
  326. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  327. - disable MD2 support
  328. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  329. - disable MDC2 support
  330. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  331. - tweak the disabling of RC5, IDEA support
  332. - tweak the makefile
  333. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  334. - strip binaries and libraries
  335. - rework certificate makefile to have the right parts for Apache
  336. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  337. - use %%{_perl} instead of /usr/bin/perl
  338. - disable alpha until it passes its own test suite
  339. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  340. - move the passwd.1 man page out of the passwd package's way
  341. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  342. - update to 0.9.5a, modified for U.S.
  343. - add perl as a build-time requirement
  344. - move certificate makefile to another package
  345. - disable RC5, IDEA, RSA support
  346. - remove optimizations for now
  347. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  348. - Bero told me to move the Makefile into this package
  349. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  350. - add lib*.so symlinks to link dynamically against shared libs
  351. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  352. - update to 0.9.5
  353. - run ldconfig directly in post/postun
  354. - add FAQ
  355. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  356. - Fix build on non-x86 platforms
  357. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  358. - move /usr/share/ssl/* from -devel to main package
  359. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  360. - inital packaging
  361. - changes from base:
  362. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  363. - handle RPM_OPT_FLAGS