openssl098-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 6
  3. %define version 0.9.8zf
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl098
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. # Source6: openssl-%{version}.pc
  14. Patch0: openssl-0.9.8b-soversion.patch
  15. Patch2: openssl-0.9.8e-rpm_opt.patch
  16. Patch4: openssl-0.9.8p-enginesdir.patch
  17. Patch8: openssl-0.9.8zf-perlfind.patch
  18. # security fix
  19. # nothing ;-)
  20. License: BSDish
  21. Group: System Environment/Libraries
  22. URL: http://www.openssl.org/
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl, sed
  25. Requires: mktemp
  26. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  30. %description
  31. The OpenSSL certificate management tool and the shared libraries that
  32. provide various cryptographic algorithms and protocols.
  33. ## to build compat32 for x86_64 architecture support
  34. %package -n compat32-%{name}
  35. Summary: Secure Sockets Layer Toolkit
  36. Group: System Environment/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. %description -n compat32-%{name}
  39. The OpenSSL certificate management tool and the shared libraries that
  40. provide various cryptographic algorithms and protocols.
  41. %prep
  42. %setup -q -n openssl-%{version}
  43. %patch0 -p1 -b .soversion
  44. %patch2 -p1 -b .rpm_opt
  45. %patch4 -p1 -b .enginesdir
  46. %patch8 -p1 -b .perlfind
  47. # security fix
  48. # nothing ;-)
  49. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  50. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  51. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  52. chmod 644 doc/ssleay.txt
  53. # Link the configuration header to the one we're going to make.
  54. ln -sf ../../crypto/opensslconf.h include/openssl/
  55. %build
  56. PATH=${PATH}:${PWD}/bin
  57. TOPDIR=${PWD}
  58. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  59. # Figure out which flags we want to use. Can't use assembler because it's
  60. # not lowest-common-denominator in most cases.
  61. perl util/perlpath.pl `dirname %{__perl}`
  62. %ifarch %ix86
  63. sslarch=linux-elf
  64. sslflags="no-asm 386"
  65. %endif
  66. %ifarch ppc
  67. sslarch=linux-ppc
  68. sslflags=no-asm
  69. %endif
  70. %ifarch sparc
  71. sslarch=linux-sparcv9
  72. sslflags=no-asm
  73. %endif
  74. %ifarch ia64
  75. sslarch=linux-ia64
  76. sslflags=no-asm
  77. %endif
  78. %ifarch alpha
  79. sslarch=linux-alpha-gcc
  80. sslflags=no-asm
  81. %endif
  82. %ifarch s390
  83. sslarch=linux-s390
  84. %endif
  85. %ifarch s390x
  86. sslarch=linux-s390x
  87. %endif
  88. %ifarch mipsel
  89. sslarch=linux-mips
  90. sslflags=no-asm
  91. %endif
  92. ## to build for x86_64 architecture support
  93. %ifarch x86_64
  94. sslarch=linux-x86_64
  95. sslflags=no-asm
  96. %endif
  97. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  98. # usable on all platforms. The Configure script already knows to use -fPIC and
  99. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  100. ./Configure \
  101. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  102. --enginesdir=%{_libdir}/openssl/engines \
  103. shared ${sslarch}
  104. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  105. # marked as not requiring an executable stack.
  106. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  107. make depend
  108. make all build-shared
  109. # Generate hashes for the included certs.
  110. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  111. export LD_LIBRARY_PATH
  112. make rehash build-shared
  113. # Verify that what was compiled actually works.
  114. make -C test apps tests
  115. # Relink the main binary to get it dynamically linked.
  116. rm apps/openssl
  117. make all build-shared
  118. %install
  119. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  120. # Install OpenSSL.
  121. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  122. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  123. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  124. # added for lib64
  125. mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  126. mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  127. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  128. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  129. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  130. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  131. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  132. chmod 755 ${lib}
  133. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  134. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  135. done
  136. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  137. # Install a makefile for generating keys and self-signed certs, and a script
  138. # for generating them on the fly.
  139. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  140. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  141. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  142. # Make sure we actually include the headers we built against.
  143. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  144. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  145. install -m644 include/openssl/`basename ${header}` ${header}
  146. fi
  147. done
  148. # Rename man pages so that they don't conflict with system man pages. We used
  149. # to change the file extensions, but that only prevents file conflicts. The
  150. # man viewer still can't select either of the two unless we physically change
  151. # the directory.
  152. for section in 1 2 3 4 5 6 7 8 ; do
  153. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  154. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  155. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  156. fi
  157. done
  158. # Pick a CA script.
  159. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  160. mv CA.sh CA
  161. popd
  162. # Install root CA stuffs.
  163. cat %{SOURCE3} > ca-bundle.crt
  164. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  165. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  166. # Fix libdir.
  167. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  168. # sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  169. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  170. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  171. # cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  172. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  173. # rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  174. %clean
  175. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  176. %files
  177. %defattr(-,root,root)
  178. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  179. %doc doc/README doc/c-indentation.el doc/openssl.txt
  180. %doc doc/openssl_button.html doc/openssl_button.gif
  181. %doc doc/ssleay.txt
  182. # %dir %{_datadir}/ssl
  183. # %{_datadir}/ssl/certs
  184. # %{_datadir}/ssl/cert.pem
  185. # %{_datadir}/ssl/misc/CA
  186. # %{_datadir}/ssl/misc/c_*
  187. # %{_datadir}/ssl/private
  188. # %config(noreplace) %{_datadir}/ssl/openssl.cnf
  189. # %attr(0755,root,root) %{_bindir}/openssl
  190. %attr(0755,root,root) /%{_lib}/*.so.*
  191. # %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  192. # %attr(0755,root,root) %dir %{_mandir}/man1*
  193. # %attr(0644,root,root) %{_mandir}/man1*/*
  194. # %attr(0755,root,root) %dir %{_mandir}/man5*
  195. # %attr(0644,root,root) %{_mandir}/man5*/*
  196. # %attr(0755,root,root) %dir %{_mandir}/man7*
  197. # %attr(0644,root,root) %{_mandir}/man7*/*
  198. ## to build compat32 for x86_64 architecture support
  199. %if %{build_compat32}
  200. %files -n compat32-%{name}
  201. %defattr(-,root,root)
  202. %attr(0755,root,root) /%{_lib}/*.so.*
  203. %endif
  204. %post -p /sbin/ldconfig
  205. %postun -p /sbin/ldconfig
  206. %post -n compat32-%{name} -p /sbin/ldconfig
  207. %postun -n compat32-%{name} -p /sbin/ldconfig
  208. %changelog
  209. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8zf-1
  210. - merge into Vine6
  211. * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zf-1
  212. - new upstream release with security fix
  213. * Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zd-1
  214. - new upstream release with security fix
  215. * Thu Oct 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zc-1
  216. - new upstream release with security fix
  217. * Thu Aug 7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zb-1
  218. - new upstream release with security fix
  219. * Sat Jun 7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8za-1
  220. - new upstream release with security fix
  221. - add Patch8: openssl-0.9.8zf-perlfind.patch
  222. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8r-1
  223. - new upstream release with security fix
  224. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  225. - new upstream release with security fix
  226. - update patch4
  227. * Wed Mar 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-2
  228. - fix files list (unneeded files were included in package)
  229. * Tue Mar 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-1
  230. - new compatible package openssl 0.9.8n for upgrade openssl 1.0.0
  231. * Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
  232. - new upstream release
  233. - update enginsdir patch (Patch4)
  234. - drop unnecessary patch: upstream fixed
  235. - dtls dos patch (Patch10)
  236. - CVE-2009-4355 (memory leak) patch (Patch11)
  237. - CVE-2009-3555 (renegotiation) patch (Patch12)
  238. - update SOURCE6 for pkgconfig
  239. - replace BuildPreReq to BuildRequires
  240. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  241. - add patch12 for fix CVE-2009-3555 (renegotiation)
  242. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  243. - add patch11 for fix CVE-2009-4355 (memory leak)
  244. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  245. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  246. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  247. - removed unnecessary %%if %{build_compat32} statements
  248. - removed lib*.a from devel package
  249. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  250. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  251. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  252. - new upstream release with security fix (CVE-2008-5077)
  253. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  254. - new upstream release
  255. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  256. - new upstream release
  257. - new versioning policy
  258. * Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  259. - new upstream release
  260. - drop patch10,20 which is merged in upstream
  261. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  262. - add security patch in advance for CVE-2007-5135
  263. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  264. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  265. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  266. - add security patch for CVE-2007-3108
  267. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  268. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  269. - new upstream release
  270. * Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  271. - update (fix) openssl.pc <BTS:437>
  272. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  273. - new upstream release (with security fix)
  274. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  275. - new upstream release
  276. - add patch2 to use RPM_OPT macro
  277. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  278. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  279. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  280. - added compat32-* packages for x86_64 architecture support
  281. - added openssl-0.9.7i.Configure-compat32.patch
  282. - changed '/lib' to '/%{_lib}'
  283. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  284. - new upstream release
  285. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  286. - rebuild on VineSeed
  287. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  288. - added a security patch from Gentoo.
  289. - Patch1: openssl-0.9.7c-tempfile.patch
  290. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  291. - sslarch for ppc was missing... added.
  292. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  293. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  294. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  295. - new upstream version
  296. - clean up of spec file
  297. -- removed old patches
  298. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  299. - new upstream release
  300. - SECURITY fix.
  301. - http://www.openssl.org/news/secadv_20040317.txt
  302. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  303. - new upstream release
  304. - [Security fix]
  305. - Vulnerabilities in ASN.1 parsing
  306. http://www.openssl.org/news/secadv_20030930.txt
  307. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  308. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  309. - add openssl.pc for pkgconfig
  310. * Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  311. - New upstream version
  312. - dropped patch10, 11
  313. -- merged upstream version
  314. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  315. - rebuild for VineSeed
  316. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  317. - [Security Fix]
  318. - Timing-based attacks on RSA keys
  319. http://www.openssl.org/news/secadv_20030317.txt
  320. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  321. http://www.openssl.org/news/secadv_20030317.txt
  322. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  323. - new upstream release 0.9.6i
  324. - [Security Fix]
  325. - build for Vine Linux 2.6 errata
  326. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  327. - new upstream release 0.9.6h
  328. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  329. - new upstream release 0.9.6g
  330. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  331. - SECURITY: CAN-2002-0659 fixed
  332. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  333. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  334. - update asn patch to fix accidental reversal of a logic check
  335. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  336. - update asn patch to reduce chance that compiler optimization will remove
  337. one of the added tests
  338. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  339. - rebuild
  340. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  341. - add patch to fix ASN.1 vulnerabilities
  342. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  343. - rename spec file name
  344. - SECURITY: CA-2002-23 fixed
  345. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  346. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  347. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  348. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  349. - added ${PATH} in LD_LIBRARY_PATH
  350. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  351. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  352. - remove --no-<cipher>
  353. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  354. - add Patch10 for mipsel shared ( Configure )
  355. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  356. - build for Vine Linux
  357. - use openssl-engine-0.9.6b.tar.gz
  358. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  359. - update to 0.9.6b
  360. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  361. - move .so symlinks back to %%{_libdir}
  362. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  363. - move shared libraries to /lib (#38410)
  364. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  365. - switch to engine code base
  366. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  367. - add a script for creating dummy certificates
  368. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  369. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  370. - add s390x support
  371. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  372. - change two memcpy() calls to memmove()
  373. - don't define L_ENDIAN on alpha
  374. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  375. - make subpackages depend on the main package
  376. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  377. - adjust the hobble script to not disturb symlinks in include/ (fix from
  378. Joe Orton)
  379. * Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  380. - drop the m2crypo patch we weren't using
  381. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  382. - configure using "shared" as well
  383. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  384. - update to 0.9.6a
  385. - use the build-shared target to build shared libraries
  386. - bump the soversion to 2 because we're no longer compatible with
  387. our 0.9.5a packages or our 0.9.6 packages
  388. - drop the patch for making rsatest a no-op when rsa null support is used
  389. - put all man pages into <section>ssl instead of <section>
  390. - break the m2crypto modules into a separate package
  391. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  392. - use BN_LLONG on s390
  393. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  394. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  395. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  396. - move c_rehash to the perl subpackage, because it's a perl script now
  397. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  398. - update to 0.9.6
  399. - enable MD2
  400. - use the libcrypto.so and libssl.so targets to build shared libs with
  401. - bump the soversion to 1 because we're no longer compatible with any of
  402. the various 0.9.5a packages circulating around, which provide lib*.so.0
  403. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  404. - change hobble-openssl for disabling MD2 again
  405. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  406. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  407. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  408. apps built against a version of the library without it
  409. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  410. - disable some inline assembly, which on x86 is Pentium-specific
  411. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  412. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  413. - fix s390 patch
  414. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  415. - added support s390
  416. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  417. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  418. - add the CA.pl man page to the perl subpackage
  419. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  420. - always build with -mcpu=ev5 on alpha
  421. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  422. - add a symlink from cert.pem to ca-bundle.crt
  423. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  424. - add a ca-bundle file for packages like Samba to reference for CA certificates
  425. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  426. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  427. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  428. - add unzip as a buildprereq (#17662)
  429. - update m2crypto to 0.05-snap4
  430. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  431. - fix some issues in building when it's not installed
  432. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  433. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  434. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  435. - add Richard Henderson's patch for BN on ia64
  436. - clean up the changelog
  437. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  438. - fix the building of python modules without openssl-devel already installed
  439. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  440. - byte-compile python extensions without the build-root
  441. - adjust the makefile to not remove temporary files (like .key files when
  442. building .csr files) by marking them as .PRECIOUS
  443. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  444. - break out python extensions into a subpackage
  445. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  446. - tweak the makefile some more
  447. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  448. - disable MD2 support
  449. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  450. - disable MDC2 support
  451. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  452. - tweak the disabling of RC5, IDEA support
  453. - tweak the makefile
  454. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  455. - strip binaries and libraries
  456. - rework certificate makefile to have the right parts for Apache
  457. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  458. - use %%{_perl} instead of /usr/bin/perl
  459. - disable alpha until it passes its own test suite
  460. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  461. - move the passwd.1 man page out of the passwd package's way
  462. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  463. - update to 0.9.5a, modified for U.S.
  464. - add perl as a build-time requirement
  465. - move certificate makefile to another package
  466. - disable RC5, IDEA, RSA support
  467. - remove optimizations for now
  468. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  469. - Bero told me to move the Makefile into this package
  470. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  471. - add lib*.so symlinks to link dynamically against shared libs
  472. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  473. - update to 0.9.5
  474. - run ldconfig directly in post/postun
  475. - add FAQ
  476. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  477. - Fix build on non-x86 platforms
  478. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  479. - move /usr/share/ssl/* from -devel to main package
  480. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  481. - inital packaging
  482. - changes from base:
  483. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  484. - handle RPM_OPT_FLAGS