readline-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359
  1. Summary: A library for editing typed in command lines.
  2. Summary(ja): Readline ライブラリ
  3. Name: readline
  4. Version: 8.2.1
  5. %global shortver %(echo %{version} | cut -d . -f 1-2)
  6. %global shortver_nodots %(echo %{shortver} | tr -d ".")
  7. Release: 2%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+
  12. URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
  13. %global baseurl https://ftp.gnu.org/gnu/readline
  14. Source: %{baseurl}/readline-%{shortver}.tar.gz
  15. # upstream patches
  16. Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
  17. # fix file permissions, remove RPATH, use CFLAGS
  18. Patch100: readline-8.0-shlib.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: sed
  21. BuildRequires: ncurses-devel
  22. Requires(post): /sbin/install-info
  23. Requires(preun): /sbin/install-info
  24. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  25. %if %{build_compat32}
  26. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  27. %endif
  28. %description
  29. The Readline library provides a set of functions that allow users to
  30. edit command lines. Both Emacs and vi editing modes are available. The
  31. Readline library includes additional functions for maintaining a list
  32. of previously-entered command lines for recalling or editing those
  33. lines, and for performing csh-like history expansion on previous
  34. commands.
  35. %description -l ja
  36. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  37. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  38. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  39. %package devel
  40. Summary: Files needed to develop programs which use the readline library.
  41. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  42. Group: programming
  43. Requires: readline = %{version}
  44. Requires: ncurses-devel
  45. %if %{build_compat32}
  46. Provides: pkgconfig(readline) = %{version}-%{release}
  47. %endif
  48. %description devel
  49. The Readline library provides a set of functions that allow users to
  50. edit typed command lines. If you want to develop programs that will
  51. use the readline library, you need to have the readline-devel package
  52. installed. You also need to have the readline package installed.
  53. %package -n compat32-%{name}
  54. Summary: A library for editing typed in command lines.
  55. Summary(ja): Readline ライブラリ
  56. Group: system,legacy
  57. Requires: %{name} = %{version}-%{release}
  58. %description -n compat32-%{name}
  59. The Readline library provides a set of functions that allow users to
  60. edit command lines. Both Emacs and vi editing modes are available. The
  61. Readline library includes additional functions for maintaining a list
  62. of previously-entered command lines for recalling or editing those
  63. lines, and for performing csh-like history expansion on previous
  64. commands.
  65. %description -n compat32-%{name} -l ja
  66. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  67. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  68. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  69. %package -n compat32-%{name}-devel
  70. Summary: Files needed to develop programs which use the readline library.
  71. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  72. Group: programming,legacy
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: %{name}-devel = %{version}-%{release}
  75. Requires: compat32-ncurses-devel
  76. %description -n compat32-%{name}-devel
  77. The Readline library provides a set of functions that allow users to
  78. edit typed command lines. If you want to develop programs that will
  79. use the readline library, you need to have the readline-devel package
  80. installed. You also need to have the readline package installed.
  81. %debug_package
  82. %prep
  83. %setup -q -n %{name}-%{shortver}
  84. %autopatch -p0 -m0 -M99
  85. %autopatch -p1 -m100
  86. %build
  87. %configure --with-curses --disable-install-examples
  88. make %{?_smp_mflags}
  89. %install
  90. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  91. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  92. make DESTDIR=$RPM_BUILD_ROOT install
  93. mkdir $RPM_BUILD_ROOT/%{_lib}
  94. mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
  95. for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
  96. ln -sf $(echo %{_libdir} | \
  97. sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
  98. done
  99. rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
  100. rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
  101. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  102. %clean
  103. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  104. %files
  105. %defattr(-,root,root)
  106. %license COPYING
  107. %doc CHANGES NEWS README USAGE
  108. /%{_lib}/libreadline*.so.*
  109. %{_libdir}/libhistory*.so.*
  110. %{_infodir}/history.info*
  111. %{_infodir}/rluserman.info*
  112. %files devel
  113. %defattr(-,root,root)
  114. %doc examples/*.c examples/*.h examples/rlfe
  115. %{_includedir}/readline
  116. %{_libdir}/lib*.a
  117. %{_libdir}/lib*.so
  118. %{_libdir}/pkgconfig/*.pc
  119. %{_infodir}/readline.info*
  120. %{_mandir}/man*/*
  121. %if %{build_compat32}
  122. %files -n compat32-%{name}
  123. %defattr(-,root,root)
  124. /%{_lib}/libreadline*.so.*
  125. %{_libdir}/libhistory*.so.*
  126. %files -n compat32-%{name}-devel
  127. %defattr(-,root,root)
  128. %{_libdir}/lib*.a
  129. %{_libdir}/lib*.so
  130. %{_libdir}/pkgconfig/*.pc
  131. %endif
  132. %changelog
  133. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-2
  134. - droped "Provides:pkgconfig(readline)" from compat32.
  135. * Sun Nov 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
  136. - new upstream release.
  137. - updated to patchlevel 001.
  138. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.2-1
  139. - updated to patchlevel 002.
  140. * Fri May 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.1-1
  141. - updated to patchlevel 001.
  142. - dropped ldconfig scriptlets.
  143. * Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1-1
  144. - new upstream release.
  145. - dropped Patch1-4.
  146. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
  147. - updated to patchlevel 004.
  148. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
  149. - new upstream release.
  150. - dropped all of official patches.
  151. - added Patch1.
  152. - dropped Patch9.
  153. - updated Patch10.
  154. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
  155. - new upstream release
  156. - update upstream patches (patch1-8)
  157. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
  158. - rebuild with VineSeed environment
  159. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
  160. - add upstream patches 13,14 (Patch13,14)
  161. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
  162. - rebuilt with new toolchain
  163. - add Requires(post,pre): /sbin/ldconfig
  164. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
  165. - build with ncurses-devel
  166. - spec in utf8
  167. - move libncurses.so.* to %%_lib from %%_libdir
  168. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
  169. - added upstream patches (patch8-12)
  170. * Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
  171. - new upstream release
  172. - update upstream patches (patch1-7)
  173. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
  174. - new upstream release
  175. - update upstream patches (patch1-4)
  176. - add doc/*.{html,pdf} instead of doc/
  177. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
  178. - s/Copyright/License/
  179. - add URL
  180. - update source URL
  181. - add PreReq: ldconfig
  182. - move outdated.patch (patch1) to patch10
  183. - add upstream patches (patch1-5)
  184. - add no_rpath.patch (patch11)
  185. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
  186. - added compat32- packages for x86_64 architecture support
  187. - fixed %files section (TODO* has been removed)
  188. * Sat Mar 8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
  189. - new upstream release 4.3
  190. - merged with rawhide package.
  191. * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
  192. - rebuild in current collinst
  193. - BuildRequires autoconf only
  194. * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
  195. - Fixed Esc-O-M stack overflow bug.
  196. * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
  197. - Updated to latest readline release 4.3
  198. * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
  199. - Fixed problem with alpha build.
  200. * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
  201. - Fixed utf8 problem (originally observed in bash).
  202. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
  203. - automated rebuild
  204. * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
  205. - automated rebuild
  206. * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
  207. - Use autoconf 2.53, not 2.52
  208. * Mon Mar 4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
  209. - Rebuild
  210. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
  211. - removed the manual symlinking of .so, readline handles this by itself
  212. - call only %%makeinstall, not %%makeinstall install install-shared as
  213. this makes bogus .old files in the buildroot
  214. * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
  215. - 4.2a
  216. * Tue Oct 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  217. - Work around autoconf bug
  218. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
  219. - Don't use readline's internal re-implementation of strpbrk on systems
  220. that have strpbrk - the system implementation is faster and better maintained.
  221. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
  222. - Make sure headers can be included from C++ applications (#51131)
  223. (Patch based on Debian's with the bugs removed ;) )
  224. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  225. - update to 4.2 and adapt patches
  226. * Fri Apr 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  227. - change the paths listed for the header files in the man page to reflect
  228. the location changes from previous versions (#35073)
  229. - note that "on" is acceptable instead of "On" in the man page (#21327)
  230. * Thu Mar 8 2001 Preston Brown <pbrown@redhat.com>
  231. - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
  232. * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  233. - mark the man page as currently out-of-date (#25294)
  234. * Tue Sep 4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
  235. - remove texi2dvi and texi2html from doc/
  236. * Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
  237. - added doc and examples
  238. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  239. - 4.1-6vl3
  240. - rebuilt for VineSeed
  241. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  242. - 4.1-6vl2
  243. - Oops, spec was written in SJIS...
  244. * Sat Dec 9 2000 Jun Nishii <jun@vinelinux.org>
  245. - 4.1-6vl1
  246. - got i18n patch from Kondara
  247. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  248. - FHS packaging (64bit systems need to use libdir).
  249. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  250. - summaries from specspo.
  251. * Wed Aug 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  252. - use "rm -f" in specfile
  253. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  254. - automatic rebuild
  255. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  256. - FHS packaging.
  257. * Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  258. - 4.1
  259. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  260. - update to 4.0
  261. * Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
  262. - added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
  263. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  264. - auto rebuild in the new build environment (release 4)
  265. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  266. - updated to 2.2.1
  267. * Wed May 06 1998 Prospector System <bugs@redhat.com>
  268. - translations modified for de, fr, tr
  269. * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
  270. - don't package /usr/info/dir
  271. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  272. - devel package moved to Development/Libraries
  273. * Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
  274. - updated to 2.2
  275. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  276. - spec file cleanups
  277. * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
  278. - added proper sonames
  279. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  280. - updated to readline 2.1
  281. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  282. - built against glibc