rrdtool-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. # Basic Information
  2. Name: rrdtool
  3. Summary: RRDtool - Round Robin Database tool
  4. Summary(ja): RRDtool - ラウンドロビンデータベースツール
  5. Version: 1.7.2
  6. Release: 5%{?_dist_release}
  7. Group: admin-tools,graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: yasumichi
  11. License: GPLv2+ with exceptions
  12. URL: http://oss.oetiker.ch/rrdtool/
  13. Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
  14. Patch3: rrdtool-1.6.0-ruby-2-fix.patch
  15. Patch5: rrdtool-1.7.2-python-rpath-fix.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. # Dependency
  18. BuildRequires: glib2-devel
  19. BuildRequires: glibc-devel
  20. BuildRequires: libdbi-devel
  21. BuildRequires: libxml2-devel
  22. BuildRequires: lua-devel
  23. BuildRequires: pango-devel
  24. BuildRequires: perl(ExtUtils::MakeMaker)
  25. BuildRequires: ruby-devel
  26. BuildRequires: tcl-devel
  27. %description
  28. It is pretty easy to gather status information from all sorts of things,
  29. ranging from the temperature in your office to the number of octets which
  30. have passed through the FDDI interface of your router. But it is not so
  31. trivial to store this data in a efficient and systematic manner. This is
  32. where RRDtool kicks in. It lets you log and analyze the data you gather from
  33. all kinds of data-sources (DS). The data analysis part of RRDtool is based
  34. on the ability to quickly generate graphical representations of the data
  35. values collected over a definable time period.
  36. #%%description -l ja
  37. %package devel
  38. Summary: Libraries and include files of RRDtool
  39. Group: system
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Libraries and include files of RRDtool
  43. %package doc
  44. Summary: RRDtool documentation
  45. Summary(ja): RRDtool のドキュメント
  46. Group: documentation
  47. BuildArch: noarch
  48. %description doc
  49. RRD is the Acronym for Round Robin Database. RRD is a system to store and
  50. display time-series data (i.e. network bandwidth, machine-room temperature,
  51. server load average). This package contains documentation on using RRD.
  52. %package tcl
  53. Summary: RRDTool modules for tcl
  54. Group: programming
  55. Requires: %{name} = %{version}-%{release}
  56. %description tcl
  57. RRDTool bindings for Tcl.
  58. %package -n perl-rrdtool
  59. Summary: Perl RRDtool bindings
  60. Summary(ja): RRDTool の perl バインディング
  61. Group: programming
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: perl >= 2:5.34.0
  64. %description -n perl-rrdtool
  65. The Perl RRDTool bindings.
  66. %package -n python3-rrdtool
  67. Summary: Python3 RRDTool bindings
  68. Summary(ja): RRDTool の Python3 バインディング
  69. Group: programming
  70. BuildRequires: python3-devel
  71. BuildRequires: python3-rpm-macros
  72. BuildRequires: python3-setuptools
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: python(abi) = %{python3_version}
  75. %description -n python3-rrdtool
  76. RDTool bindings for python3.
  77. %package -n ruby-rrdtool
  78. Summary: Ruby RRDTool bindings
  79. Summary(ja): RRDTool の ruby バインディング
  80. Group: programming
  81. Requires: %{name} = %{version}-%{release}
  82. %description -n ruby-rrdtool
  83. RRDtool bindings for Ruby.
  84. %debug_package
  85. %prep
  86. %setup -q
  87. %patch3 -p1 -b .ruby-2-fix
  88. %patch5 -p1 -b .python-rpath-fix
  89. ./bootstrap
  90. %build
  91. export PYTHON=%{__python3}
  92. %configure \
  93. --disable-rpath \
  94. --disable-static \
  95. --enable-perl-site-install \
  96. --with-perl-options="INSTALLDIRS=vendor" \
  97. --enable-ruby \
  98. --enable-ruby-site-install \
  99. --with-pic
  100. # Fix another rpath issue
  101. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
  102. bindings/perl-shared/Makefile.PL
  103. # Remove Rpath from Ruby
  104. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
  105. bindings/ruby/extconf.rb
  106. sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
  107. perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
  108. %{__make} %{?_smp_mflags}
  109. %{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
  110. %install
  111. %{__rm} -rf ${RPM_BUILD_ROOT}
  112. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  113. pushd bindings/python
  114. %{py3_install}
  115. popd
  116. # Install ruby module by force
  117. mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
  118. make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
  119. # We only want .txt and .html files for the main documentation
  120. rm -rf docs_to_be_included
  121. mkdir -p docs_to_be_included/html docs_to_be_included/txt
  122. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
  123. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
  124. # Put perl docs in perl package
  125. rm -rf docs_perl
  126. mkdir -p docs_perl/html
  127. mv docs_to_be_included/html/RRD*.html docs_perl/html/
  128. # Clean up
  129. %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
  130. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
  131. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
  132. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  133. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
  134. chmod -x ${RPM_BUILD_ROOT}%{_datadir}/rrdtool/examples/*.py
  135. %find_lang %{name}
  136. %clean
  137. %{__rm} -rf ${RPM_BUILD_ROOT}
  138. %files -f %{name}.lang
  139. %defattr(-,root,root)
  140. #doc COPYING NEWS README TODO
  141. %{_bindir}/rrd*
  142. %{_libdir}/lua/*/rrd.so.*
  143. %{_libdir}/librrd*.so.*
  144. %{_mandir}/man1/*.1*
  145. %{_datadir}/rrdtool/examples/cgi-demo.cgi
  146. %files devel
  147. %defattr(-,root,root)
  148. %{_includedir}/rrd*.h
  149. %{_libdir}/lua/*/rrd.so
  150. %{_libdir}/librrd.so
  151. %{_libdir}/pkgconfig/librrd.pc
  152. %{_mandir}/man3/librrd.3*
  153. %files doc
  154. %defattr(-,root,root,-)
  155. %license COPYRIGHT LICENSE
  156. %doc CONTRIBUTORS TODO NEWS THREADS
  157. %doc docs_to_be_included/html docs_to_be_included/txt
  158. %files tcl
  159. %defattr(-,root,root)
  160. %doc bindings/tcl/README
  161. #%{_datadir}/rrdtool/ifOctets.tcl
  162. #%{_datadir}/rrdtool/pkgIndex.tcl
  163. %{_libdir}/tclrrd*.so
  164. %{_libdir}/rrdtool/*.tcl
  165. %files -n perl-rrdtool
  166. %defattr(-,root,root)
  167. %{perl_vendorlib}/RRDp.pm
  168. %{perl_vendorarch}/RRDs.pm
  169. %{perl_vendorarch}/auto/RRDs/RRDs.so
  170. %{_datadir}/rrdtool/examples/*.pl
  171. %{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
  172. %{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
  173. %{_mandir}/man3/RRD?.3pm*
  174. %files -n python3-rrdtool
  175. %defattr(-,root,root)
  176. %license bindings/python/COPYING
  177. %doc bindings/python/README*
  178. %{python3_sitearch}/rrdtool-*-py*.egg-info
  179. %{python3_sitearch}/rrdtool.*.so
  180. %{_datadir}/rrdtool/examples/*.py
  181. %files -n ruby-rrdtool
  182. %defattr(-,root,root,-)
  183. %doc bindings/ruby/README
  184. %{ruby_vendorarchdir}/RRD.so
  185. %changelog
  186. * Fri Nov 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-5
  187. - rebuilt with perl-5.34.0.
  188. - dropped ldconfig scriptlets.
  189. * Mon Nov 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-4
  190. - rebuilt with ruby-3.0.2.
  191. - dropped python2 support.
  192. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-3
  193. - fixed dependency.
  194. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-2
  195. - rebuilt with python-3.8.
  196. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
  197. - new upstream release.
  198. - built with ruby-2.6.5.
  199. - added python3 support.
  200. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  201. - new upstream release.
  202. - rebuilt with perl-5.26.
  203. - rebuilt with ruby-2.4.6.
  204. - updated Patch3.
  205. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
  206. - rebuild with ruby-2.2.3
  207. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
  208. - rebuild with libdbi-0.9.0
  209. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
  210. - new upstream release.
  211. - added Group tag to subpackages
  212. - added ruby subpackages
  213. - split documents into subpackages
  214. - added %%post and %%postun section
  215. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
  216. - new upstream release.
  217. * Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
  218. - initial build for Vine Linux