zabbix-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744
  1. %bcond_with systemd
  2. %define only_agent 0
  3. %if %{only_agent}
  4. %bcond_with server
  5. %bcond_with proxy
  6. %bcond_with frontend
  7. %else
  8. %bcond_without server
  9. %bcond_without proxy
  10. %bcond_without frontend
  11. %endif
  12. %bcond_without agent
  13. %global php_pkgname php74
  14. Summary: The Enterprise-class Monitoring Solution for Everyone
  15. Name: zabbix
  16. Version: 6.0.22
  17. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  18. Group: system
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: iwaim
  22. License: GPLv2
  23. URL: https://www.zabbix.com/
  24. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  25. Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
  26. Source1: zabbix_server.init
  27. Source2: zabbix_proxy.init
  28. Source3: zabbix_agentd.init
  29. Source4: zabbix_server.logrotate
  30. Source5: zabbix_proxy.logrotate
  31. Source6: zabbix_agentd.logrotate
  32. Source9: %{name}-tmpfiles-zabbix.conf
  33. # systemd units -- Alternatives switches between them (they state their dependencies)
  34. # https://support.zabbix.com/browse/ZBXNEXT-1593
  35. Source10: %{name}-agent.service
  36. Source11: %{name}-proxy-mysql.service
  37. Source12: %{name}-proxy-pgsql.service
  38. Source14: %{name}-server-mysql.service
  39. Source15: %{name}-server-pgsql.service
  40. Source17: %{name}-tmpfiles-zabbixsrv.conf
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  42. %if %{with server}%{with proxy}
  43. BuildRequires: libpq-devel
  44. BuildRequires: libmariadb-devel
  45. %endif
  46. BuildRequires: libevent-devel
  47. BuildRequires: pcre-devel
  48. BuildRequires: curl-devel
  49. BuildRequires: net-snmp-devel
  50. BuildRequires: OpenIPMI-devel
  51. BuildRequires: unixODBC-devel
  52. BuildRequires: libssh2-devel
  53. BuildRequires: openssl-devel
  54. Requires(pre): glibc-common
  55. Requires(pre): shadow-utils
  56. %if %{with systemd}
  57. BuildRequires: systemd
  58. %endif
  59. %description
  60. The Enterprise-class Monitoring Solution for Everyone.
  61. %if %{with server}
  62. %package server-common
  63. Summary: common files for Zabbix Server
  64. Group: servers
  65. Requires: %{name} == %{version}-%{release}
  66. %if %{with systemd}
  67. %{?systemd_requires}
  68. %else
  69. Requires(post,preun): chkconfig
  70. Requires(preun,postun): initscripts
  71. %endif
  72. %description server-common
  73. This package include common files for Zabbix Server.
  74. %package server-mysql
  75. Summary: Zabbix Server for MySQL/MariaDB
  76. Group: servers
  77. Provides: %{name}-server
  78. Requires: %{name}-server-common == %{version}-%{release}
  79. %description server-mysql
  80. Zabbix Server for MySQL/MariaDB
  81. %package server-postgresql
  82. Summary: Zabbix Server for PostgreSQL
  83. Group: servers
  84. Provides: %{name}-server
  85. Requires: %{name}-server-common == %{version}-%{release}
  86. %description server-postgresql
  87. Zabbix Server for PostgreSQL
  88. %endif
  89. %if %{with agent}
  90. %package agent
  91. Summary: Zabbix Agent
  92. Group: system
  93. Requires: %{name} == %{version}-%{release}
  94. %if %{with systemd}
  95. %{?systemd_requires}
  96. %else
  97. Requires(post,preun): chkconfig
  98. Requires(preun,postun): initscripts
  99. %endif
  100. %description agent
  101. Zabbix Agent
  102. %endif
  103. %if %{with proxy}
  104. %package proxy-common
  105. Summary: common files for Zabbix Proxy
  106. Group: servers
  107. Requires: %{name} == %{version}-%{release}
  108. %if %{with systemd}
  109. %{?systemd_requires}
  110. %else
  111. Requires(post,preun): chkconfig
  112. Requires(preun,postun): initscripts
  113. %endif
  114. %description proxy-common
  115. This package include common files for Zabbix Proxy
  116. %package proxy-mysql
  117. Summary: Zabbix Proxy for MySQL/MariaDB
  118. Group: servers
  119. Provides: %{name}-proxy
  120. Requires: %{name}-proxy-common == %{version}-%{release}
  121. %description proxy-mysql
  122. Zabbix Proxy for MySQL/MariaDB
  123. %package proxy-postgresql
  124. Summary: Zabbix Proxy for PostgreSQL
  125. Group: servers
  126. Provides: %{name}-proxy
  127. Requires: %{name}-proxy-common == %{version}-%{release}
  128. %description proxy-postgresql
  129. Zabbix Proxy for PostgreSQL
  130. %endif
  131. %if %{with frontend}
  132. %package frontend-php
  133. Summary: Zabbix web frontend with PHP
  134. Group: servers
  135. Requires: %{php_pkgname}
  136. Requires: TrueType-vlgothic
  137. %description frontend-php
  138. Zabbix web frontend with PHP.
  139. %package frontend-php-mysql
  140. Summary: Zabbix web frontend with PHP and MySQL/MariaDB
  141. Group: servers
  142. Provides: %{name}-frontend-php == %{version}-%{release}
  143. Requires: %{php_pkgname}-mysql
  144. %description frontend-php-mysql
  145. Zabbix web frontend with PHP and MySQL/MariaDB.
  146. %package frontend-php-postgresql
  147. Summary: Zabbix web frontend with PHP and PostgreSQL
  148. Group: servers
  149. Provides: %{name}-frontend-php == %{version}-%{release}
  150. Requires: %{php_pkgname}-pgsql
  151. %description frontend-php-postgresql
  152. Zabbix web frontend with PHP and PostgreSQL.
  153. %endif
  154. %debug_package
  155. %prep
  156. %setup -q -T -a 0 -c -n zabbix-%{version}
  157. mv zabbix-%{version} zabbix_mysql
  158. %if %{with server}%{with proxy}
  159. %setup -q -D -T -a 0 -n zabbix-%{version}
  160. mv zabbix-%{version} zabbix_pgsql
  161. %endif
  162. for v in mysql pgsql; do
  163. pushd zabbix_$v
  164. sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
  165. sed -i \
  166. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
  167. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
  168. conf/zabbix_agentd.conf
  169. sed -i \
  170. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
  171. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
  172. conf/zabbix_proxy.conf
  173. sed -i \
  174. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
  175. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
  176. conf/zabbix_server.conf
  177. #'
  178. popd
  179. done
  180. %build
  181. Build()
  182. {
  183. perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
  184. ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
  185. %configure \
  186. %{?with_server:--enable-server} \
  187. %{?with_proxy:--enable-proxy} \
  188. %{?with_agent:--enable-agent} \
  189. --enable-ipv6 \
  190. --sysconfdir=%{_sysconfdir}/zabbix \
  191. --with-libcurl \
  192. --with-openipmi \
  193. --with-net-snmp \
  194. --with-unixodbc \
  195. --with-ssh2 \
  196. --with-openssl \
  197. $@
  198. %__make
  199. }
  200. %if %{with server}%{with proxy}
  201. pushd zabbix_mysql
  202. Build --with-mysql
  203. popd
  204. pushd zabbix_pgsql
  205. Build --with-postgresql
  206. popd
  207. %else
  208. pushd zabbix_mysql
  209. Build
  210. popd
  211. %endif
  212. %install
  213. %__rm -rf %{buildroot}
  214. pushd zabbix_mysql
  215. make DESTDIR=%{buildroot} install
  216. %if %{with server}
  217. mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
  218. %endif
  219. %if %{with proxy}
  220. mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
  221. %endif
  222. # make directories
  223. %__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
  224. # DB
  225. %__mkdir_p %{buildroot}%{_datadir}/zabbix
  226. %if %{with server}%{with proxy}
  227. %__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
  228. %__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
  229. %endif
  230. %if %{with systemd}
  231. # unit files
  232. %__mkdir_p %{buildroot}%{_unitdir}
  233. # Install different systemd units because of the requirements for DBMS daemons
  234. install -m 0644 -p %{SOURCE10} %{buildroot}%{_unitdir}/zabbix-agent.service
  235. install -m 0644 -p %{SOURCE11} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
  236. install -m 0644 -p %{SOURCE12} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
  237. install -m 0644 -p %{SOURCE14} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
  238. install -m 0644 -p %{SOURCE15} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
  239. # systemd tmpfiles
  240. mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
  241. install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
  242. %else
  243. # init.d
  244. %__mkdir_p %{buildroot}%{_initddir}
  245. %if %{with server}
  246. %__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
  247. %endif
  248. %if %{with proxy}
  249. %__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
  250. %endif
  251. %if %{with agent}
  252. %__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
  253. %endif
  254. %endif
  255. # logrotate
  256. %__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
  257. %if %{with server}
  258. %__cp %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
  259. %endif
  260. %if %{with proxy}
  261. %__cp %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
  262. %endif
  263. %if %{with agent}
  264. %__cp %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
  265. %endif
  266. %if %{with frontend}
  267. # frontend-php
  268. %__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
  269. %__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
  270. %__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
  271. ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
  272. %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
  273. %endif
  274. %if %{with proxy}
  275. # proxy
  276. mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
  277. ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
  278. ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
  279. %endif
  280. popd
  281. %if %{with server}%{with proxy}
  282. pushd zabbix_pgsql
  283. install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
  284. install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
  285. popd
  286. %endif
  287. %clean
  288. %__rm -rf %{buildroot}
  289. %pre
  290. getent group zabbix >/dev/null || groupadd -r zabbix
  291. getent passwd zabbix >/dev/null || \
  292. useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
  293. -c "Zabbix Monitoring Solution" zabbix
  294. exit 0
  295. %if %{with server}
  296. %post server-mysql
  297. %if %{with systemd}
  298. %systemd_post zabbix-server-mysql.service
  299. %else
  300. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  301. zabbix_server /usr/sbin/zabbix_server.mysql 10
  302. %endif
  303. %post server-postgresql
  304. %if %{with systemd}
  305. %systemd_post zabbix-server-pgsql.service
  306. %else
  307. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  308. zabbix_server /usr/sbin/zabbix_server.pgsql 10
  309. /sbin/chkconfig --add zabbix_server
  310. %endif
  311. %endif
  312. %if %{with proxy}
  313. %post proxy-mysql
  314. %if %{with systemd}
  315. %systemd_post zabbix-proxy-mysql.service
  316. %else
  317. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  318. zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
  319. /sbin/chkconfig --add zabbix_proxy
  320. %endif
  321. %post proxy-postgresql
  322. %if %{with systemd}
  323. %systemd_post zabbix-proxy-pgsql.service
  324. %else
  325. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  326. zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
  327. /sbin/chkconfig --add zabbix_proxy
  328. %endif
  329. %endif
  330. %if %{with agent}
  331. %post agent
  332. %if %{with systemd}
  333. %systemd_post zabbix-agent.service
  334. %else
  335. /sbin/chkconfig --add zabbix_agentd
  336. %endif
  337. %endif
  338. %if %{with server}
  339. %preun server-mysql
  340. %if %{with systemd}
  341. %systemd_preun zabbix-server-mysql.service
  342. %else
  343. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  344. /sbin/service zabbix_server stop >/dev/null 2>&1
  345. /sbin/chkconfig --del zabbix_server
  346. /sbin/update-alternatives --remove zabbix_server \
  347. /usr/sbin/zabbix_server.mysql
  348. fi
  349. %endif
  350. %preun server-postgresql
  351. %if %{with systemd}
  352. %systemd_preun zabbix-server-pgysql.service
  353. %else
  354. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  355. /sbin/service zabbix_server stop >/dev/null 2>&1
  356. /sbin/chkconfig --del zabbix_server
  357. /sbin/update-alternatives --remove zabbix_server \
  358. /usr/sbin/zabbix_server.pgsql
  359. fi
  360. %endif
  361. %endif
  362. %if %{with proxy}
  363. %preun proxy-mysql
  364. %if %{with systemd}
  365. %systemd_preun zabbix-proxy-mysql.service
  366. %else
  367. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  368. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  369. /sbin/chkconfig --del zabbix_proxy
  370. /sbin/update-alternatives --remove zabbix_proxy \
  371. /usr/sbin/zabbix_proxy.mysql
  372. fi
  373. %endif
  374. %preun proxy-postgresql
  375. %if %{with systemd}
  376. %systemd_preun zabbix-proxy-pgsql.service
  377. %else
  378. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  379. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  380. /sbin/chkconfig --del zabbix_proxy
  381. /sbin/update-alternatives --remove zabbix_proxy \
  382. /usr/sbin/zabbix_proxy.pgsql
  383. fi
  384. %endif
  385. %endif
  386. %if %{with agent}
  387. %preun agent
  388. %if %{with systemd}
  389. %systemd_preun zabbix-agent.service
  390. %else
  391. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  392. /sbin/service zabbix_agentd stop >/dev/null 2>&1
  393. /sbin/chkconfig --del zabbix_agentd
  394. fi
  395. %endif
  396. %endif
  397. %if %{with server}
  398. %postun server-mysql
  399. %if %{with systemd}
  400. %systemd_postun_with_restart zabbix-server-mysql.service
  401. %else
  402. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  403. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  404. fi
  405. %endif
  406. %postun server-postgresql
  407. %if %{with systemd}
  408. %systemd_postun_with_restart zabbix-server-pgsql.service
  409. %else
  410. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  411. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  412. fi
  413. %endif
  414. %endif
  415. %if %{with proxy}
  416. %postun proxy-mysql
  417. %if %{with systemd}
  418. %systemd_postun_with_restart zabbix-proxy-mysql.service
  419. %else
  420. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  421. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  422. fi
  423. %endif
  424. %postun proxy-postgresql
  425. %if %{with systemd}
  426. %systemd_postun_with_restart zabbix-proxy-pgsql.service
  427. %else
  428. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  429. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  430. fi
  431. %endif
  432. %postun agent
  433. %if %{with systemd}
  434. %systemd_postun_with_restart zabbix-agent.service
  435. %else
  436. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  437. /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
  438. fi
  439. %endif
  440. %endif
  441. %files
  442. %defattr(-,root,root,-)
  443. %license zabbix_mysql/COPYING
  444. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  445. %attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
  446. %dir %{_datadir}/zabbix
  447. %if %{with server}%{with proxy}
  448. %{_datadir}/zabbix/mysql
  449. %{_datadir}/zabbix/postgresql
  450. %endif
  451. %if %{with systemd}
  452. %{_prefix}/lib/tmpfiles.d/zabbix.conf
  453. %endif
  454. %{_bindir}/zabbix_js
  455. %if %{with server}
  456. %files server-common
  457. %defattr(-,root,root,-)
  458. %dir %{_sysconfdir}/zabbix
  459. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
  460. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
  461. %if !%{with systemd}
  462. %{_initddir}/zabbix_server*
  463. %endif
  464. %{_mandir}/man8/zabbix_server.8*
  465. %files server-mysql
  466. %defattr(-,root,root,-)
  467. %{_sbindir}/zabbix_server.mysql
  468. %if %{with systemd}
  469. %{_unitdir}/zabbix-server-mysql.service
  470. %endif
  471. %files server-postgresql
  472. %defattr(-,root,root,-)
  473. %{_sbindir}/zabbix_server.pgsql
  474. %if %{with systemd}
  475. %{_unitdir}/zabbix-server-pgsql.service
  476. %endif
  477. %endif
  478. %if %{with agent}
  479. %files agent
  480. %defattr(-,root,root,-)
  481. %dir %{_sysconfdir}/zabbix
  482. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
  483. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
  484. %{_bindir}/zabbix_get
  485. %{_bindir}/zabbix_sender
  486. %{_sbindir}/zabbix_agentd
  487. %if %{with systemd}
  488. %{_unitdir}/zabbix-agent.service
  489. %else
  490. %{_initddir}/zabbix_agentd
  491. %endif
  492. %{_mandir}/man1/zabbix_get.1*
  493. %{_mandir}/man1/zabbix_sender.1*
  494. %{_mandir}/man8/zabbix_agentd.8*
  495. %endif
  496. %if %{with proxy}
  497. %files proxy-common
  498. %defattr(-,root,root,-)
  499. %dir %{_sysconfdir}/zabbix
  500. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
  501. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
  502. %if !%{with systemd}
  503. %{_initddir}/zabbix_proxy
  504. %endif
  505. %{_mandir}/man8/zabbix_proxy.8*
  506. %{_datadir}/zabbix-proxy
  507. %files proxy-mysql
  508. %defattr(-,root,root,-)
  509. %{_sbindir}/zabbix_proxy.mysql
  510. %if %{with systemd}
  511. %{_unitdir}/zabbix-proxy-mysql.service
  512. %endif
  513. %files proxy-postgresql
  514. %defattr(-,root,root,-)
  515. %{_sbindir}/zabbix_proxy.pgsql
  516. %if %{with systemd}
  517. %{_unitdir}/zabbix-proxy-pgsql.service
  518. %endif
  519. %endif
  520. %if %{with frontend}
  521. %files frontend-php
  522. %defattr(-,root,root,-)
  523. %license zabbix_mysql/COPYING
  524. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  525. %dir %{_datadir}/zabbix-frontend
  526. %{_datadir}/zabbix-frontend/php
  527. %files frontend-php-mysql
  528. %files frontend-php-postgresql
  529. %endif
  530. %changelog
  531. * Wed Oct 18 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.22-1
  532. - new upstream release.
  533. * Wed Jul 26 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.19-1
  534. - new upstream release.
  535. * Fri Apr 14 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.16-1
  536. - new upstream release.
  537. * Sat Dec 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.12-1
  538. - new upstream release.
  539. * Fri Sep 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.8-1
  540. - new upstream release.
  541. * Fri Jul 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.6-1
  542. - new upstream release.
  543. * Sat Jan 22 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.19-1
  544. - new upstream release.
  545. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  546. - new upstream release.
  547. * Tue Aug 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.15-1
  548. - new upstream release.
  549. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  550. - new upstream release.
  551. * Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.6-1
  552. - new upstream release.
  553. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  554. - new upstream release.
  555. * Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  556. - new upstream release.
  557. - dropped all patches: made to get the same effect by another method.
  558. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
  559. - rebuilt with libevent-2.1.11.
  560. * Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
  561. - new upstream release.
  562. - dropped Patch3: fixed in upstream.
  563. - changed R:php5 to R:php74.
  564. - added systemd support (disabled as default).
  565. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
  566. - new upstream release.
  567. - imported Patch13 from upstream to support php74.
  568. * Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  569. - new upstream release.
  570. - updated patches.
  571. * Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  572. - new upstream release.
  573. - switched to 4.0 LTS.
  574. - dropped Patch0: made to get same effect by another method.
  575. - updated Patch1 and 2.
  576. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
  577. - new upstream release.
  578. * Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
  579. - accept building only agent
  580. * Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
  581. - new upstream release.
  582. * Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  583. - new upstream release.
  584. * Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  585. - new upstream release.
  586. - disabled jabber support.
  587. * Wed Sep 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
  588. - new upstream release.
  589. * Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  590. - new upstream release.
  591. * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  592. - new upstream release.
  593. - built with both of mysql and postgresql.
  594. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  595. - update to 2.0.8
  596. * Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
  597. - use %%bcond_with mysql to build with mysql
  598. * Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
  599. - update to 2.0.5
  600. - add using MySQL client library switch: default no
  601. - define use_postfix and use_mysql
  602. - add BuildRequires: MySQL-devel
  603. - add configure option: --with-mysql
  604. * Thu Feb 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
  605. - initial build for Vine Linux