Browse Source

fix to build on VineSeed

Daisuke SUZUKI 4 months ago
parent
commit
14f8752582
2 changed files with 5 additions and 6 deletions
  1. 1 2
      Makefile
  2. 4 4
      vbootstrap-vl.spec

+ 1 - 2
Makefile

@@ -74,14 +74,13 @@ tarbz2: clean
 	fi
 	rm -rf ${NAME}-${VERSION}
 
-tarxz: clean
+tarxz:
 	git archive HEAD --prefix=${NAME}-${VERSION}/ --output=../${NAME}-${VERSION}.tar.xz
 	@if [ -d ~/rpm/SOURCES/${NAME} ]; then \
 		mv ../${NAME}-${VERSION}.tar.xz ~/rpm/SOURCES/${NAME}; \
 	else \
 		mv ../${NAME}-${VERSION}.tar.xz ~/rpm/SOURCES/; \
 	fi
-	rm -rf ${NAME}-${VERSION}
 
 rpm: tarxz
 	rpmbuild -ba ${NAME}-vl.spec

+ 4 - 4
vbootstrap-vl.spec

@@ -18,7 +18,7 @@ Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 BuildRequires: sed
 Requires: bash, apt
-%if %{?_dist_release} >= "vl7"
+%if "%{?_dist_release}" >= "vl7"
 Requires: aufs-util
 %else
 Requires: unionfs-utils
@@ -57,13 +57,13 @@ vbuilder は vbootstrap を利用して chroot 環境の構築し、
 
 %build
 %__make \
-    %if %{?_dist_release} == "vl6"
+    %if "%{?_dist_release}" == "vl6"
       VBUILDER_DEFAULT_VERSION=6.5
     %endif
-    %if %{?_dist_release} == "vl5"
+    %if "%{?_dist_release}" == "vl5"
       VBUILDER_DEFAULT_VERSION=5.2
     %endif
-    %if %{?_dist_release} == "vl4"
+    %if "%{?_dist_release}" == "vl4"
       VBUILDER_DEFAULT_VERSION=4.2
     %endif