vbootstrap.spec 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # This package is maintained with CVS. Please do not change on local.
  2. # If you find a BUG, report to Vine@vinelinux.org or mailing list or BTS.
  3. # $Id: vbootstrap.spec,v 1.4 2009/06/28 15:54:18 daisuke Exp $
  4. %define version 0.0.3
  5. Summary: bootstrap scripts to create a basic Vine Linux system
  6. Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
  7. Name: vbootstrap
  8. Version: %{version}
  9. Release: 1%{?_dist_release}
  10. License: public domain
  11. Group: Development/Tools
  12. Url: http://trac.vinelinux.org/wiki/VineBootstrap
  13. Source0: %{name}-%{version}.tar.bz2
  14. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildArch: noarch
  16. BuildRequires: sed
  17. Requires: bash, apt
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: daisuke, munepi
  21. %description
  22. vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
  23. system. It uses rpm and apt to install basic rpm package into a directory
  24. which can be chrooted into.
  25. %description -l ja
  26. vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
  27. 作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
  28. 以下に基本の rpm パッケージをインストールし、chroot できるようにします。
  29. %prep
  30. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  31. %setup
  32. %build
  33. make
  34. %install
  35. make DESTDIR=$RPM_BUILD_ROOT install
  36. %clean
  37. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  38. %files
  39. %defattr(-,root,root)
  40. %{_sbindir}/vbootstrap
  41. %{_sbindir}/vbuilder
  42. %dir %{_datadir}/vbootstrap
  43. %{_datadir}/vbootstrap/*
  44. %changelog
  45. * Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
  46. - support 5.0 (by daisuke-san)
  47. - update vbuilder.sh.in
  48. - check chroot archtecture
  49. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
  50. - add vbuilder
  51. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
  52. - initial build