Browse Source

updated 12 packages

acl-2.2.53-2

alsa-firmware-1.2.4-1

alsa-lib-1.2.4-1

alsa-utils-1.2.4-1

attr-2.4.48-2

bison-3.7.6-1

dar-2.6.13-1

e2fsprogs-1.46.2-1

fxload-2008_10_13-1

par2cmdline-0.8.1-2

python-netifaces-0.10.9-1

xz-5.2.5-2
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
e9727469ba

+ 31 - 36
a/acl/acl-vl.spec

@@ -3,16 +3,18 @@
 Name: acl
 Summary: Access control list utilities
 Version: 2.2.53
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Base
 License: GPLv2+
 URL: http://oss.sgi.com/projects/xfs/
-
 Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
-
-Vendor:        Project Vine
-Distribution:  Vine Linux
+# avoid permission denied problem with LD_PRELOAD in the test-suite
+Patch1: 0001-acl-2.2.53-test-runwrapper.patch
+# make __acl_create_entry_obj() work with LTO enabled (#1873975)
+Patch2: 0002-acl-2.2.53-setattr-segv.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: gawk
@@ -25,10 +27,11 @@ Requires: libacl = %{version}-%{release}
 This package contains the getfacl and setfacl utilities needed for
 manipulating access control lists.
 
+
 %package -n libacl
 Summary: Dynamic library for access control list support
 License: LGPLv2+
-Group: System Environment/Libraries
+Group: system
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -37,10 +40,11 @@ This package contains the libacl.so dynamic library which contains
 the POSIX 1003.1e draft standard 17 functions for manipulating access
 control lists.
 
+
 %package -n libacl-devel
 Summary: Access control list static libraries and headers.
 License: LGPLv2+
-Group: Development/Libraries
+Group: programming
 Requires: libacl = %{version}-%{release}
 Requires: libattr-devel
 
@@ -49,12 +53,12 @@ This package contains static libraries and header files needed to develop
 programs which make use of the access control list programming interface
 defined in POSIX 1003.1e draft standard 17.
 
-%if %build_compat32
 
+%if %build_compat32
 %package -n compat32-libacl
 Summary: Dynamic library for access control list support
 License: LGPLv2+
-Group: System Environment/Libraries
+Group: system,legacy
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -62,31 +66,33 @@ Requires(postun): /sbin/ldconfig
 This package contains the libacl.so dynamic library which contains
 the POSIX 1003.1e draft standard 17 functions for manipulating access
 control lists.
-
 %endif
 
+
+%debug_package
+
+
 %prep
 %setup -q
+%autopatch -p1
+
 
 %build
 touch .census
 # acl abuses libexecdir
 %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
-make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
+%make_build
+
 
 %install
 rm -rf %{buildroot}
-make install DESTDIR=%{buildroot}
-#make install-dev DESTDIR=%{buildroot}
-#make install-lib DESTDIR=%{buildroot}
+%make_install
 
 mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
 
 # get rid of libacl.a and libacl.la
-rm -f %{buildroot}/%{_lib}/libacl.a
-rm -f %{buildroot}/%{_lib}/libacl.la
-rm -f %{buildroot}%{_libdir}/libacl.a
-rm -f %{buildroot}%{_libdir}/libacl.la
+rm -f %{buildroot}/%{_lib}/libacl.{a,la}
+rm -f %{buildroot}%{_libdir}/libacl.{a,la}
 
 # fix links to shared libs and permissions
 rm -f %{buildroot}%{_libdir}/libacl.so
@@ -98,6 +104,7 @@ mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
 
 %find_lang %{name}
 
+
 %check
 if ./setfacl/setfacl -m u:`id -u`:rwx .; then
     make tests || exit $?
@@ -109,24 +116,10 @@ else
          'the test-suite will NOT run ***'
 fi
 
+
 %clean
 rm -rf %{buildroot}
 
-%post -n libacl
-/sbin/ldconfig
-
-%postun -n libacl
-/sbin/ldconfig
-
-%if %build_compat32
-
-%post -n compat32-libacl
-/sbin/ldconfig
-
-%postun -n compat32-libacl
-/sbin/ldconfig
-
-%endif
 
 %files -f %{name}.lang
 %defattr(-,root,root)
@@ -153,14 +146,16 @@ rm -rf %{buildroot}
 /%{_lib}/libacl.so.*
 
 %if %build_compat32
-
 %files -n compat32-libacl
 %defattr(-,root,root,-)
 /%{_lib}/libacl.so.*
-
 %endif
 
+
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-2
+- dropped scriptlets.
+
 * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
 - new upstream release.
 - dropped all patches: fixed in upstream.

+ 12 - 5
a/alsa-firmware/alsa-firmware-vl.spec

@@ -5,19 +5,22 @@
 Summary:        Firmware for several ALSA-supported sound cards
 Summary(ja):    ALSA がサポートするサウンドカード用のファームウェア
 Name:           alsa-firmware
-Version:        1.2.1
+Version:        1.2.4
 Release:        1%{?_dist_release}
-Group:          Applications/Multimedia
+Group:          multimedia
 Vendor:         Project Vine
 Distribution:   Vine Linux
 Packager:       shaolin
+
 # See later in the spec for a breakdown of licensing
 License:        GPL+ and BSD and GPLv2+ and GPLv2 and LGPLv2+
 URL:            https://www.alsa-project.org/wiki/Main_Page
-Source0:        ftp://ftp.alsa-project.org/pub/firmware/%{name}-%{version}.tar.bz2
+#Source0:        ftp://ftp.alsa-project.org/pub/firmware/%{name}-%{version}.tar.bz2
+Source0:        https://github.com/alsa-project/alsa-firmware/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+
 Source1:        alsa-firmware.README
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires:       alsa-tools-firmware >= %{version}
+Requires:       alsa-tools-firmware >= 1.2.2
 BuildRequires:  automake
 BuildRequires:  autoconf
 #Requires:       eudev
@@ -81,7 +84,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
-%doc COPYING README*
+%license COPYING
+%doc README*
 
 # License: KOS (BSD-alike)
 /lib/firmware/aica_firmware.bin
@@ -215,6 +219,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.4-1
+- new upstream release.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.1-1
 - new upstream release.
 

+ 9 - 9
a/alsa-lib/alsa-lib-vl.spec

@@ -2,7 +2,7 @@
 Summary: Advanced Linux Sound Architecture (ALSA) Library
 Summary(ja): Advanced Linux Sound Architecture (ALSA) ライブラリ
 Name: alsa-lib
-Version: 1.2.3.2
+Version: 1.2.4
 Release: 1%{?_dist_release}
 Group: system
 Vendor: Project Vine
@@ -11,7 +11,8 @@ Packager: shaolin
 
 License: LGPLv2+
 URL: https://www.alsa-project.org/wiki/Main_Page
-Source: ftp://ftp.alsa-project.org/pub/lib/alsa-lib-%{version}.tar.bz2
+#Source: ftp://ftp.alsa-project.org/pub/lib/alsa-lib-%{version}.tar.bz2
+Source: https://github.com/alsa-project/alsa-lib/archive/v%{version}.tar.gz#/alsa-lib-%{version}.tar.gz
 Source10: asound.conf
 Source11: modprobe-dist-alsa.conf
 Source12: modprobe-dist-oss.conf
@@ -83,7 +84,7 @@ Advanced Linux Sound Architecture (ALSA) - ライブラリ
 %package -n compat32-%{name}
 Summary: Advanced Linux Sound Architecture (ALSA) Library
 Summary(ja): Advanced Linux Sound Architecture (ALSA) ライブラリ
-Group: system
+Group: system,legacy
 Requires: alsa-lib = %{version}
 
 %description -n compat32-%{name}
@@ -114,7 +115,6 @@ Features
   - full mixer compatibity
   - full PCM (/dev/dsp) compatibility
 
-
 %description -n compat32-%{name} -l ja
 Advanced Linux Sound Architecture (ALSA) - ライブラリ
 
@@ -159,7 +159,7 @@ alsa-lib-develパッケージは静的ライブラリとヘッダファイルを
 %package -n compat32-%{name}-devel
 Summary: Development files for alsa-lib
 Summary(ja): alsa-lib の開発用ファイル
-Group: programming
+Group: programming,legacy
 Requires: %{name}-devel    = %{version}
 Requires: compat32-%{name} = %{version}
 
@@ -235,10 +235,6 @@ sed -e '/ipc_perm {/i\\tipc_gid {\n\t\t@func refer\n\t\tname defaults.pcm.ipc_gi
 rm -rf %{buildroot}
 
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-
 %files
 %defattr(-, root, root)
 %{!?_licensedir:%global license %%doc}
@@ -282,6 +278,10 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-1
+- new upstream release.
+- dropped scriptlets.
+
 * Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.3.2-1
 - new upstream release.
 - dropped Patch0: made to get same effect with sed.

+ 12 - 3
a/alsa-utils/alsa-utils-vl.spec

@@ -3,10 +3,10 @@
 Summary: Advanced Linux Sound Architecture (ALSA) Utils
 Summary(ja): Advanced Linux Sound Architecture (ALSA) ユーティリティ集
 Name: alsa-utils
-Version: 1.2.2
+Version: 1.2.4
 Release: 1%{?_dist_release}
 License: GPL
-Group: Applications/Multimedia
+Group: multimedia
 Vendor: Project Vine
 Distribution: Vine Linux
 Packager: shaolin
@@ -38,10 +38,14 @@ Advanced Linux Sound Architecture (ALSA) - Utils
 Advanced Linux Sound Architecture (ALSA) - ユーティリティ集
 
 
+%debug_package
+
+
 %prep
 %setup -q
 %patch0 -p1 -b .conf
 
+
 %build
 autoreconf -vif
 %configure --sbindir=/sbin
@@ -82,6 +86,7 @@ touch %{buildroot}/etc/asound.state
 %clean
 rm -rf %{buildroot}
 
+
 %pretrans
 if [ ! -h %{_datadir}/alsa/init ]; then
     mv %{_datadir}/alsa/init %{_datadir}/alsa/init.rpmsave > /dev/null 2>&1 ||:
@@ -104,7 +109,7 @@ exit 0
 %config /etc/alsa/*
 /sbin/*
 /lib/alsa/init/*
-/lib/udev/rules.d/89-alsa-ucm.rules
+#/lib/udev/rules.d/89-alsa-ucm.rules
 /lib/udev/rules.d/90-alsa-restore.rules
 %{_bindir}/*
 %{_sbindir}/*
@@ -115,7 +120,11 @@ exit 0
 %{_mandir}/*/man?/*
 %ghost /etc/asound.state
 
+
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-1
+- new upstream release.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.2-1
 - new upstream release.
 

+ 42 - 37
a/attr/attr-vl.spec

@@ -3,16 +3,26 @@
 Summary: Utilities for managing filesystem extended attributes
 Name: attr
 Version: 2.4.48
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
 License: GPLv2+
 URL: http://oss.sgi.com/projects/xfs/
-Group: System Environment/Base
-
 Source: http://download.savannah.nongnu.org/releases/attr/attr-%{version}.tar.gz
 
-Vendor:        Project Vine
-Distribution:  Vine Linux
+# fix test-suite failure with perl-5.26.0 (#1473853)
+Patch1:  0001-attr-2.4.48-test-suite-perl.patch
+
+# fix conflict with fakechroot (https://github.com/dex4er/fakechroot/issues/57)
+Patch2:  0002-attr-2.4.48-switch-back-to-syscall.patch
+
+# xattr.conf: remove entries for NFSv4 ACLs namespaces (#1031423)
+# https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00000.html
+# https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00001.html
+# https://lists.nongnu.org/archive/html/acl-devel/2019-05/msg00000.html
+Patch3:  0003-attr-2.4.48-xattr-conf-nfs4-acls.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: gettext
@@ -27,18 +37,20 @@ objects, in particular getfattr(1) and setfattr(1).
 An attr(1) command is also provided which is largely compatible
 with the SGI IRIX tool of the same name.
 
+
 %package -n libattr
 Summary: Dynamic library for extended attribute support
-Group: System Environment/Libraries
+Group: system
 License: LGPLv2+
 
 %description -n libattr
 This package contains the libattr.so dynamic library which contains
 the extended attribute system calls and library functions.
 
+
 %package -n libattr-devel
 Summary: Extended attribute static libraries and headers
-Group: Development/Libraries
+Group: programming
 License: LGPLv2+
 Requires: libattr = %{version}-%{release}
 
@@ -57,10 +69,11 @@ You should install libattr-devel if you want to develop programs
 which make use of extended attributes.  If you install libattr-devel,
 you'll also want to install attr.
 
+
 # compat32
 %package -n compat32-libattr
 Summary: Dynamic library for extended attribute support
-Group: System Environment/Libraries
+Group: system,legacy
 License: LGPLv2+
 
 %description -n compat32-libattr
@@ -69,7 +82,7 @@ the extended attribute system calls and library functions.
 
 %package -n compat32-libattr-devel
 Summary: Extended attribute static libraries and headers
-Group: Development/Libraries
+Group: programming,legacy
 License: LGPLv2+
 Requires: libattr-devel = %{version}-%{release}
 Requires: compat32-libattr = %{version}-%{release}
@@ -90,25 +103,27 @@ which make use of extended attributes.  If you install libattr-devel,
 you'll also want to install attr.
 
 
+%debug_package
+
+
 %prep
 %setup -q
+%autopatch -p1
+
 
 %build
 # attr abuses libexecdir
 %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
-make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
+%make_build
+
 
 %install
 rm -rf %{buildroot}
-make install DESTDIR=%{buildroot}
-#make install-dev DESTDIR=%{buildroot}
-#make install-lib DESTDIR=%{buildroot}
+%make_install
 
 # get rid of libattr.a and libattr.la
-rm -f %{buildroot}/%{_lib}/libattr.a
-rm -f %{buildroot}/%{_lib}/libattr.la
-rm -f %{buildroot}%{_libdir}/libattr.a
-rm -f %{buildroot}%{_libdir}/libattr.la
+rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.{l,}a
+rm -f $RPM_BUILD_ROOT%{_libdir}/libattr.{l,}a
 
 # fix links to shared libs and permissions
 rm -f %{buildroot}%{_libdir}/libattr.so
@@ -123,14 +138,10 @@ mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
 
 %find_lang %{name}
 
+
 %check
-if ./setfattr/setfattr -n user.name -v value .; then
+if ./setfattr -n user.name -v value .; then
     make tests || exit $?
-
-    # FIXME: root-tests are not ready for the SELinux
-    #if test 0 = `id -u`; then
-    #    make root-tests || exit $?
-    #fi
 else
     echo '*** xattrs are probably not supported by the file system,' \
          'the test-suite will NOT run ***'
@@ -139,29 +150,18 @@ fi
 %clean
 rm -rf %{buildroot}
 
-%post -n libattr
-/sbin/ldconfig
-
-%postun -n libattr
-/sbin/ldconfig
-
-%post -n compat32-libattr
-/sbin/ldconfig
-
-%postun -n compat32-libattr
-/sbin/ldconfig
 
 %files -f %{name}.lang
 %defattr(-,root,root)
-%doc doc
+%doc doc/CHANGES
+%license doc/COPYING*
 %{_bindir}/attr
 %{_bindir}/getfattr
 %{_bindir}/setfattr
 %{_mandir}/man1/attr.1*
 %{_mandir}/man1/getfattr.1*
 %{_mandir}/man1/setfattr.1*
-#%{_mandir}/man5/attr.5*
-%exclude %{_mandir}/man5/attr.5*
+
 
 %files -n libattr-devel
 %defattr(-,root,root)
@@ -188,7 +188,12 @@ rm -rf %{buildroot}
 %config(noreplace) %{_sysconfdir}/xattr.conf
 %endif
 
+
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-2
+- dropped scriptlets.
+- imported Patch1-3 from rawhide.
+
 * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-1
 - new upstream release.
 - dropped Patch1, 2.

+ 4 - 1
b/bison/bison-vl.spec

@@ -3,7 +3,7 @@
 Summary:        A GNU general-purpose parser generator.
 Summary(ja):    GNU 汎用構文解析器生成プログラム
 Name:           bison
-Version:        3.7.5
+Version:        3.7.6
 Release:        1%{?_dist_release}
 Group:          programming
 Vendor:         Project Vine
@@ -118,6 +118,9 @@ fi
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.6-1
+- new upstream release.
+
 * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7.5-1
 - new upstream release.
 

+ 15 - 9
d/dar/dar-vl.spec

@@ -1,10 +1,9 @@
 Name:           dar
 Summary:        Disk ARchive: Backup directory tree and files
 Summary(ja):    ディスクアーカイブ: ディレクトリツリーとファイルをバックアップ
-Version:        2.6.6
+Version:        2.6.13
 Release:        1%{?_dist_release}
-Group:          Applications/Archiving
-
+Group:          accessories
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
@@ -34,24 +33,30 @@ to handle extented attributes, and can make remote backups through an
 ssh session for example. Finally, DAR handles save and restore of hard
 and symbolic links.
 
+
 %package -n libdar
 Summary:    Library providing support for the DAR API
 Summary(ja): DAR API をサポートするライブラリ
-Group:      System Environment/Libraries
+Group:      system
 
 %description -n libdar
 Common library code for DAR.
 
+
 %package -n libdar-devel
 Summary:    Development files for libdar
 Summary(ja): libdar の開発用ファイル
-Group:      Development/Libraries
+Group:      programming
 Requires:   libdar = %{version}-%{release}
 
 %description -n libdar-devel
 This package contains the header files and libraries for developing
 programs that use the DAR API (libdar).
 
+
+%debug_package
+
+
 %prep
 %setup -q
 
@@ -64,6 +69,7 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
 
 make %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT html
 make install DESTDIR=$RPM_BUILD_ROOT
@@ -89,10 +95,6 @@ chmod 0644 html/samples/*
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -n libdar -p /sbin/ldconfig
-
-%postun -n libdar -p /sbin/ldconfig
-
 
 %files -f %{name}.lang
 %defattr(-,root,root,-)
@@ -120,6 +122,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6.13-1
+- new upstream release.
+- dropped scriptlets.
+
 * Sat Oct 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6.6-1
 - new upstream release.
 

+ 4 - 1
e/e2fsprogs/e2fsprogs-vl.spec

@@ -5,7 +5,7 @@
 Summary:        Utilities for managing ext2/3/4 filesystem.
 Summary(ja):    ext2/3/4 ファイルシステム操作ユーティリティ
 Name:           e2fsprogs
-Version:        1.46.1
+Version:        1.46.2
 Release:        1%{?_dist_release}
 Group:          admin-tools,system
 Vendor:         Project Vine
@@ -285,6 +285,9 @@ exit 0
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.46.2-1
+- new upstream release.
+
 * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.46.1-1
 - new upstream release.
 

+ 25 - 12
f/fxload/fxload-vl.spec

@@ -1,23 +1,24 @@
 Name: fxload
-Version: 2002_04_11
-Release: 9%{?_dist_release}
 Summary: A helper program to download firmware into FX and FX2 EZ-USB devices
 Summary(ja): FX/FX2 EZ-USB デバイスにファームウェアをダウンロードするプログラム
+Version: 2008_10_13
+Release: 1%{?_dist_release}
+Group: system
 
-Group: System Environment/Kernel
 License: GPLv2+
 URL: http://linux-hotplug.sourceforge.net/
-Source0: fxload-2002_04_11-noa3load.tar.gz
+Source0: fxload-%{version}-noa3load.tar.gz
 # The above file is derived from:
-# http://downloads.sourceforge.net/linux-hotplug/fxload-2002_04_11.tar.gz
+# http://downloads.sourceforge.net/project/linux-hotplug/fxload/2008_10_13/fxload-2008_10_13.tar.gz
 # This file contains code that is copyright Cypress Semiconductor Inc,
 # and cannot be distributed. Therefore we use this script to remove the
 # copyright code before shipping it. Download the upstream tarball and
 # invoke this script while in the tarball's directory:
-# ./fxload-generate-tarball.sh 2002_04_11
+# ./fxload-generate-tarball.sh 2008_10_13
 Source1: fxload-generate-tarball.sh
-Patch0: fxload-header.patch
-Patch1: fxload-noa3load.patch
+Patch0: fxload-noa3load.patch
+Patch1: fxload-ldflags.patch
+
 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 
 BuildRequires: kernel-headers
@@ -36,13 +37,19 @@ AnchorChips EZ-USB にファームウェアをダウンロードすることが
 本プログラムは、バス上にデバイスが検出された時に udev スクリプト経由で
 起動されるものです。
 
+
+%debug_package
+
+
 %prep
 %setup -q 
-%patch0 -p0 -b .fxload-header
-%patch1 -p1 -b .fxload-noa3load
+%patch0 -p1 -b .fxload-noa3load
+%patch1 -p1 -b .ldflags
+
 
 %build 
-make
+%{make_build} CFLAGS="$RPM_OPT_FLAGS -fPIE" LDFLAGS="$RPM_LD_FLAGS -pie"
+
 
 %install
 rm -rf %{buildroot}
@@ -51,17 +58,23 @@ install -m 755 fxload %{buildroot}/sbin
 mkdir -p -m 755 %{buildroot}/%{_mandir}/man8/
 install -m 644 fxload.8 %{buildroot}/%{_mandir}/man8/
 
+
 %clean
 rm -rf %{buildroot}
 
+
 %files
 %defattr(0644,root,root,0755)
-%doc COPYING
+%license COPYING
 %doc README.txt
 %attr(0755, root, root) /sbin/fxload
 %{_mandir}/*/*
 
+
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2008_10_13-1
+- new upstream release.
+
 * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2002_04_11-9
 - rebuild with VineSeed environment
 

+ 14 - 3
p/par2cmdline/par2cmdline-vl.spec

@@ -3,14 +3,17 @@
 Name:           par2cmdline
 Summary:        PAR 2.0 compatible file verification and repair tool
 Version:        0.8.1
-Release:        1%{?_dist_release}
-Group:          Applications/Archiving
+Release:        2%{?_dist_release}
+Group:          accessories
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
 License:        GPLv2+
 URL:            https://github.com/Parchive/par2cmdline/
 Source:         https://github.com/Parchive/par2cmdline/releases/download/v%{version}/par2cmdline-%{version}.tar.bz2
+# Fix tests to account for endianness correctly.
+# Backport of https://github.com/Parchive/par2cmdline/commit/4f3576a314d7169912842ec9dc1e595e61e52653.
+Patch0:         0001-Fix-for-Github-issue-143.-Test-did-not-account-for-e.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 Obsoletes:      parchive <= 1.1.4
@@ -24,11 +27,16 @@ capability concepts of RAID-like systems to the posting and recovery of
 multi-part archives.
 
 
+%debug_package
+
+
 %prep
-%setup -q 
+%autosetup -p 1
 
 # fix end-of-lines of several files
 sed -i 's/\r//' AUTHORS PORTING README ROADMAP
+# Remove executable permission from text files
+chmod -x ChangeLog configure.ac INSTALL Makefile.am NEWS stamp-h.in
 
 
 %build
@@ -65,6 +73,9 @@ make check-TESTS
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-2
+- imported Patch0 from upstream.
+
 * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-1
 - new upstream release.
 - dropped Patch1.

+ 21 - 53
p/python-netifaces/python-netifaces-vl.spec

@@ -1,55 +1,27 @@
-%{!?__python3:%global __python3 /usr/bin/python3}
-%{!?python3_inc:%global python3_inc %(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc(1))")}
-%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
-%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
-%{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
-%{!?__python2: %global __python2 /usr/bin/python2}
-%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
-%define py2_setup setup.py
-%define py2_shbang_opts -s
-%define py2_build() %{expand:\
- CFLAGS="%{optflags}" %{__python2} %{py2_setup} %{?py2_setup_args} build --executable="%{__python2} %{py2_shbang_opts}" %{?1}\
-}
-%define py2_install() %{expand:\
- CFLAGS="%{optflags}" %{__python2} %{py2_setup} %{?py2_setup_args} install -O1 --skip-build --root %{buildroot} %{?1}\
-}
-%define py3_setup setup.py
-%define py3_shbang_opts -s
-%define py3_build() %{expand:\
- CFLAGS="%{optflags}" %{__python3} %{py3_setup} %{?py3_setup_args} build --executable="%{__python3} %{py3_shbang_opts}" %{?1}\
-}
-%define py3_install() %{expand:\
- CFLAGS="%{optflags}" %{__python3} %{py3_setup} %{?py3_setup_args} install -O1 --skip-build --root %{buildroot} %{?1}\
-}
-%define py3dir %{_builddir}/python3-%{name}-%{version}-%{release}
-
-
 %global with_python3 1
 
 %global pypi_name netifaces
 
 Name:           python-netifaces
-Version:        0.10.4
-Release:        5%{?_dist_release}
+Version:        0.10.9
+Release:        1%{?_dist_release}
 Summary:        Python library to retrieve information about network interfaces 
-
-Group:          Development/Libraries
-License:        MIT
-URL:            https://pypi.python.org/pypi/netifaces
-
+Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
+License:        MIT
+URL:            https://pypi.python.org/pypi/netifaces
 Source0:        https://pypi.python.org/packages/source/n/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
 
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
 
-
 %description
 This package provides a cross platform API for getting address information
 from network interfaces.
 
+
 %if 0%{?with_python3}
 %package -n python3-%{pypi_name}
 Summary:        Python library to retrieve information about network interfaces
@@ -62,45 +34,36 @@ from network interfaces.
 %endif
 
 
+%debug_package
+
+
 %prep
 %setup -q -n %{pypi_name}-%{version}
 
-%if 0%{?with_python3}
-rm -rf %{py3dir}
-cp -a . %{py3dir}
-%endif
-
 
 %build
-%{__python2} setup.py build
-
+%py_build
 %if 0%{?with_python3}
-pushd %{py3dir}
-%{__python3} setup.py build
-popd
+%py3_build
 %endif
 
 
 %install
-%{__python2} setup.py install --root $RPM_BUILD_ROOT
+%py_install
 
 %if 0%{?with_python3}
-pushd %{py3dir}
-%{__python3} setup.py install --root $RPM_BUILD_ROOT
-popd
+%py3_install
 %endif
 
+
 %clean
-%if 0%{?with_python3}
-rm -rf %{py3dir}
-%endif
 rm -rf %{buildroot}
 
 
 %files
 %doc README.rst
-%{python2_sitearch}/%{pypi_name}-%{version}-*.egg-info/
-%{python2_sitearch}/%{pypi_name}.so
+%{python_sitearch}/%{pypi_name}-%{version}-*.egg-info/
+%{python_sitearch}/%{pypi_name}.so
 
 %if 0%{?with_python3}
 %files -n python3-%{pypi_name}
@@ -109,7 +72,12 @@ rm -rf %{buildroot}
 %{python3_sitearch}/%{pypi_name}*.so
 %endif
 
+
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.10.9-1
+- new upstream release.
+- cleaned up macros.
+
 * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.10.4-5
 - initial build for Vine Linux.
 

+ 22 - 12
x/xz/xz-vl.spec

@@ -2,14 +2,16 @@ Summary:        LZMA compression utilities
 Summary(ja):    LZMA 圧縮ユーティリティ
 Name:           xz
 Version:        5.2.5
-Release:        1%{?_dist_release}
-Group:          Applications/Archiving
+Release:        2%{?_dist_release}
+Group:          accessories
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
 License:        LGPLv2+
 URL:            https://tukaani.org/xz/
 Source0:        https://tukaani.org/xz/%{name}-%{version}.tar.xz
+Patch1:         xz-5.2.5-enable_CET.patch
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 Requires:       %{name}-libs = %{version}-%{release}
 
@@ -27,7 +29,7 @@ decompression speed fast.
 %package 	libs
 Summary:	Libraries for decoding LZMA compression
 Summary(ja):	LZMA圧縮をデコードするためのライブラリ
-Group:		System Environment/Libraries
+Group:		system
 License:	LGPLv2+
 
 %description 	libs
@@ -37,7 +39,7 @@ Libraries for decoding files compressed with LZMA or XZ utils.
 %package 	devel
 Summary:	Devel libraries & headers for liblzma
 Summary(ja):	liblzma の開発ライブラリとヘッダファイル
-Group:		Development/Libraries
+Group:		programming
 License:	LGPLv2+
 Requires:	%{name}-libs = %{version}-%{release}
 Requires:	pkgconfig
@@ -49,7 +51,7 @@ Devel libraries and headers for liblzma.
 %package 	lzma-compat
 Summary:	Older LZMA format compatibility binaries
 Summary(ja):	旧式のLZMAフォーマット互換バイナリ
-Group:		Applications/Archiving
+Group:		accessories
 # lz{grep,diff,more} are GPLv2+. Other binaries are LGPLv2+
 License:	GPLv2+ and LGPLv2+
 Requires:	%{name} = %{version}-%{release}
@@ -61,13 +63,22 @@ The lzma-compat package contains compatibility links for older
 commands that deal with the older LZMA format.
 
 
+%debug_package
+
+
 %prep
 %setup -q
+%autopatch -p1
 
 
 %build
-CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64" \
-CXXFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64" \
+CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
+%ifarch %ix86
+  # rhbz#1630650, annocheck reports the following message because liblzma uses
+  # crc*_x86.S asm code on i686:
+  CFLAGS="$CFLAGS -Wa,--generate-missing-build-notes=yes"
+%endif
+CXXFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
 %configure --enable-silent-rules --disable-static
 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
@@ -93,11 +104,6 @@ LD_LIBRARY_PATH=$PWD/src/liblzma/.libs make check
 rm -rf %{buildroot}
 
 
-%post libs -p /sbin/ldconfig
-
-%postun libs -p /sbin/ldconfig
-
-
 %files
 %defattr(-,root,root,-)
 %license COPYING.*
@@ -127,6 +133,10 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.5-2
+- imported Patch1 from upstream.
+- dropped scriptlets.
+
 * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.5-1
 - new upstream release.