123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271 |
- %bcond_with tests
- Name: libmemcached
- Summary: Client library and command line tools for memcached server
- Version: 1.0.18
- Release: 3%{?_dist_release}
- Group: System Environment/Libraries
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- License: BSD
- URL: http://libmemcached.org/
- # Original sources:
- # http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
- # The source tarball must be repackaged to remove the Hsieh hash
- # code, since the license is non-free. When upgrading, download the new
- # source tarball, and run "./strip-hsieh.sh <version>" to produce the
- # "-exhsieh" tarball.
- Source0: libmemcached-%{version}-exhsieh.tar.gz
- Source1: strip-hsieh.sh
- Patch0: move-ax_confix_aux_dir.patch
- Patch1: fix-gcc7-build.diff
- Patch2: c++11.patch
- Patch3: m4_pthread.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: cyrus-sasl-devel
- BuildRequires: flex bison
- %if %{with tests}
- BuildRequires: memcached
- %endif
- BuildRequires: libevent-devel
- %description
- libmemcached is a C/C++ client library and tools for the memcached server
- (http://memcached.org/). It has been designed to be light on memory
- usage, and provide full access to server side methods.
- It also implements several command line tools:
- memcapable Checking a Memcached server capibilities and compatibility
- memcat Copy the value of a key to standard output
- memcp Copy data to a server
- memdump Dumping your server
- memerror Translate an error code to a string
- memexist Check for the existance of a key
- memflush Flush the contents of your servers
- memparse Parse an option string
- memping Test to see if a server is available.
- memrm Remove a key(s) from the server
- memslap Generate testing loads on a memcached cluster
- memstat Dump the stats of your servers to standard output
- memtouch Touches a key
- %package devel
- Summary: Header files and development libraries for %{name}
- Group: Development/Libraries
- Requires: %{name}%{?_isa} = %{version}-%{release}
- Requires: pkgconfig
- Requires: cyrus-sasl-devel%{?_isa}
- %description devel
- This package contains the header files and development libraries
- for %{name}. If you like to develop programs using %{name},
- you will need to install %{name}-devel.
- %prep
- %setup -q
- %autopatch -p1
- mkdir examples
- cp -p tests/*.{cc,h} examples/
- # Will be regenerated during build
- rm -f libmemcached/csl/{parser,scanner}.cc
- # Temporary fix for SASL detection
- sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
- # fix library dependency
- # perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
- %build
- autoreconf -fiv
- # option --with-memcached=false to disable server binary check (as we don't run test)
- %configure --disable-static \
- %if ! %{with tests}
- --with-memcached=false
- %endif
- make %{_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
- %check
- %if %{with tests}
- # test suite cannot run in mock (same port use for memcache servers on all arch)
- # All tests completed successfully
- # diff output.res output.cmp fails but result depend on server version
- make test
- %else
- echo 'Test suite disabled (missing "--with tests" option)'
- %endif
- %clean
- rm -rf %{buildroot}
- %post
- /sbin/ldconfig
- %postun
- /sbin/ldconfig
-
- %files
- %defattr (-,root,root,-)
- %license COPYING
- %doc AUTHORS README THANKS TODO ChangeLog
- %{_bindir}/mem*
- %exclude %{_libdir}/lib*.la
- %{_libdir}/lib*.so.*
- %{_mandir}/man1/mem*
- %files devel
- %defattr (-,root,root,-)
- %doc examples
- %{_datadir}/aclocal/ax_libmemcached.m4
- %{_includedir}/*
- %{_libdir}/lib*.so
- %{_libdir}/pkgconfig/libmemcached.pc
- %{_mandir}/man3/libmemcached*
- %{_mandir}/man3/libhashkit*
- %{_mandir}/man3/memcached*
- %{_mandir}/man3/hashkit*
- %changelog
- * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-3
- - rebuilt with current environment.
- - imported Patch0-3 from debian.
- * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.18-2
- - rebuild with gcc-5.4.0
- * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
- - new upstream release.
- - removed all patches (fixed in upstream).
- * Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
- - new upstream release.
- * Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
- - built for Vine Linux.
- * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
- - update to 1.0.7
- - regenerate parser using flex/bison (#816766)
- * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
- - workaround for SASL detection
- * Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
- - update to 1.0.6
- - soname bump to libmemcached.so.10 and libhashkit.so.2
- * Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
- - update to 1.0.4
- - soname bump to libmemcached.so.9
- - update description
- * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
- - Rebuilt for c++ ABI breakage
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
- - update to 1.0.2
- * Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
- - update to 0.53
- * Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
- - update to 0.52
- * Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
- - update to 0.51 (soname bump libmemcached.so.8)
- * Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
- - update to 0.49
- - add build option : --with tests
- * Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
- - update to 0.47
- - remove patch merged upstream
- * Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
- - patch Makefile.in instead of include.am (to avoid autoconf)
- - donc requires pkgconfig with arch
- * Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
- - update to 0.46
- * Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
- - arch specific requires
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
- - repackage source tarball to remove non-free Hsieh hash code
- * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
- - improves SASL patch
- * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
- - enable SASL support
- * Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
- - update to 0.44
- - add soname version in %%file to detect change
- * Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
- - update to 0.43
- * Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
- - update to 0.42
- * Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
- - update to 0.40 (new soname for libmemcached.so.5)
- - new URI (site + source)
- * Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
- - update to 0.38
- * Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
- - update to 0.37 (soname bump)
- - new libhashkit (should be a separated project in the futur)
- * Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
- - update to 0.31
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
- - update to 0.30
- * Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
- - update to 0.29
- * Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
- - add upstream patch to disable nonfree hsieh hash method
- * Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
- - Initial RPM from Brian Aker spec
- - create -devel subpackage
- - add %%post %%postun %%check section
|