libsolv-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410
  1. %{!?ruby_vendorarch: %global ruby_vendorarch %(ruby -r rbconfig -e "puts RbConfig::CONFIG['vendorarchdir'].nil? ? RbConfig::CONFIG['sitearchdir'] : RbConfig::CONFIG['vendorarchdir']")}
  2. %define _unpackaged_files_terminate_build 1
  3. %define filter_provides_in(P) %{expand: \
  4. %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
  5. }
  6. %define filter_setup %{expand: \
  7. %global _use_internal_dependency_generator 0 \
  8. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
  9. %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
  10. %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
  11. }
  12. %filter_provides_in %{perl_vendorarch}/.*\.so$
  13. %filter_provides_in %{python3_sitearch}/.*\.so$
  14. %global _cmake_opts \\\
  15. -DFEDORA=1 \\\
  16. -DCMAKE_BUILD_TYPE=RelWithDebInfo \\\
  17. -DENABLE_PERL=1 \\\
  18. -DENABLE_PYTHON=1 \\\
  19. -DENABLE_RUBY=1 \\\
  20. -DUSE_VENDORDIRS=1 \\\
  21. -DENABLE_DEBIAN=1 \\\
  22. -DENABLE_ARCHREPO=1 \\\
  23. -DENABLE_SUSEREPO=1 \\\
  24. -DENABLE_HELIXREPO=1 \\\
  25. -DENABLE_LZMA_COMPRESSION=1 \\\
  26. -DMULTI_SEMANTICS=1 \\\
  27. -DENABLE_COMPLEX_DEPS=1 \\\
  28. %{nil}
  29. %filter_provides_in %{ruby_vendorarch}/.*\.so$
  30. %filter_setup
  31. Name: libsolv
  32. Summary: Package dependency solver
  33. Version: 0.7.20
  34. Release: 1%{?_dist_release}
  35. Group: system
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. License: BSD
  39. URL: https://github.com/openSUSE/libsolv
  40. Source: https://github.com/openSUSE/libsolv/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  41. #Patch0: 0001-ruby-make-compatible-with-ruby-2.2.patch
  42. BuildRequires: git git-devel
  43. BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
  44. BuildRequires: swig
  45. BuildRequires: perl ruby ruby-devel
  46. BuildRequires: python3-devel
  47. BuildRequires: python3-setuptools
  48. BuildRequires: python3-rpm-macros
  49. BuildRequires: xz-devel
  50. %description
  51. A free package dependency solver using a satisfiability algorithm. The
  52. library is based on two major, but independent, blocks:
  53. - Using a dictionary approach to store and retrieve package
  54. and dependency information.
  55. - Using satisfiability, a well known and researched topic, for
  56. resolving package dependencies.
  57. %package devel
  58. Summary: A new approach to package dependency solving
  59. Group: programming
  60. Requires: libsolv-tools%{?_isa} = %{version}-%{release}
  61. Requires: libsolv%{?_isa} = %{version}-%{release}
  62. Requires: rpm-devel%{?_isa}
  63. Requires: cmake
  64. %description devel
  65. Development files for libsolv,
  66. %package tools
  67. Summary: A new approach to package dependency solving
  68. Group: programming
  69. Requires: gzip bzip2 coreutils
  70. Requires: libsolv%{?_isa} = %{version}-%{release}
  71. %description tools
  72. Package dependency solver tools.
  73. %package demo
  74. Summary: Applications demoing the libsolv library
  75. Group: programming
  76. Requires: curl gnupg
  77. %description demo
  78. Applications demoing the libsolv library.
  79. %package -n ruby-solv
  80. Summary: Ruby bindings for the libsolv library
  81. Group: programming
  82. Requires: libsolv%{?_isa} = %{version}-%{release}
  83. %description -n ruby-solv
  84. Ruby bindings for sat solver.
  85. %package -n python3-solv
  86. Summary: Python 3 bindings for the libsolv library
  87. Group: programming
  88. Requires: python3
  89. Requires: libsolv%{?_isa} = %{version}-%{release}
  90. %{?python_provide:%python_provide python3-solv}
  91. %description -n python3-solv
  92. Python 3 bindings for sat solver.
  93. %package -n perl-solv
  94. Summary: Perl bindings for the libsolv library
  95. Group: programming
  96. Requires: perl
  97. Requires: libsolv%{?_isa} = %{version}-%{release}
  98. %description -n perl-solv
  99. Perl bindings for sat solver.
  100. %debug_package
  101. %prep
  102. %autosetup -S git
  103. %build
  104. %cmake %_cmake_opts \
  105. -DPythonLibs_FIND_VERSION=3 -DPythonLibs_FIND_VERSION_MAJOR=3
  106. %cmake_build
  107. %install
  108. %cmake_install
  109. %check
  110. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
  111. %ctest
  112. %files
  113. %license LICENSE*
  114. %doc README BUGS
  115. %_libdir/libsolv.so.*
  116. %_libdir/libsolvext.so.*
  117. %files tools
  118. %_bindir/archpkgs2solv
  119. %_bindir/archrepo2solv
  120. %_bindir/deb2solv
  121. %_bindir/deltainfoxml2solv
  122. %_bindir/dumpsolv
  123. %_bindir/helix2solv
  124. %_bindir/installcheck
  125. %_bindir/mergesolv
  126. %_bindir/repo2solv
  127. %_bindir/repomdxml2solv
  128. %_bindir/rpmdb2solv
  129. %_bindir/rpmmd2solv
  130. %_bindir/rpms2solv
  131. %_bindir/susetags2solv
  132. %_bindir/testsolv
  133. %_bindir/updateinfoxml2solv
  134. %files devel
  135. %doc examples/solv/
  136. %_libdir/libsolv.so
  137. %_libdir/libsolvext.so
  138. %_includedir/solv
  139. %_datadir/cmake/Modules/FindLibSolv.cmake
  140. %{_mandir}/man?/*
  141. %{_libdir}/pkgconfig/%{name}.pc
  142. %{_libdir}/pkgconfig/%{name}ext.pc
  143. %files demo
  144. %_bindir/solv
  145. %files -n perl-solv
  146. %doc examples/p5solv
  147. %{perl_vendorarch}/*
  148. %files -n ruby-solv
  149. %doc examples/rbsolv
  150. %{ruby_vendorarch}/*
  151. %files -n python3-solv
  152. %doc examples/pysolv
  153. %{python3_sitearch}/*
  154. %changelog
  155. * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.20-1
  156. - new upstream release.
  157. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.19-1
  158. - new upstream release.
  159. - dropped ldconfig scriptlets.
  160. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-2
  161. - rebuilt with rpm-4.16.
  162. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-1
  163. - new upstream release.
  164. - dropped python2 support.
  165. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.11-1
  166. - new upstream release.
  167. * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.6-1
  168. - new upstream release.
  169. * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.35-1
  170. - new upstream release.
  171. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.30-1
  172. - new upstream release.
  173. * Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.22-1
  174. - new upstream release.
  175. * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.20-1
  176. - new upstream release.
  177. * Sun Nov 22 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.14-4
  178. - initial build for Vine Linux.
  179. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.14-3
  180. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  181. * Wed Oct 14 2015 Michal Luscon <mluscon@redhat.com> - 0.6.14-2
  182. - Backport patches from upstream
  183. * Mon Oct 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.14-1
  184. - Update to 0.6.14
  185. - Backport patches from upstream
  186. * Thu Sep 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.12-1
  187. - Update to 0.6.12
  188. * Wed Aug 05 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-3
  189. - added compile flag to support rich dependencies
  190. - new version adding MIPS support
  191. - Distribute testsolv in -tools subpackage (Igor Gnatenko)
  192. - Enable python3 bindings for fedora (Igor Gnatenko)
  193. * Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.6.11-2
  194. - make bindings require the exact matching version of the lib (#1243737)
  195. * Mon Jun 22 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-1
  196. - new version fixing segfault
  197. - RbConfig fixed in the upstream (1928f1a), libsolv-ruby22-rbconfig.patch erased
  198. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-2
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  200. * Wed Mar 25 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.10-1
  201. - new version fixing segfault
  202. * Fri Mar 6 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.8-3
  203. - Rebuilt with new provides selection feature
  204. * Mon Jan 19 2015 Vít Ondruch <vondruch@redhat.com> - 0.6.8-2
  205. - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
  206. * Fri Jan 16 2015 Richard Hughes <richard@hughsie.com> - 0.6.8-2
  207. - Update to latest upstream release to fix a crash in PackageKit.
  208. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.4-3
  209. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  210. * Mon Aug 11 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-2
  211. - Rebase to upstream 12af31a
  212. * Mon Jul 28 2014 Aleš Kozumplík <akozumpl@redhat.com> - 0.6.4-1
  213. - Rebase to upstream 5bd9589
  214. * Mon Jul 14 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-0.git2a5c1c4
  215. - Rebase to upstream 2a5c1c4
  216. - Filename selector can start with a star
  217. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2.git6d968f1
  218. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  219. * Tue May 27 2014 Aleš Kozumplík <ales@redhat.com> - 0.6.1-1.git6d968f1
  220. - Rebase to upstream 6d968f1
  221. - Fix RhBug:1049209
  222. * Fri Apr 25 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.1-0.gitf78f5de
  223. - Rebase to 0.6.0, upstream commit f78f5de.
  224. * Thu Apr 24 2014 Vít Ondruch <vondruch@redhat.com> - 0.6.0-0.git05baf54.1
  225. - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
  226. * Wed Apr 9 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.0-0.git05baf54
  227. - Rebase to 0.6.0, upstream commit 05baf54.
  228. * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-1.gitbcedc98
  229. - Rebase upstream bcedc98
  230. - Fix RhBug:1051917.
  231. * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-0.gita8e47f1
  232. - Rebase to 0.4.1, upstream commit a8e47f1.
  233. * Fri Nov 22 2013 Zdenek Pavlas <zpavlas@redhat.com> - 0.4.0-2.git4442b7f
  234. - Rebase to 0.4.0, upstream commit 4442b7f.
  235. - support DELTA_LOCATION_BASE for completeness
  236. * Tue Oct 29 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.0-1.gitd49d319
  237. - Rebase to 0.4.0, upstream commit d49d319.
  238. * Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-9.gita59d11d
  239. - Perl 5.18 rebuild
  240. * Wed Jul 31 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-8.gita59d11d
  241. - Rebase to upstream a59d11d.
  242. * Fri Jul 19 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-7.git228d412
  243. - Add build flags, including Deb, Arch, LZMA and MULTI_SEMANTICS. (RhBug:985905)
  244. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-6.git228d412
  245. - Perl 5.18 rebuild
  246. * Mon Jun 24 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-5.git228d412
  247. - Rebase to upstream 228d412.
  248. - Fixes hawkey github issue https://github.com/akozumpl/hawkey/issues/13
  249. * Thu Jun 20 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-4.git209e9cb
  250. - Rebase to upstream 209e9cb.
  251. - Package the new man pages.
  252. * Thu May 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-3.git7399ad1
  253. - Run 'make test' with libsolv build.
  254. * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-2.git7399ad1
  255. - Rebase to upstream 7399ad1.
  256. - Fixes RhBug:905209
  257. * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-1.gite372b78
  258. - Rebase to upstream e372b78.
  259. - Fixes RhBug:e372b78
  260. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-2.gitf663ca2
  261. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  262. * Thu Aug 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-17.git6c9d3eb
  263. - Rebase to upstream 6c9d3eb.
  264. - Drop the solv.i stdbool.h fix integrated upstream.
  265. - Dropped the job reasons fix.
  266. * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-16.git1617994
  267. - Fix build problems with Perl bindings.
  268. * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-15.git1617994
  269. - Rebuilt after a failed mass rebuild.
  270. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.0-14.git1617994
  271. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  272. * Mon Jul 16 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-13.git1617994%{?dist}
  273. - preliminary fix for JOB resons in solver_describe_decision().
  274. * Sun Jul 1 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-12.git1617994%{?dist}
  275. - Rebase to upstream 1617994.
  276. - Support for RPM_ADD_WITH_HDRID.
  277. * Thu Jun 7 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-11.gitd39a42b%{?dist}
  278. - Rebase to upstream d39a42b.
  279. - Fix the epochs.
  280. - Move the ruby modules into vendorarch dir, where they are expected.
  281. * Thu May 17 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-9.git8cf7650%{?dist}
  282. - Rebase to upstream 8cf7650.
  283. - ruby bindings: fix USE_VENDORDIRS for Fedora.
  284. * Thu Apr 12 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-7.gitaf1465a2%{?dist}
  285. - Rebase to the upstream.
  286. - Make repo_add_solv() work without stub repodata.
  287. * Thu Apr 5 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-6.git80afaf7%{?dist}
  288. - Rebuild for the new libdb package.
  289. * Mon Apr 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-5.git80afaf7%{?dist}
  290. - Rebuild for the new rpm package.
  291. * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-4.git80afaf7%{?dist}
  292. - New upstream version, fix the .rpm release number.
  293. * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-3.git80afaf7%{?dist}
  294. - New upstream version.
  295. * Tue Feb 7 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-2.git857fe28%{?dist}
  296. - Adapted to Ruby 1.9.3 (workaround for broken CMake in Fedora and
  297. ruby template correction in bindings)
  298. * Thu Feb 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-1.git857fe28
  299. - Initial packaging
  300. - Based on Jindra Novy's spec file
  301. - Based on upstream spec file