perl-XML-LibXML-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111
  1. Summary: Perl interface to the libxml2 library
  2. Name: perl-XML-LibXML
  3. Version: 1.66
  4. Release: 1%{?_dist_release}
  5. License: GPL or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/XML-LibXML/
  8. Source0: XML-LibXML-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl >= 2:5.8.0
  11. BuildRequires: perl-XML-LibXML-Common
  12. BuildRequires: perl-XML-NamespaceSupport
  13. BuildRequires: perl-XML-SAX
  14. BuildRequires: libxml2-devel
  15. Requires: perl >= %(perl -MConfig -e 'print $Config{version}')
  16. %description
  17. This module implements a Perl interface to the GNOME libxml2 library
  18. which provides interfaces for parsing and manipulating XML files. This
  19. module allows Perl programmers to make use of the highly capable
  20. validating XML parser and the high performance DOM implementation.
  21. %prep
  22. %setup -q -n XML-LibXML-%{version}
  23. %build
  24. CFLAGS="$RPM_OPT_FLAGS" SKIP_SAX_INSTALL=1 perl Makefile.PL INSTALLDIRS=vendor
  25. make OPTIMIZE="$RPM_OPT_FLAGS"
  26. %install
  27. rm -rf $RPM_BUILD_ROOT
  28. make install \
  29. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
  30. INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
  31. find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
  32. -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
  33. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  34. chmod -R u+w $RPM_BUILD_ROOT/*
  35. for i in Changes; do
  36. /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && /bin/mv -f $i.conv $i
  37. done
  38. %check || :
  39. make test
  40. %clean
  41. rm -rf $RPM_BUILD_ROOT
  42. %triggerin -- perl-XML-SAX
  43. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  44. perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" || :
  45. done
  46. %preun
  47. if [ $1 -eq 0 ] ; then
  48. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  49. perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
  50. 2>/dev/null || :
  51. done
  52. fi
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc Changes LICENSE README
  56. %{perl_vendorarch}/auto/XML
  57. %{perl_vendorarch}/XML
  58. %{_mandir}/man3/*.3*
  59. %changelog
  60. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
  61. - new upsteream release
  62. - built with perl-5.10.0-2
  63. - changed Group to Development/Libraries
  64. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
  65. - changed Group to Development/Languages
  66. - rebuilt with libxml2-2.6.26
  67. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
  68. - rebuilt for Vine Linux
  69. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
  70. - bump again for double-long bug on ppc(64)
  71. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
  72. - rebuilt for new gcc4.1 snapshot and glibc changes
  73. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
  74. - rebuild for new perl-5.8.8
  75. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  76. - rebuilt for new gcc
  77. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  78. - rebuilt for new gcj
  79. * Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
  80. - rebuild
  81. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
  82. - #121168
  83. - Update to 1.58.
  84. - Require perl(:MODULE_COMPAT_*).
  85. - Handle ParserDetails.ini parser registration.
  86. - BuildRequires libxml2-devel.
  87. - Own installed directories.
  88. * Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
  89. - Specfile autogenerated.