123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111 |
- Summary: Perl interface to the libxml2 library
- Name: perl-XML-LibXML
- Version: 1.66
- Release: 1%{?_dist_release}
- License: GPL or Artistic
- Group: Development/Libraries
- URL: http://search.cpan.org/dist/XML-LibXML/
- Source0: XML-LibXML-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: perl >= 2:5.8.0
- BuildRequires: perl-XML-LibXML-Common
- BuildRequires: perl-XML-NamespaceSupport
- BuildRequires: perl-XML-SAX
- BuildRequires: libxml2-devel
- Requires: perl >= %(perl -MConfig -e 'print $Config{version}')
- %description
- This module implements a Perl interface to the GNOME libxml2 library
- which provides interfaces for parsing and manipulating XML files. This
- module allows Perl programmers to make use of the highly capable
- validating XML parser and the high performance DOM implementation.
- %prep
- %setup -q -n XML-LibXML-%{version}
- %build
- CFLAGS="$RPM_OPT_FLAGS" SKIP_SAX_INSTALL=1 perl Makefile.PL INSTALLDIRS=vendor
- make OPTIMIZE="$RPM_OPT_FLAGS"
- %install
- rm -rf $RPM_BUILD_ROOT
- make install \
- PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
- INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
- find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
- -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
- find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
- chmod -R u+w $RPM_BUILD_ROOT/*
- for i in Changes; do
- /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && /bin/mv -f $i.conv $i
- done
- %check || :
- make test
- %clean
- rm -rf $RPM_BUILD_ROOT
- %triggerin -- perl-XML-SAX
- for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
- perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" || :
- done
- %preun
- if [ $1 -eq 0 ] ; then
- for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
- perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
- 2>/dev/null || :
- done
- fi
- %files
- %defattr(-,root,root,-)
- %doc Changes LICENSE README
- %{perl_vendorarch}/auto/XML
- %{perl_vendorarch}/XML
- %{_mandir}/man3/*.3*
- %changelog
- * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
- - new upsteream release
- - built with perl-5.10.0-2
- - changed Group to Development/Libraries
- * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
- - changed Group to Development/Languages
- - rebuilt with libxml2-2.6.26
- * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
- - rebuilt for Vine Linux
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
- - rebuild for new perl-5.8.8
- * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt for new gcc
- * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt for new gcj
- * Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
- - rebuild
- * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
- - #121168
- - Update to 1.58.
- - Require perl(:MODULE_COMPAT_*).
- - Handle ParserDetails.ini parser registration.
- - BuildRequires libxml2-devel.
- - Own installed directories.
- * Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
- - Specfile autogenerated.
|