123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262 |
- %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
- %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
- %define gecko_version 1.9.1
- Summary: A library handling all the details of proxy configuration
- Name: libproxy
- Version: 0.4.6
- Release: 1%{?_dist_release}
- Group: System Environment/Libraries
- License: LGPLv2+
- URL: http://code.google.com/p/libproxy/
- Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
- Patch0: libproxy-0.2.3-dbus.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: python-devel
- #Virtual Provides - We need either mozjs or WebKit
- Requires: %{name}-pac >= %{version}
- #
- Requires: libproxy-python = %{version}-%{release}
- Requires: libproxy-bin = %{version}-%{release}
- BuildRequires: cmake
- # gnome
- BuildRequires: GConf2-devel
- # mozjs
- BuildRequires: gecko-devel >= %{gecko_version}
- # NetworkManager
- BuildRequires: NetworkManager-devel
- BuildRequires: dbus-devel
- # webkit (gtk)
- BuildRequires: WebKit-gtk-devel
- # kde
- BuildRequires: kdelibs-devel
- BuildRequires: libXmu-devel
- BuildRequires: libX11-devel
- %description
- libproxy offers the following features:
- * extremely small core footprint (< 35K)
- * no external dependencies within libproxy core
- (libproxy plugins may have dependencies)
- * only 3 functions in the stable external API
- * dynamic adjustment to changing network topology
- * a standard way of dealing with proxy settings across all scenarios
- * a sublime sense of joy and accomplishment
- Non-default rpmbuild options:
- --with webkit: Enable WebKit-gtk support
- %package bin
- Summary: Binary to test %{name}
- Group: Applications/System
- Requires: %{name} = %{version}-%{release}
- %description bin
- The %{name}-bin package contains the proxy binary for %{name}
- %package python
- Summary: Binding for %{name} and python
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- %description python
- The %{name}-python package contains the python binding for %{name}
- %package gnome
- Summary: Plugin for %{name} and gnome
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- %description gnome
- The %{name}-gnome package contains the %{name} plugin for gnome.
- %package kde
- Summary: Plugin for %{name} and kde
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- %description kde
- The %{name}-kde package contains the %{name} plugin for kde.
- %package mozjs
- Summary: Plugin for %{name} and mozjs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}
- #Tweak this according to the current gecko-libs version
- Requires: gecko-libs >= %{gecko_version}
- Provides: %{name}-pac = %{version}-%{release}
- %description mozjs
- The %{name}-mozjs package contains the %{name} plugin for mozjs.
- %package webkit
- Summary: Plugin for %{name} and webkit
- Group: System Environment/Libraries
- Requires: %{name} = %{version}
- Provides: %{name}-pac = %{version}-%{release}
- %description webkit
- The %{name}-webkit package contains the %{name} plugin for
- webkit.
- %package devel
- Summary: Development files for %{name}
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- The %{name}-devel package contains libraries and header files for
- developing applications that use %{name}.
- %prep
- %setup -q
- ## %patch0 -p1 -b .dbus
- ## touch -r configure.dbus configure
- ##touch -r configure.ac.dbus configure.ac
- %build
- %cmake \
- -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
- -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
- -DWITH_PERL=OFF \
- .
- make VERBOSE=1 %{?_smp_mflags}
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
- find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS COPYING README
- %{_libdir}/*.so.*
- %dir %{_libdir}/%{name}
- %dir %{_libdir}/%{name}/%{version}
- %dir %{_libdir}/%{name}/%{version}/modules
- %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
- %files bin
- %defattr(-,root,root,-)
- %{_bindir}/proxy
- %files python
- %defattr(-,root,root,-)
- %{python_sitearch}/libproxy.py
- %files gnome
- %defattr(-,root,root,-)
- %{_libdir}/%{name}/%{version}/modules/config_gnome.so
- %{_libexecdir}/pxgconf
- %files kde
- %defattr(-,root,root,-)
- %{_libdir}/%{name}/%{version}/modules/config_kde4.so
- %files mozjs
- %defattr(-,root,root,-)
- %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
- %files webkit
- %defattr(-,root,root,-)
- %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/proxy.h
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/libproxy-1.0.pc
- %{_datadir}/cmake/Modules/Findlibproxy.cmake
- %changelog
- * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
- - new upstream release
- - drop Patch0
- - add BuildRequires: cmake, kdelibs-devel
- - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
- * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
- - rebuild with rpm-4.8.1 for pkg-config file
- * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
- - rebuild with python-2.6
- * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
- - rebuild with gecko-1.9.1
- * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
- - rebuild with WebKit-gtk-1.0.0-8.svn41944
- * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
- - initial build for Vine Linux
- * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
- - Rebuild for webkit
- - Raise requirement for xulrunner to 1.9.1
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
- - Merge NetworkManager module into the main libproxy package
- - Main Requires the -python and -bin subpackage
- (splitted for multilibs compliance).
- * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
- - Disable Gnome/KDE default support via builtin modules.
- (it needs to be integrated via Gconf2/neon instead).
- * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
- - Disable Obsoletes.
- - Requires ev instead of evr for optionnals sub-packages.
- * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
- - Use conditionals build.
- * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
- - Remove plugin- in the name of the packages
- * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
- - Move proxy.h to libproxy/proxy.h
- This will prevent it to be included in the default include path
- - Split main to libs and util and use libproxy to install all
- * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
- - Rename binding-python to python
- - Add Requires: gecko-libs >= %%{gecko_version}
- - Fix some descriptions
- - Add plugin-webkit package
-
- * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
- - Convert to Fedora spec
- * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
- - Updated to version 0.2.3
- * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
- - Extended spec file to build all available plugins
- * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
- - Initial spec file for Version 0.2.2
|