libproxy-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define gecko_version 1.9.1
  4. Summary: A library handling all the details of proxy configuration
  5. Name: libproxy
  6. Version: 0.4.6
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://code.google.com/p/libproxy/
  11. Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
  12. Patch0: libproxy-0.2.3-dbus.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: python-devel
  15. #Virtual Provides - We need either mozjs or WebKit
  16. Requires: %{name}-pac >= %{version}
  17. #
  18. Requires: libproxy-python = %{version}-%{release}
  19. Requires: libproxy-bin = %{version}-%{release}
  20. BuildRequires: cmake
  21. # gnome
  22. BuildRequires: GConf2-devel
  23. # mozjs
  24. BuildRequires: gecko-devel >= %{gecko_version}
  25. # NetworkManager
  26. BuildRequires: NetworkManager-devel
  27. BuildRequires: dbus-devel
  28. # webkit (gtk)
  29. BuildRequires: WebKit-gtk-devel
  30. # kde
  31. BuildRequires: kdelibs-devel
  32. BuildRequires: libXmu-devel
  33. BuildRequires: libX11-devel
  34. %description
  35. libproxy offers the following features:
  36. * extremely small core footprint (< 35K)
  37. * no external dependencies within libproxy core
  38. (libproxy plugins may have dependencies)
  39. * only 3 functions in the stable external API
  40. * dynamic adjustment to changing network topology
  41. * a standard way of dealing with proxy settings across all scenarios
  42. * a sublime sense of joy and accomplishment
  43. Non-default rpmbuild options:
  44. --with webkit: Enable WebKit-gtk support
  45. %package bin
  46. Summary: Binary to test %{name}
  47. Group: Applications/System
  48. Requires: %{name} = %{version}-%{release}
  49. %description bin
  50. The %{name}-bin package contains the proxy binary for %{name}
  51. %package python
  52. Summary: Binding for %{name} and python
  53. Group: System Environment/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description python
  56. The %{name}-python package contains the python binding for %{name}
  57. %package gnome
  58. Summary: Plugin for %{name} and gnome
  59. Group: System Environment/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. %description gnome
  62. The %{name}-gnome package contains the %{name} plugin for gnome.
  63. %package kde
  64. Summary: Plugin for %{name} and kde
  65. Group: System Environment/Libraries
  66. Requires: %{name} = %{version}-%{release}
  67. %description kde
  68. The %{name}-kde package contains the %{name} plugin for kde.
  69. %package mozjs
  70. Summary: Plugin for %{name} and mozjs
  71. Group: System Environment/Libraries
  72. Requires: %{name} = %{version}
  73. #Tweak this according to the current gecko-libs version
  74. Requires: gecko-libs >= %{gecko_version}
  75. Provides: %{name}-pac = %{version}-%{release}
  76. %description mozjs
  77. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  78. %package webkit
  79. Summary: Plugin for %{name} and webkit
  80. Group: System Environment/Libraries
  81. Requires: %{name} = %{version}
  82. Provides: %{name}-pac = %{version}-%{release}
  83. %description webkit
  84. The %{name}-webkit package contains the %{name} plugin for
  85. webkit.
  86. %package devel
  87. Summary: Development files for %{name}
  88. Group: Development/Libraries
  89. Requires: %{name} = %{version}-%{release}
  90. Requires: pkgconfig
  91. %description devel
  92. The %{name}-devel package contains libraries and header files for
  93. developing applications that use %{name}.
  94. %prep
  95. %setup -q
  96. ## %patch0 -p1 -b .dbus
  97. ## touch -r configure.dbus configure
  98. ##touch -r configure.ac.dbus configure.ac
  99. %build
  100. %cmake \
  101. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  102. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  103. -DWITH_PERL=OFF \
  104. .
  105. make VERBOSE=1 %{?_smp_mflags}
  106. make %{?_smp_mflags}
  107. %install
  108. rm -rf $RPM_BUILD_ROOT
  109. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  110. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  111. %clean
  112. rm -rf $RPM_BUILD_ROOT
  113. %post -p /sbin/ldconfig
  114. %postun -p /sbin/ldconfig
  115. %files
  116. %defattr(-,root,root,-)
  117. %doc AUTHORS COPYING README
  118. %{_libdir}/*.so.*
  119. %dir %{_libdir}/%{name}
  120. %dir %{_libdir}/%{name}/%{version}
  121. %dir %{_libdir}/%{name}/%{version}/modules
  122. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  123. %files bin
  124. %defattr(-,root,root,-)
  125. %{_bindir}/proxy
  126. %files python
  127. %defattr(-,root,root,-)
  128. %{python_sitearch}/libproxy.py
  129. %files gnome
  130. %defattr(-,root,root,-)
  131. %{_libdir}/%{name}/%{version}/modules/config_gnome.so
  132. %{_libexecdir}/pxgconf
  133. %files kde
  134. %defattr(-,root,root,-)
  135. %{_libdir}/%{name}/%{version}/modules/config_kde4.so
  136. %files mozjs
  137. %defattr(-,root,root,-)
  138. %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
  139. %files webkit
  140. %defattr(-,root,root,-)
  141. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  142. %files devel
  143. %defattr(-,root,root,-)
  144. %{_includedir}/proxy.h
  145. %{_libdir}/*.so
  146. %{_libdir}/pkgconfig/libproxy-1.0.pc
  147. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  148. %changelog
  149. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  150. - new upstream release
  151. - drop Patch0
  152. - add BuildRequires: cmake, kdelibs-devel
  153. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  154. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  155. - rebuild with rpm-4.8.1 for pkg-config file
  156. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  157. - rebuild with python-2.6
  158. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  159. - rebuild with gecko-1.9.1
  160. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  161. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  162. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  163. - initial build for Vine Linux
  164. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  165. - Rebuild for webkit
  166. - Raise requirement for xulrunner to 1.9.1
  167. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  169. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  170. - Merge NetworkManager module into the main libproxy package
  171. - Main Requires the -python and -bin subpackage
  172. (splitted for multilibs compliance).
  173. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  174. - Disable Gnome/KDE default support via builtin modules.
  175. (it needs to be integrated via Gconf2/neon instead).
  176. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  177. - Disable Obsoletes.
  178. - Requires ev instead of evr for optionnals sub-packages.
  179. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  180. - Use conditionals build.
  181. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  182. - Remove plugin- in the name of the packages
  183. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  184. - Move proxy.h to libproxy/proxy.h
  185. This will prevent it to be included in the default include path
  186. - Split main to libs and util and use libproxy to install all
  187. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  188. - Rename binding-python to python
  189. - Add Requires: gecko-libs >= %%{gecko_version}
  190. - Fix some descriptions
  191. - Add plugin-webkit package
  192. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  193. - Convert to Fedora spec
  194. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  195. - Updated to version 0.2.3
  196. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  197. - Extended spec file to build all available plugins
  198. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  199. - Initial spec file for Version 0.2.2