db4-vl.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
  3. %define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
  4. ##VINE##
  5. %undefine java_arches
  6. %define __soversion 4.8
  7. %define _libdb_a libdb-%{__soversion}.a
  8. %define _libcxx_a libdb_cxx-%{__soversion}.a
  9. Summary: The Berkeley DB database library (version 4) for C
  10. Name: db4
  11. Version: 4.8.26
  12. Release: 2%{?_dist_release}
  13. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  14. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  15. # patches for db1.85
  16. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  17. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  18. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  19. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  20. Patch20: db-1.85-errno.patch
  21. Patch22: db-4.6.21-1.85-compat.patch
  22. Patch24: db-4.5.20-jni-include-dir.patch
  23. URL: http://www.oracle.com/database/berkeley-db/
  24. License: BSD-style
  25. Group: System Environment/Libraries
  26. Obsoletes: db1, db2, db3
  27. BuildRequires: perl, libtool, ed, tcl >= 8.4.4
  28. #BuildRequires: util-linux-ng
  29. %ifarch %{java_arches}
  30. BuildRequires: gcc-java
  31. BuildRequires: java-1.5.0-gcj
  32. BuildRequires: java-1.5.0-gcj-devel
  33. %endif
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  35. %description
  36. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  37. provides embedded database support for both traditional and
  38. client/server applications. The Berkeley DB includes B+tree, Extended
  39. Linear Hashing, Fixed and Variable-length record access methods,
  40. transactions, locking, logging, shared memory caching, and database
  41. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  42. used by many applications, including Python and Perl, so this should
  43. be installed on all systems.
  44. %package -n compat32-%{name}
  45. Summary: The Berkeley DB database library (version 4) for C.
  46. Group: System Environment/Libraries
  47. Requires: db4 = %{version}-%{release}
  48. %description -n compat32-%{name}
  49. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  50. provides embedded database support for both traditional and
  51. client/server applications. The Berkeley DB includes B+tree, Extended
  52. Linear Hashing, Fixed and Variable-length record access methods,
  53. transactions, locking, logging, shared memory caching, and database
  54. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  55. used by many applications, including Python and Perl, so this should
  56. be installed on all systems.
  57. %package cxx
  58. Summary: The Berkeley DB database library (version 4) for C++
  59. Group: System Environment/Libraries
  60. %description cxx
  61. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  62. provides embedded database support for both traditional and
  63. client/server applications. The Berkeley DB includes B+tree, Extended
  64. Linear Hashing, Fixed and Variable-length record access methods,
  65. transactions, locking, logging, shared memory caching, and database
  66. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  67. used by many applications, including Python and Perl, so this should
  68. be installed on all systems.
  69. %package -n compat32-%{name}-cxx
  70. Summary: The Berkeley DB database library (version 4) for C++
  71. Group: System Environment/Libraries
  72. %description -n compat32-%{name}-cxx
  73. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  74. provides embedded database support for both traditional and
  75. client/server applications. The Berkeley DB includes B+tree, Extended
  76. Linear Hashing, Fixed and Variable-length record access methods,
  77. transactions, locking, logging, shared memory caching, and database
  78. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  79. used by many applications, including Python and Perl, so this should
  80. be installed on all systems.
  81. %package utils
  82. Summary: Command line tools for managing Berkeley DB (version 4) databases
  83. Group: Applications/System
  84. Requires: db4 = %{version}-%{release}
  85. Obsoletes: db1-utils, db2-utils, db3-utils
  86. %description utils
  87. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  88. provides embedded database support for both traditional and
  89. client/server applications. Berkeley DB includes B+tree, Extended
  90. Linear Hashing, Fixed and Variable-length record access methods,
  91. transactions, locking, logging, shared memory caching, and database
  92. recovery. DB supports C, C++, Java and Perl APIs.
  93. %package devel
  94. Summary: C development files for the Berkeley DB (version 4) library
  95. Group: Development/Libraries
  96. Requires: db4 = %{version}-%{release}
  97. Obsoletes: db1-devel, db2-devel, db3-devel
  98. %description devel
  99. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  100. provides embedded database support for both traditional and
  101. client/server applications. This package contains the header files,
  102. libraries, and documentation for building programs which use the
  103. Berkeley DB.
  104. %package -n compat32-%{name}-devel
  105. Summary: Development files for the Berkeley DB (version 4) library.
  106. Group: Development/Libraries
  107. Requires: compat32-%{name} = %{version}-%{release}
  108. Requires: %{name}-devel = %{version}-%{release}
  109. %description -n compat32-%{name}-devel
  110. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  111. provides embedded database support for both traditional and
  112. client/server applications. This package contains the header files,
  113. libraries, and documentation for building programs which use the
  114. Berkeley DB.
  115. %package tcl
  116. Summary: Development files for using the Berkeley DB (version 4) with tcl
  117. Group: Development/Libraries
  118. Requires: %{name} = %{version}-%{release}
  119. %description tcl
  120. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  121. provides embedded database support for both traditional and
  122. client/server applications. This package contains the libraries
  123. for building programs which use the Berkeley DB in Tcl.
  124. %package -n compat32-%{name}-tcl
  125. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  126. Group: Development/Libraries
  127. Requires: compat32-%{name} = %{version}-%{release}
  128. Requires: %{name}-tcl = %{version}-%{release}
  129. %description -n compat32-%{name}-tcl
  130. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  131. provides embedded database support for both traditional and
  132. client/server applications. This package contains the libraries
  133. for building programs which use the Berkeley DB in Tcl.
  134. %package java
  135. Summary: Development files for using the Berkeley DB (version 4) with Java
  136. Group: Development/Libraries
  137. Requires: %{name} = %{version}-%{release}
  138. %description java
  139. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  140. provides embedded database support for both traditional and
  141. client/server applications. This package contains the libraries
  142. for building programs which use the Berkeley DB in Java.
  143. %prep
  144. %setup -q -n db-%{version} -a 1
  145. pushd db.1.85/PORT/linux
  146. %patch10 -p0 -b .1.1
  147. popd
  148. pushd db.1.85
  149. %patch11 -p0 -b .1.2
  150. %patch12 -p0 -b .1.3
  151. %patch13 -p0 -b .1.4
  152. %patch20 -p1 -b .errno
  153. popd
  154. %patch22 -p1 -b .185compat
  155. %patch24 -p1 -b .4.5.20.jni
  156. # Remove tags files which we don't need.
  157. find . -name tags | xargs rm -f
  158. # Define a shell function for fixing HREF references in the docs, which
  159. # would otherwise break when we split the docs up into subpackages.
  160. fixup_href() {
  161. for doc in $@ ; do
  162. chmod u+w ${doc}
  163. sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
  164. -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
  165. -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
  166. -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
  167. -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
  168. -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
  169. -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
  170. -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
  171. -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
  172. -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
  173. -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
  174. -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
  175. -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
  176. -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
  177. -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
  178. -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
  179. -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
  180. -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
  181. touch -r ${doc} ${doc}.new
  182. cat ${doc}.new > ${doc}
  183. touch -r ${doc}.new ${doc}
  184. rm -f ${doc}.new
  185. done
  186. }
  187. set +x # XXX painful to watch
  188. # Fix all of the HTML files.
  189. fixup_href `find . -name "*.html"`
  190. set -x # XXX painful to watch
  191. cd dist
  192. ./s_config
  193. %build
  194. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
  195. # Build the old db-185 libraries.
  196. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  197. build() {
  198. test -d dist/$1 || mkdir dist/$1
  199. # Static link db_dump185 with old db-185 libraries.
  200. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
  201. /bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  202. pushd dist/$1
  203. ln -sf ../configure .
  204. # XXX --enable-diagnostic should be disabled for production (but is
  205. # useful).
  206. # XXX --enable-debug_{r,w}op should be disabled for production.
  207. %configure -C \
  208. --enable-compat185 --enable-dump185 \
  209. --enable-shared --enable-static \
  210. --enable-tcl --with-tcl=%{_libdir} \
  211. --enable-cxx \
  212. %ifarch %{java_arches}
  213. --enable-java \
  214. %else
  215. --disable-java \
  216. %endif
  217. --enable-test \
  218. # --enable-diagnostic \
  219. # --enable-debug --enable-debug_rop --enable-debug_wop \
  220. # Remove libtool predep_objects and postdep_objects wonkiness so that
  221. # building without -nostdlib doesn't include them twice. Because we
  222. # already link with g++, weird stuff happens if you don't let the
  223. # compiler handle this.
  224. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  225. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  226. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  227. make %{?_smp_mflags}
  228. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  229. LDBJ=./.libs/libdb_java-%{__soversion}.la
  230. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  231. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  232. fi
  233. popd
  234. }
  235. build dist-tls
  236. %install
  237. rm -rf ${RPM_BUILD_ROOT}
  238. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  239. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  240. %makeinstall -C dist/dist-tls
  241. # XXX Nuke non-versioned archives and symlinks
  242. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
  243. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
  244. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
  245. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
  246. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
  247. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  248. # Move the main shared library from /usr/lib* to /lib* directory.
  249. if [ "%{_libdir}" != "/%{_lib}" ]; then
  250. mkdir -p $RPM_BUILD_ROOT/%{_lib}/
  251. mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
  252. # Leave relative symlinks in %{_libdir}.
  253. touch $RPM_BUILD_ROOT/rootfile
  254. root=..
  255. while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
  256. root=${root}/..
  257. done
  258. rm $RPM_BUILD_ROOT/rootfile
  259. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
  260. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
  261. ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
  262. fi
  263. # Move the header files to a subdirectory, in case we're deploying on a
  264. # system with multiple versions of DB installed.
  265. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
  266. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
  267. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  268. for i in db.h db_cxx.h db_185.h; do
  269. ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
  270. done
  271. %ifarch %{java_arches}
  272. # Move java jar file to the correct place
  273. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  274. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  275. %endif
  276. # Eliminate installed doco
  277. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  278. # XXX Avoid Permission denied. strip when building as non-root.
  279. chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
  280. %clean
  281. rm -rf ${RPM_BUILD_ROOT}
  282. %post -p /sbin/ldconfig
  283. %postun -p /sbin/ldconfig
  284. %post -n compat32-%{name} -p /sbin/ldconfig
  285. %postun -n compat32-%{name} -p /sbin/ldconfig
  286. %post -p /sbin/ldconfig cxx
  287. %postun -p /sbin/ldconfig cxx
  288. %post -n compat32-%{name}-cxx -p /sbin/ldconfig
  289. %postun -n compat32-%{name}-cxx -p /sbin/ldconfig
  290. %post -p /sbin/ldconfig tcl
  291. %postun -p /sbin/ldconfig tcl
  292. %post -n compat32-%{name}-tcl -p /sbin/ldconfig
  293. %postun -n compat32-%{name}-tcl -p /sbin/ldconfig
  294. %post -p /sbin/ldconfig java
  295. %postun -p /sbin/ldconfig java
  296. %files
  297. %defattr(-,root,root)
  298. %doc LICENSE README
  299. /%{_lib}/libdb-%{__soversion}.so
  300. %{_libdir}/libdb-%{__soversion}.so
  301. %files cxx
  302. %defattr(-,root,root)
  303. %{_libdir}/libdb_cxx-%{__soversion}.so
  304. %files utils
  305. %defattr(-,root,root)
  306. %doc docs/utility
  307. %{_bindir}/db*_archive
  308. %{_bindir}/db*_checkpoint
  309. %{_bindir}/db*_deadlock
  310. %{_bindir}/db*_dump*
  311. %{_bindir}/db*_load
  312. %{_bindir}/db*_printlog
  313. %{_bindir}/db*_recover
  314. %{_bindir}/db*_stat
  315. %{_bindir}/db*_upgrade
  316. %{_bindir}/db*_verify
  317. %{_bindir}/db*_hotbackup
  318. %{_bindir}/db*_sql
  319. %files devel
  320. %defattr(-,root,root)
  321. %doc docs/api_c docs/api_cxx docs/api_tcl docs/index.html
  322. %doc docs/ref docs/images
  323. %doc examples_c examples_cxx
  324. %{_libdir}/libdb.so
  325. %{_libdir}/libdb-%{__soversion}.la
  326. %{_libdir}/%{_libdb_a}
  327. %{_libdir}/libdb_cxx.so
  328. %{_libdir}/libdb_cxx-%{__soversion}.la
  329. %{_libdir}/%{_libcxx_a}
  330. %dir %{_includedir}/%{name}
  331. %{_includedir}/%{name}/db.h
  332. %{_includedir}/%{name}/db_185.h
  333. %{_includedir}/%{name}/db_cxx.h
  334. %{_includedir}/db.h
  335. %{_includedir}/db_185.h
  336. %{_includedir}/db_cxx.h
  337. %files tcl
  338. %defattr(-,root,root)
  339. %{_libdir}/libdb_tcl-%{__soversion}.a
  340. %{_libdir}/libdb_tcl-%{__soversion}.la
  341. %{_libdir}/libdb_tcl-%{__soversion}.so
  342. %ifarch %{java_arches}
  343. %files java
  344. %defattr(-,root,root)
  345. %doc docs/java
  346. %doc examples_java
  347. %{_libdir}/libdb_java*
  348. %{_datadir}/java/*.jar
  349. %endif
  350. %if %{build_compat32}
  351. %files -n compat32-%{name}
  352. %defattr(-,root,root)
  353. /%{_lib}/libdb-%{__soversion}.so
  354. %{_libdir}/libdb-%{__soversion}.so
  355. %files -n compat32-%{name}-cxx
  356. %defattr(-,root,root)
  357. %{_libdir}/libdb_cxx-%{__soversion}.so
  358. %files -n compat32-%{name}-devel
  359. %defattr(-,root,root)
  360. %{_libdir}/libdb.so
  361. %{_libdir}/libdb-%{__soversion}.la
  362. %{_libdir}/libdb_cxx-%{__soversion}.la
  363. %{_libdir}/%{_libdb_a}
  364. %{_libdir}/%{_libcxx_a}
  365. %files -n compat32-%{name}-tcl
  366. %defattr(-,root,root)
  367. %{_libdir}/libdb_tcl-%{__soversion}.a
  368. %{_libdir}/libdb_tcl-%{__soversion}.la
  369. %{_libdir}/libdb_tcl-%{__soversion}.so
  370. %endif
  371. %changelog
  372. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.26-2
  373. - rebuilt with gcc-4.4.3-3 on ppc
  374. * Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.26-1
  375. - update to 4.8.26
  376. - remove '--enable-rpc'
  377. - rpc support is removed from db4
  378. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
  379. - initial build of db-4.6.21 on Vine Linux
  380. - temporarily commented out "libtoolize" and "s_config" lines
  381. until Vine's autotools get updated (maybe?)
  382. * Fri Apr 3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
  383. - add upstream patch to fix a race condition between checkpoint
  384. and DB->close which can result in the checkpoint thread self-deadlocking
  385. * Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
  386. - don't list headers twice in filelist (#436701)
  387. * Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
  388. - manual rebuild because of gcc-4.3 (#434185)
  389. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
  390. - Autorebuild for GCC 4.3
  391. * Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
  392. - update to 4.6.21
  393. - own %%{_includedir}/db4 (#274251)
  394. * Mon Sep 3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
  395. - update to 4.6.19 (#273461)
  396. * Thu Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
  397. - rebuild for BuildID
  398. - BR util-linux-ng
  399. * Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
  400. - update to 4.6.18
  401. - drop upstream patches for 4.5.20 and gcj patch
  402. - remove nptl-abi-note.S, useless as we are definitely
  403. running kernel >= 2.4.20 (#245416)
  404. - move C++ stuff to subpackages to reduce dependency bloat (#220484)
  405. - package db_codegen
  406. - correct open() calls so that new db4 compiles with the new glibc
  407. * Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
  408. - Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
  409. * Mon Dec 4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
  410. - apply upstream patches for 4.5.20
  411. (Java API <-> core API related fixes)
  412. * Fri Dec 1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
  413. - temporarily remove ppc64 from java arches
  414. * Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
  415. - sync db4 and compat-db licenses to BSD-style as the result of
  416. consultation with legal department
  417. - fix some rpmlint warnings
  418. * Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
  419. - update to db-4.5.20 (#198038)
  420. - fix BuildRoot
  421. - drop .64bit patch
  422. - patch/source URLs now point to correct location
  423. * Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
  424. - rebuild
  425. * Wed Sep 6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
  426. - revert the previous fix, it crashes OOo help
  427. * Sun Sep 3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
  428. - fix memleak caused by SET_TXN macro in xa_db.c, when opening
  429. database created with DB_XA_CREATE flag (#204920)
  430. * Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
  431. - fix sparc64 build (#199358)
  432. * Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
  433. - rebuild because of gnu_hash
  434. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
  435. - rebuild
  436. * Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
  437. - drop useless java, lfs patches
  438. * Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
  439. - apply x86_64 fix from Henrik Nordstrom (#184588)
  440. - don't nuke non-versioned archives twice
  441. * Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
  442. - don't package /usr/share/doc/images in the main db4 package
  443. and move it to db4-devel (#33328)
  444. - make db4 LFS capable (#33849)
  445. - move db4-devel, db4-tcl, db4-java to Development/Libraries
  446. group instead of System Environment/Libraries (#54320)
  447. - BuildPrereq -> BuildRequires
  448. - don't use RPM_SOURCE_DIR
  449. - Obsoletes db3, db2
  450. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
  451. - bump again for double-long bug on ppc(64)
  452. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
  453. - rebuilt for new gcc4.1 snapshot and glibc changes
  454. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  455. - rebuilt
  456. * Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
  457. - New upstream release
  458. * Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
  459. - Re-enable java for ppc64
  460. * Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
  461. - Add fno-strict-aliasing for java (#168965)
  462. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
  463. - no java for ppc64 for now (#166657)
  464. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
  465. - FC5 is nptl only (derived from jbj's spec)
  466. - upgrade to 4.3.28
  467. * Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
  468. - re-enable db4-java
  469. * Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
  470. - /usr/lib/tls/ix86 dirs (#151371)
  471. * Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
  472. - add libdb_cxx.so link (#149191)
  473. * Fri Mar 4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
  474. - rebuild with gcc4.
  475. * Sat Jan 1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
  476. - upgrade to 4.3.27.
  477. * Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
  478. - upgrade to 4.3.21, no db4-java for the moment again again.
  479. * Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
  480. - on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
  481. the availability of an NPTL libpthread in glibc > 2.3.3-48
  482. - run ldconfig in db4-java's %%post/%%postun
  483. - when building java support, assume that libgcj is equivalent enough to 1.3
  484. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  485. - rebuilt
  486. * Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
  487. - remove dangling symlinks (#123721 et al).
  488. - remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
  489. - apply 2 patches from sleepycat.
  490. - resurrect db4-java using sun jvm-1.4.2.
  491. - cripple autoconf sufficiently to build db4-java with gcj, without jvm.
  492. - check javac first, gcj34 next, then gcj-ssa, finally gcj.
  493. - add ed build dependency (#125180).
  494. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  495. - rebuilt
  496. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  497. - rebuilt
  498. * Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
  499. - fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
  500. * Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
  501. - upgrade to db-4.2.52, no db4-java for the moment.
  502. * Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
  503. - Add build requires tcl-devel
  504. * Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
  505. - symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
  506. that the run-time linker can find the right copy for of apps which use an
  507. RPATH to point at %%{_libdir}/libdb-4.1.so
  508. * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
  509. - add another section to the ABI note for the TLS libdb so that it's marked as
  510. not needing an executable stack (from Arjan Van de Ven)
  511. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
  512. - build both with and without support for shared mutex locks, which require NPTL
  513. - make behavior wrt where we put libdb the same for all OSs
  514. - revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
  515. doesn't work
  516. - fix dangling HREFs in utility docs (pointed to main docs dir, while they're
  517. actually in the -utils docs dir)
  518. - run ldconfig when installing/removing the -utils subpackage, as it contains
  519. shared libraries
  520. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
  521. - fix multiple-inclusion problem of startup files when building shlibs without
  522. the -nostdlib flag
  523. * Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
  524. - link shared libraries without -nostdlib, which created an unresolvable dep
  525. on a hidden symbol
  526. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  527. - allow compiling without tcl dependency
  528. * Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
  529. - update to 4.2.42.
  530. - build in build_unix subdir.
  531. - eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
  532. - create db4-tcl sub-pkg to isolate libtcl dependencies.
  533. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
  534. - rebuild
  535. * Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
  536. - add missing tcl-devel buildrequires (#101814)
  537. * Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
  538. - rebuild
  539. * Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
  540. - build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
  541. - whack out libtool predep_objects wonkiness.
  542. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
  543. - rebuild.
  544. * Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
  545. - hack out O_DIRECT support in db4 for now.
  546. * Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
  547. - replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
  548. cause a mismatch
  549. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  550. - rebuilt
  551. * Wed Jun 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
  552. - change configure to only warn if JNI includes aren't found, assuming that
  553. the C compiler can find them
  554. - remove build requirement on jdkgcj -- gcj is sufficient
  555. * Mon May 5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
  556. - upgrade to 4.1.25, crypto version.
  557. - enable posix mutexes using nptl on all arches.
  558. * Mon Mar 3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
  559. - enabled db4-java for x86_64
  560. * Wed Feb 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
  561. - add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
  562. linking with -ldb-4.0 will work again
  563. * Tue Feb 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
  564. - rebuild to use link the shared object with the same libraries we use
  565. for the bundled utils, should pull in libpthread when needed
  566. - move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
  567. * Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
  568. - add java for s390x
  569. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
  570. - rebuilt
  571. * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
  572. - add java for s390
  573. * Tue Oct 8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
  574. - add java bits back in for x86 boxes
  575. * Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
  576. - Added better fix for s390/s390x/x86_64
  577. * Thu Sep 05 2002 Arjan van de Ven
  578. - remove java bits for x86-64
  579. * Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
  580. - include libdb_tcl-4.1.a library.
  581. - obsolete db1 packages.
  582. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
  583. - include patch to avoid db_recover (#70362)
  584. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  585. - rebuilt with gcc-3.2 (we hope)
  586. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
  587. - own %%{_includedir}/%{name}
  588. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
  589. - build using gcc-3.2-0.1
  590. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  591. - automated rebuild
  592. * Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
  593. - Add java bindings
  594. - Fix C++ bindings
  595. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  596. - automated rebuild
  597. * Thu May 9 2002 Jeff Johnson <jbj@redhat.com>
  598. - re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
  599. - make sure that -ldb is functional.
  600. * Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
  601. - avoid db_util name collisions with multiple versions installed.
  602. * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
  603. - remove relocatability stuffs
  604. - swallow a local copy of db1 and build db185_dump statically with it, to
  605. remove the build dependency and simplify bootstrapping new arches
  606. * Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
  607. - have subpackages obsolete their db3 counterparts, because they conflict anyway
  608. * Tue Jan 8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
  609. - upgrade to 4.0.14.
  610. * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  611. - fix dangling docs symlinks
  612. - fix dangling doc HREFs (#33328)
  613. - apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
  614. * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
  615. - turn off --enable-debug
  616. * Thu May 10 2001 Than Ngo <than@redhat.com>
  617. - fixed to build on s390x
  618. * Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
  619. - update to 3.2.9.
  620. * Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
  621. - rebuild to remove 777 directories.
  622. * Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
  623. - don't build with --enable-diagnostic.
  624. - add build prereq on tcl.
  625. - default value for %%_lib macro if not found.
  626. * Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
  627. - add /usr/lib/libdb-3.1.so symlink to %%files.
  628. - remove dangling tags symlink from examples.
  629. * Mon Oct 9 2000 Jeff Johnson <jbj@redhat.com>
  630. - rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
  631. - turn off --enable-diagnostic for performance.
  632. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  633. - update to 3.1.17.
  634. - disable posix mutexes Yet Again.
  635. * Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
  636. - add c++ and posix mutex support.
  637. * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
  638. - put nss_db into a separate package
  639. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  640. - rebuild to cope with glibc locale binary incompatibility, again
  641. * Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
  642. - remove redundant strip of libnss_db* that is nuking symbols.
  643. - change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
  644. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  645. - summaries from specspo.
  646. - all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
  647. * Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
  648. - temporarily build nss_db in this package, should be moved
  649. into separate nss_db package soon
  650. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  651. - rebuild to cope with glibc locale binary incompatibility
  652. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  653. - automatic rebuild
  654. * Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
  655. - upgrade to 3.1.14.
  656. - create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
  657. - FHS packaging.
  658. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  659. - disable tcl Yet Again, base packages cannot depend on libtcl.so.
  660. * Sat Jun 3 2000 Jeff Johnson <jbj@redhat.com>
  661. - enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
  662. * Tue May 30 2000 Matt Wilson <msw@redhat.com>
  663. - include /lib/libdb.so in the devel package
  664. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  665. - put in "System Environment/Libraries" per msw instructions.
  666. * Tue May 9 2000 Jeff Johnson <jbj@redhat.com>
  667. - install shared library in /lib, not /usr/lib.
  668. - move API docs to db3-devel.
  669. * Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
  670. - don't rename db_* to db3_*.
  671. * Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
  672. - disable --enable-test --enable-debug_rop --enable-debug_wop.
  673. - disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
  674. problems.
  675. * Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
  676. - add 3.0.55.1 alignment patch.
  677. - add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
  678. - add --enable-tcl (needed -lpthreads).
  679. * Sat Apr 1 2000 Jeff Johnson <jbj@redhat.com>
  680. - add --enable-debug_{r,w}op for now.
  681. - add variable to set shm perms.
  682. * Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
  683. - update to 3.0.55
  684. * Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
  685. - Add --enable-cxx to configure.
  686. * Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
  687. - Create.