libxml++-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221
  1. %global apiver 2.6
  2. Name: libxml++
  3. Version: 2.40.1
  4. Release: 2%{?_dist_release}
  5. Summary: C++ wrapper for the libxml2 XML parser library
  6. Summary(ja): libxml2 XML 解析ライブラリの C++ ラッパー
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://libxmlplusplus.sourceforge.net/
  10. Source: http://ftp.gnome.org/pub/GNOME/sources/libxml++/2.40/libxml++-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel >= 2.6.1
  13. BuildRequires: glibmm-devel >= 2.4.0
  14. BuildRequires: doxygen, graphviz
  15. %description
  16. libxml++ is a C++ wrapper for the libxml2 XML parser library. It's original
  17. author is Ari Johnson and it is currently maintained by Christophe de Vienne
  18. and Murray Cumming.
  19. %package devel
  20. Summary: Development files for %{name}
  21. Summary(ja): %{name} の開発用ファイル
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. Requires: libxml2-devel
  26. Requires: glibmm-devel
  27. %description devel
  28. This package contains the headers and libraries for libxml++ development.
  29. %prep
  30. %setup -q
  31. # fix wrong end of line
  32. sed -i s'#\r##' examples/dom_parser/example_with_namespace.xml
  33. %build
  34. %configure \
  35. %if %{?_dist_release} == "vl5"
  36. --disable-documentation \
  37. %endif
  38. --disable-static
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. %makeinstall
  43. find $RPM_BUILD_ROOT -name "*.la" -o -name '*.a' | xargs rm -f
  44. # Modify temporary working directories for files section.
  45. rm -rf _reference _examples _manual
  46. mkdir -m 755 _reference _examples _manual
  47. %if %{?_dist_release} != "vl5"
  48. cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{apiver}/reference/html _reference/reference
  49. %endif
  50. cp -a docs/manual/html _manual/manual
  51. cp -a examples _examples/examples
  52. rm -rf $RPM_BUILD_ROOT%{_docdir}
  53. # Delete non-working makefiles, object files, prebuilt binaries and
  54. # empty files.
  55. find _examples -type f -a \( -name Makefile\* -o -name \*.o \
  56. -o \( -name example -a -perm +0111 \) -o -empty \) | xargs rm -f
  57. find _examples -type d -name '*.libs' -o -name '.deps' | xargs rm -rf
  58. %if %{?_dist_release} != "vl5"
  59. # fix devhelp index file
  60. sed -i "s#"$RPM_BUILD_ROOT"##g" \
  61. $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  62. sed -i "s#"/%{name}-%{apiver}/reference/html"#"/%{name}-devel-%{version}/reference"#" \
  63. $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  64. %endif
  65. %post -p /sbin/ldconfig
  66. %postun -p /sbin/ldconfig
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %files
  70. %defattr (-,root,root,-)
  71. %doc AUTHORS COPYING NEWS README ChangeLog
  72. %{_libdir}/*.so.*
  73. %files devel
  74. %defattr (-,root,root,-)
  75. %doc _examples/examples _manual/manual
  76. %{_includedir}/*
  77. %{_libdir}/*.so
  78. %{_libdir}/pkgconfig/*
  79. %dir %{_libdir}/%{name}-%{apiver}
  80. %dir %{_libdir}/%{name}-%{apiver}/include
  81. %{_libdir}/%{name}-%{apiver}/include/*.h
  82. %if %{?_dist_release} != "vl5"
  83. %doc _reference/reference
  84. %{_datadir}/devhelp/books/%{name}-%{apiver}/%{name}-%{apiver}.devhelp2
  85. %endif
  86. %changelog
  87. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
  88. - rebuild with gcc-5.4.0
  89. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  90. - new upstream release
  91. * Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  92. - new upstream release
  93. * Tue Nov 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
  94. - new upstream release
  95. * Wed Jun 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.34.2-1
  96. - new upstream release
  97. - changed source archive type to xz
  98. * Thu Jan 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32.0-1
  99. - new upstream release
  100. - fixed spec file for Vine Linux 5
  101. - added Japanese summary
  102. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-3
  103. - rebuild with rpm-4.8.1 for pkg-config file
  104. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.30.0-2
  105. - Initial build for VineLinux
  106. * Fri Apr 09 2010 Haïkel Guémar <hguemar@gmail.com> - 2.30.0-1
  107. - Update to upstream 2.30.0
  108. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.26.0-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  110. * Sun Apr 12 2009 Denis Leroy <denis@poolshark.org> - 2.26.0-1
  111. - Update to upstream 2.26.0 (to match Gnome release)
  112. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.24.2-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  114. * Thu Jan 15 2009 Denis Leroy <denis@poolshark.org> - 2.24.2-1
  115. - Update to 2.24.2 (memleak fixes)
  116. - Fixed Gnome FTP URL
  117. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.23.2-2
  118. - Include unowned directories
  119. * Tue Aug 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.2-1
  120. - update to 2.23.2
  121. * Tue May 13 2008 Denis Leroy <denis@poolshark.org>
  122. - Removed unneeded example binaries from devel package
  123. * Thu Mar 13 2008 Denis Leroy <denis@poolshark.org> - 2.22.0-1
  124. - Update to upstream 2.22.0
  125. - GCC 4.3 patch upstreamed
  126. * Sun Feb 17 2008 Denis Leroy <denis@poolshark.org> - 2.20.0-2
  127. - Added patch for gcc 4.3 rebuild
  128. * Thu Sep 20 2007 Denis Leroy <denis@poolshark.org> - 2.20.0-1
  129. - Update to new 2.20 stable branch
  130. * Thu Aug 16 2007 Denis Leroy <denis@poolshark.org> - 2.18.2-2
  131. - Update to upstream 2.18.2 (mem leak fix)
  132. - Fixed License tag
  133. * Wed Jul 25 2007 Jesse Keating <jkeating@redhat.com> - 2.18.1-2
  134. - Rebuild for RH #249435
  135. * Tue Jul 24 2007 Denis Leroy <denis@poolshark.org> - 2.18.1-1
  136. - Update to version 2.18.1
  137. * Sun Sep 03 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1.1
  138. - FC6 rebuild
  139. * Tue May 02 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.14.0-1
  140. - Version 2.14.0
  141. * Mon Feb 13 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2.1
  142. - FC5 Rebuild
  143. * Thu Jan 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 2.12.0-2
  144. - Rebuilt to address RH #178592
  145. * Thu Sep 08 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.12.0-1
  146. - Version 2.12.0
  147. - Use --disable-static for configure.
  148. * Thu Jul 21 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 2.10.0-1
  149. - Version 2.10.0
  150. - Rearrange and conform to new FE standards
  151. - Buildrequire glibmm24-devel
  152. - Add devel requires to -devel
  153. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.26.0-5
  154. - rebuild on all arches
  155. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  156. - rebuilt
  157. * Tue Nov 04 2003 Panu Matilainen <pmatilai@welho.com> - 0:0:26.0-0.fdr.3
  158. - remove empty .libs directories
  159. * Mon Nov 3 2003 Michael Schwendt <mschwendt[AT]users.sf.net> - 0:0.26.0-0.fdr.2
  160. - buildrequires graphviz
  161. - devel package requires main package and pkgconfig
  162. - own %%_includedir/libxml++-1.0
  163. - clean up examples tree
  164. * Tue Oct 21 2003 Panu Matilainen <pmatilai@welho.com>
  165. - Initial Fedora packaging