xorg-x11-font-utils-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315
  1. %define pkgname font-utils
  2. Summary: X.Org X11 font utilities
  3. Summary(ja): X.Org X11 font ユーティリティ
  4. Name: xorg-x11-%{pkgname}
  5. Version: 7.7
  6. Release: 5%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.1.tar.bz2
  11. Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.5.tar.bz2
  12. Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
  13. Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.2.1.tar.bz2
  14. Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.3.2.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pkgconfig
  17. # xorg-x11-libXfont-devel needed for bdftopcf
  18. BuildRequires: libXfont-devel
  19. # xorg-x11-libX11-devel needed for fonttosfnt
  20. BuildRequires: libX11-devel
  21. # xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
  22. BuildRequires: libfontenc-devel >= 0.99.2-2
  23. # freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
  24. BuildRequires: freetype2-devel
  25. # zlib-devel needed for bdftopcf
  26. BuildRequires: zlib-devel
  27. # xorg-x11-proto-devel is needed for mkfontscale, which includes headers
  28. # from it directly.
  29. BuildRequires: xorg-x11-proto-devel
  30. BuildRequires: xorg-x11-util-macros
  31. BuildRequires: autoconf
  32. Requires(pre): xorg-x11-filesystem
  33. # NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
  34. # bug #173875 is installed in order for mkfontscale/mkfontdir to work
  35. # properly. It is a "pre" dep, to ensure libfontenc gets installed before
  36. # xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
  37. # set, avoiding a possible race condition.
  38. Requires(pre): libfontenc
  39. Provides: %{pkgname}
  40. Provides: XOrg-%{pkgname} = %{version}
  41. Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
  42. # NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
  43. # is needed for upgrades to work properly from OS releases that had XFree86
  44. Obsoletes: XFree86-font-utils, XOrg-font-utils
  45. # NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
  46. # this is needed for upgrades to work.
  47. Obsoletes: XFree86
  48. # NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
  49. # xorg-x11-font-utils in 6.7.99.903-3
  50. Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
  51. # NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
  52. Obsoletes: XOrg-tools <= 6.7.99.903-3
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. %description
  56. X.Org X11 font utilities required for font installation, conversion,
  57. and generation.
  58. %package -n bdftruncate
  59. Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
  60. Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
  61. Group: Applications/System
  62. %description -n bdftruncate
  63. bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
  64. other ISO10646-1 BDF fonts in which all characters above a threshold
  65. code value are stored unencoded. This is often desirable because the
  66. Xlib API and X11 protocol data structures used for representing font
  67. metric information are extremely inefficient when handling sparsely
  68. populated fonts.
  69. %prep
  70. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  71. %build
  72. # Build all apps
  73. {
  74. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
  75. pushd $app-*
  76. # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
  77. case $app in
  78. font-util)
  79. autoconf
  80. ;;
  81. esac
  82. %configure
  83. make
  84. popd
  85. done
  86. }
  87. %install
  88. rm -rf $RPM_BUILD_ROOT
  89. # Install all apps
  90. {
  91. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
  92. pushd $app-*
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. popd
  95. done
  96. for i in */README ; do
  97. [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
  98. done
  99. for i in */COPYING ; do
  100. grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
  101. done
  102. }
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %files
  106. %defattr(-,root,root,-)
  107. %license COPYING-*
  108. %doc README-*
  109. %{_bindir}/bdftopcf
  110. %{_bindir}/fonttosfnt
  111. %{_bindir}/mkfontdir
  112. %{_bindir}/mkfontscale
  113. %{_bindir}/ucs2any
  114. # blech. this one should be in -filesystem
  115. %dir %{_datadir}/fonts/X11
  116. %dir %{_datadir}/fonts/X11/util
  117. %{_datadir}/fonts/X11/util/map-*
  118. %{_datadir}/aclocal/fontutil.m4
  119. %{_libdir}/pkgconfig/fontutil.pc
  120. %{_mandir}/man1/bdftopcf.1*
  121. %{_mandir}/man1/fonttosfnt.1*
  122. %{_mandir}/man1/mkfontdir.1*
  123. %{_mandir}/man1/mkfontscale.1*
  124. %{_mandir}/man1/ucs2any.1*
  125. %files -n bdftruncate
  126. %defattr(-,root,root,-)
  127. %{_bindir}/bdftruncate
  128. %{_mandir}/man1/bdftruncate.1*
  129. %changelog
  130. * Fri Sep 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.7-5
  131. - bdftopcf-1.1
  132. - fonttosfnt-1.0.5
  133. - mkfontscale-1.2.1
  134. - font-util-1.3.2
  135. * Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-4
  136. - font-util-1.3.1
  137. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-3
  138. - bdftopcf-1.0.5
  139. - mkfontscale-1.1.2
  140. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
  141. - mkfontscale-1.1.1
  142. - font-util-1.3.0
  143. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
  144. - bdftopcf-1.0.4
  145. * Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
  146. - mkfontdir-1.0.7
  147. - mkfontscale-1.1.0
  148. - add BuildRequires: xorg-x11-util-macros
  149. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
  150. - mkfontscale-1.0.9
  151. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
  152. - mkfontdir-1.0.6
  153. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
  154. - bdftopcf-1.0.3
  155. - mkfontscale-1.0.8
  156. - font-util-1.2.0
  157. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
  158. - rebuild with rpm-4.8.1 for pkg-config file
  159. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  160. - bdftopcf-1.0.2
  161. - mkfontdir-1.0.5
  162. - mkfontscale-1.0.7
  163. - font-util-1.1.1
  164. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
  165. - mkfontscale 1.0.6
  166. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  167. - fonttosfnt 1.0.4
  168. - mkfontdir 1.0.4
  169. - mkfontscale 1.0.5
  170. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
  171. - new versioning policy
  172. * Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
  173. - initial build for Vine Linux
  174. * Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
  175. - Move bdftruncate (and its perl dependency) to a subpackage.
  176. - %%doc for the non-empty READMEs and non-stub COPYINGs.
  177. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
  178. - Rebuild for build id
  179. * Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
  180. - bdftopcf 1.0.1
  181. - Superstition bump to 7.2-1
  182. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
  183. - mkfontdir 1.0.3
  184. * Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
  185. - fonttosfnt 1.0.3
  186. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
  187. - Remove X11R6 symlinks.
  188. * Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
  189. - Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
  190. with new freetype 2.2.
  191. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
  192. - rebuild
  193. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
  194. - Update to font-util-1.0.1 from X11R7.1
  195. - Set package version to X11 release the tarballs are based from.
  196. * Wed Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
  197. - Update mkfontdir
  198. * Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
  199. - Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
  200. itself. Leftover from the original package template it seems. (#182439)
  201. * Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
  202. - Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
  203. mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
  204. binaries. This will provide backward compatibilty for Fedora Core 5, however
  205. 3rd party developers and rpm package maintainers should update to using the
  206. new X11R7 locations immediately, as these compatibility links are temporary,
  207. and will be removed from a future OS release.
  208. - Remove system directories from file manifest to appease the banshees.
  209. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
  210. - bump again for double-long bug on ppc(64)
  211. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
  212. - rebuilt for new gcc4.1 snapshot and glibc changes
  213. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
  214. - Updated all utilities to the versions shipped in X11R7.0.
  215. * Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
  216. - Updated all utilities to version 1.0.0 from X11R7 RC4.
  217. - Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
  218. - Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
  219. variable "fontdir" to the fontutil.pc file which all of the font packages
  220. can autodetect and use instead of having to put manual fontdir overrides
  221. in every single rpm package.
  222. * Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
  223. - Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
  224. and font-util to version 0.99.2 from X11R7 RC3.
  225. - Changed manpage dir from man1x back to man1 due to another upstream change.
  226. - Added fontutil.m4 to file manifest.
  227. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
  228. - Changed package version to 0.99.1 to match the upstream font-util tarball
  229. version, and added "Epoch: 1" to the package for upgrades.
  230. - Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
  231. mapfiles data to install into datadir instead of libdir (#173943)
  232. - Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
  233. libfontenc to be installed that fixes bug #173453, and to also force it
  234. to be installed before xorg-x11-font-utils in a multi-package rpm
  235. transaction, which will ensure that when font packages get installed
  236. during upgrades via anaconda or yum, that the right libfontenc is being
  237. used by mkfontscale/mkfontdir.
  238. - Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
  239. people rebuilding xorg-x11-font-utils, as they'll need to install the new
  240. libfontenc now anyway before they can install the font-utils package.
  241. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
  242. - require newer filesystem (#172610)
  243. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
  244. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  245. X11R7 RC1.
  246. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
  247. - Glob util/map-* files in file manifest.
  248. - Added missing "Obsoletes: xorg-x11-font-utils".
  249. - Added "BuildRequires: pkgconfig".
  250. * Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
  251. - Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
  252. ucs2any, bdftruncate.
  253. * Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
  254. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  255. X11R7 RC1.
  256. - Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
  257. - Updated file manifest to to find the manpages in "man1x".
  258. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
  259. - Initial build.