gnome-software-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784
  1. %global glib2_version 2.56.0
  2. %global gtk3_version 3.22.4
  3. %global json_glib_version 1.2.0
  4. %global packagekit_version 1.1.1
  5. %global appstream_glib_version 0.7.14-3
  6. %global libsoup_version 2.52.0
  7. %global gsettings_desktop_schemas_version 3.12.0
  8. %global gnome_desktop_version 3.18.0
  9. %global fwupd_version 1.0.7
  10. %global flatpak_version 0.9.4
  11. Summary: A software center for GNOME
  12. Name: gnome-software
  13. Version: 3.36.1
  14. Release: 2%{?_dist_release}
  15. Group: admin-tools,desktop-gnome
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. License: GPLv2+
  19. URL: https://wiki.gnome.org/Apps/Software
  20. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  21. Source0: https://download.gnome.org/sources/gnome-software/%{shortver}/%{name}-%{version}.tar.xz
  22. # /usr/share/pixmaps/backgrounds/Vine/vinelinux7-7-1920x1200.jpg from vine-backgrounds
  23. Source1: vine.jpg
  24. BuildRequires: gcc
  25. BuildRequires: gettext
  26. BuildRequires: libxslt
  27. BuildRequires: docbook-style-xsl
  28. BuildRequires: desktop-file-utils
  29. #BuildRequires: fwupd-devel >= %{fwupd_version}
  30. BuildRequires: glib2-devel >= %{glib2_version}
  31. BuildRequires: gnome-desktop3-devel
  32. BuildRequires: gnome-online-accounts-devel
  33. BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
  34. BuildRequires: gspell-devel
  35. BuildRequires: gtk3-devel >= %{gtk3_version}
  36. BuildRequires: gtk-doc
  37. BuildRequires: json-glib-devel >= %{json_glib_version}
  38. BuildRequires: libappstream-glib-devel >= %{appstream_glib_version}
  39. BuildRequires: libsoup-devel
  40. BuildRequires: libxmlb-devel
  41. BuildRequires: meson
  42. BuildRequires: PackageKit-devel >= %{packagekit_version}
  43. BuildRequires: polkit-devel
  44. BuildRequires: libsecret-devel
  45. BuildRequires: flatpak-devel >= %{flatpak_version}
  46. BuildRequires: ostree-devel
  47. #BuildRequires: rpm-ostree-devel
  48. BuildRequires: libgudev-devel
  49. #BuildRequires: valgrind-devel
  50. Requires: appstream-data
  51. Requires: flatpak%{?_isa} >= %{flatpak_version}
  52. Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
  53. #Requires: fwupd%{?_isa} >= %{fwupd_version}
  54. Requires: glib2%{?_isa} >= %{glib2_version}
  55. Requires: gnome-desktop3%{?_isa} >= %{gnome_desktop_version}
  56. # gnome-menus is needed for app folder .directory entries
  57. Requires: gnome-menus%{?_isa}
  58. Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
  59. Requires: gtk3%{?_isa} >= %{gtk3_version}
  60. Requires: json-glib%{?_isa} >= %{json_glib_version}
  61. Requires: iso-codes
  62. Requires: libappstream-glib%{?_isa} >= %{appstream_glib_version}
  63. # librsvg2 is needed for gdk-pixbuf svg loader
  64. Requires: librsvg2%{?_isa}
  65. Requires: libsoup%{?_isa} >= %{libsoup_version}
  66. Requires: PackageKit%{?_isa} >= %{packagekit_version}
  67. # this is not a library version
  68. %define gs_plugin_version 13
  69. %description
  70. gnome-software is an application that makes it easy to add, remove
  71. and update software in the GNOME desktop.
  72. %package devel
  73. Summary: Headers for building external gnome-software plugins
  74. Group: programming
  75. Requires: %{name}%{?_isa} = %{version}-%{release}
  76. %description devel
  77. These development files are for building gnome-software plugins outside
  78. the source tree. Most users do not need this subpackage installed.
  79. %prep
  80. %autosetup -p1
  81. %build
  82. %meson \
  83. -Dsnap=false \
  84. -Dgudev=true \
  85. -Dpackagekit=true \
  86. -Dexternal_appstream=true \
  87. %if 0
  88. -Drpm_ostree=true \
  89. %else
  90. -Drpm_ostree=false \
  91. %endif
  92. -Dmalcontent=false \
  93. -Dtests=false \
  94. -Dubuntuone=false \
  95. -Dubuntu_reviews=false \
  96. -Dfwupd=false \
  97. -Dvalgrind=false
  98. %meson_build
  99. %install
  100. %meson_install
  101. # make the software center load faster
  102. desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
  103. --set-key=X-AppInstall-Package --set-value=%{name}
  104. %if 0
  105. # set up for Fedora
  106. cat >> %{buildroot}%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override << FOE
  107. [org.gnome.software]
  108. official-repos = [ 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source' ]
  109. FOE
  110. %endif
  111. # Install upgrade background image
  112. mkdir -p %{buildroot}%{_datadir}/gnome-software/backgrounds
  113. cp -a %{SOURCE1} %{buildroot}%{_datadir}/gnome-software/backgrounds/
  114. rm -rf %{buildroot}%{_docdir}/gnome-software
  115. %find_lang %name --with-gnome
  116. %check
  117. desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
  118. %post
  119. if [ $1 -eq 1 ]; then
  120. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  121. update-desktop-database -q > /dev/null || :
  122. fi
  123. %postun
  124. if [ $1 -eq 0 ]; then
  125. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  126. update-desktop-database -q > /dev/null || :
  127. fi
  128. %files -f %{name}.lang
  129. %doc AUTHORS README.md
  130. %license COPYING
  131. %{_bindir}/gnome-software
  132. %{_datadir}/applications/gnome-software-local-file.desktop
  133. %{_datadir}/applications/org.gnome.Software.desktop
  134. %{_mandir}/man1/gnome-software.1.gz
  135. %{_datadir}/icons/hicolor/*/apps/*
  136. %{_datadir}/icons/hicolor/scalable/status/software-installed-symbolic.svg
  137. %dir %{_datadir}/gnome-software
  138. %{_datadir}/gnome-software/*.png
  139. %{_datadir}/gnome-software/backgrounds/
  140. %{_datadir}/gnome-software/featured-*.svg
  141. %{_datadir}/gnome-software/featured-*.jpg
  142. %{_datadir}/metainfo/org.gnome.Software.appdata.xml
  143. %{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
  144. %if 0
  145. %{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
  146. %endif
  147. %{_datadir}/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
  148. %{_datadir}/polkit-1/actions/org.gnome.software.external-appstream.policy
  149. %dir %{_libdir}/gs-plugins-%{gs_plugin_version}
  150. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_appstream.so
  151. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-categories.so
  152. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-menu-path.so
  153. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dpkg.so
  154. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
  155. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-pkgdb-collections.so
  156. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_flatpak.so
  157. %if 0
  158. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fwupd.so
  159. %endif
  160. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_external-appstream.so
  161. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
  162. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_generic-updates.so
  163. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-blacklist.so
  164. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-popular.so
  165. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_icons.so
  166. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors-metadata.so
  167. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors.so
  168. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_modalias.so
  169. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_odrs.so
  170. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_os-release.so
  171. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-history.so
  172. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-local.so
  173. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-offline.so
  174. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-proxy.so
  175. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine-repos.so
  176. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine.so
  177. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refresh.so
  178. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-upgrade.so
  179. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-url-to-app.so
  180. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit.so
  181. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance-license.so
  182. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance.so
  183. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_repos.so
  184. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rewrite-resource.so
  185. %if 0
  186. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rpm-ostree.so
  187. %endif
  188. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_systemd-updates.so
  189. %{_sysconfdir}/xdg/autostart/gnome-software-service.desktop
  190. %{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
  191. %{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
  192. %{_datadir}/dbus-1/services/org.gnome.Software.service
  193. %{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
  194. %{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
  195. %if 0
  196. %{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override
  197. %endif
  198. %{_libexecdir}/gnome-software-cmd
  199. %{_libexecdir}/gnome-software-install-appstream
  200. %{_libexecdir}/gnome-software-restarter
  201. %files devel
  202. %{_libdir}/pkgconfig/gnome-software.pc
  203. %dir %{_includedir}/gnome-software
  204. %{_includedir}/gnome-software/*.h
  205. %{_datadir}/gtk-doc/html/gnome-software
  206. %changelog
  207. * Fri Aug 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-2
  208. - added R:appstream-data.
  209. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-1
  210. - new upstream release.
  211. * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.30.6-5
  212. - initial build for Vine Linux.
  213. * Tue May 07 2019 Kalev Lember <klember@redhat.com> - 3.30.6-4
  214. - Fix distro upgrade progress bar to actually work
  215. * Sun Apr 28 2019 Kalev Lember <klember@redhat.com> - 3.30.6-3
  216. - Add artwork for F30 upgrades
  217. * Mon Feb 25 2019 Kalev Lember <klember@redhat.com> - 3.30.6-2
  218. - Backport various fixes to error messages to avoid the dreaded
  219. "Unable to update '(null)'" error
  220. * Tue Dec 18 2018 Kalev Lember <klember@redhat.com> - 3.30.6-1
  221. - Update to 3.30.6
  222. * Wed Oct 24 2018 Kalev Lember <klember@redhat.com> - 3.30.5-1
  223. - Update to 3.30.5
  224. * Thu Oct 18 2018 Kalev Lember <klember@redhat.com> - 3.30.3-1
  225. - Update to 3.30.3
  226. * Fri Oct 05 2018 Kalev Lember <klember@redhat.com> - 3.30.2-1
  227. - Update to 3.30.2
  228. * Wed Sep 26 2018 Kalev Lember <klember@redhat.com> - 3.30.1-2
  229. - Add modular repos to official repos list
  230. * Tue Sep 25 2018 Kalev Lember <klember@redhat.com> - 3.30.1-1
  231. - Update to 3.30.1
  232. * Thu Sep 06 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
  233. - Update to 3.30.0
  234. * Tue Aug 28 2018 Richard Hughes <rhughes@redhat.com> - 3.29.92-1
  235. - Update to 3.29.92
  236. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.29.1-2
  237. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  238. * Wed May 09 2018 Kalev Lember <klember@redhat.com> - 3.29.1-1
  239. - Update to 3.29.1
  240. * Mon Apr 09 2018 Kalev Lember <klember@redhat.com> - 3.28.1-1
  241. - Update to 3.28.1
  242. * Thu Mar 29 2018 Kalev Lember <klember@redhat.com> - 3.28.0-5
  243. - Fix empty OS Updates showing up
  244. - Make rpm-ostree update triggering work
  245. * Thu Mar 15 2018 Kalev Lember <klember@redhat.com> - 3.28.0-4
  246. - Fix opening results from gnome-shell search provider
  247. * Wed Mar 14 2018 Kalev Lember <klember@redhat.com> - 3.28.0-3
  248. - Fix crash on initial run with no network (#1554986)
  249. * Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-2
  250. - Backport an upstream patch to fix shell extensions app ID
  251. * Mon Mar 12 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
  252. - Update to 3.28.0
  253. * Sun Mar 11 2018 Kalev Lember <klember@redhat.com> - 3.27.92-3
  254. - Rebuilt for gspell 1.8
  255. * Wed Mar 07 2018 Kalev Lember <klember@redhat.com> - 3.27.92-2
  256. - Move org.gnome.Software.Featured.xml from -editor to main package
  257. * Mon Mar 05 2018 Kalev Lember <klember@redhat.com> - 3.27.92-1
  258. - Update to 3.27.92
  259. * Sun Mar 04 2018 Neal Gompa <ngompa13@gmail.com> - 3.27.90-4
  260. - Drop obsolete snapd-login-service requirement for snap plugin subpackage
  261. * Mon Feb 19 2018 Adam Williamson <awilliam@redhat.com> - 3.27.90-3
  262. - Backport fix for RHBZ #1546893 from upstream git
  263. * Mon Feb 19 2018 Kalev Lember <klember@redhat.com> - 3.27.90-2
  264. - Re-enable rpm-ostree plugin
  265. * Thu Feb 15 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
  266. - Update to 3.27.90
  267. - Temporarily disable the rpm-ostree plugin
  268. * Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.27.4-4
  269. - Rebuild against newer gnome-desktop3 package
  270. * Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-3
  271. - Add fedora-workstation-repositories to nonfree-sources schema defaults
  272. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.27.4-2
  273. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  274. * Mon Jan 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-1
  275. - Update to 3.27.4
  276. - Drop unused --without packagekit option
  277. * Fri Jan 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.27.3-2
  278. - Remove obsolete scriptlets
  279. * Sat Dec 16 2017 Kalev Lember <klember@redhat.com> - 3.27.3-1
  280. - Update to 3.27.3
  281. * Mon Nov 13 2017 Kalev Lember <klember@redhat.com> - 3.27.2-1
  282. - Update to 3.27.2
  283. * Thu Nov 09 2017 Kalev Lember <klember@redhat.com> - 3.26.2-1
  284. - Update to 3.26.2
  285. - Re-enable fwupd support
  286. * Tue Oct 31 2017 Kalev Lember <klember@redhat.com> - 3.26.1-5
  287. - Enable the rpm-ostree plugin
  288. * Wed Oct 25 2017 Kalev Lember <klember@redhat.com> - 3.26.1-4
  289. - Fix "too many results returned" error after distro upgrades (#1496489)
  290. * Tue Oct 10 2017 Kalev Lember <klember@redhat.com> - 3.26.1-3
  291. - Backport a flatpakref installation fix
  292. * Mon Oct 09 2017 Richard Hughes <rhughes@redhat.com> - 3.26.1-2
  293. - Disable fwupd support until we get a 3.27.1 tarball
  294. * Sun Oct 08 2017 Kalev Lember <klember@redhat.com> - 3.26.1-1
  295. - Update to 3.26.1
  296. * Mon Sep 11 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
  297. - Update to 3.26.0
  298. * Sun Aug 27 2017 Kalev Lember <klember@redhat.com> - 3.25.91-1
  299. - Update to 3.25.91
  300. * Tue Aug 15 2017 Kalev Lember <klember@redhat.com> - 3.25.90-1
  301. - Update to 3.25.90
  302. * Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-6
  303. - Rebuilt after RPM update (№ 3)
  304. * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-5
  305. - Rebuilt for RPM soname bump
  306. * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-4
  307. - Rebuilt for RPM soname bump
  308. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-3
  309. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  310. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  312. * Fri Jul 21 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
  313. - Update to 3.25.4
  314. * Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 3.25.3-6
  315. - Drop a meson workaround now that meson is fixed
  316. * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-5
  317. - Actually properly enable snap subpackage after removing conditional
  318. * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-4
  319. - Remove unnecessary arch-specific conditional for snap subpackage
  320. * Tue Jun 27 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-3
  321. - Ensure snap subpackage is installed if snapd is installed
  322. * Fri Jun 23 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-2
  323. - Enable the snap subpackage
  324. * Fri Jun 23 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
  325. - Update to 3.25.3
  326. - Switch to the meson build system
  327. - Add an -editor subpackage with new banner editor
  328. * Mon May 15 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-1
  329. - Update to 3.23.3
  330. - Fix a common crash when installing flatpakrepo files
  331. - Ensure we show the banner when upgrades are available
  332. * Tue May 09 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
  333. - Update to 3.24.2
  334. * Tue Apr 25 2017 Adam Williamson <awilliam@redhat.com> - 3.24.1-2
  335. - Backport crasher fix from upstream (RHBZ #1444669 / BGO #781217)
  336. * Tue Apr 11 2017 Kalev Lember <klember@redhat.com> - 3.24.1-1
  337. - Update to 3.24.1
  338. * Tue Mar 21 2017 Kalev Lember <klember@redhat.com> - 3.24.0-1
  339. - Update to 3.24.0
  340. * Thu Mar 16 2017 Kalev Lember <klember@redhat.com> - 3.23.92-1
  341. - Update to 3.23.92
  342. * Mon Feb 27 2017 Richard Hughes <rhughes@redhat.com> - 3.23.91-1
  343. - Update to 3.23.91
  344. * Mon Feb 13 2017 Richard Hughes <rhughes@redhat.com> - 3.23.90-1
  345. - Update to 3.23.90
  346. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.3-2
  347. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  348. * Thu Dec 15 2016 Richard Hughes <rhughes@redhat.com> - 3.23.3-1
  349. - Update to 3.23.3
  350. * Wed Nov 23 2016 Kalev Lember <klember@redhat.com> - 3.23.2-1
  351. - Update to 3.23.2
  352. * Tue Nov 08 2016 Kalev Lember <klember@redhat.com> - 3.22.2-1
  353. - Update to 3.22.2
  354. * Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
  355. - Update to 3.22.1
  356. * Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
  357. - Update to 3.22.0
  358. * Wed Sep 14 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
  359. - Update to 3.21.92
  360. - Don't set group tags
  361. * Thu Sep 01 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
  362. - Update to 3.21.91
  363. * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-2
  364. - Rebuilt for fixed libappstream-glib headers
  365. * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-1
  366. - Update to 3.21.90
  367. - Tighten -devel subpackage dependencies
  368. * Thu Jul 28 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-2
  369. - Allow building without PackageKit for the atomic workstation.
  370. * Mon Jul 18 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-1
  371. - Update to 3.21.4
  372. * Thu May 26 2016 Kalev Lember <klember@redhat.com> - 3.21.2-2
  373. - Build with flatpak support
  374. * Mon May 23 2016 Richard Hughes <rhughes@redhat.com> - 3.21.2-1
  375. - Update to 3.21.2
  376. * Tue May 10 2016 Kalev Lember <klember@redhat.com> - 3.21.1-2
  377. - Require PackageKit 1.1.1 for system upgrade support
  378. * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.21.1-1
  379. - Update to 3.21.1
  380. * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.20.2-1
  381. - Update to 3.20.1
  382. - Allow popular and featured apps to match any plugin
  383. - Do not make the ODRS plugin depend on xdg-app
  384. - Fix many of the os-upgrade issues and implement the latest mockups
  385. - Make all the plugins more threadsafe
  386. - Return all update descriptions newer than the installed version
  387. - Show some non-fatal error messages if installing fails
  388. - Use a background PackageKit transaction when downloading upgrades
  389. * Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
  390. - Update to 3.20.1
  391. * Fri Apr 01 2016 Richard Hughes <rhughes@redhat.com> - 3.20.1-2
  392. - Set the list of official sources
  393. - Compile with xdg-app support
  394. * Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
  395. - Update to 3.20.0
  396. * Mon Mar 14 2016 Richard Hughes <rhughes@redhat.com> - 3.19.92-1
  397. - Update to 3.19.92
  398. * Thu Mar 03 2016 Kalev Lember <klember@redhat.com> - 3.19.91-2
  399. - Set minimum required json-glib version
  400. * Mon Feb 29 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
  401. - Update to 3.19.91
  402. * Mon Feb 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.90-1
  403. - Update to 3.19.90
  404. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.4-2
  405. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  406. * Fri Jan 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.4-1
  407. - Update to 3.19.4
  408. * Thu Dec 03 2015 Kalev Lember <klember@redhat.com> - 3.18.3-2
  409. - Require librsvg2 for the gdk-pixbuf svg loader
  410. * Thu Nov 05 2015 Richard Hughes <rhughes@redhat.com> - 3.18.3-1
  411. - Update to 3.18.3
  412. - Use the correct user agent string when downloading firmware
  413. - Fix a crash in the limba plugin
  414. - Fix installing web applications
  415. * Mon Oct 26 2015 Kalev Lember <klember@redhat.com> - 3.18.2-2
  416. - Fix apps reappearing as installed a few seconds after removal (#1275163)
  417. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 3.18.2-1
  418. - Update to 3.18.2
  419. * Tue Oct 13 2015 Kalev Lember <klember@redhat.com> - 3.18.1-1
  420. - Update to 3.18.1
  421. * Wed Oct 07 2015 Kalev Lember <klember@redhat.com> - 3.18.0-2
  422. - Backport two crasher fixes from upstream
  423. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
  424. - Update to 3.18.0
  425. * Tue Sep 15 2015 Kalev Lember <klember@redhat.com> - 3.17.92-2
  426. - Update dependency versions
  427. * Tue Sep 15 2015 Richard Hughes <rhughes@redhat.com> - 3.17.92-1
  428. - Update to 3.17.92
  429. * Thu Sep 10 2015 Richard Hughes <rhughes@redhat.com> - 3.17.91-2
  430. - Fix firmware updates
  431. * Thu Sep 03 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
  432. - Update to 3.17.91
  433. * Wed Aug 19 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
  434. - Update to 3.17.90
  435. * Wed Aug 12 2015 Richard Hughes <rhughes@redhat.com> - 3.17.3-1
  436. - Update to 3.17.3
  437. * Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.17.2-3
  438. - Bump for new gnome-desktop3
  439. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.17.2-2
  440. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  441. * Fri Jun 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.2-1
  442. - Update to 3.17.2
  443. * Mon May 25 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.1-1
  444. - Update to 3.17.1
  445. * Fri May 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-2
  446. - Fix a crash under Wayland (#1221968)
  447. * Mon May 11 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
  448. - Update to 3.16.2
  449. * Tue Apr 14 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
  450. - Update to 3.16.1
  451. * Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
  452. - Update to 3.16.0
  453. * Mon Mar 16 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
  454. - Update to 3.15.92
  455. - Use license macro for the COPYING file
  456. - Add a patch to adapt to gnome-terminal desktop file rename
  457. * Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
  458. - Update to 3.15.91
  459. * Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-3
  460. - Export DisplayName property on the packagekit session service
  461. * Thu Feb 19 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-2
  462. - Backport a crash fix
  463. * Tue Feb 17 2015 Richard Hughes <rhughes@redhat.com> - 3.15.90-1
  464. - Update to 3.15.90
  465. * Mon Jan 19 2015 Richard Hughes <rhughes@redhat.com> - 3.15.4-1
  466. - Update to 3.15.4
  467. * Tue Nov 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.15.2-1
  468. - Update to 3.15.2
  469. * Thu Nov 13 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-3
  470. - Fix non-Fedora build
  471. * Tue Nov 11 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-2
  472. - Backport a patch to fix compilation
  473. * Mon Nov 10 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.2-1
  474. - Update to 3.14.2
  475. * Sat Nov 08 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-3
  476. - Update the list of system apps
  477. * Sat Nov 01 2014 David King <amigadave@amigadave.com> - 3.14.1-2
  478. - Rebuild for new libappstream-glib (#1156494)
  479. * Mon Oct 13 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
  480. - Update to 3.14.1
  481. * Thu Oct 09 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-2
  482. - Depend on gnome-menus for app folder directory entries
  483. * Mon Sep 22 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
  484. - Update to 3.14.0
  485. * Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-2
  486. - Set minimum required dependency versions (#1136343)
  487. * Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-1
  488. - Update to 3.13.92
  489. - Replace gnome-system-log with gnome-logs in the system apps list
  490. * Tue Sep 02 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.91-1
  491. - Update to 3.13.91
  492. * Tue Aug 19 2014 Richard Hughes <rhughes@redhat.com> - 3.13.90-1
  493. - Update to 3.13.90
  494. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.5-0.2.git5c89189
  495. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  496. * Mon Aug 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-0.1.git5c89189
  497. - Update to 3.13.5 git snapshot
  498. - Ship HighContrast icons
  499. * Sun Aug 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-2
  500. - Replace Epiphany with Firefox in the system apps list
  501. * Wed Jul 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
  502. - Update to 3.13.4
  503. * Wed Jun 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-1
  504. - Update to 3.13.3
  505. * Thu Jun 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.3-0.2.git7491627
  506. - Depend on the newly-created appstream-data package and stop shipping
  507. the metadata here.
  508. * Sat Jun 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-0.1.git7491627
  509. - Update to 3.13.3 git snapshot
  510. * Wed May 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.2-2
  511. - Rebuild with new metadata.
  512. * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.2-1
  513. - Update to 3.13.2
  514. * Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-4
  515. - Depend on gsettings-desktop-schemas
  516. * Mon May 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-3
  517. - Update the metadata and use appstream-util to install the metadata.
  518. * Wed May 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-2
  519. - Drop gnome-icon-theme dependency
  520. * Mon Apr 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-1
  521. - Update to 3.13.1
  522. * Fri Apr 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-2
  523. - Rebuild with new metadata.
  524. * Fri Apr 11 2014 Richard Hughes <rhughes@redhat.com> - 3.12.1-1
  525. - Update to 3.12.1
  526. * Mon Mar 24 2014 Richard Hughes <rhughes@redhat.com> - 3.12.0-1
  527. - Update to 3.12.0
  528. * Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
  529. - Update to 3.11.92
  530. * Tue Mar 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-2
  531. - Rebuild with new metadata.
  532. * Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
  533. - Update to 3.11.91
  534. * Tue Feb 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
  535. - Update to 3.11.90
  536. * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-2
  537. - Require epiphany-runtime rather than the full application
  538. * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-1
  539. - Update to 3.11.5
  540. * Thu Jan 30 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-3
  541. - Rebuild for libpackagekit-glib soname bump
  542. * Wed Jan 22 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-2
  543. - Rebuild with metadata that has the correct screenshot url.
  544. * Thu Jan 16 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-1
  545. - Update to 3.11.4
  546. * Tue Dec 17 2013 Richard Hughes <rhughes@redhat.com> - 3.11.3-1
  547. - Update to 3.11.3
  548. * Tue Nov 19 2013 Richard Hughes <rhughes@redhat.com> - 3.11.2-1
  549. - Update to 3.11.2
  550. * Tue Oct 29 2013 Richard Hughes <rhughes@redhat.com> - 3.11.1-1
  551. - Update to 3.11.1
  552. - Add a gnome shell search provider
  553. - Add a module to submit the user rating to the fedora-tagger web service
  554. - Add support for 'missing' codecs that we know exist but we can't install
  555. - Add support for epiphany web applications
  556. - Handle offline installation sensibly
  557. - Save the user rating if the user clicks the rating stars
  558. - Show a modal error message if install or remove actions failed
  559. - Show a star rating on the application details page
  560. - Show font screenshots
  561. - Show more detailed version numbers when required
  562. - Show screenshots to each application
  563. * Wed Sep 25 2013 Richard Hughes <richard@hughsie.com> 3.10.0-1
  564. - New upstream release.
  565. - New metadata for fedora, updates and updates-testing
  566. - Add a plugin to query the PackageKit prepared-update file directly
  567. - Do not clear the offline-update trigger if rebooting succeeded
  568. - Do not load incompatible projects when parsing AppStream data
  569. - Lots of updated translations
  570. - Show the window right away when starting
  571. * Fri Sep 13 2013 Richard Hughes <richard@hughsie.com> 3.9.3-1
  572. - New upstream release.
  573. - Lots of new and fixed UI and updated metadata for Fedora 20
  574. * Tue Sep 03 2013 Richard Hughes <richard@hughsie.com> 3.9.2-1
  575. - New upstream release.
  576. - Allow stock items in the AppStream XML
  577. - Extract the AppStream URL and description from the XML
  578. - Only present the window when the overview is complete
  579. - Return the subcategories sorted by name
  580. * Mon Sep 02 2013 Richard Hughes <richard@hughsie.com> 3.9.1-1
  581. - New upstream release which is a technical preview for the alpha.
  582. * Sun Sep 01 2013 Richard Hughes <richard@hughsie.com> 0.1-3
  583. - Use buildroot not RPM_BUILD_ROOT
  584. - Own all gnome-software directories
  585. - Drop gtk-update-icon-cache requires and the mime database functionality
  586. * Thu Aug 29 2013 Richard Hughes <richard@hughsie.com> 0.1-2
  587. - Add call to desktop-file-validate and fix other review comments.
  588. * Wed Aug 28 2013 Richard Hughes <richard@hughsie.com> 0.1-1
  589. - First release for Fedora package review