Browse Source

gd-2.1.0-1 and dependencies.

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@7856 ec354946-7b23-47d6-9f5a-488ba84defc7
tomop 9 years ago
parent
commit
2aa6d8e1d2

+ 5 - 2
b/bogl/bogl-vl.spec

@@ -3,7 +3,7 @@ Summary(ja): コンソール上でユニコードを表示するためのター
 Name: bogl
 Epoch: 0
 Version: 0.1.18
-Release: 12%{?_dist_release}
+Release: 13%{?_dist_release}
 URL: http://www.msu.edu/user/pfaffben/projects.html
 
 Source0: http://ftp.debian.org/debian/pool/main/b/bogl/bogl_0.1.18-1.5.tar.gz
@@ -105,6 +105,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/bogl
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1.18-13
+- rebuilt with gd-2.1.0.
+
 * Thu Sep 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-12
 - remove bterm terminfo which is shipped in ncurses>=5.9
 
@@ -243,7 +246,7 @@ rm -rf $RPM_BUILD_ROOT
 - package wlite for use in loader
 - use %%{_libdir} to get lib64 right
 
-* Mon Dec 10 2002 Adrian Havill <havill@redhat.com>
+* Tue Dec 10 2002 Adrian Havill <havill@redhat.com>
 - swapped out utf8 code with new and improved wlite
 
 * Tue Nov 26 2002 Adrian Havill <havill@redhat.com>

+ 14 - 29
g/gd/gd-vl.spec

@@ -2,20 +2,11 @@
 Summary: A graphics library for drawing .png files.
 Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
 Name: gd
-Version: 2.0.35
-Release: 8%{_dist_release}
-Source0: http://www.libgd.org/releases/gd-%{version}.tar.bz2
-Patch0:        gd-2.0.33-freetype.patch
-Patch3:        gd-2.0.34-multilib.patch
-Patch4:        gd-loop.patch
-Patch5:        gd-2.0.34-sparc64.patch
-Patch6:        gd-2.0.35-overflow.patch
-Patch7:        gd-2.0.35-AALineThick.patch
-Patch8:        gd-2.0.33-BoxBound.patch
-Patch9:        gd-2.0.34-fonts-vine.patch
-Patch10:       gd-2.0.35-time.patch
-Patch11:       gd-2.0.35-security3.patch
-Patch12:       gd-2.0.35-runtests.patch
+Version: 2.1.0
+Release: 1%{_dist_release}
+Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
+Patch0:        gd-2.1.0-multilib.patch
+Patch1:        gd-2.1.0-fonts-vine.patch
 License: BSD-style
 URL: http://www.libgd.org/
 Group: System Environment/Libraries
@@ -115,19 +106,9 @@ If you're installing the gd graphics library, you must install gd-devel.
 
 
 %prep
-%setup -q
-%patch0 -p1 -b .freetype
-%patch3 -p1 -b .mlib
-%patch4 -p1 -b .loop
-%patch6 -p1 -b .overflow
-%patch5 -p1 -b .sparc64 
-%patch7 -p1 -b .AALineThick
-%patch8 -p1 -b .bb
-%patch9 -p1 -b .fonts-vine
-%patch10 -p1 -b .time
-%patch11 -p1 -b .sec3
-%patch12 -p1 -b .runtests
-
+%setup -q -n libgd-%{version}
+%patch0 -p1 -b .mlib
+%patch1 -p1 -b .fonts-vine
 
 %build
 %configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
@@ -152,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 
 %files
 %defattr(-,root,root)
-%doc COPYING README*
+%doc ChangeLog COPYING NEWS docs/*
 %{_libdir}/*.so.*
 
 %files progs
@@ -177,6 +158,10 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 %endif
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
+- new upstream release.
+- dropped unnecessary patches.
+
 * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
 - import patches from fedora package
 - modified font path patch for Vine Linux
@@ -258,7 +243,7 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 - 1.8.3-0vl2
 - symlink to libgd.so.1 (for backward compatibility)
 
-* Mon Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
+* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
 - first gd 1.8.x release for Vine from rawhide.
 - enable freetype support and defined JISX208 macro.
 

+ 286 - 0
g/gd20/gd20-vl.spec

@@ -0,0 +1,286 @@
+%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
+Summary: A graphics library for drawing .png files.
+Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
+Name: gd20
+Version: 2.0.35
+Release: 9%{_dist_release}
+Source0: http://www.libgd.org/releases/gd-%{version}.tar.bz2
+Patch0:        gd-2.0.33-freetype.patch
+Patch3:        gd-2.0.34-multilib.patch
+Patch4:        gd-loop.patch
+Patch5:        gd-2.0.34-sparc64.patch
+Patch6:        gd-2.0.35-overflow.patch
+Patch7:        gd-2.0.35-AALineThick.patch
+Patch8:        gd-2.0.33-BoxBound.patch
+Patch9:        gd-2.0.34-fonts-vine.patch
+Patch10:       gd-2.0.35-time.patch
+Patch11:       gd-2.0.35-security3.patch
+Patch12:       gd-2.0.35-runtests.patch
+License: BSD-style
+URL: http://www.libgd.org/
+Group: System Environment/Libraries
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+BuildRequires: libjpeg-devel zlib-devel freetype2-devel
+BuildRequires: libpng-devel >= 2:1.2.5
+BuildRequires: libX11-devel libXpm-devel
+
+Vendor: Project Vine
+Distribution: Vine Linux
+Packager: daisuke
+
+%description
+Gd is a graphics library for drawing .png files.  Gd allows your code to
+quickly draw images (lines, arcs, text, multiple colors, cutting and
+pasting from other images, flood fills) and write out the result as a
+.png file. Gd is particularly useful in web applications, where .pngs
+are commonly used as inline images.  Note, however, that gd is not a
+paint program.
+
+Install gd if you are developing applications which need to draw .png
+files.  If you install gd, you'll also need to install the gd-devel
+package.
+
+%description -l ja
+GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
+画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
+簡単に描写して、PNGファイルへ結果を出力することができます。
+Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
+便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
+ん。
+
+PNGファイルを描写する必要のあるアプリケーションを開発する場合、
+Gdをインストールしてください。gdをインストールした場合、gd-devel
+パッケージも必要になります。
+
+%package progs
+Summary: Utility programs that use libgd.
+Summary(ja): libgd を用いたユーティリティプログラム
+Group: Applications/Graphics
+Requires: gd20 = %{version}, perl
+
+%description progs
+These are utility programs supplied with gd, the .png graphics library.
+If you install these, you must install gd.
+
+%description progs -l ja
+これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
+プログラムです。これをインストールするには, gdをインストールする必要
+があります。
+
+%package devel
+Requires: gd20 = %{version}
+Summary: The development libraries and header files for gd.
+Summary(ja): gd用の開発ライブラリとヘッダファイル
+Group: Development/Libraries
+
+%description devel
+These are the development libraries and header files for gd, the .png
+graphics library.
+
+If you're installing the gd graphics library, you must install gd-devel.
+
+%description devel -l ja
+これらは開発ライブラリです。
+PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
+です。
+
+gdをインストールした場合、gd-develパッケージも必要になります。
+
+
+## to build compat32 for x86_64 architecture support
+%package -n compat32-%{name}
+Summary: A graphics library for drawing .png files.
+Group: System Environment/Libraries
+%description -n compat32-%{name}
+Gd is a graphics library for drawing .png files.  Gd allows your code to
+quickly draw images (lines, arcs, text, multiple colors, cutting and
+pasting from other images, flood fills) and write out the result as a
+.png file. Gd is particularly useful in web applications, where .pngs
+are commonly used as inline images.  Note, however, that gd is not a
+paint program.
+
+Install gd if you are developing applications which need to draw .png
+files.  If you install gd, you'll also need to install the gd-devel
+package.
+
+%package -n compat32-%{name}-devel
+Summary: The development libraries and header files for gd.
+Group: Development/Libraries
+%description -n compat32-%{name}-devel
+These are the development libraries and header files for gd, the .png
+graphics library.
+
+If you're installing the gd graphics library, you must install gd-devel.
+
+
+%prep
+%setup -q -n gd-%{version}
+%patch0 -p1 -b .freetype
+%patch3 -p1 -b .mlib
+%patch4 -p1 -b .loop
+%patch6 -p1 -b .overflow
+%patch5 -p1 -b .sparc64 
+%patch7 -p1 -b .AALineThick
+%patch8 -p1 -b .bb
+%patch9 -p1 -b .fonts-vine
+%patch10 -p1 -b .time
+%patch11 -p1 -b .sec3
+%patch12 -p1 -b .runtests
+
+
+%build
+%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
+make %{?_smp_mflags}
+
+%install
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
+make DESTDIR=$RPM_BUILD_ROOT install
+## remove unuse files
+rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
+
+%clean
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%if %{build_compat32}
+%post -n compat32-%{name} -p /sbin/ldconfig
+%postun -n compat32-%{name} -p /sbin/ldconfig
+%endif
+
+%files
+%defattr(-,root,root)
+%doc COPYING README*
+%{_libdir}/*.so.*
+
+%files progs
+%defattr(-,root,root)
+%{_bindir}/*
+%exclude %{_bindir}/gdlib-config
+
+%files devel
+%defattr(-,root,root)
+%{_bindir}/gdlib-config
+%{_includedir}/*
+%{_libdir}/*.so
+%{_libdir}/pkgconfig/*.pc
+
+%if %{build_compat32}
+%files -n compat32-%{name}
+%defattr(-,root,root)
+%{_libdir}/*.so.*
+%files -n compat32-%{name}-devel
+%defattr(-,root,root)
+%{_libdir}/*.so
+%endif
+
+%changelog
+* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.35-9
+- changed %%name to "gd20" for compatibility.
+
+* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
+- import patches from fedora package
+- modified font path patch for Vine Linux
+- drop static library
+- remove "-DJISX0208"
+- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
+
+* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
+- move gdlib-config from gd-progs subpackage to gd-devel subpackage
+
+* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
+- build on current VineSeed
+
+* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
+- fix build_compat32 if-endif sections
+
+* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
+- add patch2 for fix CVE-2009-3546 (_gdGetColors())
+
+* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
+- updated URL
+- changed progs Group to Applications/Graphics
+- added %%postun section
+
+* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
+- removed  *.la
+- spec in utf-8
+
+* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
+- add patch1 from centos5
+- new versioning policy
+
+* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
+- new upstream release with security fix (CVE-2007-2756)
+
+* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
+- new upstream release with security fix
+- change source tarball format gz -> bz2
+
+* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
+- added compat32-* packages for x86_64 architecture support
+
+* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
+- source upgrade
+
+* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
+- source update
+- added -DJISX0208 flag
+
+* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
+- source upgrade
+- BuildPrereq: XOrg-devel instead of XFree86-devel
+
+* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
+- source upgrade
+- remove patch0 (no need for freetype2-2.1.7)
+
+* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
+- add patch0 to build against freetype2-2.1.7
+
+* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
+- source upgrade
+- add URL
+- remove all patches
+- use %%configure script
+- add BuildPrereq: freetype2-devel XFree86-devel
+- remove BuildPrereq: VFlib-devel
+- update %%files
+- update Requires:
+- use License tag instead of Copyright
+
+* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
+- rebuild with libpng-devel-1.2.5-0vl1
+
+* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
+- rebuild with new toolchain
+
+* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
+- 1.8.3-0vl2
+- symlink to libgd.so.1 (for backward compatibility)
+
+* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
+- first gd 1.8.x release for Vine from rawhide.
+- enable freetype support and defined JISX208 macro.
+
+* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com> 
+- break out a -progs subpackage
+- disable freetype support
+
+* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com> 
+- update to latest version (1.8.2)
+- disable xpm support
+
+* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com> 
+- auto rebuild in the new build environment (release 6)
+
+* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
+- auto rebuild in the new build environment (release 5)
+
+* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
+- buiuld for glibc 2.1
+
+* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
+- built for 5.2

+ 4 - 1
g/graphviz/graphviz-vl.spec

@@ -1,7 +1,7 @@
 Name:           graphviz
 Summary:        Graph Visualization Tools
 Version:        2.30.1
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 Group:          Applications/Graphics
 License:        CPL
 URL:            http://www.graphviz.org/
@@ -237,6 +237,9 @@ fi
 
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
+- rebuilt with gd-2.1.0.
+
 * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
 - new upstream release
 

+ 4 - 1
lib/libg/libgphoto2/libgphoto2-vl.spec

@@ -2,7 +2,7 @@ Summary: Library for accessing digital cameras
 Summary(ja): デジタルカメラにアクセスするためのライブラリ
 Name: libgphoto2
 Version: 2.5.0
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 
 # GPLV2+ for the main lib (due to exif.c) and most plugins, some plugins GPLv2
 License: GPLv2+ and GPLv2
@@ -168,6 +168,9 @@ rm -rf "${RPM_BUILD_ROOT}"
 
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.0-2
+- rebuilt with gd-2.1.0.
+
 * Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.0-1
 - update to 2.5.0
 - drop MAX_ENTRIES patch (Patch4): obsolete

+ 4 - 1
m/m17n-lib/m17n-lib-vl.spec

@@ -1,5 +1,5 @@
 %define ver 1.5.5
-%define rel 3
+%define rel 4
 
 Summary: a multilingual text processing library for the C language
 Name: m17n-lib
@@ -84,6 +84,9 @@ fi
 
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-4
+- rebuilt with gd-2.1.0.
+
 * Sun May  8 2011 IWAI, Masaharu <iwai@alib.jp> 1.5.5-3
 - add BuildRequires: libxml2-devel
 - add BuildConflicts: anthy-devel

+ 7 - 1
m/memcached/memcached-vl.spec

@@ -5,7 +5,7 @@ Summary: a high-performance, distributed memory object caching system
 Summary(ja): ハイパフォーマンスな分散メモリオブジェクトキャッシングシステム
 Name: memcached
 Version: %{memcached_version}
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Source0: http://www.danga.com/memcached/dist/%{name}-%{memcached_version}.tar.gz
 Source1: repcached-%{repcached_version}-%{memcached_version}.tar.gz
 
@@ -109,6 +109,9 @@ if [ "$1" = 0 ]; then
   /sbin/update-alternatives --auto memcached ||:
 fi
 
+%triggerpostun -- memcached < 1.4.13
+/sbin/update-alternatives --auto memcached ||:
+
 %files
 %defattr(-,root,root)
 %doc AUTHORS COPYING ChangeLog ChangeLog.repcached NEWS README
@@ -126,6 +129,9 @@ fi
 %{_includedir}/memcached/*
 
 %changelog
+* Fri May 11 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.13-2
+- fixed missing symlink.
+
 * Sat Apr 28 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.13-1
 - new upstream release.
 - made be able to choose between memcached and repcached by alternatives.

+ 4 - 1
n/nginx/nginx-vl.spec

@@ -26,7 +26,7 @@ Summary:        Robust, small and high performance http and reverse proxy server
 Summary(ja):    堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
 Name:           nginx
 Version:        1.4.1
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 
 Group:          System Environment/Daemons   
 # BSD License (two clause)
@@ -360,6 +360,9 @@ fi
 
 
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
+- rebuilt with gd-2.1.0.
+
 * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
 - update to 1.4.1
 

+ 0 - 0
p/php-ext-apc/obsoleted


+ 6 - 2
p/php-ext-clearsilver/php-ext-clearsilver-vl.spec

@@ -2,9 +2,10 @@ Summary: ClearSilver extension for PHP
 Summary(ja): PHP用ClearSilverモジュール
 Name: php-ext-clearsilver
 Version: 0.4
-Release: 3%{_dist_release}
+Release: 4%{_dist_release}
 URL: http://www.geodata.soton.ac.uk/software/php_clearsilver/
 Source: php-clearsilver-%{version}.tar.gz
+Patch0: php-clearsilver-0.4-php5.5.0.patch
 License: The PHP License
 Group: Development/Languages
 BuildRequires: clearsilver, php5-devel
@@ -20,7 +21,7 @@ This module adds ClearSilver functions to PHP.
 
 %prep
 %setup -q -n php-clearsilver-%{version}
-##perl -pi -e 's/refcount/refcount__gc/s' clearsilver.c
+%patch0 -p1 -b .php55
 
 %build
 aclocal
@@ -53,6 +54,9 @@ rm -rf %{buildroot}
 %{_sysconfdir}/php5/php.d/*
 
 %changelog
+* Tue Jun 25 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-4
+- added a patch for PHP 5.5.0.
+
 * Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-3
 - converted encoding to UTF-8.
 

+ 14 - 4
p/php-ext-memcache/php-ext-memcache-vl.spec

@@ -1,10 +1,10 @@
 Summary: memcache extension for PHP
 Summary(ja): PHP用memcache拡張
 Name: php-ext-memcache
-Version: 2.2.6
-Release: 3%{_dist_release}
+Version: 3.0.8
+Release: 1%{_dist_release}
 Source: memcache-%{version}.tgz
-Patch0: memcache-2.2.6-session_strict.patch
+##Patch0: memcache-2.2.6-session_strict.patch
 License: The PHP License
 Group: Development/Languages
 BuildRequires: php5-devel
@@ -12,6 +12,10 @@ BuildRequires: zlib-devel
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Requires: %{req_php_api}
 
+Vendor: Project Vine
+Distribution: Vine Linux
+Packager: tomop
+
 %description
 This module enable to access memcached in PHP scripts.
 
@@ -20,7 +24,7 @@ This module enable to access memcached in PHP scripts.
 
 %prep
 %setup -q -n memcache-%{version}
-%patch0 -p1 -b .session_strict
+##%patch0 -p1 -b .session_strict
 mv ../package.xml ./
 phpize
 
@@ -58,6 +62,12 @@ rm -rf %{buildroot}
 %config(noreplace) %{_sysconfdir}/php5/php.d/*
 
 %changelog
+* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
+- new upstream release.
+
+* Tue Jun 25 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.7-1
+- new upstream release.
+
 * Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-3
 - converted encoding to UTF-8.
 

+ 5 - 2
p/php-ext-mysqlnd_ms/php-ext-mysqlnd_ms-vl.spec

@@ -1,8 +1,8 @@
 Summary: The mysqlnd replication and load balancing plugin
 Summary(ja): mysqlnd レプリケーション・ロードバランスプラグイン
 Name: php-ext-mysqlnd_ms
-Version: 1.3.2
-Release: 2%{_dist_release}
+Version: 1.6.0
+Release: 1%{_dist_release}
 URL: http://pecl.php.net/package/mysqlnd_ms
 Source: mysqlnd_ms-%{version}.tgz
 License: The PHP License
@@ -54,6 +54,9 @@ rm -rf %{buildroot}
 %{_sysconfdir}/php5/php.d/*
 
 %changelog
+* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.0-1
+- new upstream release.
+
 * Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-2
 - converted encoding to UTF-8.
 

+ 12 - 3
p/php-ext-mysqlnd_qc/php-ext-mysqlnd_qc-vl.spec

@@ -1,16 +1,19 @@
 Summary: A query cache plugin for mysqlnd
 Summary(ja): mysqlnd クエリキャッシュプラグイン
 Name: php-ext-mysqlnd_qc
-Version: 1.1.1
+Version: 1.2.0
 Release: 1%{_dist_release}
 URL: http://pecl.php.net/package/mysqlnd_qc
 Source: mysqlnd_qc-%{version}.tgz
 License: The PHP License
 Group: Development/Languages
-BuildRequires: php5-devel
+BuildRequires: php5-devel, libmemcached-devel
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Requires: php5-mysql
+
+%if "%{?req_php_api}" != ""
 Requires: %{req_php_api}
+%endif
 
 %description
  The mysqlnd query result cache plugin is a mysqlnd plugin. It adds basic
@@ -31,7 +34,7 @@ rm -f ../package.xml
 /usr/bin/phpize
 
 %build
-%configure
+%configure --enable-mysqlnd-qc-memcache
 %__make %{_smp_mflags}
 
 %install
@@ -56,6 +59,12 @@ rm -rf %{buildroot}
 %{_sysconfdir}/php5/php.d/*
 
 %changelog
+* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-1
+- new upstream release.
+
+* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
+- enabled memcache handler.
+
 * Sat Apr 28 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
 - initial build.
 

+ 5 - 2
p/php-ext-zip/php-ext-zip-vl.spec

@@ -1,8 +1,8 @@
 Summary: A zip management extension for PHP
 Summary(ja): PHP用zip拡張
 Name: php-ext-zip
-Version: 1.10.2
-Release: 3%{_dist_release}
+Version: 1.12.1
+Release: 1%{_dist_release}
 Source: zip-%{version}.tgz
 License: The PHP License
 Group: Development/Languages
@@ -49,6 +49,9 @@ rm -rf %{buildroot}
 %config(noreplace) %{_sysconfdir}/php5/php.d/*
 
 %changelog
+* Tue Jun 25 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-1
+- new upstream release.
+
 * Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.2-3
 - converted encoding to UTF-8.
 

+ 49 - 30
p/php5/php5-vl.spec

@@ -45,7 +45,7 @@
 Name: php5
 Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
 Summary(ja): HTML 埋め込み型スクリプト言語 PHP
-Version: 5.3.21
+Version: 5.5.4
 Release: 1%{_dist_release}
 
 Vendor: Project Vine
@@ -56,7 +56,7 @@ License: The PHP License
 Group: Development/Languages
 URL: http://www.php.net/
 
-Source0: http://www.php.net/distributions/%{srcname}.tar.bz2
+Source0: http://www.php.net/distributions/%{srcname}.tar.xz
 
 # borrowed from Fedora's php-pear 1:1.9.4-5
 Source13: macros.pear
@@ -74,7 +74,7 @@ Source30: find-provides.sh.in
 
 Patch33: php-5.2.4-phpincludedir.patch
 # Additional feature
-Patch51: php-5.3.0-session_strict_mode.patch
+
 
 # security fix
 #Patch1000: php-5.3.7-bug55439.patch
@@ -118,6 +118,7 @@ BuildRequires: readline-devel
 BuildRequires: sqlite3-devel
 BuildRequires: zlib-devel
 BuildRequires: libicu-devel >= 3.6
+BuildRequires: libXpm-devel
 %if %{?_dist_release} != "vl4"
 BuildRequires: krb5-devel
 %endif
@@ -132,6 +133,8 @@ Requires(post,preun): alternatives
 Conflicts: php <= 4.4.2-0vl1.2
 Provides: php = %{version}-%{release}
 
+Obsoletes: php5-sqlite < 5.5.0
+
 %description 
 PHP is an HTML-embedded scripting language. PHP attempts to make it
 easy for developers to write dynamically generated webpages. PHP also
@@ -305,7 +308,7 @@ support for encrypt/decrypt functions to PHP.
 %package mysql
 Summary: A module for PHP applications that use MySQL databases.
 Group: Development/Languages
-BuildRequires: MySQL-devel >= 5.1.40
+##BuildRequires: MySQL-devel >= 5.1.40
 # for MySQL-devel Requires bug..
 Requires: %{name} = %{version}-%{release}
 Requires: %{name}-pdo
@@ -391,22 +394,6 @@ support for querying SNMP devices to PHP.  PHP is an HTML-embeddable
 scripting language. If you need SNMP support for PHP applications, you
 will need to install this package and the php package.
 
-#----------------------------------------------------------------------
-%package sqlite
-Summary: A module for PHP applications that use SQLite databases.
-Group: Development/Languages
-Requires: %{name} = %{version}-%{release}
-Requires: %{name}-pdo
-Provides: %{name}_database
-Provides: php-sqlite = %{version}-%{release}
-
-%description sqlite
-The php-sqlite package includes a dynamic shared object (DSO) that can
-be compiled in to the Apache Web server to add SQLite database support
-to PHP. SQLite is a C library that implements an embeddable SQL database
-engine. Programs that link with the SQLite library can have SQL database
-access without running a separate RDBMS process.
-
 #----------------------------------------------------------------------
 %package xmlrpc
 Summary: A module for PHP applications which use the XML-RPC protocol
@@ -444,13 +431,24 @@ Process Control should not be enabled within a web server environment
 and unexpected results may happen if any Process Control functions are
 used within a web server environment.
 
+#----------------------------------------------------------------------
+%package opcache
+Summary: A zend extension to cache script bytecode
+Group: Development/Languages
+Requires: %{name} = %{version}-%{release}
+Provides: php-opcache = %{version}-%{release}
+
+%description opcache
+ OPcache improves PHP performance by storing precompiled script bytecode
+in shared memory, thereby removing the need for PHP to load and parse scripts
+on each request.
+
 
 #======================================================================
 %prep
 %setup -q -n %{srcname}
 
 %patch33 -p1 -b .phpincludedir
-%patch51 -p1 -b .strict_session
 
 ##%patch2000 -p0 -b .fix319823
 
@@ -693,7 +691,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/nginx
 #----------------------------------------------------------------------
 # Generate files lists and stub .ini files for each subpackage
 for mod in dba imap ldap mcrypt snmp xmlrpc intl gd \
-    mysql mysqli odbc pgsql sqlite \
+    mysql mysqli odbc pgsql \
     pdo pdo_odbc pdo_mysql pdo_pgsql pdo_sqlite; do
     cat > %{buildroot}%{php_confdir}/php.d/${mod}.ini <<EOF
 ; Enable ${mod} extension module
@@ -705,6 +703,18 @@ EOF
 EOF
 done
 
+# Zend extensions
+for mod in opcache; do
+    cat > %{buildroot}%{php_confdir}/php.d/${mod}.ini <<EOF
+; Enable ${mod} zend extension module
+zend_extension=${mod}.so
+EOF
+    cat > files.${mod} <<EOF
+%attr(0755,root,root) %{_libdir}/%{_name}/${mod}.so
+%config(noreplace) %attr(0644,root,root) %{php_confdir}/php.d/${mod}.ini
+EOF
+done
+
 # pcntl extension should be enabled with CLI/CGI SAPI only.
 cat > %{buildroot}%{php_confdir}/php.d/pcntl.ini <<EOF
 ; Enable pcntl extension module
@@ -928,13 +938,22 @@ rm -f files.*
 %files pdo -f files.pdo
 %files pgsql -f files.pgsql
 %files snmp -f files.snmp
-%files sqlite -f files.sqlite
 %files xmlrpc -f files.xmlrpc
 %files intl -f files.intl
 %files pcntl -f files.pcntl
+%files opcache -f files.opcache
 
 #======================================================================
 %changelog
+* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.4-1
+- new upstream release.
+- removed %%patch51 (commited to upstream).
+
+* Sun Jun 23 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.0-1
+- new upstream release.
+- removed a sub-package "sqlite".
+- fixed invalid date in %%changelog.
+
 * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 5.3.21-1
 - new upstream release
 - add configure options to fix broken fonts in some
@@ -1276,7 +1295,7 @@ rm -f files.*
   -- remove BuildRequires: libsablotron0-devel
   -- remove --enable-xslt, --with-xslt-sablot configure option
 
-* Thu Dec 07 2005 Atsushi SHICHI <ats7@a.email.ne.jp> 5.1.1-0vl2
+* Wed Dec 07 2005 Atsushi SHICHI <ats7@a.email.ne.jp> 5.1.1-0vl2
 - add %%{with_test}
 - drop Patch5: php-4.3.3-install.patch
 - drop Patch6: php-5.1.0-tests.patch
@@ -1319,7 +1338,7 @@ rm -f files.*
 * Thu Oct 06 2005 Atsushi SHICHI <ats7@a.email.ne.jp> 5.0.5-0vl4
 - modify Source21: vine.ini
 
-* Tue Oct 06 2005 HOTTA Michihide <hotta@net-newbie.com> 5.0.5-0vl3
+* Thu Oct 06 2005 HOTTA Michihide <hotta@net-newbie.com> 5.0.5-0vl3
 - drop Patch3: php-5.0.5-lib64.patch
 - drop Patch11: php-5.0.5-phpize_in.patch [VinePlus:02737]
 - add --libdir=%%{_libdir}/php option to configure [VinePlus:02737]
@@ -1343,7 +1362,7 @@ rm -f files.*
 * Fri Jun 17 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 5.0.3-0vl3.2
 - added a security patch for CAN-2005-0524 and CAN-2005-0525 from SuSE.
 
-* Thu May 16 2005 HOTTA Michihide <hotta@net-newbie.com> 5.0.3-0vl3.1
+* Mon May 16 2005 HOTTA Michihide <hotta@net-newbie.com> 5.0.3-0vl3.1
 - for VinePlus/3.0
 - add README.vine again
 - add php-4.3.11-mbfilter.patch for workaround against degrade at 5.0.3
@@ -1452,7 +1471,7 @@ for text/hdml.
 - applied php-4.2.2-mb-decode.patch to fix decode problem of GET parameters.
 - Patch to fix a problem where, given multiple cookies to set, only the last one would be made (#67853)
 
-* Tue Jul 24 2002 HOTTA Michihide <hotta@net-newbie.com> 4.2.2-0vl2
+* Wed Jul 24 2002 HOTTA Michihide <hotta@net-newbie.com> 4.2.2-0vl2
 - for VineSeedPlus
   -- applied php-4.2.2-multibyte.patch.gz which obsolets 4.2.1's
   -- dropped --enable-trans-sid configure option which is no longer meaningful
@@ -1511,7 +1530,7 @@ for text/hdml.
 - added ereg_replace patch (4.2.0-reg.patch)
 - updated manual(en, ja)
 
-* Thu Apr 30 2002 Satoshi MACHINO <machino@vinelinux.org> 4.2.0-0vl1
+* Tue Apr 30 2002 Satoshi MACHINO <machino@vinelinux.org> 4.2.0-0vl1
 - updated php-4.2.0
 
 * Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1.2-0vl1
@@ -1689,11 +1708,11 @@ for text/hdml.
 - build_ext defines HAVE_PGSQL so pgsql.so in fact contains symbols
 - post/un scripts tweak php.ini correctly now
 
-* Thu Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
+* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
 - update to 4.0.1
 - refresh manual
 
-* Tue Jun 26 2000 Nalin Dahyabhai <nalin@redhat.com>
+* Mon Jun 26 2000 Nalin Dahyabhai <nalin@redhat.com>
 - rebuild against new krb5 package
 
 * Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>