Browse Source

updated 10 packages

binutils-2.36.1-2

elfutils-0.183-2

gcc-10.3.1-1

glibc-2.33-3

isl-0.23-2

libnsl2-1.3.0-1

libtirpc-1.3.1-2

libtool-2.4.6-8

libxcrypt-4.4.19-1

valgrind-3.17.0-1
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
002452d9b0

+ 25 - 16
b/binutils/binutils-vl.spec

@@ -29,29 +29,32 @@
 %define isnative 1
 %define enable_shared 1
 
+%bcond_without testsuite
 %bcond_without docs
 
-Summary: A GNU collection of binary utilities.
-Summary(ja): GNU 版バイナリユーティリティ集
-Name: binutils
-Version: 2.36.1
-Release: 1%{?_dist_release}
-Group: programming
+Summary:        A GNU collection of binary utilities.
+Summary(ja):    GNU 版バイナリユーティリティ集
+Name:           binutils
+Version:        2.36.1
+Release:        2%{?_dist_release}
+Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
 Packager:       kenta, shaolin, inagaki
 
-License: GPLv3+
-URL: http://sources.redhat.com/binutils
+License:        GPLv3+
+URL:            http://sources.redhat.com/binutils
 # Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
 # The ftp.kernel.org/pub/linux/devel/binutils/ page is (temporarily) unavailable
 # so we use the GNU site instead.
 # Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
-Source: https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.xz
-Source2: binutils-2.19.50.0.1-output-format.sed
+Source:         https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.xz
+Source2:        binutils-2.19.50.0.1-output-format.sed
 
 #----------------------------------------------------------------------------
 
+Patch00: binutils-2.36-20210410.patch
+
 # Purpose:  Use /lib64 and /usr/lib64 instead of /lib and /usr/lib in the
 #           default library search path of 64-bit targets.
 # Lifetime: Permanent, but it should not be.  This is a bug in the libtool
@@ -169,9 +172,7 @@ Patch34: binutils-testsuite-failures.patch
 
 Patch1001: binutils-2.26-uio-vine.patch
 
-%if %{?_dist_release} > vl6
 %define gold_arches %ix86 x86_64
-%endif
 
 %if 0%{?_with_debug:1}
 # Define this if you want to skip the strip step and preserve debug info.
@@ -303,7 +304,7 @@ case %{binutils_target} in i?86*|sparc*|ppc*|s390*|sh*|arm*|aarch64*)
 esac
 
 case %{binutils_target} in x86_64*|i?86*|arm*|aarch64*)
-  CARGS="$CARGS --enable-targets=x86_64-pep"
+  CARGS="$CARGS --enable-targets=x86_64-pep,bpf-unknown-none"
   ;;
 esac
 
@@ -314,7 +315,7 @@ esac
 %endif
 
 %if 0%{?_with_debug:1}
-CFLAGS="$CFLAGS -O0 -ggdb2"
+CFLAGS="$CFLAGS -O0 -ggdb2 -Wno-error -D_FORTIFY_SOURCE=0"
 %define enable_shared 0
 %endif
 
@@ -336,6 +337,7 @@ CFLAGS="$CFLAGS -O0 -ggdb2"
   --with-sysroot=%{_prefix}/%{binutils_target}/sys-root \
   --program-prefix=%{cross} \
 %endif
+  --with-system-zlib \
 %if %{enable_shared}
   --enable-shared \
 %else
@@ -362,7 +364,7 @@ CFLAGS="$CFLAGS -O0 -ggdb2"
   $CARGS \
   --enable-plugins \
   --disable-werror \
-  --with-bugurl=http://bugzilla.redhat.com/bugzilla/
+  --with-bugurl=http://mantis.vinelinux.org/
 
 %if %{with docs}
 make %{_smp_mflags} tooldir=%{_prefix} all
@@ -400,6 +402,7 @@ if [ -f gold/testsuite/test-suite.log ]; then
 fi
 %endif
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %if %{with docs}
@@ -520,6 +523,7 @@ fi
 
 /bin/ls %{buildroot}%{_bindir} | sed -e 's|^|%{_bindir}/|' -e '/\/ld$/d' > binutils.list
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -609,8 +613,13 @@ fi
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.36.1-2
+- imported Patch00 from upstream.
+- built with gcc-10.3.
+- updated Patch34.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.36.1-1
-- updated to 2.34.
+- updated to 2.36.
 - dropped Patch10, 11 and 16.
 - renumbered patches.
 - imported Patch15-34 from rawhide.

+ 25 - 24
e/elfutils/elfutils-vl.spec

@@ -1,17 +1,17 @@
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%global nocheck true
+%global nocheck false
 
 Summary: A collection of utilities and DSOs to handle compiled objects
 Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
 Name: elfutils
 Version:        0.183
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
-License:        GPLv3+ and (GPLv2+ or LGPLv3+)
+License:        GPLv3+ and (GPLv2+ or LGPLv3+) and GFDL
 URL:            https://sourceware.org/elfutils/
 Source:         https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
 
@@ -20,18 +20,18 @@ Requires: elfutils-libs-%{_arch} = %{version}-%{release}
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires: bison >= 1.875
-BuildRequires: bzip2
-BuildRequires: bzip2-devel
 BuildRequires: flex >= 2.5.4a
 BuildRequires: gcc >= 9.0.0
 BuildRequires: gettext
-BuildRequires: libzstd-devel
 BuildRequires: m4
+BuildRequires: bzip2-devel
+BuildRequires: libzstd-devel
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
-BuildRequires: zstd
 # Need <byteswap.h> that gives unsigned bswap_16 etc.
 BuildRequires: glibc-headers >= 2.3.4-11
+BuildRequires: bzip2
+BuildRequires: zstd
 
 %define _gnu %{nil}
 %define _program_prefix eu-
@@ -178,6 +178,14 @@ find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
 
 
 %build
+# This package uses top level ASM constructs which are incompatible with LTO.
+# Top level ASMs are often used to implement symbol versioning.  gcc-10
+# introduces a new mechanism for symbol versioning which works with LTO.
+# Converting packages to use that mechanism instead of toplevel ASMs is
+# recommended.
+# Disable LTO
+%define _lto_cflags %{nil}
+
 # Remove -Wall from default flags.  The makefiles enable enough warnings
 # themselves, and they use -Werror.  Appending -Wall defeats the cases where
 # the makefiles disable some specific warnings for specific code.
@@ -207,27 +215,20 @@ chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
 }
 
 
+# failed on i686 container hosted by x86_64
+%ifarch x86_64
 %check
-make -s check || (cat tests/test-suite.log; %{nocheck})
-
+%make_build -s check || (cat tests/test-suite.log; %{nocheck})
+%endif
 
 %clean
 rm -rf ${RPM_BUILD_ROOT}
 
 
-%post libs -p /sbin/ldconfig
-%postun libs -p /sbin/ldconfig
-
-%post libelf -p /sbin/ldconfig
-%postun libelf -p /sbin/ldconfig
-
-%post -n compat32-%{name}-libelf -p /sbin/ldconfig
-%postun -n compat32-%{name}-libelf -p /sbin/ldconfig
-
-
 %files -f %{name}.lang
 %defattr(-,root,root)
-%doc README TODO
+%license COPYING COPYING-GPLV2 COPYING-LGPLV3 doc/COPYING-GFDL
+%doc README TODO CONTRIBUTING
 %{_bindir}/eu-addr2line
 %{_bindir}/eu-ar
 %{_bindir}/eu-elfclassify
@@ -250,6 +251,7 @@ rm -rf ${RPM_BUILD_ROOT}
 
 %files libs
 %defattr(-,root,root)
+%license COPYING-GPLV2 COPYING-LGPLV3
 %{_libdir}/libasm-%{version}.so
 %{_libdir}/libasm.so.*
 %{_libdir}/libdw-%{version}.so
@@ -270,19 +272,16 @@ rm -rf ${RPM_BUILD_ROOT}
 %{_libdir}/libdw.so
 %{_libdir}/pkgconfig/libdw.pc
 
-
 %files devel-static
 %defattr(-,root,root)
 %{_libdir}/libasm.a
 %{_libdir}/libdw.a
 
-
 %files libelf
 %defattr(-,root,root)
 %{_libdir}/libelf-%{version}.so
 %{_libdir}/libelf.so.*
 
-
 %files libelf-devel
 %defattr(-,root,root)
 %{_includedir}/libelf.h
@@ -292,7 +291,6 @@ rm -rf ${RPM_BUILD_ROOT}
 %{_libdir}/pkgconfig/libelf.pc
 %{_mandir}/man3/elf_*
 
-
 %files libelf-devel-static
 %defattr(-,root,root)
 %{_libdir}/libelf.a
@@ -306,6 +304,9 @@ rm -rf ${RPM_BUILD_ROOT}
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-2
+- rebuilt with current environment.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
 - new upstream release.
 

+ 36 - 120
g/gcc/gcc-vl.spec

@@ -1,12 +1,27 @@
 %bcond_with check
 
 # version of tarball
-%global gcc_version 10.2.0
+%global gcc_version 10.3.0
 %global gcc_major 10
 # Note, gcc_release must be integer, if you want to add suffixes to
 # %{release}, append them after %{gcc_release} on Release: line.
-%global gcc_release 1%{?_dist_release}
-#global _unpackaged_files_terminate_build 0
+%global gcc_release 1
+
+Summary:        GNU Compiler Collection (C, C++, Objective-C, ...)
+Summary(ja):    GNU コンパイラコレクション (C, C++, Objective-C, ...)
+Name:           gcc
+Version:        10.3.1
+Release:        %{gcc_release}%{?_dist_release}
+Group:          programming
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
+# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
+# GCC Runtime Exception.
+License:        GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
+URL:            https://gcc.gnu.org
+Source0:        https://ftp.gnu.org/gnu/%{name}/%{name}-%{gcc_version}/%{name}-%{gcc_version}.tar.xz
+
 %{?!_fmoddir: %global _fmoddir %{_libdir}/gfortran/modules}
 %global multilib_64_archs sparc64 ppc64 s390x x86_64
 %global build_objc 1
@@ -87,20 +102,6 @@
 %global multilib_32_arch i686
 %endif
 
-Summary:        GNU Compiler Collection (C, C++, Objective-C, ...)
-Summary(ja):    GNU コンパイラコレクション (C, C++, Objective-C, ...)
-Name:           gcc
-Version:        10.2.1
-Release:        %{gcc_release}
-Group:          programming
-Vendor:         Project Vine
-Distribution:   Vine Linux
-
-# libgcc, libgfortran, libgomp, libstdc++ and crtstuff have
-# GCC Runtime Exception.
-License:        GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
-Source0:        https://ftp.gnu.org/gnu/%{name}/%{name}-%{gcc_version}/%{name}-%{gcc_version}.tar.xz
-URL:            https://gcc.gnu.org
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 # Need binutils with -pie support >= 2.14.90.0.4-4
 # Need binutils which can omit dot symbols and overlap .opd on ppc64 >= 2.15.91.0.2-4
@@ -227,7 +228,7 @@ Patch9: gcc10-Wno-format-security.patch
 Patch10: gcc10-rh1574936.patch
 Patch11: gcc10-d-shared-libphobos.patch
 
-Patch10000: gcc-10.2-20210209.patch
+Patch10000: gcc-10.3-20210410.patch
 
 # On ARM EABI systems, we do want -gnueabi to be part of the
 # target triple.
@@ -245,7 +246,6 @@ Patch10000: gcc-10.2-20210209.patch
 %endif
 
 ################################################# gcc
-
 %description
 The gcc package contains the GNU Compiler Collection version %{version}.
 You'll need this package in order to compile C code.
@@ -256,7 +256,6 @@ gcc パッケージには、GNU Compiler Collection バージョン %{version} 
 必要となります。
 
 ################################################# libgcc
-
 %package -n libgcc
 Summary: GCC version %{version} shared support library
 Summary(ja): GCC バージョン %{version} 共有サポートライブラリ
@@ -275,7 +274,6 @@ e.g. for exception handling support.
 これは例えば例外ハンドリングサポートに必要です。
 
 ################################################# c++
-
 %package c++
 Summary: C++ support for GCC
 Summary(ja): GNU コンパイラ集 - C++ サポート
@@ -300,7 +298,6 @@ including templates and exception handling.
 サポートします。
 
 ################################################# libstdc++
-
 %package -n libstdc++
 Summary: GNU Standard C++ Library
 Summary(ja): GNU 標準 C++ ライブラリ
@@ -321,7 +318,6 @@ libstdc++ パッケージには、標準準拠に書き直された
 GCC 標準 C++ ライブラリが収録されています。
 
 ################################################# libstdc++-devel
-
 %package -n libstdc++-devel
 Summary: Header files and libraries for C++ development
 Summary(ja): C++ 開発用ヘッダ/ライブラリ
@@ -340,7 +336,6 @@ development. This includes rewritten implementation of STL.
 収録されています。これには STL の実装も含まれます。
 
 ################################################# libstdc++-static
-
 %package -n libstdc++-static
 Summary: Static libraries for the GNU standard C++ library
 Summary(ja): GNU 標準 C++ ライブラリの静的リンクライブラリ
@@ -355,7 +350,6 @@ Static libraries for the GNU standard C++ library.
 GNU 標準 C++ ライブラリの静的リンクライブラリ
 
 ################################################# libstdc++-docs
-
 %package -n libstdc++-docs
 Summary: Documentation for the GNU standard C++ library
 Summary(ja): GNU 標準 C++ ライブラリのドキュメント
@@ -370,7 +364,6 @@ for the GNU standard C++ library.
 GNU 標準 C++ ライブラリのマニュアル、Doxygenで生成した API情報と FAQ集
 
 ################################################# objc
-
 %package objc
 Summary: Objective-C support for GCC
 Summary(ja): GNU コンパイラ集 - Objective C サポート
@@ -390,7 +383,6 @@ Objective-C は C 言語から派生したオブジェクト指向言語で、
 主に NeXTSTEP システムで使われてきました。
 
 ################################################# objc++
-
 %package objc++
 Summary: Objective-C++ support for GCC
 Summary(ja): GNU コンパイラ集 - Objective C++ サポート
@@ -406,7 +398,6 @@ gcc-objc++ package provides Objective-C++ support for the GCC.
 gcc-objc++ パッケージは GCC に Objective-C++ サポートを追加します。
 
 ################################################# libobjc
-
 %package -n libobjc
 Summary: Objective-C runtime
 Summary(ja): Objective C ランタイムライブラリ
@@ -423,7 +414,6 @@ Objective-C dynamically linked programs.
 なります。
 
 ################################################# gfortran
-
 %package gfortran
 Summary: Fortran support
 Summary(ja): GNU コンパイラ集 - Fortran サポート
@@ -451,7 +441,6 @@ gcc-gfortran パッケージは GNU Compiler Collection に
 Fortran プログラムをコンパイルする機能を追加するものです。
 
 ################################################# libgfortran
-
 %package -n libgfortran
 Summary: Fortran runtime
 Summary(ja): Fortran ランタイム
@@ -471,7 +460,6 @@ Fortran dynamically linked programs.
 必要となります。
 
 ################################################# libgfortran-static
-
 %package -n libgfortran-static
 Summary: Static Fortran libraries
 Summary(ja): Fortranの静的リンクライブラリ
@@ -489,7 +477,6 @@ This package contains static Fortran libraries.
 このパッケージには Fortran 静的リンクライブラリが収められています。
 
 ################################################# libgomp
-
 %package -n libgomp
 Summary: GCC OpenMP v3.0 shared support library
 Summary(ja): GCC OpenMP v3.0 共有ライブラリ
@@ -506,7 +493,6 @@ for OpenMP v3.0 support.
 収められています。
 
 ################################################# gdb-plugin
-
 %package gdb-plugin
 Summary: GCC plugin for GDB
 Group: programming
@@ -516,7 +502,6 @@ Requires: gcc = %{version}-%{release}
 This package contains GCC plugin for GDB C expression evaluation.
 
 ################################################# libgccjit
-
 %package -n libgccjit
 Summary: Library for embedding GCC inside programs and libraries
 Group: system
@@ -526,7 +511,6 @@ Requires: gcc = %{version}-%{release}
 This package contains shared library with GCC JIT front-end.
 
 ################################################# libgccjit-devel
-
 %package -n libgccjit-devel
 Summary: Support for embedding GCC inside programs and libraries
 Group: programming
@@ -539,7 +523,6 @@ Requires(preun): /sbin/install-info
 This package contains header files and documentation for GCC JIT front-end.
 
 ################################################# libquadmath
-
 %package -n libquadmath
 Summary: GCC __float128 shared support library
 Summary(ja): GCC __float128 サポートのための共有ライブラリ
@@ -556,7 +539,6 @@ for __float128 math support and for Fortran REAL*16 support.
 ために必要な GCC 共有ライブラリが収められています。
 
 ################################################# libquadmath-devel
-
 %package -n libquadmath-devel
 Summary: GCC __float128 support
 Summary(ja): GCC __float128 サポート
@@ -573,7 +555,6 @@ REAL*16 and programs using __float128 math.
 使った Fortranプログラムをビルドするためのヘッダーが収められています。
 
 ################################################# libquadmath-static
-
 %package -n libquadmath-static
 Summary: Static libraries for __float128 support
 Summary(ja): __float128 サポートのための静的リンクライブラリ
@@ -590,7 +571,6 @@ using REAL*16 and programs using __float128 math.
 れています。
 
 ################################################# libitm
-
 %package -n libitm
 Summary: The GNU Transactional Memory library
 Group: system
@@ -602,7 +582,6 @@ This package contains the GNU Transactional Memory library
 which is a GCC transactional memory support runtime library.
 
 ################################################# libitm-devel
-
 %package -n libitm-devel
 Summary: The GNU Transactional Memory support
 Group: programming
@@ -614,7 +593,6 @@ This package contains headers and support files for the
 GNU Transactional Memory library.
 
 ################################################# libitm-static
-
 %package -n libitm-static
 Summary: The GNU Transactional Memory static library
 Group: programming
@@ -624,7 +602,6 @@ Requires: libitm-devel = %{version}-%{release}
 This package contains GNU Transactional Memory static libraries.
 
 ################################################# libatomic
-
 %package -n libatomic
 Summary: The GNU Atomic library
 Group: system
@@ -637,7 +614,6 @@ which is a GCC support runtime library for atomic operations not supported
 by hardware.
 
 ################################################# libatomic-static
-
 %package -n libatomic-static
 Summary: The GNU Atomic static library
 Group: programming
@@ -647,7 +623,6 @@ Requires: libatomic = %{version}-%{release}
 This package contains GNU Atomic static libraries.
 
 ################################################# libasan
-
 %package -n libasan
 Summary: The Address Sanitizer runtime library
 Group: system
@@ -659,7 +634,6 @@ This package contains the Address Sanitizer library
 which is used for -fsanitize=address instrumented programs.
 
 ################################################# libasan-static
-
 %package -n libasan-static
 Summary: The Address Sanitizer static library
 Group: programming
@@ -669,7 +643,6 @@ Requires: libasan = %{version}-%{release}
 This package contains Address Sanitizer static runtime library.
 
 ################################################# libtsan
-
 %package -n libtsan
 Summary: The Thread Sanitizer runtime library
 Group: system
@@ -681,7 +654,6 @@ This package contains the Thread Sanitizer library
 which is used for -fsanitize=thread instrumented programs.
 
 ################################################# libtsan-static
-
 %package -n libtsan-static
 Summary: The Thread Sanitizer static library
 Group: programming
@@ -691,7 +663,6 @@ Requires: libtsan = %{version}-%{release}
 This package contains Thread Sanitizer static runtime library.
 
 ################################################# libubsan
-
 %package -n libubsan
 Summary: The Undefined Behavior Sanitizer runtime library
 Group: system
@@ -703,7 +674,6 @@ This package contains the Undefined Behavior Sanitizer library
 which is used for -fsanitize=undefined instrumented programs.
 
 ################################################# libubsan-static
-
 %package -n libubsan-static
 Summary: The Undefined Behavior Sanitizer static library
 Group: programming
@@ -713,7 +683,6 @@ Requires: libubsan = %{version}-%{release}
 This package contains Undefined Behavior Sanitizer static runtime library.
 
 ################################################# liblsan
-
 %package -n liblsan
 Summary: The Leak Sanitizer runtime library
 Group: system
@@ -725,7 +694,6 @@ This package contains the Leak Sanitizer library
 which is used for -fsanitize=leak instrumented programs.
 
 ################################################# liblsan-static
-
 %package -n liblsan-static
 Summary: The Leak Sanitizer static library
 Group: programming
@@ -735,7 +703,6 @@ Requires: liblsan = %{version}-%{release}
 This package contains Leak Sanitizer static runtime library.
 
 ################################################# gcc-cpp
-
 %package cpp
 Summary: The C Preprocessor
 Summary(ja): C プリプロセッサ
@@ -768,7 +735,6 @@ You should install this package if you are a C programmer and you use
 macros.
 
 ################################################# gcc-gnat
-
 %package gnat
 Summary: Ada 95 support for GCC
 Summary(ja): GNU コンパイラ集 - Ada 95 サポート
@@ -791,7 +757,6 @@ GNAT は GCC 用の GNU Ada 95 フロントエンドです。
 収録されています。
 
 ################################################# libgnat
-
 %package -n libgnat
 Summary: GNU Ada 95 runtime shared libraries
 Summary(ja): GNU コンパイラ集 - Ada 95 ランタイム共有ライブラリ
@@ -809,7 +774,6 @@ GNAT は GCC 用の GNU Ada 95 フロントエンドです。
 共有ライブラリが収録されています。
 
 ################################################# libgnat-devel
-
 %package -n libgnat-devel
 Summary: GNU Ada 95 libraries
 Group: programming
@@ -820,7 +784,6 @@ GNAT is a GNU Ada 95 front-end to GCC. This package includes libraries,
 which are required to compile with the GNAT.
 
 ################################################# libgnat-static
-
 %package -n libgnat-static
 Summary: GNU Ada 95 static libraries
 Group: programming
@@ -831,7 +794,6 @@ Autoreq: true
 GNAT is a GNU Ada 95 front-end to GCC. This package includes static libraries.
 
 ################################################# gcc-go
-
 %package go
 Summary: Go support
 Group: programming
@@ -847,7 +809,6 @@ The gcc-go package provides support for compiling Go programs
 with the GNU Compiler Collection.
 
 ################################################# libgo
-
 %package -n libgo
 Summary: Go runtime
 Group: system
@@ -858,7 +819,6 @@ This package contains Go shared library which is needed to run
 Go dynamically linked programs.
 
 ################################################# libgo-devel
-
 %package -n libgo-devel
 Summary: Go development libraries
 Group: programming
@@ -870,7 +830,6 @@ This package includes libraries and support files for compiling
 Go programs.
 
 ################################################# libgo-static
-
 %package -n libgo-static
 Summary: Static Go libraries
 Group: programming
@@ -881,7 +840,6 @@ Requires: gcc = %{version}-%{release}
 This package contains static Go libraries.
 
 ################################################# gcc-plugin-devel
-
 %package plugin-devel
 Summary: Support for compiling GCC plugins
 Group: programming
@@ -894,9 +852,10 @@ for compiling GCC plugins.  The GCC plugin ABI is currently
 not stable, so plugins must be rebuilt any time GCC is updated.
 
 #####################################################################
-
 %debug_package
 
+#####################################################################
+
 
 %prep
 %setup -q -n gcc-%{gcc_version}
@@ -934,8 +893,8 @@ sed -i -e 's/Common Driver Var(flag_report_bug)/& Init(1)/' gcc/common.opt
 # This test causes fork failures, because it spawns way too many threads
 rm -f gcc/testsuite/go.test/test/chan/goroutines.go
 
-%build
 
+%build
 # Undo the broken autoconf change in recent Fedora versions
 export CONFIG_SITE=NONE
 
@@ -978,7 +937,7 @@ enablelgo=,go
 
 CONFIGURE_OPTS="\
 	--prefix=%{_prefix} --mandir=%{_mandir} --infodir=%{_infodir} \
-	--with-bugurl=http://bugzilla.redhat.com/bugzilla \
+	--with-bugurl=http://mantis.vinelinux.org/ \
 	--enable-shared --enable-threads=posix --enable-checking=release \
 	--with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions \
 	--enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only \
@@ -1727,6 +1686,7 @@ for f in asan atomic gcc_s gfortran go gomp itm lsan objc quadmath stdc++ tsan u
 done
 rm -f %{buildroot}%{_prefix}/lib/libssp*
 
+
 %check
 %if %{with check}
 cd obj-%{gcc_target_platform}
@@ -1745,11 +1705,14 @@ tar cf - testlogs-%{_target_platform}-%{version}-%{release} | xz -9e \
   | uuencode testlogs-%{_target_platform}.tar.xz || :
 rm -rf testlogs-%{_target_platform}-%{version}-%{release}
 
-%endif # %{with check}
+%endif
+# check
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %post
 if [ -f %{_infodir}/gcc.info.gz ]; then
   /sbin/install-info \
@@ -1844,24 +1807,7 @@ if posix.access ("/sbin/ldconfig", "x") then
   end
 end
 
-%post -n libstdc++ -p /sbin/ldconfig
-
-%postun -n libstdc++ -p /sbin/ldconfig
-
-%post -n libobjc -p /sbin/ldconfig
-
-%postun -n libobjc -p /sbin/ldconfig
-
-%post -n libgfortran -p /sbin/ldconfig
-
-%postun -n libgfortran -p /sbin/ldconfig
-
-%post -n libgnat -p /sbin/ldconfig
-
-%postun -n libgnat -p /sbin/ldconfig
-
 %post -n libgomp
-/sbin/ldconfig
 if [ -f %{_infodir}/libgomp.info.gz ]; then
   /sbin/install-info \
     --info-dir=%{_infodir} %{_infodir}/libgomp.info.gz || :
@@ -1873,16 +1819,6 @@ if [ $1 = 0 -a -f %{_infodir}/libgomp.info.gz ]; then
     --info-dir=%{_infodir} %{_infodir}/libgomp.info.gz || :
 fi
 
-%postun -n libgomp -p /sbin/ldconfig
-
-%post gdb-plugin -p /sbin/ldconfig
-
-%postun gdb-plugin -p /sbin/ldconfig
-
-%post -n libgccjit -p /sbin/ldconfig
-
-%postun -n libgccjit -p /sbin/ldconfig
-
 %post -n libgccjit-devel
 if [ -f %{_infodir}/libgccjit.info.gz ]; then
   /sbin/install-info \
@@ -1896,7 +1832,6 @@ if [ $1 = 0 -a -f %{_infodir}/libgccjit.info.gz ]; then
 fi
 
 %post -n libquadmath
-/sbin/ldconfig
 if [ -f %{_infodir}/libquadmath.info.gz ]; then
   /sbin/install-info \
     --info-dir=%{_infodir} %{_infodir}/libquadmath.info.gz || :
@@ -1908,33 +1843,6 @@ if [ $1 = 0 -a -f %{_infodir}/libquadmath.info.gz ]; then
     --info-dir=%{_infodir} %{_infodir}/libquadmath.info.gz || :
 fi
 
-%postun -n libquadmath -p /sbin/ldconfig
-
-%postun -n libitm -p /sbin/ldconfig
-
-%post -n libatomic -p /sbin/ldconfig
-
-%postun -n libatomic -p /sbin/ldconfig
-
-%post -n libasan -p /sbin/ldconfig
-
-%postun -n libasan -p /sbin/ldconfig
-
-%post -n libtsan -p /sbin/ldconfig
-
-%postun -n libtsan -p /sbin/ldconfig
-
-%post -n libubsan -p /sbin/ldconfig
-
-%postun -n libubsan -p /sbin/ldconfig
-
-%post -n liblsan -p /sbin/ldconfig
-
-%postun -n liblsan -p /sbin/ldconfig
-
-%post -n libgo -p /sbin/ldconfig
-
-%postun -n libgo -p /sbin/ldconfig
 
 %files -f %{name}.lang
 %defattr(-,root,root,-)
@@ -2924,7 +2832,15 @@ fi
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/plugin/libcp1plugin.so*
 %doc rpm.doc/changelogs/libcc1/ChangeLog*
 
+
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3.1-1
+- imported Patch10000 from upstream (10.3.1).
+
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3.1-0
+- updated tarball to 10.3.0.
+- imported Patch10000 from upstream (10.3.1).
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2.1-1
 - updated tarball to 10.2.0.
 - imported Patch10000 from upstream (10.2.1).

+ 74 - 51
g/glibc/glibc-vl.spec

@@ -3,48 +3,16 @@
 
 %define glibcversion 2.33
 %define glibcsrcdir glibc-%{glibcversion}
-%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
-### glibc.spec.in follows:
-%define run_glibc_tests 1
-%define auxarches athlon sparcv9v sparc64v alphaev6
-%if %{build_compat32}
-%define auxarches i586 athlon sparcv9 alphaev6
-%endif
-%define xenarches i686 athlon
-%ifarch %{xenarches}
-%define buildxen 1
-%define xenpackage 0
-%else
-%define buildxen 0
-%define xenpackage 0
-%endif
-%ifarch ppc64
-%define buildpower6 1
-%else
-%define buildpower6 0
-%endif
-%define biarcharches %{ix86} x86_64 ppc ppc64 s390 s390x
-%global _enable_debug_packages 1
-%define debuginfocommonarches %{biarcharches} alpha alphaev6
-%define multiarcharches ppc ppc64 %{ix86} x86_64 %{sparc}
-# Remove -s to get verbose output.
-%define silentrules PARALLELMFLAGS=-s
-
-# We need to run ldconfig manually because __brp_ldconfig assumes that
-# glibc itself is always installed in $RPM_BUILD_ROOT, but with sysroots
-# we may be installed into a subdirectory of that path.  Therefore we
-# unset __brp_ldconfig and run ldconfig by hand with the sysroots path
-# passed to -r.
-%undefine __brp_ldconfig
 
 Summary: The GNU libc libraries
 Summary(ja): GNU libc ライブラリ
 Name: glibc
 Version: %{glibcversion}
-Release: 2%{?_dist_release}%{?with_systemd:.systemd}
+Release: 3%{?_dist_release}%{?with_systemd:.systemd}
 Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
+
 # GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
 # Things that are linked directly into dynamically linked programs
 # and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
@@ -67,7 +35,7 @@ Source11: SUPPORTED
 Source1000: rpm-old-changelog.txt
 
 # patched form upstream
-Patch0: glibc-2.33-20210308.patch
+Patch0: glibc-2.33-20210409.patch
 
 # patches from Fedora
 #Patch1: glibc-post_upgrade.patch
@@ -96,6 +64,44 @@ Patch29: glibc-fedora-nsswitch.patch
 
 # security
 
+%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
+
+### glibc.spec.in follows:
+%define run_glibc_tests 1
+%define auxarches athlon sparcv9v sparc64v alphaev6
+%if %{build_compat32}
+%define auxarches i586 athlon sparcv9 alphaev6
+%endif
+%define xenarches i686 athlon
+%ifarch %{xenarches}
+%define buildxen 1
+%define xenpackage 0
+%else
+%define buildxen 0
+%define xenpackage 0
+%endif
+%ifarch ppc64
+%define buildpower6 1
+%else
+%define buildpower6 0
+%endif
+%define biarcharches %{ix86} x86_64 ppc ppc64 s390 s390x
+%global _enable_debug_packages 1
+%define debuginfocommonarches %{biarcharches} alpha alphaev6
+%define multiarcharches ppc ppc64 %{ix86} x86_64 %{sparc}
+# Remove -s to get verbose output.
+%define silentrules PARALLELMFLAGS=-s
+
+# Only some architectures have static PIE support.
+%define pie_arches %{ix86} x86_64
+
+# We need to run ldconfig manually because __brp_ldconfig assumes that
+# glibc itself is always installed in $RPM_BUILD_ROOT, but with sysroots
+# we may be installed into a subdirectory of that path.  Therefore we
+# unset __brp_ldconfig and run ldconfig by hand with the sysroots path
+# passed to -r.
+%undefine __brp_ldconfig
+
 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 Obsoletes: glibc-profile < 2.4
 Provides: ldconfig
@@ -450,6 +456,11 @@ xtrace (関数呼出しトレーサ)。
 %define debug_package %{nil}
 %define __debug_install_post %{nil}
 %global __debug_package 1
+# Disable thew new features that glibc packages don't use.
+%undefine _debugsource_packages
+%undefine _debuginfo_subpackages
+%undefine _unique_debug_names
+%undefine _unique_debug_srcs
 
 %package debuginfo
 Summary: Debug information for package %{name}
@@ -520,6 +531,7 @@ diff -u %{SOURCE11} localedata/SUPPORTED
 
 cp -f %{SOURCE1000} ./
 
+
 %build
 
 # We build using the native system compilers.
@@ -558,38 +570,47 @@ rpm_inherit_flags ()
 rpm_inherit_flags \
 	"-Wp,-D_GLIBCXX_ASSERTIONS" \
 	"-fasynchronous-unwind-tables" \
-%if %{without gcc5}
 	"-fstack-clash-protection" \
-%endif
 	"-funwind-tables" \
 	"-m31" \
 	"-m32" \
 	"-m64" \
+	"-march=armv8-a+lse" \
+	"-march=armv8.1-a" \
+	"-march=haswell" \
 	"-march=i686" \
 	"-march=x86-64" \
+	"-march=x86-64-v2" \
+	"-march=x86-64-v3" \
+	"-march=x86-64-v4" \
 	"-march=z13" \
 	"-march=z14" \
+	"-march=z15" \
 	"-march=zEC12" \
+	"-mbranch-protection=standard" \
+	"-mcpu=power10" \
+	"-mcpu=power8" \
+	"-mcpu=power9" \
 	"-mfpmath=sse" \
 	"-msse2" \
 	"-mstackrealign" \
 	"-mtune=generic" \
+	"-mtune=power10" \
+	"-mtune=power8" \
+	"-mtune=power9" \
 	"-mtune=z13" \
 	"-mtune=z14" \
+	"-mtune=z15" \
 	"-mtune=zEC12" \
 	"-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1" \
 
-# Propagate additional build flags to BuildFlagsNonshared.  This is
-# very special because some of these files are part of the startup
-# code.  We essentially hope that these flags have little effect
-# there, and only specify the, for consistency, so that annobin
-# records the expected compiler flags.
-BuildFlagsNonshared=
-rpm_append_flag () {
-    BuildFlagsNonshared="$BuildFlagsNonshared $*"
-}
-rpm_inherit_flags \
-	"-Wp,-D_FORTIFY_SOURCE=2" \
+# libc_nonshared.a cannot be built with the default hardening flags
+# because the glibc build system is incompatible with
+# -D_FORTIFY_SOURCE.  The object files need to be marked as to be
+# skipped in annobin annotations.  (The -specs= variant of activating
+# annobin does not work here because of flag ordering issues.)
+# See <https://bugzilla.redhat.com/show_bug.cgi?id=1668822>.
+BuildFlagsNonshared="-Wa,--generate-missing-build-notes=yes"
 
 # Special flag to enable annobin annotations for statically linked
 # assembler code.  Needs to be passed to make; not preserved by
@@ -635,9 +656,7 @@ build()
 %endif
 		${core_with_options} \
 %ifarch x86_64 %{ix86}
-%if %{without gcc5}
-	       --enable-cet \
-%endif
+		--enable-cet \
 %endif
 %ifarch %{ix86}
 		--disable-multi-arch \
@@ -1948,6 +1967,10 @@ rm -f *.filelist*
 %endif
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.33-3
+- updated Patch0.
+- built with gcc-10.3.
+
 * Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.33-2
 - updated Patch0.
 - added filetriggers.

+ 4 - 5
i/isl/isl-vl.spec

@@ -1,7 +1,7 @@
 Summary: Integer point manipulation library
 Name: isl
 Version: 0.23
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -101,10 +101,6 @@ cd isl-%{version}
 #make check
 
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-
 %files
 %{_libdir}/libisl.so.%{libmajor}
 %{_libdir}/libisl.so.%{libversion}
@@ -122,6 +118,9 @@ cd isl-%{version}
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.23-2
+- rebuilt with current environment.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.23-1
 - new upstream release.
 

+ 15 - 13
lib/libn/libnsl2/libnsl2-vl.spec

@@ -1,9 +1,8 @@
-Name:         libnsl2
-Version:      1.2.0
-Release:      2%{?_dist_release}
 Summary:      Public client interface library for NIS(YP) and NIS+
-Group:        System Environment/Libraries
-
+Name:         libnsl2
+Version:      1.3.0
+Release:      1%{?_dist_release}
+Group:        system
 Vendor:       Project Vine
 Distribution: Vine Linux
 
@@ -11,11 +10,6 @@ License:      BSD and LGPLv2+
 URL:          https://github.com/thkukuk/libnsl
 Source0:      https://github.com/thkukuk/libnsl/archive/v%{version}.tar.gz#/libnsl-%{version}.tar.gz
 
-Patch1:       0001-Don-t-include-ltmain.sh-since-this-would-require-the.patch
-Patch2:       0002-Remove-outdated-download-url-issue-4.patch
-Patch3:       0003-Detect-recursive-lock-between-yp_all-and-do_ypcall.patch
-Patch4:       0004-Detect-recursive-NIS-calls.patch
-
 Patch100:     libnsl2-1.0.5-include_stdint.patch
 
 BuildRequires: autoconf, automake, gettext-devel, libtool, libtirpc-devel
@@ -36,9 +30,13 @@ Requires: glibc-devel >= 2.28
 Development files for libnsl2
 
 
+%debug_package
+
+
 %prep
 %autosetup -n libnsl-%{version} -p1
 
+
 %build
 export CFLAGS="%{optflags}"
 autoreconf -fiv
@@ -56,20 +54,24 @@ rm -rf %{buildroot}
 rm %{buildroot}/%{_libdir}/libnsl.a
 rm %{buildroot}/%{_libdir}/libnsl.la
 
+
 %files
 %license COPYING
-%{_libdir}/libnsl.so.2
-%{_libdir}/libnsl.so.2.0.0
+%{_libdir}/libnsl.so.*
 
 %files devel
 %{_libdir}/libnsl.so
 %{_includedir}/*
 %{_libdir}/pkgconfig/libnsl.pc
 
+
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
+- new upstream release.
+- dropped Patch1-4.
+
 * Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-2
 - rebuilt with current environment.
 
 * Fri Jan 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-1
 - initial build for Vine Linux.
-

+ 5 - 5
lib/libt/libtirpc/libtirpc-vl.spec

@@ -2,7 +2,7 @@
 
 Name:		libtirpc
 Version:	1.3.1
-Release:	1%{?_dist_release}
+Release:	2%{?_dist_release}
 Summary:	Transport Independent RPC Library
 Group:		system
 Vendor:		Project Vine
@@ -75,10 +75,6 @@ mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
 rm -rf %{buildroot}
 
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-
 %files
 %defattr(-,root,root)
 %license COPYING
@@ -132,6 +128,10 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-2
+- rebuilt with gcc-10.3.
+- dropped ldconfig scriptlets.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
 - updated to 1.3.1.
 

+ 6 - 10
lib/libt/libtool/libtool-vl.spec

@@ -1,12 +1,12 @@
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%define gcc_version 10.2.1
+%define gcc_version 10.3.1
 
 Summary: The GNU Portable Library Tool
 Summary(ja): GNU ポータブルライブラリツール
 Name:    libtool
 Version: 2.4.6
-Release: 7%{?_dist_release}
+Release: 8%{?_dist_release}
 Group: programming
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -88,8 +88,6 @@ Group:    system
 Provides: libtool-libs = %{version}-%{release}
 Obsoletes: libtool-libs < 1.5.20
 License:  LGPL
-Requires(post):  /sbin/ldconfig
-Requires(postun):  /sbin/ldconfig
 
 
 %description ltdl
@@ -187,12 +185,6 @@ if [ "$1" = 0 ]; then
    /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
 fi
 
-%post ltdl -p /sbin/ldconfig
-%postun ltdl -p /sbin/ldconfig
-
-%post -n compat32-%{name}-ltdl -p /sbin/ldconfig
-%postun -n compat32-%{name}-ltdl -p /sbin/ldconfig
-
 
 %files
 %defattr(-,root,root)
@@ -231,6 +223,10 @@ fi
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-8
+- rebuilt with gcc-10.3.1.
+- dropped ldconfig scriptltes.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-7
 - rebuilt with gcc-10.2.1.
 

+ 27 - 66
lib/libx/libxcrypt/libxcrypt-vl.spec

@@ -5,6 +5,26 @@
 %bcond_with check
 %endif
 
+Name:           libxcrypt
+Summary:        Extended crypt library for descrypt, md5crypt, bcrypt, and others
+Version:        4.4.19
+Release:        1%{?_dist_release}
+Group:          system
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
+# For explicit license breakdown, see the
+# LICENSING file in the source tarball.
+License:        LGPLv2+ and BSD and Public Domain
+URL:            https://github.com/besser82/%{name}
+Source0:        %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
+
+# Patch 0000 - 2999: Backported patches from upstream.
+
+# Patch 3000 - 5999: Backported patches from pull requests.
+
+# Patch 6000 - 9999: Downstream patches.
+
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
 # Build with new api?
@@ -13,14 +33,6 @@
 # Build the compat package?
 %bcond_without compat_pkg
 
-# Run memcheck?
-# Valgrind does not work well on %%{power64} arches.
-%ifnarch %{power64}
-%bcond_without memcheck
-%else
-%bcond_with    memcheck
-%endif
-
 # Shared object version of libcrypt.
 %if %{with new_api}
 %global soc  2
@@ -40,7 +52,6 @@
 %global sov  %{soc}.%{sol}.%{sof}
 %endif
 
-
 # Hash methods and API supported by libcrypt.
 # NEVER EVER touch this, if you do NOT know what you are doing!
 %if %{with new_api}
@@ -55,14 +66,12 @@
 %global obsolete_api   glibc
 %endif
 
-
 # Needed for the distribution README file.
 %global distname .vine
 
 # Needed for out-of-tree builds.
 %global _configure ../"configure"
 
-
 # Common configure options.
 %global common_configure_options           \\\
   --libdir=/%{_lib}                        \\\
@@ -70,15 +79,10 @@
   --disable-silent-rules                   \\\
   --enable-shared                          \\\
   --enable-static                          \\\
-%if %{with memcheck}                       \
-  --enable-valgrind                        \\\
-%else                                      \
   --disable-valgrind                       \\\
-%endif                                     \
   --srcdir=..                              \\\
   --with-pkgconfigdir=%{_libdir}/pkgconfig
 
-
 %if %{with fipstest}
 # Add generation of HMAC checksums of the final stripped
 # binaries.  %%define with lazy globbing is used here
@@ -103,30 +107,7 @@ fi                                                             \
 %{nil}
 %endif
 
-Name:           libxcrypt
-Summary:        Extended crypt library for descrypt, md5crypt, bcrypt, and others
-Version:        4.4.17
-Release:        1%{?_dist_release}
-Group:          system
-Vendor:         Project Vine
-Distribution:   Vine Linux
-
-# For explicit license breakdown, see the
-# LICENSING file in the source tarball.
-License:        LGPLv2+ and BSD and Public Domain
-URL:            https://github.com/besser82/%{name}
-Source0:        %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
-
-# Patch 0000 - 2999: Backported patches from upstream.
-
-# Patch 3000 - 5999: Backported patches from pull requests.
-
-# Patch 6000 - 9999: Downstream patches.
-
 BuildRequires:  libtool
-%if %{with memcheck}
-BuildRequires:  valgrind
-%endif
 %if %{with check}
 BuildRequires:  glibc-debuginfo
 %endif
@@ -331,11 +312,11 @@ rm -rf %{buildroot}
 
 %if %{with check}
 %check
+build_dirs="%{_vpath_builddir}"
 %if %{with new_api} && %{with compat_pkg}
-for dir in %{_vpath_builddir} %{_vpath_builddir}-compat; do
-%else
-for dir in %{_vpath_builddir}; do
+build_dirs="${build_dirs} %{_vpath_builddir}-compat"
 %endif
+for dir in ${build_dirs}; do
   %make_build -C ${dir} check || \
     {
       rc=$?;
@@ -344,34 +325,10 @@ for dir in %{_vpath_builddir}; do
       echo "-----END TESTLOG: ${dir}-----";
       exit $rc;
     }
-%if %{with memcheck}
-  %make_build -C ${dir} check-valgrind-memcheck || \
-    {
-      rc=$?;
-      echo "-----BEGIN TESTLOG: ${dir}-----";
-      %{__cat} ${dir}/test-suite-memcheck.log;
-      echo "-----END TESTLOG: ${dir}-----";
-      exit $rc;
-    }
-%endif
 done
 %endif
 
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-%if %{with new_api} && %{with compat_pkg}
-%post compat -p /sbin/ldconfig
-%postun compat -p /sbin/ldconfig
-%endif
-
-%if 0%{?build_compat32}
-%post -n compat32-%{name} -p /sbin/ldconfig
-%postun -n compat32-%{name} -p /sbin/ldconfig
-%endif
-
-
 %files
 %doc NEWS README* THANKS
 %license AUTHORS COPYING.LIB LICENSING
@@ -424,6 +381,10 @@ done
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.19-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.17-1
 - new upstream release.
 

+ 25 - 58
v/valgrind/valgrind-vl.spec

@@ -29,8 +29,8 @@
 Summary:        Tool for finding memory management bugs in programs
 Summary(ja):    プログラムのメモリ管理バグを発見するためのツール
 Name:           valgrind
-Version:        3.16.1
-Release:        2%{?_dist_release}
+Version:        3.17.0
+Release:        1%{?_dist_release}
 Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -48,30 +48,13 @@ Patch2: valgrind-3.9.0-helgrind-race-supp.patch
 # Make ld.so supressions slightly less specific.
 Patch3: valgrind-3.9.0-ldso-supp.patch
 
-# We want all executables and libraries in libexec instead of lib
-# so they are only available for valgrind usage itself and so the
-# same directory is used independent of arch.
-Patch4: valgrind-3.16.0-pkglibexecdir.patch
-
 # Add some stack-protector
-Patch5: valgrind-3.16.0-some-stack-protector.patch
+Patch4: valgrind-3.16.0-some-stack-protector.patch
 
 # Add some -Wl,z,now.
-Patch6: valgrind-3.16.0-some-Wl-z-now.patch
-
-# KDE#422174  unhandled instruction bytes: 0x48 0xE9 (REX prefix JMP instr)
-Patch7: valgrind-3.16.1-REX-prefix-JMP.patch
-
-# KDE#422623  epoll_ctl warns for uninit padding on non-amd64 64bit arches
-Patch8: valgrind-3.16.1-epoll.patch
+Patch5: valgrind-3.16.0-some-Wl-z-now.patch
 
-# KDE#369029  handle linux syscalls sched_getattr and sched_setattr
-Patch9: valgrind-3.16.1-sched_getsetattr.patch
-
-# KDE#415293  Incorrect call-graph tracking due to new _dl_runtime_resolve*
-Patch10: valgrind-3.16.1-dl_runtime_resolve.patch
-
-Buildroot: 	%{_tmppath}/%{name}-%{version}-root
+BuildRoot: 	%{_tmppath}/%{name}-%{version}-root
 %if %{build_multilib}
 # Ensure glibc{,-devel} is installed for both multilib arches
 BuildRequires: 	compat32-glibc-devel
@@ -171,16 +154,7 @@ Valgrind User Manual for details.
 
 %prep
 %setup -q -n %{name}-%{version}
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%patch9 -p1
-%patch10 -p1
+%autopatch -p1
 
 # Some patches (might) touch Makefile.am or configure.ac files.
 # Just always autoreconf so we don't need patches to prebuild files.
@@ -188,6 +162,11 @@ Valgrind User Manual for details.
 
 
 %build
+# LTO triggers undefined symbols in valgrind.  Valgrind has a --enable-lto
+# configure time option, but that doesn't seem to help.
+# Disable LTO for now.
+%define _lto_cflags %{nil}
+
 CC=gcc
 %if %{build_multilib}
 # Ugly hack - libgcc 32-bit package might not be installed
@@ -220,7 +199,11 @@ CC="gcc -B `pwd`/shared/libgcc/"
 # like __libc_freeres.
 %undefine _hardened_build
 %undefine _strict_symbol_defs_build
-OPTFLAGS="`echo " %{optflags} " | sed 's/ -m\(64\|3[21]\) / /g;s/ -fexceptions / /g;s/ -fstack-protector\([-a-z]*\) / / g;s/ -Wp,-D_FORTIFY_SOURCE=2 / /g;s/ -O2 / /g;s/ -mcpu=\([a-z0-9]\+\) / /g;s/^ //;s/ $//'`"
+CFLAGS="`echo " %{optflags} " | sed 's/ -fstack-protector\([-a-z]*\) / / g;s/ -O2 / /g;'`"
+LDFLAGS="`echo " %{build_ldflags} "    | sed 's/ -Wl,-z,now / / g;'`"
+
+export CFLAGS
+export LDFLAGS
 
 %configure CC="$CC" CFLAGS="$OPTFLAGS" CXXFLAGS="$OPTFLAGS" \
   --with-mpicc=%{mpiccpath} \
@@ -228,24 +211,6 @@ OPTFLAGS="`echo " %{optflags} " | sed 's/ -m\(64\|3[21]\) / /g;s/ -fexceptions /
 
 make %{?_smp_mflags}
 
-# Ensure there are no unexpected file descriptors open,
-# the testsuite otherwise fails.
-cat > close_fds.c <<EOF
-#include <stdlib.h>
-#include <unistd.h>
-int main (int argc, char *const argv[])
-{
-  int i, j = sysconf (_SC_OPEN_MAX);
-  if (j < 0)
-    exit (1);
-  for (i = 3; i < j; ++i)
-    close (i);
-  execvp (argv[1], argv + 1);
-  exit (1);
-}
-EOF
-gcc $RPM_OPT_FLAGS -o close_fds close_fds.c
-
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -255,7 +220,6 @@ mkdir docs/installed
 mv $RPM_BUILD_ROOT%{_datadir}/doc/valgrind/* docs/installed/
 rm -f docs/installed/*.ps
 
-
 # We want the MPI wrapper installed under the openmpi libdir so the script
 # generating the MPI library requires picks them up and sets up the right
 # openmpi libmpi.so requires. Install symlinks in the original/upstream
@@ -279,9 +243,6 @@ done
 popd
 %endif
 
-# remove unuse files
-rm -f $RPM_BUILD_ROOT%{_libdir}/valgrind/*.supp.in
-
 %if %{build_tools_devel}
 %ifarch %{ix86} x86_64
 # To avoid multilib clashes in between i?86 and x86_64,
@@ -311,7 +272,7 @@ chmod 644 $RPM_BUILD_ROOT%{_libexecdir}/valgrind/vgpreload*-*-*so
 %if %{with check}
 %check
 # Make sure a basic binary runs. There should be no errors.
-./vg-in-place --error-exitcode=1 /bin/true
+./vg-in-place --error-exitcode=1 /bin/true --help
 
 # Build the test files with the software collection compiler if available.
 %{?scl:PATH=%{_bindir}${PATH:+:${PATH}}}
@@ -325,9 +286,9 @@ export PYTHONCOERCECLOCALE=0
 
 echo ===============TESTING===================
 %if 0%{?run_full_regtest}
-  ./close_fds make regtest || :
+  make regtest || :
 %else
-  ./close_fds make nonexp-regtest || :
+  make nonexp-regtest || :
 %endif
 
 # Make sure test failures show up in build.log
@@ -381,6 +342,7 @@ echo ===============END TESTING===============
 %{_includedir}/valgrind/drd.h
 %{_includedir}/valgrind/helgrind.h
 %{_includedir}/valgrind/memcheck.h
+%{_includedir}/valgrind/dhat.h
 %{_libdir}/pkgconfig/valgrind.pc
 
 %if %{build_tools_devel}
@@ -403,6 +365,11 @@ echo ===============END TESTING===============
 
 
 %changelog
+* Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.17.0-1
+- new upstream release.
+- dropped Patch4, 7-10.
+- renumbered patches.
+
 * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.16.1-2
 - rebuilt with current environment.