Browse Source

updated 25 packages

Field3D-1.7.3-4

aqbanking-6.2.10-1

evolution-data-server-3.40.0-2

gnucash-4.5-1

harfbuzz-2.8.0-2

icu-69.1-1

inih-53-1

lvm2-2.03.11-1

libboost-1.75.0-2

librevenge-0.0.4-3

libvisio-0.1.7-4

php74-7.4.16-2

php80-8.0.3-2

postfix-3.5.9-2

postgresql-13.2-2

python-markdown-3.3.4-3

python-pyudev-0.22.0-2

rspamd-2.7-2

samba-4.14.2-1

tepl-6.00.0-2

tracker-miners-3.1.1-1

tracker-3.1.1-1

vte3-0.64.0-2

webkitgtk4-2.32.0-2

xfsprogs-5.11.0-1
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
bc388f1368

+ 10 - 17
F/Field3D/Field3D-vl.spec

@@ -1,6 +1,6 @@
 Name:           Field3D
 Version:        1.7.3
-Release:        3%{?_dist_release}
+Release:        4%{?_dist_release}
 Summary:        Library for storing voxel data
 Summary(ja):    ボクセルデータを蓄積するためのライブラリ
 Group:          system
@@ -66,35 +66,24 @@ sed -i \
 export CFLAGS="%{?optflags} -DH5_USE_110_API=1"
 export CXXFLAGS="%{?optflags} -DH5_USE_110_API=1"
 
-rm -rf build && mkdir build && pushd build
-%cmake -DINSTALL_DOCS=OFF \
-       ../
-
-make %{?_smp_mflags}
-popd
+%cmake -DINSTALL_DOCS=OFF
+%cmake_build
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
-pushd build
-make install DESTDIR=$RPM_BUILD_ROOT
-popd
+%cmake_install
 
 install -D -m 0644 man/f3dinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/f3dinfo.1
 
 
 %check
-pushd build
-LD_LIBRARY_PATH=`pwd` ./unitTest
-popd
+%ctest
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
 
 %files
 %license COPYING
@@ -110,6 +99,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-4
+- rebuilt with icu69.
+- dropped ldconfig scriptlets.
+
 * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-3
 - rebuilt with libboost-1.75.0.
 

+ 5 - 7
a/aqbanking/aqbanking-vl.spec

@@ -1,6 +1,6 @@
 Name: aqbanking
 Summary: A library for online banking functions and financial data import/export
-Version: 6.2.8
+Version: 6.2.10
 Release: 1%{?_dist_release}
 Group: system
 Vendor: Project Vine
@@ -19,8 +19,6 @@ BuildRequires: xmlsec1-gnutls-devel
 BuildRequires: gettext
 BuildRequires: libtool
 BuildRequires: libtool-ltdl-devel
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
 Obsoletes: aqhbci <= 1.0.3
 Obsoletes: g2banking < 3.7.2-1
 Obsoletes: python-aqbanking
@@ -104,10 +102,6 @@ popd
 rm -rf $RPM_BUILD_ROOT
 
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-
 %files -f %{name}.lang
 %defattr(-,root,root)
 %license COPYING
@@ -140,6 +134,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.2.10-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.2.8-1
 - new upstream release.
 

+ 4 - 1
e/evolution-data-server/evolution-data-server-vl.spec

@@ -29,7 +29,7 @@ Summary: Backend data server for evolution
 Summary(ja): Evolution バックエンドデータサーバ
 Name: evolution-data-server
 Version: 3.40.0
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Group: system,desktop-gnome
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -319,6 +319,9 @@ rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.40.0-2
+- rebuilt with icu69.
+
 * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.40.0-1
 - new upstream release.
 - dropped scriptlets.

+ 9 - 21
g/gnucash/gnucash-vl.spec

@@ -3,7 +3,7 @@
 Name:           gnucash
 Summary:        GnuCash is an application to keep track of your finances.
 Summary(ja):    個人用財務管理アプリケーション
-Version:        4.4
+Version:        4.5
 Release:        1%{?_dist_release}
 Group:          office
 Vendor:         Project Vine
@@ -84,17 +84,17 @@ GnuCashは 個人用財務管理をするアプリケーションです.
 %build
 %global optflags %{optflags} -Wno-parentheses
 
-%cmake . \
+%cmake \
        -DCMAKE_INSTALL_DOCDIR=%{_datadir}/doc/gnucash-%{version} \
        -DWITH_SQL=OFF
 
-%make_build
+%cmake_build
 
 
 %install
 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
 
-%make_install
+%cmake_install
 
 %find_lang %name
 
@@ -113,23 +113,6 @@ find $RPM_BUILD_ROOT%{_libdir} -name *.la -exec rm -f {} \;
 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
 
 
-%post
-/sbin/ldconfig
-touch --no-create %{_datadir}/icons/hicolor || :
-gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
-
-%postun 
-if [ $1 -eq 0 ] ; then
-    /sbin/ldconfig
-    touch --no-create %{_datadir}/icons/hicolor || :
-    gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
-    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
-fi
-
-%posttrans
-glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
-
-
 %files -f %{name}.lang
 %defattr(-,root,root,755)
 %doc %{_docdir}/gnucash-%{version}/*
@@ -148,6 +131,11 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.5-1
+- new upstream release.
+- built with icu69.
+- dropped scriptlets.
+
 * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4-1
 - new upstream release.
 - built with boost-1.75.0.

+ 4 - 1
h/harfbuzz/harfbuzz-vl.spec

@@ -3,7 +3,7 @@
 Summary:	Text shaping library
 Name:		harfbuzz
 Version:	2.8.0
-Release:	1%{?_dist_release}
+Release:	2%{?_dist_release}
 Group:		system
 Vendor:		Project Vine
 Distribution:	Vine Linux
@@ -151,6 +151,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.0-2
+- built with icu-69.
+
 * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.0-1
 - new upstream release.
 - dropped scriptlets.

+ 17 - 18
i/icu/icu-vl.spec

@@ -1,26 +1,25 @@
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%define sover 67
-%define minorver 1
-
 Summary:        International Components for Unicode
 Summary(ja):    ユニコード用国際化コンポーネント
 Name:           icu
-Version:        %{sover}.%{minorver}
+Version:        69.1
 Release:        1%{?_dist_release}
-Group:          Development/Tools
+Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
+%define sover   %(echo %{version} | cut -d . -f 1)
+%define minorver %(echo %{version} | cut -d . -f 2)
+
 License:        MIT
 URL:            http://icu-project.org/
-
 Source0:        https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
 Source1:        https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 BuildRequires:  gcc-c++
-BuildRequires:  unzip perl 
+BuildRequires:  unzip perl
 Requires:       libicu%{sover} = %{version}-%{release}
 
 %description
@@ -32,7 +31,7 @@ properties, along with converters and time zones data.
 %package -n libicu%{sover}
 Summary: International Components for Unicode (library)
 Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
-Group: System Environment/Libraries
+Group: system
 Provides: libicu = %{version}-%{release}
 
 %description -n libicu%{sover}
@@ -44,7 +43,7 @@ contain any of the data files needed at runtime.
 %package -n libicu-devel
 Summary: Header files, libraries and development documentation for libicu
 Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
-Group: Development/Libraries
+Group: programming
 Requires: libicu%{sover} = %{version}-%{release}
 
 %description -n libicu-devel
@@ -56,7 +55,7 @@ If you like to develop programs using %{name}, you will need to install
 %package -n libicu-doc
 Summary: Documentation for International Components for Unicode
 Summary(ja): ユニコード用国際化コンポーネントのドキュメント
-Group: Applications/Documentation
+Group: documentation
 Requires: libicu%{sover} = %{version}-%{release}
 
 %description -n libicu-doc
@@ -68,7 +67,7 @@ This package contains the development documentation for %{name}.
 %package -n compat32-libicu%{sover}
 Summary: International Components for Unicode (library)
 Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
-Group: System Environment/Libraries
+Group: system,legacy
 Provides: compat32-libicu = %{version}-%{release}
 
 %description -n compat32-libicu%{sover}
@@ -107,9 +106,10 @@ make -C source install DESTDIR=$RPM_BUILD_ROOT
 cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
 chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
 
+
 %ifarch x86_64
-%check || :
-make %{?_smp_mflags} -C source check
+%check
+%make_build -C source check
 %endif
 
 
@@ -117,11 +117,6 @@ make %{?_smp_mflags} -C source check
 rm -rf $RPM_BUILD_ROOT
 
 
-%post -n libicu%{sover} -p /sbin/ldconfig
-
-%postun -n libicu%{sover} -p /sbin/ldconfig
-
-
 %files
 %defattr(-, root, root, 0755)
 %license LICENSE
@@ -170,6 +165,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 69.1-1
+- updated to 69.1.
+- dropped ldconfig scriptlets.
+
 * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 67.1-1
 - updated to 67.1.
 

+ 118 - 0
i/inih/inih-vl.spec

@@ -0,0 +1,118 @@
+Name:		inih
+Summary:	Simple INI file parser library
+Summary(ja):	シンプルなINIファイル解析ライブラリ
+Version:	53
+Release:	1%{?_dist_release}
+Group:		system
+Vendor:		Project Vine
+Distribution:	Vine Linux
+
+License:  BSD
+URL:      https://github.com/benhoyt/inih
+Source0:  %{url}/archive/r%{version}/%{name}-r%{version}.tar.gz
+
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: meson
+
+%description
+The inih package provides simple INI file parser which is only a couple of
+pages of code, and it was designed to be small and simple, so it's good for
+embedded systems.
+
+
+%package devel
+Summary: Development package for %{name}
+Group: programming
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+This package contains development files for %{name}.
+
+The inih package provides simple INI file parser which is only a couple of
+pages of code, and it was designed to be small and simple, so it's good for
+embedded systems.
+
+
+%debug_package
+
+
+%prep
+%autosetup -n %{name}-r%{version}
+
+
+%build
+%meson -Ddefault_library=shared -Ddistro_install=true
+%meson_build
+
+
+%install
+%meson_install
+
+
+%files
+%license LICENSE.txt
+%doc README.md
+%{_libdir}/lib*.so.*
+
+%files devel
+%{_includedir}/*.h
+%{_libdir}/pkgconfig/*.pc
+%{_libdir}/lib*.so
+
+
+%changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 53-1
+- initial build for Vine Linux.
+- new upstream release.
+
+* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 49-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 49-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Wed Jun  3 2020 Christian Kellner <ckellner@redhat.com> - 49-1
+- New upstream release 49
+- Switch to meson build system.
+- Ship the pkg-config file.
+- Remove ldconfig scriptlets.
+
+* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 36-13
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 36-12
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 36-11
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 36-10
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 36-9
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 36-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 36-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 36-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Wed Aug 31 2016 Jan F. Chadima <jfch@jagda.eu> - 36-5
+- implement license tag
+
+* Wed Aug 31 2016 Jan F. Chadima <jfch@jagda.eu> - 36-4
+- implement next review hints
+
+* Tue Aug 30 2016 Jan F. Chadima <jfch@jagda.eu> - 36-3
+- implement another review results
+
+* Tue Aug 30 2016 Jan F. Chadima <jfch@jagda.eu> - 36-2
+- implement review results
+
+* Mon Aug 29 2016 Jan F. Chadima <jfch@jagda.eu> - 36-1
+- initial version

+ 26 - 19
l/lvm2/lvm2-vl.spec

@@ -1,18 +1,17 @@
 %bcond_with systemd
 
-%define device_mapper_version 1.02.171
 %define _unpackaged_files_terminate_build 1
 
-# Do not reset Release to 1 unless both lvm2 and device-mapper 
-# versions are increased together.
-
 Summary: Userland logical volume management tools
 Summary(ja): 論理ボリューム管理ツール
 Name: lvm2
-Version: 2.03.09
+Version: 2.03.11
 %global lvm_version %{version}
-Release: 2%{?_dist_release}%{?with_systemd:.systemd}
-Group: System Environment/Base
+%define device_mapper_version 1.02.175
+# Do not reset Release to 1 unless both lvm2 and device-mapper 
+# versions are increased together.
+Release: 1%{?_dist_release}%{?with_systemd:.systemd}
+Group: admin-tools
 Distribution: Vine Linux
 Vendor: Project Vine
 Packager: daisuke
@@ -32,7 +31,6 @@ Requires: device-mapper-event >= %{device_mapper_version}-%{release}
 Requires: %{name}-libs = %{version}-%{release}
 %if %{with systemd}
 BuildRequires: python3
-BuildRequires: python3-rpm-macros
 BuildRequires: python3-pyudev
 BuildRequires: dbus-python3
 BuildRequires: systemd-devel
@@ -58,7 +56,7 @@ or more physical volumes and creating one or more logical volumes
 %package devel
 Summary: Development libraries and headers for lvm2
 Summary(ja): LVM2 の開発用ライブラリ及びヘッダファイル
-Group: Development/Libraries
+Group: programming
 License: LGPLv2
 Requires: %{name} = %{version}-%{release}
 Requires: %{name}-libs = %{version}-%{release}
@@ -75,15 +73,17 @@ the lvm2 libraries.
 Summary: lvm2 shared libraries
 Summary(ja): LVM2 の共有ライブラリ
 License: LGPLv2
-Group: System Environment/Libraries
+Group: system
 
 %description libs
 This package contains shared lvm2 libraries for applications.
 
+
 %if %{with systemd}
 %package dbusd
 Summary: LVM2 D-Bus daemon
 Summary(ja): LVM2 D-Bus デーモン
+Group: system
 License: GPLv2
 BuildArch: noarch
 Requires: lvm2 >= %{version}-%{release}
@@ -91,14 +91,15 @@ Requires: dbus
 Requires: dbus-python3
 Requires: python3-pyudev
 Requires: python3-pygobject
-Requires(post): systemd-units >= %{systemd_version}
-Requires(preun): systemd-units >= %{systemd_version}
-Requires(postun): systemd-units >= %{systemd_version}
+Requires(post): systemd-units
+Requires(preun): systemd-units
+Requires(postun): systemd-units
 
 %description dbusd
 Daemon for access to LVM2 functionality through a D-Bus interface.
 %endif
 
+
 # device-mapper
 %package -n device-mapper
 Summary: Device mapper utility
@@ -106,7 +107,7 @@ Summary(ja): Device-mapper ユーティリティ集
 Version: %{device_mapper_version}
 Release: %{release}
 License: GPLv2
-Group: System Environment/Base
+Group: system
 URL: http://sources.redhat.com/dm
 Requires: device-mapper-libs = %{device_mapper_version}-%{release}
 Requires: eudev-libudev
@@ -124,7 +125,7 @@ Summary(ja): Device-mapper の開発用ライブラリ及びヘッダファイ
 Version: %{device_mapper_version}
 Release: %{release}
 License: LGPLv2
-Group: Development/Libraries
+Group: programming
 Requires: device-mapper = %{device_mapper_version}-%{release}
 Requires: device-mapper-libs = %{device_mapper_version}-%{release}
 
@@ -139,7 +140,7 @@ Summary(ja): Device-mapper の共有ライブラリ
 Version: %{device_mapper_version}
 Release: %{release}
 License: LGPLv2
-Group: System Environment/Libraries
+Group: system
 Obsoletes: device-mapper < 1.02.30-1
 
 %description -n device-mapper-libs
@@ -149,9 +150,9 @@ This package contains the device-mapper shared library, libdevmapper.
 %package -n device-mapper-event
 Summary: Device-mapper event daemon
 Summary(ja): Device-mapper イベントデーモン
-Group: System Environment/Base
 Version: %{device_mapper_version}
 Release: %{release}
+Group: system
 Requires: device-mapper = %{device_mapper_version}-%{release}
 Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
 
@@ -165,8 +166,8 @@ Summary: Device-mapper event daemon shared library
 Summary(ja): Device-mapper イベントデーモン共有ライブラリ
 Version: %{device_mapper_version}
 Release: %{release}
+Group: system
 License: LGPLv2
-Group: System Environment/Libraries
 
 %description -n device-mapper-event-libs
 This package contains the device-mapper event daemon shared library,
@@ -178,8 +179,8 @@ Summary: Development libraries and headers for the device-mapper event daemon
 Summary(ja): Device-mapper イベントデーモンの開発用ライブラリ及びヘッダファイル
 Version: %{device_mapper_version}
 Release: %{release}
+Group: programming
 License: LGPLv2
-Group: Development/Libraries
 Requires: device-mapper-event = %{device_mapper_version}-%{release}
 Requires: pkgconfig
 
@@ -188,6 +189,9 @@ This package contains files needed to develop applications that use
 the device-mapper event library.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n LVM2.%{lvm_version}
 %patch0 -p1 -b .preferred_names
@@ -555,6 +559,9 @@ fi
 /usr%{_libdir}/pkgconfig/devmapper-event.pc
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.03.11-1
+- new upstream release.
+
 * Wed May 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.03.09-2
 - added systemd support (disabled as default).
 

+ 4 - 1
lib/libb/libboost/libboost-vl.spec

@@ -29,7 +29,7 @@ Summary: Portable C++ source libraries
 Summary(ja): ポータブルな C++ ソースライブラリ
 Name: libboost
 Version: 1.75.0
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -1605,6 +1605,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.75.0-2
+- built with icu-69.
+
 * Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.75.0-1
 - new upstream release.
 - dropped libboost-jam.

+ 21 - 13
lib/libr/librevenge/librevenge-vl.spec

@@ -1,19 +1,17 @@
 %global apiversion 0.0
 
 Name: librevenge
-Version: 0.0.4
-Release: 2%{?_dist_release}
 Summary: A base library for writing document import filters
 Summary(ja): ドキュメントのインポートフィルタを作成するための基礎ライブラリ
+Version: 0.0.4
+Release: 3%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
 # src/lib/RVNGOLEStream.{h,cpp} are BSD
 License: (LGPLv2+ or MPLv2.0) and BSD
-Group: System Environment/Libraries
 URL: http://sourceforge.net/p/libwpd/wiki/librevenge/
-
-Vendor: Project Vine
-Distribution: Vine Linux
-
 Source: http://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -27,28 +25,35 @@ BuildRequires: zlib-devel
 interfaces for text documents, vector graphics, spreadsheets and
 presentations.
 
+
 %package devel
 Summary: Development files for %{name}
 Summary(ja): %{name} の開発用ファイル
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 
 %description devel
 The %{name}-devel package contains libraries and header files for
 developing applications that use %{name}.
 
+
 %package doc
 Summary: Documentation of %{name} API
 Summary(ja): %{name} API のドキュメント
-Group: Documentation
+Group: documentation
 BuildArch: noarch
 
 %description doc
 The %{name}-doc package contains documentation files for %{name}.
 
+
+%debug_package
+
+
 %prep
 %autosetup -p1
 
+
 %build
 %configure --disable-silent-rules --disable-static --disable-werror --enable-pretty-printers
 sed -i \
@@ -57,6 +62,7 @@ sed -i \
     libtool
 make %{?_smp_mflags}
 
+
 %install
 rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
@@ -64,15 +70,12 @@ rm -f %{buildroot}/%{_libdir}/*.la
 # we install API docs directly from build
 rm -rf %{buildroot}/%{_docdir}/%{name}
 
-%post
-/sbin/ldconfig
-%postun
-/sbin/ldconfig
 
 #%check
 #export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
 #make %{?_smp_mflags} check
 
+
 %clean
 rm -rf %{buildroot}
 
@@ -101,7 +104,12 @@ rm -rf %{buildroot}
 %doc COPYING.*
 %doc docs/doxygen/html
 
+
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0.4-3
+- rebuilt with current environment.
+- dropped ldconfig scriptlets.
+
 * Sun Jul  3 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0.4-2
 - fixed %%post and %%postun scripts.
 

+ 20 - 7
lib/libv/libvisio/libvisio-vl.spec

@@ -2,10 +2,10 @@
 
 Name: libvisio
 Version: 0.1.7
-Release: 3%{?_dist_release}
+Release: 4%{?_dist_release}
 Summary: A library for import of Microsoft Visio diagrams
 Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
-Group: System Environment/Libraries
+Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
 
@@ -33,35 +33,42 @@ being used in libreoffice.
 %package devel
 Summary: Development files for %{name}
 Summary(ja): %{name} の開発用ファイル
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 
 %description devel
 The %{name}-devel package contains libraries and header files for
 developing applications that use %{name}.
 
+
 %package doc
 Summary: Documentation of %{name} API
 Summary(ja): %{name} API のドキュメント
-Group: Documentation
+Group: documentation
 BuildArch: noarch
 
 %description doc
 The %{name}-doc package contains documentation files for %{name}.
 
+
 %package tools
 Summary: Tools to transform Microsoft Visio diagrams into other formats
 Summary(ja): Microsoft Visio ダイアグラムを他のフォーマットに変換するツール
-Group: Applications/Productivity
+Group: office
 Requires: %{name} = %{version}-%{release}
 
 %description tools
 Tools to transform Microsoft Visio diagrams into other formats.
 Currently supported: XHTML, raw, plain text.
 
+
+%debug_package
+
+
 %prep
 %setup -q
 
+
 %build
 %configure --disable-static --disable-silent-rules
 sed -i \
@@ -78,6 +85,7 @@ help2man -N -n 'debug the conversion library' -o vss2raw.1 ./src/conv/raw/.libs/
 help2man -N -n 'convert Visio stencil into SVG' -o vss2xhtml.1 ./src/conv/svg/.libs/vss2xhtml
 help2man -N -n 'convert Visio stencil into plain text' -o vss2text.1 ./src/conv/text/.libs/vss2text
 
+
 %install
 rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
@@ -88,8 +96,6 @@ rm -rf %{buildroot}/%{_docdir}/%{name}
 install -m 0755 -d %{buildroot}/%{_mandir}/man1
 install -m 0644 vsd2*.1 vss2*.1 %{buildroot}/%{_mandir}/man1
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
 
 %check
 export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
@@ -97,9 +103,11 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PA
 export TZ='CET'
 make check %{?_smp_mflags}
 
+
 %clean
 rm -rf %{buildroot}
 
+
 %files
 %license COPYING.*
 %doc AUTHORS
@@ -129,7 +137,12 @@ rm -rf %{buildroot}
 %{_mandir}/man1/vss2text.1*
 %{_mandir}/man1/vss2xhtml.1*
 
+
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-4
+- rebuilt with icu-69.
+- dropped ldconfig scriptlets.
+
 * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-3
 - rebuilt with icu-67.
 

+ 13 - 121
p/php74/php74-vl.spec

@@ -1,11 +1,6 @@
 %bcond_with systemd
-%bcond_with debug
 %bcond_without apache2
 
-%if %{with debug}
-%define __spec_install_post /usr/lib/rpm/brp-compress 
-%endif
-
 %global majorver 74
 %global ap_suffix 7
 %global _name php%{majorver}
@@ -27,13 +22,6 @@
 %define gd_name gd
 %endif
 
-%{!?_without_pear:%global _with_pear 1}
-%global with_pear %{?_with_pear:1}%{!?_with_pear:0}
-%if %{with_pear}
-%global pear_rootdir %{_datadir}/%{_name}-pear
-%global pear_cachedir %{_localstatedir}/cache/%{_name}-pear
-%endif
-
 %global apache2_confdir %{_sysconfdir}/apache2/conf.d
 %global apache2_moduledir %{_libdir}/apache2/modules
 %global apache2_contentdir /var/www
@@ -56,7 +44,7 @@ Name: php%{majorver}
 Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
 Summary(ja): HTML 埋め込み型スクリプト言語 PHP
 Version: 7.4.16
-Release: 1%{_dist_release}%{?with_systemd:.systemd}
+Release: 2%{_dist_release}%{?with_systemd:.systemd}
 Group: programming
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -67,9 +55,6 @@ URL: https://www.php.net/
 
 Source0: http://www.php.net/distributions/%{srcname}.tar.xz
 
-# borrowed from Fedora's php-pear 1:1.9.4-5
-Source13: macros.pear
-
 Source20: README.vine
 Source21: php.ini-vine
 Source24: php.conf-apache2
@@ -78,7 +63,7 @@ Source26: php-fpm.conf
 Source27: default-pool.conf.in
 Source28: php-fpm.logrotate
 Source29: php_params
-Source31: macros.pear.ver
+Source31: macros.php.ver
 Source32: php-fpm.service
 
 Patch33: php-5.2.4-phpincludedir.patch
@@ -151,13 +136,12 @@ Requires: www-common
 %endif
 
 Requires(post,preun): alternatives
-%{?_with_pear:Requires: %{name}-pear = %{version}-%{release}}
 Conflicts: php5 < 5.6.11
 Conflicts: php <= 4.4.2-0vl1.2
 Provides: php = %{version}-%{release}
 Provides: php_extension_api(%{php_extension_api})
 Provides: php_zend_extension_api(%{zend_extension_api})
-Obsoletes: php5-sqlite < 5.5.0
+Obsoletes: php74-pear < 7.4.16-2
 
 %description 
 PHP is an HTML-embedded scripting language. PHP attempts to make it
@@ -193,24 +177,6 @@ The php-devel package contains the files needed for building PHP
 extensions. If you need to compile your own PHP extensions, you will
 need to install this package.
 
-#----------------------------------------------------------------------
-%if %{with_pear}
-%package pear
-Group: programming
-Summary: PHP Extension and Application Repository Components
-Requires(post): alternatives
-Requires: %{name} = %{version}-%{release}
-Conflicts: php-pear <= 4.4.2-0vl2
-Provides: php-pear = %{version}-%{release}
-# pear's version itself is 1.9.4
-Provides: php-pear(PEAR) = 1.9.4
-Conflicts: php5-pear < 5.6.11
-
-%description pear
-PEAR is a framework and distribution system for reusable PHP
-components.  This package contains the basic PEAR components.
-%endif
-
 #----------------------------------------------------------------------
 %if %{with apache2}
 %package apache2
@@ -508,14 +474,7 @@ export EXTENSION_DIR=%{_libdir}/%{_name}
 build() {
 ln -sf ../configure
 
-%if %{with debug}
-export CFLAGS="%{optflags} -fPIC -g"
-export CXXFLAGS="%{optflags} -fPIC --std=c++0x -g"
-%else
-export CFLAGS="%{optflags} -fPIC"
-export CXXFLAGS="%{optflags} -fPIC --std=c++0x"
-%endif
-
+export CFLAGS=$(echo $RPM_OPT_FLAGS -mshstk -fno-strict-aliasing -Wno-pointer-sign | sed 's/-mstackrealign//')
 
 %configure \
   --cache-file=../config.cache \
@@ -564,7 +523,7 @@ export CXXFLAGS="%{optflags} -fPIC --std=c++0x"
   --with-xsl \
   --with-zip=shared \
   --with-zlib \
-  %{?_with_pear:--with-pear=%{pear_rootdir}}%{!?_with_pear:--without-pear} \
+  --without-pear \
   $*
 if test $? != 0; then
   tail -500 config.log
@@ -611,19 +570,6 @@ popd
 %install
 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
 
-#export PHP_PEAR_SYSCONF_DIR=%{php_confdir}
-#export PHP_PEAR_TEMP_DIR=%{pear_cachedir}
-#export PHP_PEAR_CACHE_DIR=%{buildroot}%{pear_cachedir}
-#export PHP_PEAR_DOWNLOAD_DIR=%{pear_cachedir}
-#export PHP_PEAR_PHP_BIN=%{_bindir}/%{_name}
-
-export PHP_PEAR_SYSCONF_DIR=%{php_confdir}
-export PHP_PEAR_TEMP_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_CACHE_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_DOWNLOAD_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_PHP_BIN=%{buildroot}%{_bindir}/%{_name}
-unset http_proxy
-
 #----------------------------------------------------------------------
 pushd build-cgi
 # Install everything from the CGI SAPI build
@@ -651,28 +597,11 @@ sed -i \
 #mv %{buildroot}%{_mandir}/man1/phar.1 %{buildroot}%{_mandir}/man1/phar%{majorver}.1
 #rm %{buildroot}%{_mandir}/man1/phar.phar.1
 
-%if %{with_pear}
-# http://pear.php.net/bugs/bug.php?id=6154
-perl -pi -e 's#s:([0-9]+):(.)(%{buildroot})+#"s:".($1-length($3)).":$2"#eg;' %{buildroot}%{php_confdir}/pear.conf
-
-for cmd in pear peardev pecl; do
-  cp %{buildroot}%{_bindir}/${cmd}{,%{majorver}}
-done
-%{__install} -m 755 -d %{buildroot}%{pear_cachedir}
-
-# install rpmmacro file for pear
-mkdir -p %{buildroot}%{_datadir}/php%{majorver}
-install -m 644 -c %{SOURCE13} \
-  %{buildroot}%{_datadir}/php%{majorver}/macros.pear
-sed -i -e 's/@majorver@/%{majorver}/g' \
-  %{buildroot}%{_datadir}/php%{majorver}/macros.pear
-
-mkdir -p %{buildroot}%{_sysconfdir}/rpm 
+mkdir -p %{buildroot}%{_rpmmacrodir}
 install -m 644 -c %{SOURCE31} \
-	%{buildroot}%{_sysconfdir}/rpm/macros.pear%{majorver}
+	%{buildroot}%{_rpmmacrodir}/macros.php%{majorver}
 sed -i -e 's/@majorver@/%{majorver}/g' \
-  %{buildroot}%{_sysconfdir}/rpm/macros.pear%{majorver}
-%endif
+  %{buildroot}%{_rpmmacrodir}/macros.php%{majorver}
 
 # Install cgi/fcgi binaries
 mv %{buildroot}%{_bindir}/php-cgi%{majorver} %{buildroot}%{_bindir}/%{_name}-cgi
@@ -794,14 +723,6 @@ rm -f %{buildroot}%{_libdir}/%{_name}/*.a
 # Remove irrelevant docs
 rm -f README.{Zeus,QNX,CVS-RULES}
 
-# ad-hoc fix for incorrect paths to php5
-for X in pear%{majorver} peardev%{majorver} pecl%{majorver} ; do
-  sed -i -e 's|%{buildroot}||g' %{buildroot}%{_bindir}/$X
-done
-
-rm -rf %{buildroot}/{.channels,.depdb*,.filemap,.lock}
-rm -f %{buildroot}%{_bindir}/{pear,peardev,pecl,phar}
-
 #----------------------------------------------------------------------
 %post
 /sbin/update-alternatives \
@@ -882,27 +803,6 @@ if [ "$1" = 0 ]; then
   /sbin/update-alternatives --remove php-nginx %{_sysconfdir}/nginx/%{_name}_params
 fi
 
-%post pear
-/sbin/update-alternatives \
-  --install %{_bindir}/pear     pear    %{_bindir}/pear%{majorver} %{majorver} \
-  --slave   %{_bindir}/peardev  peardev %{_bindir}/peardev%{majorver} \
-  --slave   %{_bindir}/pecl     pecl    %{_bindir}/pecl%{majorver} \
-  --slave   %{_sysconfdir}/rpm/macros.pear macros.pear %{_datadir}/php%{majorver}/macros.pear
-
-
-# fix broken symlink if it's there
-if [ ! -f %{_bindir}/pear ] ; then
-    /sbin/update-alternatives --auto pear
-fi
-
-%triggerpostun pear -- php5-pear < 5.1.4-0vl1
-/sbin/update-alternatives --auto pear
-
-%preun pear
-if [ "$1" = 0 ]; then
-  /sbin/update-alternatives --remove pear %{_bindir}/pear%{majorver}
-fi
-
 %post devel
 /sbin/update-alternatives \
   --install %{_bindir}/php-config php-devel   %{_bindir}/php-config%{majorver} %{majorver} \
@@ -987,6 +887,7 @@ rm -f files.*
 # gd extension (should be separated package?)
 %config(noreplace) %{php_confdir}/php.d/gd.ini
 %{_libdir}/%{_name}/gd.so
+%config %{_rpmmacrodir}/macros.php%{majorver}
 
 %files devel
 %defattr(-,root,root)
@@ -997,19 +898,6 @@ rm -f files.*
 %{_includedir}/%{_name}
 %{_libdir}/%{_name}/build
 
-%if %{with_pear}
-%files pear
-%defattr(-,root,root)
-%config %{php_confdir}/pear.conf
-%config %{_datadir}/%{_name}/macros.pear
-%config %{_sysconfdir}/rpm/macros.pear%{majorver}
-%{_bindir}/pear%{majorver}
-%{_bindir}/peardev%{majorver}
-%{_bindir}/pecl%{majorver}
-%{pear_rootdir}
-%dir %{pear_cachedir}
-%endif
-
 %if %{with apache2}
 %files apache2
 %defattr(-,root,root)
@@ -1054,6 +942,10 @@ rm -f files.*
 
 #======================================================================
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4.16-2
+- rebuilt with icu69.
+- dropped php-pear (no longer maintained in upstream).
+
 * Fri Mar 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4.16-1
 - new upstream release.
 

+ 13 - 141
p/php80/php80-vl.spec

@@ -1,11 +1,6 @@
 %bcond_with systemd
-%bcond_with debug
 %bcond_without apache2
 
-%if %{with debug}
-%define __spec_install_post /usr/lib/rpm/brp-compress 
-%endif
-
 %global majorver 80
 %global ap_suffix 8
 %global _name php%{majorver}
@@ -23,13 +18,6 @@
 
 %define gd_name gd
 
-%{!?_without_pear:%global _with_pear 1}
-%global with_pear %{?_with_pear:1}%{!?_with_pear:0}
-%if %{with_pear}
-%global pear_rootdir %{_datadir}/%{_name}-pear
-%global pear_cachedir %{_localstatedir}/cache/%{_name}-pear
-%endif
-
 %global apache2_confdir %{_sysconfdir}/apache2/conf.d
 %global apache2_moduledir %{_libdir}/apache2/modules
 %global apache2_contentdir /var/www
@@ -45,7 +33,7 @@ Name: php%{majorver}
 Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
 Summary(ja): HTML 埋め込み型スクリプト言語 PHP
 Version: 8.0.3
-Release: 1%{_dist_release}%{?with_systemd:.systemd}
+Release: 2%{_dist_release}%{?with_systemd:.systemd}
 Group: programming
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -53,12 +41,8 @@ Packager: tomop
 
 License: The PHP License
 URL: https://www.php.net/
-
 Source0: http://www.php.net/distributions/%{srcname}.tar.xz
 
-# borrowed from Fedora's php-pear 1:1.9.4-5
-Source13: macros.pear
-
 Source20: README.vine
 Source21: php.ini-vine
 Source24: php.conf-apache2
@@ -67,7 +51,7 @@ Source26: php-fpm.conf
 Source27: default-pool.conf.in
 Source28: php-fpm.logrotate
 Source29: php_params
-Source31: macros.pear.ver
+Source31: macros.php.ver
 Source32: php-fpm.service
 
 Patch33: php-5.2.4-phpincludedir.patch
@@ -134,13 +118,13 @@ BuildRequires: www-common
 Requires: www-common
 
 Requires(post,preun): alternatives
-%{?_with_pear:Requires: %{name}-pear = %{version}-%{release}}
 Conflicts: php5 < 5.6.11
 Conflicts: php <= 4.4.2-0vl1.2
 Provides: php = %{version}-%{release}
 Provides: php_extension_api(%{php_extension_api})
 Provides: php_zend_extension_api(%{zend_extension_api})
 Obsoletes: php5-sqlite < 5.5.0
+Obsoletes: php80-pear < 8.0.3-2
 
 %description 
 PHP is an HTML-embedded scripting language. PHP attempts to make it
@@ -176,24 +160,6 @@ The php-devel package contains the files needed for building PHP
 extensions. If you need to compile your own PHP extensions, you will
 need to install this package.
 
-#----------------------------------------------------------------------
-%if %{with_pear}
-%package pear
-Group: programming
-Summary: PHP Extension and Application Repository Components
-Requires(post): alternatives
-Requires: %{name} = %{version}-%{release}
-Conflicts: php-pear <= 4.4.2-0vl2
-Provides: php-pear = %{version}-%{release}
-# pear's version itself is 1.9.4
-Provides: php-pear(PEAR) = 1.9.4
-Conflicts: php5-pear < 5.6.11
-
-%description pear
-PEAR is a framework and distribution system for reusable PHP
-components.  This package contains the basic PEAR components.
-%endif
-
 #----------------------------------------------------------------------
 %if %{with apache2}
 %package apache2
@@ -205,7 +171,6 @@ Requires: %{name} = %{version}-%{release}
 Requires: apache2 >= 2.0.50-0vl2
 Requires(post): sed, file
 Provides: php-apache2 = %{version}-%{release}
-Conflicts: php5-pache2 < 5.6.11
 
 %description apache2
  This package contains the php5 module for Apache version 2.
@@ -245,7 +210,6 @@ Summary: A database abstraction layer module for PHP applications
 Group: programming
 Requires: %{name} = %{version}-%{release}
 Provides: php-dba = %{version}-%{release}
-Conflicts: php5-dba < 5.6.11
 
 %description dba
 The php-dba package contains a dynamic shared object that will add
@@ -270,7 +234,6 @@ BuildRequires: uw-imap-devel >= 2000c-1.6.0
 BuildRequires: openssl-devel
 Requires: %{name} = %{version}-%{release}
 Provides: php-imap = %{version}-%{release}
-Conflicts: php5-imap < 5.6.11
 
 %description imap
 The php-imap package contains a dynamic shared object (DSO) for the
@@ -290,7 +253,6 @@ BuildRequires: openldap-devel
 BuildRequires: openssl-devel
 Requires: %{name} = %{version}-%{release}
 Provides: php-ldap = %{version}-%{release}
-Conflicts: php5-ldap < 5.6.11
 
 %description ldap
 The php-ldap package is a dynamic shared object (DSO) for the Apache
@@ -310,7 +272,6 @@ Requires: %{name} = %{version}-%{release}
 Requires: %{name}-pdo
 Provides: %{name}_database
 Provides: php-mysql = %{version}-%{release}
-Conflicts: php5-mysql < 5.6.11
 
 %description mysql
 The php-mysql package contains a dynamic shared object that will add
@@ -328,7 +289,6 @@ Requires: %{name} = %{version}-%{release}
 Requires: %{name}-pdo
 Provides: %{name}_database
 Provides: php-odbc = %{version}-%{release}
-Conflicts: php5-odbc < 5.6.11
 
 %description odbc
 The php-odbc package contains a dynamic shared object that will add
@@ -345,7 +305,6 @@ Summary: A database access abstraction module for PHP applications
 Group: programming
 Requires: %{name} = %{version}-%{release}
 Provides: php-pdo = %{version}-%{release}
-Conflicts: php5-pdo < 5.6.11
 
 %description pdo
 The php-pdo package contains a dynamic shared object that will add
@@ -363,7 +322,6 @@ Requires: %{name} = %{version}-%{release}
 Requires: %{name}-pdo
 Provides: %{name}_database
 Provides: php-pgsql = %{version}-%{release}
-Conflicts: php5-pgsql < 5.6.11
 
 %description pgsql
 The php-pgsql package includes a dynamic shared object (DSO) that can
@@ -387,7 +345,6 @@ BuildRequires: rpm-devel
 BuildRequires: zlib-devel
 Requires: %{name} = %{version}-%{release}
 Provides: php-snmp = %{version}-%{release}
-Conflicts: php5-snmp < 5.6.11
 
 %description snmp
 The php-snmp package contains a dynamic shared object that will add
@@ -401,7 +358,6 @@ Summary: A module for PHP applications to use the ICU APIs
 Group: programming
 Requires: %{name} = %{version}-%{release}
 Provides: php-intl = %{version}-%{release}
-Conflicts: php5-intl < 5.6.11
 
 %description intl
  The php-intl package is a wrapper for ICU library, enabling PHP programmers
@@ -416,7 +372,6 @@ Requires: %{name} = %{version}-%{release}
 Provides: php-zip = %{version}-%{release}
 Provides: php-ext-zip
 Obsoletes: php-ext-zip < 1.12.4
-Conflicts: php5-zip < 5.6.11
 
 %description zip
  The php-zip package is an extension to create, modify and read zip files.
@@ -427,7 +382,6 @@ Summary: A module for PHP-CLI applications to use Process Control (pcntl)
 Group: programming
 Requires: %{name} = %{version}-%{release}
 Provides: php-pcntl = %{version}-%{release}
-Conflicts: php5-pcntl < 5.6.11
 
 %description pcntl
  Process Control support in PHP implements the Unix style of process
@@ -442,7 +396,6 @@ Summary: A zend extension to cache script bytecode
 Group: programming
 Requires: %{name} = %{version}-%{release}
 Provides: php-opcache = %{version}-%{release}
-Conflicts: php5-opcache < 5.6.11
 
 %description opcache
  OPcache improves PHP performance by storing precompiled script bytecode
@@ -486,14 +439,7 @@ export EXTENSION_DIR=%{_libdir}/%{_name}
 build() {
 ln -sf ../configure
 
-%if %{with debug}
-export CFLAGS="%{optflags} -fPIC -g"
-export CXXFLAGS="%{optflags} -fPIC --std=c++0x -g"
-%else
-export CFLAGS="%{optflags} -fPIC"
-export CXXFLAGS="%{optflags} -fPIC --std=c++0x"
-%endif
-
+export CFLAGS=$(echo $RPM_OPT_FLAGS -mshstk -fno-strict-aliasing -Wno-pointer-sign | sed 's/-mstackrealign//')
 
 %configure \
   --cache-file=../config.cache \
@@ -542,7 +488,7 @@ export CXXFLAGS="%{optflags} -fPIC --std=c++0x"
   --with-xsl \
   --with-zip=shared \
   --with-zlib \
-  %{?_with_pear:--with-pear=%{pear_rootdir}}%{!?_with_pear:--without-pear} \
+  --without-pear \
   $*
 if test $? != 0; then
   tail -500 config.log
@@ -588,20 +534,6 @@ popd
 #======================================================================
 %install
 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
-
-#export PHP_PEAR_SYSCONF_DIR=%{php_confdir}
-#export PHP_PEAR_TEMP_DIR=%{pear_cachedir}
-#export PHP_PEAR_CACHE_DIR=%{buildroot}%{pear_cachedir}
-#export PHP_PEAR_DOWNLOAD_DIR=%{pear_cachedir}
-#export PHP_PEAR_PHP_BIN=%{_bindir}/%{_name}
-
-export PHP_PEAR_SYSCONF_DIR=%{php_confdir}
-export PHP_PEAR_TEMP_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_CACHE_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_DOWNLOAD_DIR=%{buildroot}%{pear_cachedir}
-export PHP_PEAR_PHP_BIN=%{buildroot}%{_bindir}/%{_name}
-unset http_proxy
-
 #----------------------------------------------------------------------
 pushd build-cgi
 # Install everything from the CGI SAPI build
@@ -623,34 +555,11 @@ sed -i \
   -e 's/@majorver@/%{majorver}/g' \
   %{buildroot}%{php_confdir}/php.ini
 
-# fix path in phar
-#perl -pi -e 's|^#!/.+/build-cgi/sapi/cli/php$|#!/usr/bin/%{_name}|' %{buildroot}%{_bindir}/phar.phar
-#mv %{buildroot}%{_bindir}/phar.phar %{buildroot}%{_bindir}/phar%{majorver}.phar
-#mv %{buildroot}%{_mandir}/man1/phar.1 %{buildroot}%{_mandir}/man1/phar%{majorver}.1
-#rm %{buildroot}%{_mandir}/man1/phar.phar.1
-
-%if %{with_pear}
-# http://pear.php.net/bugs/bug.php?id=6154
-perl -pi -e 's#s:([0-9]+):(.)(%{buildroot})+#"s:".($1-length($3)).":$2"#eg;' %{buildroot}%{php_confdir}/pear.conf
-
-for cmd in pear peardev pecl; do
-  cp %{buildroot}%{_bindir}/${cmd}{,%{majorver}}
-done
-%{__install} -m 755 -d %{buildroot}%{pear_cachedir}
-
-# install rpmmacro file for pear
-mkdir -p %{buildroot}%{_datadir}/php%{majorver}
-install -m 644 -c %{SOURCE13} \
-  %{buildroot}%{_datadir}/php%{majorver}/macros.pear
-sed -i -e 's/@majorver@/%{majorver}/g' \
-  %{buildroot}%{_datadir}/php%{majorver}/macros.pear
-
-mkdir -p %{buildroot}%{_sysconfdir}/rpm 
+mkdir -p %{buildroot}%{_rpmmacrodir}
 install -m 644 -c %{SOURCE31} \
-	%{buildroot}%{_sysconfdir}/rpm/macros.pear%{majorver}
+	%{buildroot}%{_rpmmacrodir}/macros.php%{majorver}
 sed -i -e 's/@majorver@/%{majorver}/g' \
-  %{buildroot}%{_sysconfdir}/rpm/macros.pear%{majorver}
-%endif
+  %{buildroot}%{_rpmmacrodir}/macros.php%{majorver}
 
 # Install cgi/fcgi binaries
 mv %{buildroot}%{_bindir}/php-cgi%{majorver} %{buildroot}%{_bindir}/%{_name}-cgi
@@ -772,14 +681,6 @@ rm -f %{buildroot}%{_libdir}/%{_name}/*.a
 # Remove irrelevant docs
 rm -f README.{Zeus,QNX,CVS-RULES}
 
-# ad-hoc fix for incorrect paths to php5
-for X in pear%{majorver} peardev%{majorver} pecl%{majorver} ; do
-  sed -i -e 's|%{buildroot}||g' %{buildroot}%{_bindir}/$X
-done
-
-rm -rf %{buildroot}/{.channels,.depdb*,.filemap,.lock}
-rm -f %{buildroot}%{_bindir}/{pear,peardev,pecl,phar}
-
 #----------------------------------------------------------------------
 %post
 /sbin/update-alternatives \
@@ -860,27 +761,6 @@ if [ "$1" = 0 ]; then
   /sbin/update-alternatives --remove php-nginx %{_sysconfdir}/nginx/%{_name}_params
 fi
 
-%post pear
-/sbin/update-alternatives \
-  --install %{_bindir}/pear     pear    %{_bindir}/pear%{majorver} %{majorver} \
-  --slave   %{_bindir}/peardev  peardev %{_bindir}/peardev%{majorver} \
-  --slave   %{_bindir}/pecl     pecl    %{_bindir}/pecl%{majorver} \
-  --slave   %{_sysconfdir}/rpm/macros.pear macros.pear %{_datadir}/php%{majorver}/macros.pear
-
-
-# fix broken symlink if it's there
-if [ ! -f %{_bindir}/pear ] ; then
-    /sbin/update-alternatives --auto pear
-fi
-
-%triggerpostun pear -- php5-pear < 5.1.4-0vl1
-/sbin/update-alternatives --auto pear
-
-%preun pear
-if [ "$1" = 0 ]; then
-  /sbin/update-alternatives --remove pear %{_bindir}/pear%{majorver}
-fi
-
 %post devel
 /sbin/update-alternatives \
   --install %{_bindir}/php-config php-devel   %{_bindir}/php-config%{majorver} %{majorver} \
@@ -946,6 +826,7 @@ rm -f files.*
 # gd extension (should be separated package?)
 %config(noreplace) %{php_confdir}/php.d/gd.ini
 %{_libdir}/%{_name}/gd.so
+%config %{_rpmmacrodir}/macros.php%{majorver}
 
 %files devel
 %defattr(-,root,root)
@@ -956,19 +837,6 @@ rm -f files.*
 %{_includedir}/%{_name}
 %{_libdir}/%{_name}/build
 
-%if %{with_pear}
-%files pear
-%defattr(-,root,root)
-%config %{php_confdir}/pear.conf
-%config %{_datadir}/%{_name}/macros.pear
-%config %{_sysconfdir}/rpm/macros.pear%{majorver}
-%{_bindir}/pear%{majorver}
-%{_bindir}/peardev%{majorver}
-%{_bindir}/pecl%{majorver}
-%{pear_rootdir}
-%dir %{pear_cachedir}
-%endif
-
 %if %{with apache2}
 %files apache2
 %defattr(-,root,root)
@@ -1013,6 +881,10 @@ rm -f files.*
 
 #======================================================================
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.3-2
+- rebuilt with icu69.
+- dropped php-pear (no longer maintained in upstream).
+
 * Fri Mar 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.3-1
 - new upstream release.
 

+ 5 - 4
p/postfix/postfix-vl.spec

@@ -24,7 +24,7 @@
 %define postfix_command_dir     %{_sbindir}
 %define postfix_queue_dir       %{_var}/spool/postfix
 %define postfix_data_dir        %{_var}/lib/postfix
-%define postfix_doc_dir         %{_docdir}/%{name}-%{version}
+%define postfix_doc_dir         %{_pkgdocdir}
 %define postfix_sample_dir      %{postfix_doc_dir}/samples
 %define postfix_readme_dir      %{postfix_doc_dir}/README_FILES
 
@@ -32,7 +32,7 @@ Summary:        Postfix Mail Transport Agent
 Summary(ja):    Postfix メールトランスポートエージェント
 Name:           postfix
 Version:        3.5.9
-Release:        1%{?_dist_release}%{?with_systemd:.systemd}
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
 Group:          servers
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -370,7 +370,6 @@ exit 0
 
 
 %post
-/sbin/ldconfig
 # upgrade configuration files if necessary
 %{_sbindir}/postfix set-permissions upgrade-configuration \
   daemon_directory=%{postfix_daemon_dir} \
@@ -410,7 +409,6 @@ fi
 %endif
 
 %postun
-/sbin/ldconfig
 %if %{with systemd}
 %systemd_postun_with_restart %{name}.service
 %else
@@ -560,6 +558,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/postfix/postfix-files.d/pcre
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-2
+- rebuilt with icu69.
+
 * Mon Jan 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
 - new upstream release.
 

+ 5 - 19
p/postgresql/postgresql-vl.spec

@@ -18,7 +18,7 @@ Summary: PostgreSQL client programs
 Summary(ja): PostgreSQL のクライアントプログラム群
 Name: postgresql
 Version: 13.2
-Release: 1%{?_dist_release}%{?with_systemd:.systemd}
+Release: 2%{?_dist_release}%{?with_systemd:.systemd}
 Group: office
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -181,7 +181,6 @@ Summary: The programs needed to create and run a PostgreSQL server.
 Summary(ja): PostgreSQL サーバを構築・実行するのに必要なプログラム
 Group: servers
 Requires: %{name} = %{version}
-Requires: /sbin/ldconfig
 Requires(pre): shadow-utils
 %if %{with systemd}
 BuildRequires: systemd-devel
@@ -573,7 +572,6 @@ EOF
 fi
 
 %post server
-/sbin/ldconfig
 %if %{with systemd}
 %systemd_post postgresql.service
 %else
@@ -590,7 +588,6 @@ fi
 %endif
 
 %postun server
-/sbin/ldconfig 
 %if %{with systemd}
 %systemd_postun_with_restart postgresql.service
 %else
@@ -605,21 +602,6 @@ if [ $1 = 0 ] ; then
 fi
 %endif
 
-%if %{with plperl}
-%post -p /sbin/ldconfig   plperl
-%postun -p /sbin/ldconfig   plperl
-%endif
-
-%if %{with plpython3}
-%post -p /sbin/ldconfig   plpython3
-%postun -p /sbin/ldconfig   plpython3
-%endif
-
-%if %{with pltcl}
-%post -p /sbin/ldconfig   pltcl
-%postun -p /sbin/ldconfig   pltcl
-%endif
-
 %if %test
 %post test
 chown -R postgres.postgres %{_datadir}/pgsql/test >/dev/null 2>&1 || :
@@ -858,6 +840,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.2-2
+- rebuilt with icu69.
+- dropped ldconfig scriptlets.
+
 * Fri Feb 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.2-1
 - new upstream release.
 

+ 325 - 0
p/python-markdown/python-markdown-vl.spec

@@ -0,0 +1,325 @@
+%global srcname Markdown
+%global pkgname markdown
+
+Name:           python-%{pkgname}
+Summary:        Markdown implementation in Python
+Version:        3.3.4
+Release:        3%{?_dist_release}
+Group:          programming
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
+License:        BSD
+URL:            https://python-markdown.github.io/
+Source0:        %{pypi_source}
+
+BuildArch:      noarch
+
+%description
+This is a Python implementation of John Gruber’s Markdown. It is
+almost completely compliant with the reference implementation, though
+there are a few very minor differences.
+
+
+%package -n python3-%{pkgname}
+Summary:        Markdown implementation in Python
+Group:          programming
+BuildRequires:  python3-devel
+BuildRequires:  python3-PyYAML
+BuildRequires:  python3-setuptools
+%if 0%{?rhel} && 0%{?rhel} < 9
+BuildRequires:  python3-importlib-metadata
+Requires:       python3-importlib-metadata
+%endif
+
+%{?python_provide:%python_provide python3-%{pkgname}}
+
+%description -n python3-%{pkgname}
+This is a Python implementation of John Gruber's Markdown. It is
+almost completely compliant with the reference implementation, though
+there are a few known issues.
+
+
+%prep
+%autosetup -p1 -n %{srcname}-%{version}
+
+
+%build
+%py3_build
+
+
+%install
+%py3_install
+
+# process license file
+PYTHONPATH=%{buildroot}%{python3_sitelib} \
+  %{buildroot}%{_bindir}/markdown_py \
+  LICENSE.md > LICENSE.html
+
+
+%check
+python3 -m unittest discover tests
+
+
+%files -n python3-%{pkgname}
+# temporarily skip packaging docs - see also
+# https://github.com/Python-Markdown/markdown/issues/621
+#doc python3/build/docs/*
+%license LICENSE.*
+%{python3_sitelib}/*
+%{_bindir}/markdown_py
+
+
+%changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.3.4-3
+- initial build for Vine Linux.
+
+* Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-2
+- Apply PR6 by Igor Raits <ignatenkobrain@fedoraproject.org>: Support
+  for building on EPEL8 + upstream tests invocation.
+- Remove unused BR on python3-tidy (we'd need pytidylib instead, which
+  doesn't seem to be packaged).
+
+* Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-1
+- Update to 3.3.4.
+
+* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.3-1
+- Update to 3.3.3.
+
+* Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.2-1
+- Update to 3.3.2.
+
+* Tue Oct 13 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.1-1
+- Update to 3.3.1.
+
+* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.2-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 3.2.2-3
+- Rebuilt for Python 3.9
+
+* Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-2
+- Update BRs.
+
+* Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-1
+- Update to 3.2.2.
+
+* Sat Feb 22 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.1-1
+- Update to 3.2.1.
+
+* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-6
+- Rebuilt for Python 3.8.0rc1 (#1748018)
+
+* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-5
+- Rebuilt for Python 3.8
+
+* Tue Aug 13 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-4
+- Drop versioned binaries.
+
+* Tue Aug 13 2019 Gwyn Ciesla <gwync@protonmail.com> - 3.1.1-3
+- Drop Python 2.
+
+* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Sat May 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-1
+- Update to 3.1.1.
+
+* Fri May 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1-2
+- Move /usr/bin/markdown_py to python3-markdown (#1705777)
+
+* Tue Mar 26 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1-1
+- Update to 3.1.
+
+* Mon Mar 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.0.1-1
+- Update to 3.0.1.
+- Simplify spec file.
+- CLI tool uses Python3 now.
+- Update BRs.
+
+* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Sun Jun 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.6.11-3
+- Rebuilt for Python 3.7
+
+* Sun Jun  3 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-2
+- Try to fix a FTBFS with Python 3.7 (rhbz#1583678).
+
+* Sun Feb 11 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-1
+- Update to 2.6.11.
+
+* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.9-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-2
+- Fix BRs.
+
+* Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-1
+- Update to 2.6.9.
+- Allow building a python3 subpackage on EPEL7+.
+
+* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Sun Jan 29 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.8-1
+- Update to 2.6.8.
+
+* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.6.7-2
+- Rebuild for Python 3.6
+
+* Sat Sep 24 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.7-1
+- Update to 2.6.7.
+- Update Source0 URL.
+
+* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.6-2
+- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
+
+* Tue Apr  5 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.6-1
+- Update to 2.6.6.
+
+* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Sun Nov 29 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.5-1
+- Update to 2.6.5.
+
+* Sat Nov 21 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.4-1
+- Update to 2.6.4.
+- Follow updated Python packaging guidelines.
+
+* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
+
+* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Wed Apr 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.2-1
+- Update to 2.6.2.
+
+* Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-2
+- Add license file.
+
+* Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-1
+- Update to 2.6.1.
+- Apply updated Python packaging guidelines.
+
+* Sun Feb 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6-1
+- Update to 2.6.
+- Update the upstream URL.
+
+* Sun Nov 23 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-1
+- Update to 2.5.2.
+
+* Thu Oct  2 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.1-1
+- Update to 2.5.1.
+
+* Thu Sep 25 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5-1
+- Update to 2.5.
+- Add BR on PyYAML.
+
+* Wed Jun  4 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4.1-1
+- Update to 2.4.1.
+
+* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 2.4-2
+- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
+
+* Tue Apr 15 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4-1
+- Update to 2.4.
+- Update Python3 conditional.
+- Fix wrong line endings.
+
+* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Fri Jul 19 2013 Thomas Moschny <thomas.moschny@gmx.dee> - 2.3.1-2
+- Move python3 runtime dependency to python3 subpackage (rhbz#986376).
+
+* Mon Apr  8 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3.1-1
+- Update to 2.3.1.
+
+* Mon Mar 18 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3-1
+- Update to 2.3.
+- Spec file cleanups.
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Fri Nov 23 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
+- Update to 2.2.1.
+
+* Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 2.2.0-3
+- rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
+
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jul 14 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.0-1
+- Update to 2.2.0.
+- Update url.
+- Add patch from upstream git for failing test.
+
+* Wed Feb  8 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.1-1
+- Update to 2.1.1.
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Sat Dec 17 2011 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.0-1
+- Update to 2.1.0.
+- Fix rhel conditional.
+- Binary has been renamed.
+- Build python3 subpackage.
+- Include documentation in HTML instead of Markdown format.
+- Run tests.
+
+* Wed Sep 07 2011 Jesse Keating <jkeating@redhat.com> - 2.0.3-4
+- Set a version in the rhel macro
+
+* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.0.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
+
+* Thu Oct  8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.3-1
+- Update to 2.0.3.
+
+* Thu Aug 27 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-3
+- Add requirement on python-elementtree, which was a separate package
+  before Python 2.5.
+- Re-add changelog entries accidentally removed earlier.
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sat Jul 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-1
+- Update to 2.0.1.
+- Upstream stripped .py of the cmdline script.
+
+* Sat Apr 25 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-1
+- Update to 2.0.
+- Adjusted source URL.
+- License changed to BSD only.
+- Upstream now provides a script to run markdown from the cmdline.
+
+* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7-2
+- Rebuild for Python 2.6
+
+* Mon Aug  4 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.7-1
+- New package.

+ 4 - 1
p/python-pyudev/python-pyudev-vl.spec

@@ -4,7 +4,7 @@
 Summary:          A libudev binding
 Name:             python-%{srcname}
 Version:          0.22.0
-Release:          1%{?_dist_release}
+Release:          2%{?_dist_release}%{?with_systemd:.systemd}
 Group:            programming
 Vendor:           Project Vine
 Distribution:     Vine Linux
@@ -85,6 +85,9 @@ rm -rf pyudev.egg-info
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-2
+- added systemd support (disabled as default).
+
 * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-1
 - new upstream release.
 

+ 4 - 1
r/rspamd/rspamd-vl.spec

@@ -12,7 +12,7 @@
 Summary:        Rapid spam filtering system
 Name:           rspamd
 Version:        2.7
-Release:        1%{?_dist_release}%{?with_systemd:.systemd}
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
 Group:          servers
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -243,6 +243,9 @@ fi
 
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7-2
+- rebuilt with icu69.
+
 * Sat Jan 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7-1
 - new upstream release.
 

+ 13 - 11
s/samba/samba-vl.spec

@@ -2,11 +2,11 @@
 %bcond_with tracker
 %bcond_without pidl
 
-%define samba_version 4.13.7
+%define samba_version 4.14.2
 #define rc_number rc4
-%define samba_release 2
+%define samba_release 1
 
-%define doc_version 4.13.2-1
+%define doc_version 4.14.0-1
 %define api_version 4.0
 %define libwbc_soname 0
 %define libwbc_sover 0.15
@@ -139,7 +139,9 @@ BuildRequires: pkgconfig
 BuildRequires: popt-devel
 BuildRequires: python3-devel
 BuildRequires: python3-rpm-macros
+BuildRequires: python3-dns
 BuildRequires: python3-gpg
+BuildRequires: python3-markdown
 BuildRequires: python3-tdb
 #BuildRequires: python3-ldb-devel
 #BuildRequires: python3-talloc-devel
@@ -417,7 +419,7 @@ link against the SMB, RPC and other protocols.
 %package -n compat32-samba-libs
 Summary: Samba libraries
 Summary(ja): Samba ライブラリ
-Group: system
+Group: system,legacy
 %if %with_libwbclient
 Requires: compat32-libwbclient
 %endif
@@ -431,7 +433,7 @@ link against the SMB, RPC and other protocols provided by the Samba suite.
 %package -n compat32-libsmbclient
 Summary: The SMB client library
 Summary(ja): SMB クライアントライブラリ
-Group: system
+Group: system,legacy
 Requires: samba-common = %{samba_version}-%{release}
 
 %description -n compat32-libsmbclient
@@ -445,7 +447,7 @@ libsmbclient は Samba クライアントの機能を提供するライブラリ
 %package -n compat32-libwbclient
 Summary: The winbind client library
 Summary(ja): Winbind クライアントライブラリ
-Group: system
+Group: system,legacy
 Requires: samba-common = %{samba_version}-%{release}
 Requires(pre): /usr/sbin/groupadd
 Requires(post): /sbin/chkconfig, /sbin/service, coreutils
@@ -456,6 +458,7 @@ Requires(preun): /sbin/chkconfig, /sbin/service
 the Samba suite.
 
 %endif
+
 ## --------------------------------------------------------------------
 %debug_package
 
@@ -508,7 +511,6 @@ make distclean
 ##export PATH=$PATH:$PWD/buildtools/bin
 export PYTHON=%{__python3}
 
-LDFLAGS="-Wl,-z,relro,-z,now" \
 %configure \
   --enable-fhs \
   --bundled-libraries=%{_samba4_libraries} \
@@ -853,7 +855,6 @@ setfacl -m u:named:rwx /var/lib/samba/private >/dev/null 2>/dev/null || :
 		%{_libdir}/libwbclient.so.%{libwbc_soname} \
 		libwbclient.so.%{libwbc_soname}%{libwbc_alternatives_suffix} \
 		%{_libdir}/samba/wbclient/libwbclient.so.%{libwbc_soname}
-/sbin/ldconfig
 
 ## --------------------------------------------------------------------
 
@@ -904,7 +905,6 @@ fi
 		libwbclient.so.%{libwbc_sover}%{libwbc_alternatives_suffix} \
 		%{_libdir}/samba/wbclient/libwbclient.so.%{libwbc_sover} \
 		10
-/sbin/ldconfig
 
 ## --------------------------------------------------------------------
 
@@ -913,7 +913,6 @@ fi
 	--remove \
 		libwbclient.so.%{libwbc_sover}%{libwbc_alternatives_suffix} \
 		%{_libdir}/samba/wbclient/libwbclient.so.%{libwbc_sover}
-/sbin/ldconfig
 %endif
 
 
@@ -1350,6 +1349,7 @@ fi
 %defattr(-,root,root)
 %ghost %{_libdir}/krb5/plugins/libkrb5/winbind_krb5_locator.so
 %{_libdir}/samba/krb5/winbind_krb5_locator.so
+%{_libdir}/samba/krb5/async_dns_krb5_locator.so
 %{_mandir}/man8/winbind_krb5_locator.8*
 # ja manual
 %{_mandir}/ja/man8/winbind_krb5_locator.8*
@@ -1558,7 +1558,6 @@ fi
 #%{samba_includedir}/util/memory.h
 #%{samba_includedir}/util/safe_string.h
 %{samba_includedir}/util/signal.h
-%{samba_includedir}/util/string_wrappers.h
 %{samba_includedir}/util/substitute.h
 #%{samba_includedir}/util/talloc_stack.h
 %{samba_includedir}/util/tevent_ntstatus.h
@@ -1802,6 +1801,9 @@ fi
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.0-1
+- new upstream release.
+
 * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.13.7-2
 - rebuilt without tracker.
 

+ 4 - 1
t/tepl/tepl-vl.spec

@@ -1,7 +1,7 @@
 Summary:        Text editor product line
 Name:           tepl
 Version:        6.00.0
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -77,6 +77,9 @@ developing applications that use %{name}.
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.00.0-2
+- rebuilt with icu69.
+
 * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.00.0-1
 - new upstream release.
 - dropped ldconfig scriptlets.

+ 6 - 2
t/tracker-miners/tracker-miners-vl.spec

@@ -4,7 +4,7 @@
 %global with_libcue 1
 %global with_rss 0
 
-%global tracker_version 3.1.0
+%global tracker_version 3.1.1
 
 %if %{with_rss}
 %global systemd_units tracker-extract-3.service tracker-miner-fs-3.service tracker-miner-fs-control-3.service tracker-miner-rss-3.service tracker-writeback-3.service
@@ -17,7 +17,7 @@
 %global __requires_exclude ^(libtracker-extract\.so|libtracker-miner-3\.0\.so|libextract-.*\.so|libwriteback-.*\.so)
 
 Name:           tracker-miners
-Version:        3.1.0
+Version:        3.1.1
 Release:        1%{?_dist_release}%{?with_systemd:.systemd}
 Summary:        Tracker miners and metadata extractors
 Group:          system
@@ -158,6 +158,10 @@ This package contains various miners and metadata extractors for tracker.
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.1-1
+- new upstream release.
+- built with icu69.
+
 * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.0-1
 - new upstream release.
 

+ 5 - 1
t/tracker/tracker-vl.spec

@@ -5,7 +5,7 @@
 Summary: An object database, tag/metadata database, search tool and indexer
 Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
 Name: tracker
-Version: 3.1.0
+Version: 3.1.1
 Release: 1%{?_dist_release}%{?with_systemd:.systemd}
 Group: desktop-gnome,accesories
 Vendor: Project Vine
@@ -188,6 +188,10 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
+- new upstream release.
+- built with icu69.
+
 * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.0-1
 - new upstream release.
 

+ 7 - 2
v/vte3/vte3-vl.spec

@@ -7,7 +7,7 @@ Summary: An terminal emulator.
 Summary(ja): ターミナルエミュレータ
 Name: vte3
 Version: 0.64.0
-Release: 1%{?_dist_release}%{?with_systemd:.systemd}
+Release: 2%{?_dist_release}%{?with_systemd:.systemd}
 Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
@@ -24,7 +24,6 @@ BuildRequires: gtk3-devel
 BuildRequires: gobject-introspection-devel
 BuildRequires: ncurses-devel
 BuildRequires: gnutls-devel
-BuildRequires: vala-devel
 BuildRequires: vala
 BuildRequires: fribidi-devel
 BuildRequires: libicu-devel
@@ -147,6 +146,12 @@ rm -fr $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.64.0-2
+- rebuilt with icu69.
+
+* Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.64.0-1
+- new upstream release.
+
 * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.3-1
 - new upstream release.
 - dropped ldconfig scriptlets.

+ 7 - 1
w/webkitgtk4/webkitgtk4-vl.spec

@@ -11,7 +11,7 @@
 Summary:        GTK+ Web content engine library
 Name:           webkitgtk4
 Version:        2.32.0
-Release:        1%{?_dist_release}%{?with_systemd:.systemd}
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
 Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -19,6 +19,7 @@ Distribution:   Vine Linux
 License:        LGPLv2
 URL:            http://www.webkitgtk.org/
 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
+Patch1:         webkitgtk-2.32.0-icu69.patch
 
 %if %{with clang}
 BuildRequires:  clang
@@ -123,6 +124,7 @@ files for developing applications that use JavaScript engine from %{name}.
 
 %prep
 %setup -q -n webkitgtk-%{version}
+%autopatch -p1
 
 # Remove bundled libraries
 rm -rf Source/ThirdParty/leveldb/
@@ -231,6 +233,10 @@ export NINJA_STATUS="[%f/%t][%e] "
 
 
 %changelog
+* Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.32.0-2
+- rebuilt with icu69.
+- added Patch1 to build with icu69.
+
 * Thu Apr 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.32.0-1
 - new upstream release.
 - dropped ldconfig scriptlets.

+ 24 - 13
x/xfsprogs/xfsprogs-vl.spec

@@ -1,11 +1,11 @@
 Summary:	Utilities for managing the XFS filesystem
 Summary(ja):	XFS ファイルシステムを管理するためのユーティリティ
 Name:		xfsprogs
-Version:	5.6.0
-Release:        1%{?_dist_release}
-Group:		System Environment/Base
-Vendor:         Project Vine
-Distribution:   Vine Linux
+Version:	5.11.0
+Release:	1%{?_dist_release}
+Group:		admin-tools
+Vendor:		Project Vine
+Distribution:	Vine Linux
 
 # Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
 # in source, with no mention of version.
@@ -15,14 +15,15 @@ License:	GPL+ and LGPLv2+
 URL:		http://xfs.org/
 Source0:	https://mirrors.edge.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.xz
 
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:	libtool, gettext
 BuildRequires:	libattr-devel
 BuildRequires:  libblkid-devel
-BuildRequires:  libicu-devel
+BuildRequires:	libicu-devel
 BuildRequires:	libuuid-devel
-BuildRequires:  lvm2-devel
-BuildRequires:  readline-devel
+BuildRequires:	lvm2-devel
+BuildRequires:	readline-devel
+BuildRequires:	inih-devel
 
 %description
 A set of commands to use the XFS filesystem, including mkfs.xfs.
@@ -38,10 +39,11 @@ Refer to the documentation at http://oss.sgi.com/projects/xfs/
 for complete details.  This implementation is on-disk compatible
 with the IRIX version of XFS.
 
+
 %package devel
 Summary: XFS filesystem-specific static libraries and headers
 Summary(ja): XFS ファイルシステム特有の静的ライブラリとヘッダファイル
-Group: Development/Libraries
+Group: programming
 Requires: xfsprogs = %{version}-%{release}
 
 %description devel
@@ -52,9 +54,14 @@ You should install xfsprogs-devel if you want to develop XFS
 filesystem-specific programs,  If you install xfsprogs-devel, you'll
 also want to install xfsprogs.
 
+
+%debug_package
+
+
 %prep
 %setup -q
 
+
 %build
 # xfsprogs abuses libexecdir
 export tagname=CC DEBUG=-DNDEBUG
@@ -66,6 +73,7 @@ export tagname=CC DEBUG=-DNDEBUG
 
 make V=1 %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 make V=1 DIST_ROOT=$RPM_BUILD_ROOT install install-dev
@@ -82,12 +90,10 @@ rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/xfsprogs/
 
 %find_lang %{name}
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
 
 %files -f %{name}.lang
 %defattr(-,root,root)
@@ -109,6 +115,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/*
 
 %changelog
+* Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.11.0-1
+- new upstream release.
+- built with icu69.
+- dropped ldconfig scriptlets.
+
 * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.6.0-1
 - new upstream release.
 - built with icu67.