Browse Source

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@5297 ec354946-7b23-47d6-9f5a-488ba84defc7
munepi 10 years ago
parent
commit
b73c98ec38
24 changed files with 508 additions and 378 deletions
  1. 74 83
      nonfree/self-build-avidemux/avidemux-vl.spec
  2. 40 12
      nonfree/self-build-avidemux/self-build-avidemux-vl.spec
  3. 50 45
      nonfree/self-build-ffmpeg/ffmpeg-vl.spec
  4. 24 33
      nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec
  5. 12 11
      nonfree/self-build-ffmpeg2theora/ffmpeg2theora-vl.spec
  6. 6 4
      nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec
  7. 25 30
      nonfree/self-build-gpac/gpac-vl.spec
  8. 47 17
      nonfree/self-build-gpac/self-build-gpac-vl.spec
  9. 9 4
      nonfree/self-build-gstreamer-plugins-bad/gstreamer-plugins-bad-vl.spec
  10. 9 4
      nonfree/self-build-gstreamer-plugins-bad/self-build-gstreamer-plugins-bad-vl.spec
  11. 6 3
      nonfree/self-build-gstreamer-plugins-ffmpeg/gstreamer-plugins-ffmpeg-vl.spec
  12. 5 2
      nonfree/self-build-gstreamer-plugins-ffmpeg/self-build-gstreamer-plugins-ffmpeg-vl.spec
  13. 7 2
      nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec
  14. 9 3
      nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec
  15. 12 6
      nonfree/self-build-libdvbpsi/libdvbpsi-vl.spec
  16. 8 3
      nonfree/self-build-libdvbpsi/self-build-libdvbpsi-vl.spec
  17. 7 1
      nonfree/self-build-libquicktime/libquicktime-vl.spec
  18. 7 1
      nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec
  19. 71 43
      nonfree/self-build-mplayer/mplayer-vl.spec
  20. 34 38
      nonfree/self-build-mplayer/self-build-mplayer-vl.spec
  21. 4 1
      nonfree/self-build-vlc/self-build-vlc-vl.spec
  22. 4 1
      nonfree/self-build-vlc/vlc-vl.spec
  23. 17 9
      nonfree/self-build-x264/self-build-x264-vl.spec
  24. 21 22
      nonfree/self-build-x264/x264-vl.spec

+ 74 - 83
nonfree/self-build-avidemux/avidemux-vl.spec

@@ -1,8 +1,8 @@
 %define _pkgbuilddir %{_builddir}/%{name}_%{version}
 
 Name:           avidemux
-Version:        2.5.2
-Release:        5%{?_dist_release}
+Version:        2.5.5
+Release:        1%{?_dist_release}
 Summary:        Graphical video editing and transcoding tool
 
 Group:          Applications/Multimedia
@@ -16,21 +16,35 @@ Source2:        %{name}-qt.desktop
 Patch0:         2.5.0-coreImage-parallel-build.patch
 Patch1:         avidemux-2.5-pulseaudio-default.patch
 Patch2:         avidemux-2.4-qt4.patch
-Patch3:         avidemux-2.5-i18n.patch
-Patch4:         avidemux-2.5-libmpeg2enc-altivec.patch
-Patch5:         avidemux-2.5-checkfunction-includes.patch
-Patch6:         avidemux-2.5.1-tmplinktarget.patch
-Patch7:         avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch
+# Prevents avidemux from creating the symlinks for .so files, which we do below
+Patch3:         avidemux-2.5.3-tmplinktarget.patch
+# libADM_xvidRateCtl.so and libADM_vidEnc_pluginOptions.so are supposed to be
+# build statically according to upstream... Let's get them installed instead
+Patch4:         avidemux-2.5.3-mpeg2enc.patch
+Patch5:         avidemux-2.5.3-pluginlibs.patch
+# Patch8 obtained from http://lists.rpmfusion.org/pipermail/rpmfusion-developers/2010-October/008645.html
+#Patch6:         avidemux_2.5.4-ffmpeg-aac.patch
+Patch6:         avidemux_2.5.5-ffmpeg_aac.patch
+Patch7:         avidemux-2.5.5-gcc46_tmp_fix.patch
+# Patch needed for version of x264 in F15/rawhide.
+# Use system libraries
+Patch8:         avidemux-2.5.4-libass.patch
+Patch9:         avidemux-2.5.4-liba52.patch
+Patch10:        avidemux-2.5.4-libmad.patch
+Patch11:        avidemux-2.5.4-libtwolame.patch
+Patch12:        avidemux-2.5.5_fix_lav_audio_encoder.patch
+# Patch for ABI change in x264 115.
+Patch13:        avidemux-2.5.5-x264_i_to_b_open_gop.patch
+# Uses a header file not found in the standard package
+#Patch16:        avidemux-2.5.4-mpeg2enc.patch
 
 ## Vine customization patches
-Patch10:         avidemux-2.4.3-alsa-device-default.patch
-Patch11:         avidemux-2.5.2-no-qt4-ui.patch
+Patch50:         avidemux-2.5.2-no-qt4-ui.patch
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires:       %{name}-cli  = %{version}
-Requires:       %{name}-gui = %{version}
-Obsoletes:      %{name}-qt < 2.5.0
+Obsoletes:      %{name}-cli %{name}-gui %{name}-qt
+Obsoletes:      %{name}-devel <= 2.5.5
 
 # *-devel pacages provided by other self-build-* should only be listed
 # in self-build-%{name}.spec as PreReq.
@@ -90,6 +104,15 @@ BuildRequires:  libvorbis-devel >= 1.0.1
 # Finally...
 BuildRequires:  desktop-file-utils
 
+#gtk
+BuildRequires:  gtk2-devel >= 2.8.0
+BuildRequires:  cairo-devel
+
+%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
+BuildRequires:  qt4-devel >= 4.5.0-9
+BuildRequires:  qt4-designer
+%endif
+
 %description
 Avidemux is a free video editor designed for simple cutting, filtering and
 encoding tasks. It supports many file types, including AVI, DVD compatible
@@ -100,55 +123,19 @@ For compatability reasons, avidemux is a meta-package which installs the
 graphical, command line and plugin packages. If you want a smaller setup,
 you may selectively install one or more of the avidemux-* subpackages.
 
-%package cli
-Summary:        CLI for %{name}
-Group:          Applications/Multimedia
-Requires:       %{name} = %{version}-%{release}
-
-%description cli
-This package provides a command-line interface to editing videos with %{name}.
-
-%package gtk
-Summary:        GTK interface for %{name}
-Group:          Applications/Multimedia
-BuildRequires:  gtk2-devel >= 2.8.0
-BuildRequires:  cairo-devel
-# Slightly higher so it is default, but it can be avoided by installing
-# avidemux-qt directly or it can be removed later once avidemux-qt is installed
-Provides:       %{name}-gui = %{version}-%{release}.1
-Requires:       %{name} = %{version}-%{release}
-
-%description gtk
-This package provides the GTK graphical interface for %{name}.
-
-%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
-%package qt
-Summary:        Qt interface for %{name}
-Group:          Applications/Multimedia
-# 4.5.0-9 fixes a failure when there are duplicate translated strings
-# https://bugzilla.redhat.com/show_bug.cgi?id=491514
-BuildRequires:  qt4-devel >= 4.5.0-9
-BuildRequires:  qt4-designer
-Provides:       %{name}-gui = %{version}-%{release}
-Requires:       %{name} = %{version}-%{release}
-
-%description qt
-This package contains the Qt graphical interface for %{name}.
-%endif
-
-%package devel
-Summary:        Development files for %{name}
-Group:          Development/Libraries
-Requires:       %{name} = %{version}-%{release}
-
-%description devel
-This package contains files required to develop with or extend %{name}.
 
 %prep
 %__rm -rf $RPM_BUILD_ROOT
 
 %setup -q -n avidemux_%{version}
 
+# Remove unneeded external libraries
+rm -rf plugins/ADM_videoFilters/Ass/ADM_libAss
+rm -rf plugins/ADM_audioEncoders/twolame/ADM_libtwolame
+rm -rf plugins/ADM_audioDecoders/ADM_ad_mad/ADM_libMad
+rm -rf plugins/ADM_audioDecoders/ADM_ad_ac3/ADM_liba52
+#rm -rf plugins/ADM_videoEncoder/ADM_vidEnc_mpeg2enc/mpeg2enc
+
 # change hardcoded libdir paths
 %ifarch x86_64 ppc64
 %__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
@@ -158,14 +145,19 @@ This package contains files required to develop with or extend %{name}.
 %patch0 -p1 -b .parallel
 %patch1 -p1 -b .pulse
 #%patch2 -p1 -b .qt4
-%patch3 -p1 -b .i18n
-%patch4 -p1 -b .altivec
-%patch5 -p1 -b .cfincludes
-#%patch6 -p1 -b .tmplinktarget
-%patch7 -p1 -b .blind
-
-#%patch10 -p1 -b .alsa
-%{!?with_qt_ui:%patch11 -p1 -b .qt4}
+%patch3 -p1 -b .tmplinktarget
+%patch4 -p1 -b .mpeg2enc
+%patch5 -p1 -b .pluginlibs
+#%patch6 -p1 -b .ffmpegaac
+%patch7 -p1 -b .gcc46tmpfix
+%patch8 -p1 -b .libass
+%patch9 -p1 -b .liba52
+%patch10 -p1 -b .libmad
+%patch11 -p1 -b .libtwolame
+%patch12 -p1 -b .lavencode
+%patch13 -p1 -b .x264
+
+%{!?with_qt_ui:%patch50 -p1 -b .qt4}
 
 %build
 # Out of source build
@@ -173,6 +165,7 @@ This package contains files required to develop with or extend %{name}.
 %cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
        -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
        -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
+       -DUSE_SYSTEM_SPIDERMONKEY:BOOL=OFF \
        ..
 %__make %{?_smp_mflags}
 # Create the temp link directory manuall since otherwise it happens too early
@@ -190,18 +183,18 @@ find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
 
 %install
 %__rm -rf $RPM_BUILD_ROOT
-# Temporary workaround since the i18n files aren't being built
-%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/%{name}
 
 %__make -C build install DESTDIR=$RPM_BUILD_ROOT
 %__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
-# Install the build configuration for devel package
-%__install -d -m755 $RPM_BUILD_ROOT%{_includedir}
-%__install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
 
 # Find and remove all la files
 find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
 
+# Remove Windows-only executables
+# Must check this for new Linux-relevant files upon new avidemux releases
+%__rm -rf %{buildroot}%{_datadir}/ADM_addons/avsfilter
+%__rm -rf %{buildroot}%{_datadir}/ADM_addons/
+
 # Install .desktop shortcuts
 desktop-file-install --vendor vine \
     --dir $RPM_BUILD_ROOT%{_datadir}/applications \
@@ -211,9 +204,17 @@ desktop-file-install --vendor vine \
 desktop-file-install --vendor vine \
     --dir $RPM_BUILD_ROOT%{_datadir}/applications \
     %{SOURCE2}
+
+# Remove duplicated Qt translations
+rm -f %{buildroot}%{_datadir}/%{name}/i18n/qt_*.qm
+# find_lang.sh doesn't recognize this one, and there already is avidemux_sr.qm
+rm -f %{buildroot}%{_datadir}/%{name}/i18n/avidemux_sr@latin.qm
+
+# Qt-style translations
+%find_lang %{name} --with-qt --without-mo
+mv -f %{name}.lang %{name}-qt.lang
 %endif
 
-find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
 %find_lang %{name}
 
 %clean
@@ -229,30 +230,20 @@ find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
 %{_datadir}/ADM_scripts/
 %{_libdir}/libADM*
 %{_libdir}/ADM_plugins/
-
-%files cli
-%defattr(-,root,root,-)
 %{_bindir}/avidemux2_cli
-
-%files gtk
-%defattr(-,root,root,-)
 %{_bindir}/avidemux2_gtk
 %{_datadir}/applications/*gtk*.desktop
-
 %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
-%files qt
-%defattr(-,root,root,-)
-#{_datadir}/%{name}/i18n/
 %{_bindir}/avidemux2_qt4
 %{_datadir}/applications/*qt*.desktop
 %endif
 
-%files devel
-%defattr(-,root,root,-)
-%{_includedir}/ADM_coreConfig.h
-
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.5-1
+- new upstream release
+- Obsoletes: avidemux-cli avidemux-gui avidemux-qt avidemux-devel <= 2.5.5
+
 * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-5
 - dropped BuildRequires: esound-devel
 

+ 40 - 12
nonfree/self-build-avidemux/self-build-avidemux-vl.spec

@@ -1,7 +1,7 @@
 %define pkgname avidemux
 %define name    self-build-%{pkgname}
-%define version 2.5.2
-%define release 5%{?_dist_release}
+%define version 2.5.5
+%define release 1%{?_dist_release}
 
 %define source0path	%{pkgname}/%{pkgname}_%{version}.tar.gz
 
@@ -11,23 +11,42 @@ Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
 
-Obsoletes:      %{pkgname}-qt < 2.5.0
+Obsoletes:      avidemux-cli avidemux-gui avidemux-qt
+Obsoletes:      avidemux-devel <= 2.5.5
 
 Source0:	%{pkgname}-vl.spec
 Source1:        %{pkgname}-gtk.desktop
 Source2:        %{pkgname}-qt.desktop
 
+# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
+# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
 Source100:         2.5.0-coreImage-parallel-build.patch
 Source101:         avidemux-2.5-pulseaudio-default.patch
 Source102:         avidemux-2.4-qt4.patch
-Source103:         avidemux-2.5-i18n.patch
-Source104:         avidemux-2.5-libmpeg2enc-altivec.patch
-Source105:         avidemux-2.5-checkfunction-includes.patch
-Source106:         avidemux-2.5.1-tmplinktarget.patch
-Source107:         avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch
-
-Source110:         avidemux-2.4.3-alsa-device-default.patch
-Source111:         avidemux-2.5.2-no-qt4-ui.patch
+# Prevents avidemux from creating the symlinks for .so files, which we do below
+Source103:         avidemux-2.5.3-tmplinktarget.patch
+# libADM_xvidRateCtl.so and libADM_vidEnc_pluginOptions.so are supposed to be
+# build statically according to upstream... Let's get them installed instead
+Source104:         avidemux-2.5.3-mpeg2enc.patch
+Source105:         avidemux-2.5.3-pluginlibs.patch
+# Source108 obtained from http://lists.rpmfusion.org/pipermail/rpmfusion-developers/2010-October/008645.html
+#Source106:         avidemux_2.5.4-ffmpeg-aac.patch
+Source106:         avidemux_2.5.5-ffmpeg_aac.patch
+Source107:         avidemux-2.5.5-gcc46_tmp_fix.patch
+# Source10 needed for version of x264 in F15/rawhide.
+# Use system libraries
+Source108:         avidemux-2.5.4-libass.patch
+Source109:         avidemux-2.5.4-liba52.patch
+Source110:        avidemux-2.5.4-libmad.patch
+Source111:        avidemux-2.5.4-libtwolame.patch
+Source112:        avidemux-2.5.5_fix_lav_audio_encoder.patch
+# Source10 for ABI change in x264 115.
+Source113:        avidemux-2.5.5-x264_i_to_b_open_gop.patch
+# Uses a header file not found in the standard package
+#Source116:        avidemux-2.5.4-mpeg2enc.patch
+
+## Vine customization patches
+Source150:         avidemux-2.5.2-no-qt4-ui.patch
 
 License:	GPLv2+
 Group:		Restricted Software
@@ -150,8 +169,13 @@ Avidemux は簡単なカット,フィルターリング,エンコード作
 %{__install} -m 644 %{SOURCE105} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE106} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE107} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE108} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE109} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE110} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE113} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE150} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 
 
 %clean
@@ -159,13 +183,17 @@ Avidemux は簡単なカット,フィルターリング,エンコード作
 
 %posttrans
 /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
-    http://download{,2}.berlios.de/%{source0path} 3126000
+    http://download{,2}.berlios.de/%{source0path} 3922000
 
 %files
 %defattr(-,root,root)
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.5-1
+- new upstream release
+- Obsoletes: avidemux-cli avidemux-gui avidemux-qt avidemux-devel <= 2.5.5
+
 * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-5
 - dropped Requires(post): esound-devel
 

+ 50 - 45
nonfree/self-build-ffmpeg/ffmpeg-vl.spec

@@ -1,59 +1,56 @@
-#TODO: Build with openjpeg, opencore-amr
+#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
 #TODO: add make test to %%check section
 
 #% define svndate	20100625
-## available for v0.6 or lower
-%define with_libfaad 1
-
 %define with_faac 1
-
 %define with_vaapi 1
 %define with_libvpx 1
 
+%define use_prebuilt_man 1
+
 Summary:	Digital VCR and streaming server
 Name:		ffmpeg
-Version:	0.6.3
-Release:	3%{?svndate:.%svndate}%{?_dist_release}
+Version:	0.9
+Release:	1%{?svndate:.%svndate}%{?_dist_release}
 Source:		http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
 Source1:        %{name}-snapshot.sh
 
 # pre-built man files
-Source90:       ffmpeg.1.gz
-Source91:       ffplay.1.gz
-Source92:       ffserver.1.gz
-Source93:       ffprobe.1.gz
-
-# CVE-2011-3362
-# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=91d5da9321c52e8197fb14046ebb335f3e6ff4a0;hp=08ddfb77a1aff378345026ba49fea9fb93ff1e70
-Patch1:         ffmpeg-0.6.3-CVE-2011-3362.patch
-# CVE-2011-3973, CVE-2011-3974
-# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=bd968d260aef322fb32e254a3de0d2036c57bd56;hp=00c5cf4beb0e45e936544a5766b56e241ae03234
-Patch2:         ffmpeg-0.6.3-CVE-2011-3974.patch
-
-License:	GPLv2+
+%if %{use_prebuilt_man}
+#$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.9-doc.tar.xz ffmpeg-0.9/doc/*.html ffmpeg-0.9/doc/*.pod ffmpeg-0.9/doc/*.1
+Source90:       ffmpeg-%{version}-doc.tar.xz
+%endif
+
+%if 0%{?_with_amr:1}
+License:        GPLv3+
+%else
+License:        GPLv2+
+%endif
 Group:		Applications/Multimedia
 URL:		http://ffmpeg.org/
 
 BuildRequires:  bzip2-devel
+BuildRequires:  celt-devel
 ##BuildRequires:  dirac-devel
+BuildRequires:  freetype2-devel
 BuildRequires:	gsm-devel
 BuildRequires:	imlib2-devel
 BuildRequires:	libdc1394-devel
+BuildRequires:	libogg-devel
 BuildRequires:	libraw1394-devel
 BuildRequires:	librtmp-devel >= 2.3
 BuildRequires:	libtheora-devel
 %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
 BuildRequires:  libvdpau-devel
 BuildRequires:	libvorbis-devel
-%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
-%{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
+%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
+%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
 ##BuildRequires:  openjpeg-devel
 ##BuildRequires:  schroedinger-devel
 BuildRequires:	SDL-devel
 BuildRequires:  speex-devel
-##BuildRequires:	texi2html
+%{!?use_prebuilt_man:BuildRequires:	texi2html}
 BuildRequires:	zlib-devel 
-BuildRequires:	libogg-devel
 BuildRequires:	yasm
 # *-devel packages provided by other self-build-* should only be listed
 # in self-build-%{name}.spec as PreReq.
@@ -61,7 +58,6 @@ BuildRequires:	yasm
 #BuildRequires: faac-devel
 #BuildRequires: lame-devel
 #BuildRequires: libdca-devel
-#BuildRequires: faad2-devel
 #BuildRequires: x264-devel >= 0.0.0-15.20110322
 #BuildRequires: xvidcore-devel
 
@@ -104,10 +100,9 @@ This package contains development files for %{name}.
 
 %prep
 %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
-#% setup -q
-#%patch0 -p1 -b .textrel
-%patch1 -p1 -b .CVE-2011-3362
-%patch2 -p1 -b .CVE-2011-3974
+%if %{use_prebuilt_man}
+tar -C .. -xf %{SOURCE90}
+%endif
 
 %build
 %ifarch ppc
@@ -131,13 +126,14 @@ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
 %endif
     --enable-runtime-cpudetect \
     --extra-cflags="$RPM_OPT_FLAGS" \
-    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
+    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
     --enable-bzlib \
     --enable-zlib \
+    --enable-libcelt \
     --enable-libdc1394 \
     %{?_with_libdirac:--enable-libdirac} \
     %{?with_faac:--enable-libfaac --enable-nonfree} \
-    %{?with_libfaad:--enable-libfaad} \
+    --enable-libfreetype \
     --enable-libgsm \
     --enable-libmp3lame \
     %{?_with_openjpeg:--enable-libopenjpeg} \
@@ -156,26 +152,31 @@ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
     --disable-static \
     --enable-shared \
     --enable-gpl \
-    --disable-doc \
+    %{?use_prebuilt_man:--disable-doc} \
     --disable-debug \
     --disable-stripping \
     ;
 
-%{__make} %{?_smp_mflags}
-#% {__make}
-#%{__make} documentation
+%__make %{?_smp_mflags}
+
+%if %{!use_prebuilt_man}
+%__make documentation
+%endif
+
+%__make alltools
 
 
 %install
 %__make install DESTDIR=$RPM_BUILD_ROOT
 
-# ## install tool/qt-faststart
-# %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
+## install tool/qt-faststart
+%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
 
-## install man
+# ## install man
+%if %{!use_prebuilt_man}
 %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
-%__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
-    $RPM_BUILD_ROOT%{_mandir}/man1/
+%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
+%endif
 
 
 %clean
@@ -188,11 +189,13 @@ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
 %files
 %defattr(-,root,root,-)
 %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
+%{_bindir}/avconv
 %{_bindir}/ffmpeg
 %{_bindir}/ffplay
 %{_bindir}/ffprobe
 %{_bindir}/ffserver
-#%{_bindir}/qt-faststart
+%{_bindir}/qt-faststart
+%{_mandir}/man1/avconv.1*
 %{_mandir}/man1/ffmpeg.1*
 %{_mandir}/man1/ffplay.1*
 %{_mandir}/man1/ffprobe.1*
@@ -206,16 +209,18 @@ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
 
 %files devel
 %defattr(-,root,root,-)
-%doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
+%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
 %{_includedir}/ffmpeg
 %{_libdir}/pkgconfig/lib*.pc
 %{_libdir}/lib*.so
 
 
 %changelog
-* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
-- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
-  from git.videolan.org
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
+- new upstream release
+- enable CELT decoding via libcelt
+- enable FreeType support
+- drop faad2 support (dropped upstream)
 
 * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
 - change release to sync with self-build-ffmpeg-vl.spec

+ 24 - 33
nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec

@@ -1,44 +1,34 @@
-%define gpac_postinstall     \
+%global gpac_postinstall     \
     gpac_postinstall_sh=$(mktemp) && \
     rpm -q --scripts self-build-gpac | \
     /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
     /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
 
-%define pkgname ffmpeg
-%define name	self-build-%{pkgname}
-%define version 0.6.3
+%global pkgname ffmpeg
+%global name	self-build-%{pkgname}
+%global version 0.9
 #% define svndate	20110326
-%define release	3%{?svndate:.%svndate}%{?_dist_release}
+%global release	1%{?svndate:.%svndate}%{?_dist_release}
 
-%define sourceurl0	http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
+%global sourceurl0	http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
 
 ## available for v0.6 or lower
-%define with_libfaad 1
+%global with_libfaad 1
 
-%define with_faac 1
+%global with_faac 1
 
-%define with_vaapi 1
-%define with_libvpx 1
+%global with_vaapi 1
+%global with_libvpx 1
 
 Summary:	Package to automatically build %{pkgname} rpm package
 Summary(ja): 	%{pkgname} の rpm パッケージを自動作成するパッケージ
 Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
-Source0:	%{pkgname}-vl6.spec
+Source0:	%{pkgname}-vl.spec
 #Source1:	%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
 Source2:        %{pkgname}-snapshot.sh
-Source90:	ffmpeg.1.gz
-Source91:	ffplay.1.gz
-Source92:	ffserver.1.gz
-Source93:	ffprobe.1.gz
-
-# CVE-2011-3362
-# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=91d5da9321c52e8197fb14046ebb335f3e6ff4a0;hp=08ddfb77a1aff378345026ba49fea9fb93ff1e70
-Source101:         ffmpeg-0.6.3-CVE-2011-3362.patch
-# CVE-2011-3973, CVE-2011-3974
-# from http://git.videolan.org/?p=ffmpeg.git;a=patch;h=bd968d260aef322fb32e254a3de0d2036c57bd56;hp=00c5cf4beb0e45e936544a5766b56e241ae03234
-Source102:         ffmpeg-0.6.3-CVE-2011-3974.patch
+Source90:       ffmpeg-%{version}-doc.tar.xz
 
 License:	GPLv2+
 Group:		Restricted Software
@@ -48,6 +38,9 @@ Requires(post):		self-build-setup >= 0.9.9
 
 # (build)requies of target package.
 Requires(post):  bzip2-devel
+Requires(post):  celt-devel
+##Requires(post):  dirac-devel
+Requires(post):  freetype2-devel
 Requires(post):	gsm-devel
 Requires(post):	imlib2-devel
 Requires(post):	libdc1394-devel
@@ -57,8 +50,8 @@ Requires(post):	libtheora-devel
 %{?with_vaapi:Requires(post):	libva-devel >= 0.31.0}
 Requires(post):  libvdpau-devel
 Requires(post):	libvorbis-devel
-%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
-%{?_with_opencore_amr:Requires(post):  opencore-amr-devel}
+%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
+%{?_with_opencore_amr:Requires(post):  opencore-amr-devel vo-amrwbenc-devel}
 ##Requires(post):  openjpeg-devel
 ##Requires(post):  schroedinger-devel
 Requires(post):	SDL-devel
@@ -152,18 +145,14 @@ MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
 %{__rm} -rf ${RPM_BUILD_ROOT}
 %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
-    %{SOURCE101} %{SOURCE102} \
-    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 
 %clean
 %{__rm} -rf ${RPM_BUILD_ROOT}
 
 %posttrans
 #/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
-/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl6.spec "%{sourceurl0}" 77000
+/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 77000
 /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
                                  %{pkgname}-libs-%{version}-%{release} \
                                  %{pkgname}-devel-%{version}-%{release}
@@ -194,9 +183,11 @@ Rebuild_gpac_$LOCALE
 %{_datadir}/%{name}
 
 %changelog
-* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
-- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
-  from git.videolan.org
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
+- new upstream release
+- enable CELT decoding via libcelt
+- enable FreeType support
+- drop faad2 support (dropped upstream)
 
 * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
 - added BuildArch: noarch

+ 12 - 11
nonfree/self-build-ffmpeg2theora/ffmpeg2theora-vl.spec

@@ -1,14 +1,10 @@
-%define pkg_version	0.27
-%define pkg_release	1%{?_dist_release}
-
+Name:		ffmpeg2theora
+Version:	0.28
+Release: 	1%{?_dist_release}
 Summary:	Convert any file that ffmpeg can decode to theora
 Summary(ja): 	ffmpeg がデコード可能なファイルを theora に変換するツール
-Name:		ffmpeg2theora
-Version:	%{pkg_version}
-Release: 	%{pkg_release}
 Source0:	http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{name}-%{version}.tar.bz2
-Patch0:         ffmpeg2theora-0.27-ldflags.patch
-License:	GPL
+License:	GPLv2+
 Group:		Applications/Multimedia
 URL:		http://www.v2v.cc/~j/ffmpeg2theora/
 
@@ -24,9 +20,11 @@ BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 
 
 %description
-with ffmpeg2theora you can convert any file that ffmpeg can
+With ffmpeg2theora you can convert any file that ffmpeg can
 decode to theora. right now the settings are hardcoded into
-the binary. 
+the binary. the idea is to provide ffmpeg2theora as a binary
+along sites like v2v.cc to enable as many people as possible
+to encode video clips with the same settings.
 
 %description -l ja
 ffmpeg2theora を使えば ffmpeg がデコードできるどんな種類のファイル
@@ -37,7 +35,6 @@ ffmpeg2theora を使えば ffmpeg がデコードできるどんな種類のフ
 %prep
 
 %setup -q
-%patch0 -p1 -b .ldflags
 
 
 %build
@@ -63,6 +60,10 @@ scons install destdir=$RPM_BUILD_ROOT prefix=%{_prefix}
 %{_mandir}/man1/ffmpeg2theora.1.gz
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
+- new upstream release
+- License: GPLv2+
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
 - new upstream release
 - fixed the location of %%Source0

+ 6 - 4
nonfree/self-build-ffmpeg2theora/self-build-ffmpeg2theora-vl.spec

@@ -1,6 +1,6 @@
 %define pkgname ffmpeg2theora
 %define name	self-build-%{pkgname}
-%define version	0.27
+%define version	0.28
 %define release	1%{?_dist_release}
 
 %define sourceurl	http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
@@ -11,8 +11,7 @@ Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
 Source0:	%{pkgname}-vl.spec
-Source100:	ffmpeg2theora-0.27-ldflags.patch
-License:	GPL
+License:	GPLv2+
 Group:		Restricted Software
 
 Requires(post):		self-build-setup >= 0.9.9
@@ -99,7 +98,6 @@ ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
 %{__rm} -rf ${RPM_BUILD_ROOT}
 %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 
 
 %clean
@@ -114,6 +112,10 @@ ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
+- new upstream release
+- License: GPLv2+
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
 - new upstream release
 - fixed the location of %%sourceurl

+ 25 - 30
nonfree/self-build-gpac/gpac-vl.spec

@@ -1,24 +1,21 @@
+%define svndate  20111217
+
 %define with_static   1
 
 Name:        gpac
 Summary:     MPEG-4 multimedia framework
-Version:     0.4.5
-Release:     11%{?_dist_release}
+Version:     0.4.6
+Release:     1%{?svndate:.svn%svndate}%{?_dist_release}
 License:     LGPLv2+
 Group:       System Environment/Libraries
 URL:         http://gpac.sourceforge.net/
-Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
-#Source0:     http://rpms.kwizart.net/fedora/SOURCE/gpac-%{version}-repack.tar.bz2
-#Source9:     gpac-snapshot.sh
-Patch0:      gpac-0.4.5-makefix.patch
-Patch1:      gpac-0.4.5-soname.patch
-Patch2:      gpac-0.4.5-amr.patch
-Patch3:      gpac-0.4.5-lib64.patch
-Patch4:      gpac-0.4.5-system_openjpeg.patch
-Patch6:      gpac-0.4.5-shared_sggen.patch
-Patch7:      gpac-0.4.5-libxml2.patch
-Patch8:      gpac-ppc64.patch
-Patch9:      gpac-0.4.5-ffmpeg.patch
+#Source0:     http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
+Source0:     gpac-%{svndate}.tar.bz2
+Source9:     gpac-snapshot-vine.sh
+
+Patch1:      gpac-0.4.6_15-soname.patch
+Patch2:      gpac-0.4.6-amr.patch
+Patch5:      gpac-0.4.6-js_cflags.patch
 
 BuildRoot:   %{_tmppath}/%{name}-%{version}-%{release}-root
 
@@ -100,28 +97,15 @@ Static library for gpac.
 ## remove extra_libs directory
 %__rm -rf extra_libs
 
-%patch0 -p1 -b .makefix
 %patch1 -p1 -b .soname
 %patch2 -p1 -b .amr
-%ifarch x86_64
-%patch3 -p1 -b .lib64
-%endif
-#%patch4 -p1 -b .openjpeg
-%patch6 -p1 -b .shared
-%patch7 -p1 -b .libxml2
-%patch8 -p1 -b .ppc64
-%patch9 -p1 -b .ffmpeg
+%patch5 -p1 -b .jscflags
 
 ## kwizart - enable dynamic mode - hardcoded with patch2
 # define SONAME number from the first number of gpac version.
 #define soname libgpac.so.0
 #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
 
-# # Update doxygen
-# pushd doc
-# doxygen -u
-# popd
-
 # Fix encoding warnings
 %__cp -p Changelog Changelog.origine
 iconv -f ISO-8859-1 -t UTF8 Changelog.origine >  Changelog
@@ -146,9 +130,10 @@ chmod +x configure
     --disable-wx \
     --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
     --disable-oss-audio \
+    %{?_with_amr:--enable-amr} \
     --use-js=no \
-    --use-openjpeg=local \
     ;
+    # --use-openjpeg=local \
 
 # Parallele build will fail
 %__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC" 
@@ -165,8 +150,14 @@ chmod +x configure
 %__rm -rf $RPM_BUILD_ROOT
 %__make DESTDIR=$RPM_BUILD_ROOT install install-lib
 
+#hack
+%if %{_lib} == "lib64"
+  %__mv $RPM_BUILD_ROOT%{_prefix}/lib $RPM_BUILD_ROOT%{_libdir}
+%endif
+
 ## kwizart - rpmlint gpac no-ldconfig-symlink
-%__ln_s -f libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
+#%__ln_s -f libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
+%__ln_s -f libgpac.so.%{version}-DEV $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
 %__ln_s -f libgpac.so.0 $RPM_BUILD_ROOT%{_libdir}/libgpac.so
 
 #Install generated sggen binaries
@@ -217,6 +208,10 @@ done
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
+- update snapshot svn20111217
+- removed upstreamed/obsolated patches
+
 * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
 - rebuilt with internal openjpeg
   - added --use-openjpeg=local in configure options

+ 47 - 17
nonfree/self-build-gpac/self-build-gpac-vl.spec

@@ -1,9 +1,11 @@
+%define svndate  20111217
+
 %define pkgname gpac
 %define name	self-build-%{pkgname}
-%define version 0.4.5
-%define release	11%{?_dist_release}
+%define version 0.4.6
+%define release	1%{?svndate:.svn%svndate}%{?_dist_release}
 
-%define sourceurl0	http://prdownloads.sourceforge.net/gpac/%{pkgname}-%{version}.tar.gz
+#% define sourceurl0	http://prdownloads.sourceforge.net/gpac/%{pkgname}-%{version}.tar.gz
 #% define sourceurl0	http://dl.sourceforge.net/sourceforge/gpac/%{pkgname}-%{version}.tar.gz
 
 Summary:	Package to automatically build %{pkgname} rpm package
@@ -13,20 +15,17 @@ Version:	%{version}
 Release: 	%{release}
 Source0:	%{pkgname}-vl.spec
 
-Source100:      gpac-0.4.5-makefix.patch
-Source101:      gpac-0.4.5-soname.patch
-Source102:      gpac-0.4.5-amr.patch
-Source103:      gpac-0.4.5-lib64.patch
-Source104:      gpac-0.4.5-system_openjpeg.patch
-Source106:      gpac-0.4.5-shared_sggen.patch
-Source107:      gpac-0.4.5-libxml2.patch
-Source108:      gpac-ppc64.patch
-Source109:      gpac-0.4.5-ffmpeg.patch
+Source9:     gpac-snapshot-vine.sh
+
+Source101:      gpac-0.4.6_15-soname.patch
+Source102:      gpac-0.4.6-amr.patch
+Source105:      gpac-0.4.6-js_cflags.patch
 
 License:	LGPLv2+
 Group:		Restricted Software
 
 Requires(post):		self-build-setup >= 0.9.9
+Requires(post):		subversion
 
 Requires(post):  ImageMagick
 Requires(post):  SDL-devel
@@ -38,7 +37,7 @@ Requires(post):  libjpeg-devel
 Requires(post):  libpng-devel >= 1.2.5
 Requires(post):  libxml2-devel
 Requires(post):  openssl-devel
-Requires(post):  openjpeg-devel
+#Requires(post):  openjpeg-devel
 Requires(post):  pulseaudio-libs-devel
 Requires(post):  zlib-devel
 Requires(post):  libogg-devel libvorbis-devel libtheora-devel
@@ -146,26 +145,57 @@ for MP4 and 3GPP(2) files and many tools for scene descriptions
 %{__rm} -rf ${RPM_BUILD_ROOT}
 %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 \
-    %{SOURCE100} %{SOURCE101} %{SOURCE102} %{SOURCE103} %{SOURCE104} \
-    %{SOURCE106} %{SOURCE107} %{SOURCE108} %{SOURCE109} \
+%{__install} -m 644 %{SOURCE9} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE101} %{SOURCE102} %{SOURCE105} \
     ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 
 %clean
 %{__rm} -rf ${RPM_BUILD_ROOT}
 
 %posttrans
-/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 169000
+## svn checkout
+# set locale
+case $LANG in
+    ja*)LOCALE=ja ;;
+    *) LOCALE=C ;;
+esac
+
+GetSrc_C(){
+    echo -n "     "
+    echo "Download source file with Subversion..."
+}
+
+GetSrc_ja(){
+    echo -n "     "
+    echo "Subversion を用いてソースファイルをダウンロードしています..."
+}
+
+GetSrc_$LOCALE
+
+# svn checkout
+. /etc/self-build.conf
+(cd $TEMP_DIR
+su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
+%__mv %{pkgname}-%{svndate}.tar.bz2 %{_datadir}/%{name}/ || exit 1
+)
+
+/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 169000
 /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
                                  %{pkgname}-libs-%{version}-%{release} \
                                  %{pkgname}-devel-%{version}-%{release} \
                                  %{pkgname}-devel-static-%{version}-%{release}
 
+
 %files
 %defattr(-,root,root)
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
+- update snapshot svn20111217
+- removed upstreamed/obsolated patches
+- added Requires(post): subversion
+
 * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
 - rebuilt with internal openjpeg
 

+ 9 - 4
nonfree/self-build-gstreamer-plugins-bad/gstreamer-plugins-bad-vl.spec

@@ -1,13 +1,13 @@
 %define majorminor   0.10
 %define gstreamer    gstreamer
 
-%define gst_minver   0.10.22.1
-%define gstpb_minver 0.10.22.1
+%define gst_minver   0.10.33
+%define gstpb_minver 0.10.33
 
 Summary: GStreamer streaming media framework "bad" plug-ins
 Name: gstreamer-plugins-bad
-Version: 0.10.21
-Release: 2%{?_dist_release}
+Version: 0.10.22
+Release: 1%{?_dist_release}
 # The freeze and nfs plugins are LGPLv2 (only)
 License: LGPLv2+
 Group: Applications/Multimedia
@@ -62,6 +62,7 @@ BuildRequires: openssl-devel
 BuildRequires: twolame-devel
 BuildRequires: libvdpau-devel
 BuildRequires: librtmp-devel
+BuildRequires: libvpx-devel
 
 %description
 GStreamer is a streaming media framework, based on graphs of elements which
@@ -256,6 +257,10 @@ enough quality.
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
+- new upstream release
+- added BuildRequires: libvpx-devel
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
 - s/self-build-libdvdnav/libdvdnav/
 

+ 9 - 4
nonfree/self-build-gstreamer-plugins-bad/self-build-gstreamer-plugins-bad-vl.spec

@@ -1,10 +1,10 @@
 %define pkgname gstreamer-plugins-bad
 %define majorminor   0.10
 %define gstreamer    gstreamer
-%define gst_minver   0.10.22.1
-%define gstpb_minver 0.10.22.1
-%define _gst_ver     0.10.21
-%define release	2%{?_dist_release}
+%define gst_minver   0.10.33
+%define gstpb_minver 0.10.33
+%define _gst_ver     0.10.22
+%define release	1%{?_dist_release}
 
 %define sourceurl	http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{_gst_ver}.tar.bz2
 
@@ -68,6 +68,7 @@ Requires(post): openssl-devel
 Requires(post): twolame-devel
 Requires(post): libvdpau-devel
 Requires(post): librtmp-devel
+Requires(post): libvpx-devel
 
 
 BuildArch:	noarch
@@ -166,6 +167,10 @@ gstreamer-plugins-bad は GStreamer ストリーミングメディア
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
+- new upstream release
+- added Requires(post): libvpx-devel
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
 - s/self-build-libdvdnav/libdvdnav/
 

+ 6 - 3
nonfree/self-build-gstreamer-plugins-ffmpeg/gstreamer-plugins-ffmpeg-vl.spec

@@ -1,8 +1,8 @@
 %define major		0.10
 
 Name:           gstreamer-plugins-ffmpeg
-Version:        0.10.11
-Release:        3%{?_dist_release}
+Version:        0.10.12
+Release:        1%{?_dist_release}
 Summary:        GStreamer FFmpeg-based plug-ins
 Group:		System Environment/Libraries
 # the ffmpeg plugin is LGPL, the postproc plugin is GPL
@@ -19,7 +19,7 @@ BuildRequires:  bzip2-devel
 ## Use internal ffmpeg
 # Don't require ffmpeg-devel because they are provided by 
 # self-build-ffmpeg package.
-# BuildRequires:  ffmpeg-devel
+# BuildRequires:  ffmpeg-devel >= 0.8
 
 %description
 GStreamer is a streaming media framework, based on graphs of filters which
@@ -67,6 +67,9 @@ This package provides FFmpeg-based GStreamer plug-ins.
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
+- new upstream release
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
 - dropped --with-system-ffmpeg in configure options
 

+ 5 - 2
nonfree/self-build-gstreamer-plugins-ffmpeg/self-build-gstreamer-plugins-ffmpeg-vl.spec

@@ -1,7 +1,7 @@
 %define pkgname gstreamer-plugins-ffmpeg
 %define name    self-build-%{pkgname}
-%define version 0.10.11
-%define release 3%{?_dist_release}
+%define version 0.10.12
+%define release 1%{?_dist_release}
 
 %define sourceurl0	http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-%{version}.tar.bz2
 
@@ -128,6 +128,9 @@ GStreamer はメディアデータ操作用の filter graph をベースにし
 %{_datadir}/%{name}/*
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
+- new upstream release
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.11-3
 - dropped --with-system-ffmpeg in configure options 
   (gstreamer-plugins-ffmpeg-vl.spec)

+ 7 - 2
nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec

@@ -1,8 +1,8 @@
 ## TODO: build with opencore-amr
 
 %define major		0.10
-%define _gst_ver	0.10.17
-%define _gstpb_ver	0.10.3
+%define _gst_ver	0.10.18
+%define _gstpb_ver	0.10.26
 %define pkg_release	1%{?_dist_release}
 
 Summary:	GStreamer Streaming-media framework ugly plugins
@@ -132,6 +132,11 @@ GStreamer はメディアデータ操作用の filter graph をベースにし
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
+- new upstream relase
+- built with new x264
+- License: LGPLv2+
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
 - new upstream relase
 

+ 9 - 3
nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec

@@ -1,6 +1,7 @@
 %define pkgname gstreamer-plugins-ugly
-%define _gst_ver	0.10.17
-%define _gstpb_ver	0.10.3
+%define major		0.10
+%define _gst_ver	0.10.18
+%define _gstpb_ver	0.10.26
 %define release	1%{?_dist_release}
 
 %define sourceurl	http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{_gst_ver}.tar.bz2
@@ -12,7 +13,7 @@ Version:	%{_gst_ver}
 Release: 	%{release}
 Source0:	%{pkgname}-vl.spec
 Source101:	gstreamer-plugins-ugly-x264.patch
-License:	LGPL
+License:	LGPLv2+
 Group:		Restricted Software
 
 Requires(post):		self-build-setup >= 0.9.9
@@ -129,6 +130,11 @@ gstreamer-plugins-ugly は GStreamer ストリーミングメディア
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
+- new upstream relase
+- built with new x264
+- License: LGPLv2+
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
 - new upstream relase
 

+ 12 - 6
nonfree/self-build-libdvbpsi/libdvbpsi-vl.spec

@@ -1,14 +1,15 @@
 ## -*- coding: utf-8-unix -*-
 Summary: 	Library for MPEG TS and DVB PSI tables decoding and generation
 Name: 		libdvbpsi
-Version: 	0.1.7
+Version: 	0.2.2
 Release: 	1%{?_dist_release}
-License: 	GPLv2+
+License: 	LGPLv2+
 Group: 		System Environment/Libraries
 URL: 		http://www.videolan.org/developers/libdvbpsi.html
 Source0: 	http://download.videolan.org/pub/libdvbpsi/%{version}/%{name}-%{version}.tar.bz2
 BuildRoot: 	%{_tmppath}/%{name}-%{version}-root
-BuildRequires:	graphviz doxygen
+BuildRequires:	graphviz
+#BuildRequires:	doxygen
 
 %description
 libdvbpsi is a very simple and fully portable library designed for
@@ -25,7 +26,7 @@ MPEG TS and DVB PSI table decoding and generation.
 This package contains development files for %{name}
 
 %prep
-%setup -q -n %{name}-%{version}
+%setup -q
 
 
 %build
@@ -33,7 +34,7 @@ This package contains development files for %{name}
     --disable-dependency-tracking \
     --disable-static
 %__make %{?_smp_mflags}
-%__make doc
+#%__make doc
 
 
 %install
@@ -56,13 +57,18 @@ This package contains development files for %{name}
 
 %files devel
 %defattr(-,root,root,-)
-%doc doc/doxygen/html
+#%doc doc/doxygen/html
 %{_includedir}/dvbpsi/
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/libdvbpsi.pc
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.2-1
+- updated to 0.2.2
+- Switch to LGPLv2+
+- dropped BuildRequires: doxygen
+
 * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.7-1
 - updated to 0.1.7
 

+ 8 - 3
nonfree/self-build-libdvbpsi/self-build-libdvbpsi-vl.spec

@@ -1,6 +1,6 @@
 %define pkgname libdvbpsi
 %define name	self-build-%{pkgname}
-%define version 0.1.7
+%define version 0.2.2
 %define release	1%{?_dist_release}
 
 %define sourceurl0	http://download.videolan.org/pub/libdvbpsi/%{version}/%{pkgname}-%{version}.tar.bz2
@@ -12,14 +12,14 @@ Version:	%{version}
 Release: 	%{release}
 Source0:	%{pkgname}-vl.spec
 
-License:	GPLv2+
+License:	LGPLv2+
 Group:		Restricted Software
 
 # Requires(posttrans) not yet implemented. So we use (post) instead.
 Requires(post):		self-build-setup >= 0.9.9
 
 Requires(post):		graphviz
-Requires(post):		doxygen
+#Requires(post):	doxygen
 
 BuildArch:	noarch
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
@@ -109,6 +109,11 @@ libdvbpsi は MPEG TS と DVB PSI テーブル復号と生成のために設計
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.2-1
+- updated to 0.2.2
+- Switch to LGPLv2+
+- dropped BuildRequires: doxygen
+
 * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.7-1
 - updated to 0.1.7
 

+ 7 - 1
nonfree/self-build-libquicktime/libquicktime-vl.spec

@@ -1,5 +1,5 @@
 Name:            libquicktime
-Version:         1.2.2
+Version:         1.2.3
 Release:         2%{?_dist_release}
 License:         LGPLv2+
 Group:           System Environment/Libraries
@@ -165,6 +165,12 @@ find $RPM_BUILD_ROOT%{_libdir} -type f -a -name \*.la -exec %__rm -f {} \;
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-2
+- rebuilt with new x264 (ABI 0.119) and ffmpeg (0.9.x)
+
+* Thu Dec 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
+- new upstream release
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
 - rebuilt
 

+ 7 - 1
nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec

@@ -1,6 +1,6 @@
 %define pkgname libquicktime
 %define name	self-build-%{pkgname}
-%define version 1.2.2
+%define version 1.2.3
 %define release	2%{?_dist_release}
 
 %define sourceurl0	http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
@@ -147,6 +147,12 @@ libquicktime は quicktime4linux と互換性を持ったソースです。
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-2
+- rebuilt with new x264 (ABI 0.119) and ffmpeg (0.9.x)
+
+* Thu Dec 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
+- new upstream release
+
 * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
 - rebuilt
 

+ 71 - 43
nonfree/self-build-mplayer/mplayer-vl.spec

@@ -1,17 +1,19 @@
-%define with_vaapi 1
-%define with_libvpx 1
+%global with_faac 1
+%global with_vaapi 1
+%global with_libvpx 1
 
-%define name	mplayer
-%define version	1.0
-%define extver	rc4
-%define release	44%{?extver:.%{extver}}%{?_dist_release}
-%define svndate  20100709
-#% define release	40.%{svndate}%{?_dist_release}
+# define with_ffmpeg 1
+
+%global name	mplayer
+%global version	1.0
+# define extver	rc4
+%global svndate  20111210
+%global release	45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
 
 # define dvbappver 0.95
 
-%define ttfontdir   /usr/share/fonts
-%define ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
+%global ttfontdir   /usr/share/fonts
+%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
                     TrueType-sazanami-gothic/sazanami-gothic
 
 Summary:	The Movie Player
@@ -19,8 +21,8 @@ Summary(ja): 	動画プレイヤー
 Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
-Source0:	http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
-#Source0:	mplayer-export-%{svndate}.tar.bz2
+#Source0:	http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
+Source0:	mplayer-export-%{svndate}.tar.xz
 Source1:	http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
 Source10:       mplayer-snapshot-vine.sh
 
@@ -31,12 +33,13 @@ Source10:       mplayer-snapshot-vine.sh
 # Source101: http://2sen.dip.jp/cgi-bin/dtvup/source/up0658.zip
 
 #Patch2:         %{name}-config.patch
-Patch2:         %{name}-config-20100709-vine.patch
+Patch2:         %{name}-config-20111217-vine.patch
 Patch8:         %{name}-manlinks.patch
 Patch14:        %{name}-nodvdcss.patch
+Patch18:        %{name}-ffmpeg.patch
 
 ## Vine
-Patch50:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
+# Patch50:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
 # Patch101:      mplayer-1.0rc4-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
 # Patch102:      mplayer-1.0rc4-0002-add-support-for-audio-channel-reconfiguration.patch
 # Patch103:      mplayer-1.0rc4-0003-add-support-for-dual-mono-auto-selection-and-switchi.patch
@@ -81,7 +84,7 @@ BuildRequires:  speex-devel >= 1.1
 BuildRequires:  libvdpau-devel
 BuildRequires:	libvorbis-devel
 %if %{?_dist_release} != "vl5"
-%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
+%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
 %endif
 BuildRequires:  lzo-devel >= 2
 BuildRequires:  pulseaudio-lib-devel
@@ -95,13 +98,11 @@ BuildRequires:	zlib-devel
 # in self-build-%{name}.spec as PreReq.
 ##Requires:	self-build-mplayer-codecs
 ##BuildRequires:	self-build-libdvdcss
-##BuildRequires:  self-build-faac
 ##BuildRequires:  self-build-lame
 ##BuildRequires:  self-build-libdca
 ##BuildRequires:  self-build-x264 >= 0.0.0-15.20110322
 ##BuildRequires:  self-build-xvidcore >= 0.9.2
-##BuildRequires:  self-build-faad2 >= 2.6
-##BuildRequires:  self-build-libmad
+##BuildRequires:  self-build-faad2 >= 2.6.1
 ##BuildRequires:  self-build-libmpeg2
 
 Requires:	TrueType-vlgothic
@@ -130,7 +131,8 @@ using those new codecs.
 
 %description -l ja
 MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
-またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
+またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
+で再生できます。
 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
 多くの操作は字幕と同様に、
 オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
@@ -147,14 +149,13 @@ MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフ
 
 
 %prep
-%setup -q -n MPlayer-%{version}%{extver}
-#%setup -q -n mplayer-export-%{svndate}
+#%setup -q -n MPlayer-%{version}%{extver}
+%setup -q -n mplayer-export-%{svndate}
 
-%patch2 -p1 -b .config
+%patch2 -p1 -b .vine
 %patch8 -p1 -b .manlinks
 %patch14 -p1 -b .nodvdcss
-
-%patch50 -p1 -b .x11
+%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
 
 # ## apply the DVB app. patches
 # unzip %{SOURCE100}
@@ -179,36 +180,41 @@ MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフ
 %build
 ./configure \
     --prefix=%{_prefix} \
+    --bindir=%{_bindir} \
+    --datadir=%{_datadir}/mplayer \
+    --mandir=%{_mandir} \
     --confdir=%{_sysconfdir}/mplayer \
-    --enable-runtime-cpudetection \
-    --extra-cflags="$RPM_OPT_FLAGS" \
-    --disable-libdvdcss-internal \
-    --disable-dvdread-internal \
-    --enable-dvdread \
-    --enable-dvdnav \
+    --libdir=%{_libdir} \
     \
-    --disable-faac-lavc \
-    --disable-mp3lame-lavc \
-    --disable-x264-lavc \
+    --extra-cflags="$RPM_OPT_FLAGS" \
+    --language=ja,en \
+    --enable-joystick \
+    --enable-gui --enable-menu \
+    --enable-radio --enable-radio-capture \
+    --enable-runtime-cpudetection \
     \
-    --disable-faad-internal \
+    --disable-dvdread-internal \
+    --disable-libdvdcss-internal \
+    --disable-nemesi \
     \
+    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
+    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
+    %{!?with_faac:--disable-faac} \
+    --disable-libmpeg2-internal \
     --disable-libopenjpeg \
     \
-    --enable-vdpau \
-    \
     --disable-bitmap-font \
+    --disable-dga1 --disable-dga2 \
+    --disable-directfb \
+    --disable-svga \
     --disable-termcap \
     --enable-xvmc \
     --with-xvmclib=XvMCW \
     \
-    --enable-largefiles \
-    --enable-menu \
-    --enable-gui \
-    --language=ja,en \
+    --disable-arts --disable-esd --disable-jack --disable-openal \
     ;
 
-%{__make} %{?_smp_mflags}
+%{__make} V=1 %{?_smp_mflags}
 
 %install
 %{__rm} -rf ${RPM_BUILD_ROOT}
@@ -228,6 +234,11 @@ MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフ
 %{__install} -pm 644 etc/{input,menu,codecs}.conf \
     ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
 
+# Icons
+install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
+%__mv $RPM_BUILD_ROOT%{_datadir}/pixmaps/mplayer.png \
+    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
+
 # install default skin
 %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
 pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
@@ -263,10 +274,24 @@ done
 %clean
 %{__rm} -rf ${RPM_BUILD_ROOT}
 
+%post
+touch --no-create %{_datadir}/icons/hicolor
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
+fi 
+%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
+
+%postun
+%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
+touch --no-create %{_datadir}/icons/hicolor
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
+fi || :
+
 
 %files
 %defattr(-,root,root)
-%doc AUTHORS Changelog Copyright LICENSE README
+#%doc AUTHORS Changelog Copyright LICENSE README
 %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
 %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
 %config(noreplace) %{_sysconfdir}/mplayer/input.conf
@@ -278,7 +303,7 @@ done
 %{_datadir}/mplayer/skins/default
 %{_datadir}/mplayer/subfont.ttf
 %{_datadir}/applications/mplayer.desktop
-%{_datadir}/pixmaps/mplayer.xpm
+%{_datadir}/icons/hicolor/48x48/apps/mplayer.png
 %{_mandir}/man1/mplayer.1*
 %{_mandir}/man1/mencoder.1*
 ## TOOLS
@@ -297,6 +322,9 @@ done
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
+- updated snapshot 20111217 (with ffmpeg 0.9)
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
 - s/self-build-libdvdnav/libdvdnav/
 

+ 34 - 38
nonfree/self-build-mplayer/self-build-mplayer-vl.spec

@@ -1,16 +1,18 @@
-%define pkgname mplayer
-%define name	self-build-%{pkgname}
-%define version 1.0
-%define extver	rc4
-%define release	44%{?extver:.%{extver}}%{?_dist_release}
-%define svndate  20100709
-#% define release	40.%{svndate}%{?_dist_release}
+%global with_faac 1
+%global with_vaapi 1
+%global with_libvpx 1
 
-%define source0path	MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
-%define source1path	MPlayer/skins/Blue-1.8.tar.bz2
+# define with_ffmpeg 1
 
-%define with_vaapi 1
-%define with_libvpx 1
+%global pkgname mplayer
+%global name	self-build-%{pkgname}
+%global version 1.0
+#% global extver	rc4
+%global svndate  20111210
+%global release	45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
+
+%global source0path	MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
+%global source1path	MPlayer/skins/Blue-1.8.tar.bz2
 
 Summary:	Package to automatically build %{pkgname} rpm package
 Summary(ja): 	%{pkgname} の rpm パッケージを自動作成するパッケージ
@@ -18,15 +20,13 @@ Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
 Source0:	%{pkgname}-vl.spec
-Source1:	%{pkgname}-snapshot-vine.sh
-
-#Source11:	%{pkgname}-export-%{svndate}.tar.bz2
-#Source12:	Blue-1.7.tar.bz2
+Source10:	%{pkgname}-snapshot-vine.sh
 
 #Source102:        %{pkgname}-config.patch
-Source102:        %{pkgname}-config-20100709-vine.patch
+Source102:        %{pkgname}-config-20111217-vine.patch
 Source108:        %{pkgname}-manlinks.patch
 Source114:        %{pkgname}-nodvdcss.patch
+Source118:        %{pkgname}-ffmpeg.patch
 
 Source150:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
 
@@ -69,7 +69,7 @@ Requires(post):  speex-devel >= 1.1
 Requires(post):  libvdpau-devel
 Requires(post):	libvorbis-devel
 %if %{?_dist_release} != "vl5"
-%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
+%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.6}
 %endif
 Requires(post):  lzo-devel >= 2
 Requires(post):  pulseaudio-lib-devel
@@ -82,12 +82,12 @@ Requires(post):	zlib-devel
 Requires(post):		self-build-mplayer-codecs
 Requires(post):		self-build-libdvdcss
 Requires(post):		self-build-faac
-Requires(post):		self-build-faad2 >= 2.6
+Requires(post):		self-build-faad2 >= 2.6.1
 Requires(post):		self-build-lame
 Requires(post):		self-build-libdca
 Requires(post):		self-build-libmad
 %if %{?_dist_release} != "vl5"
-Requires(post):	self-build-x264 >= 0.0.0-15.20110322
+Requires(post):	self-build-x264 >= 0.0.0-18.20111216
 %elseif %{?_dist_release} == "vl5"
 Requires(post):	self-build-x264 >= 0.0.0-9.20090522
 %endif
@@ -148,7 +148,7 @@ purpose or way of use and take appropriate action.
 %description -l ja
 MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
 またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
-で生できます。
+で生できます。
 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
 は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
 面上で確認できます。
@@ -198,25 +198,22 @@ samba-libsmbclient-devel: SMB ファイルシステムのサポート
 %{__rm} -rf ${RPM_BUILD_ROOT}
 %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-#%{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-#%{__install} -m 644 %{SOURCE12} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE108} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE114} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
-%{__install} -m 644 %{SOURCE150} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
+%{__install} -m 644 \
+    %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
+    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
 
 
 %clean
 %{__rm} -rf ${RPM_BUILD_ROOT}
 
 %posttrans
-## official tarball
-/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
-    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
-    http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
-    635000
-exit 0
+# ## official tarball
+# /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
+#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
+#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
+#     635000
+# exit 0
 
 ## svn checkout
 # set locale
@@ -241,13 +238,9 @@ GetSrc_$LOCALE
 . /etc/self-build.conf
 (cd $TEMP_DIR
 su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
-%__mv %{pkgname}-export-%{svndate}.tar.bz2 %{_datadir}/%{name}/ || exit 1
+%__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
 )
 
-# /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
-#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
-#     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
-#     635000
 /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
     http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
     635000
@@ -257,6 +250,9 @@ su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/d
 %{_datadir}/%{name}
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
+- updated snapshot 20111217 (with ffmpeg 0.9)
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
 - s/self-build-libdvdnav/libdvdnav/
 

+ 4 - 1
nonfree/self-build-vlc/self-build-vlc-vl.spec

@@ -1,7 +1,7 @@
 %define pkgname vlc
 %define name    self-build-%{pkgname}
 %define version 1.1.12
-%define release 2%{?_dist_release}
+%define release 3%{?_dist_release}
 
 %define with_mozilla	 		0
 %define with_dc1394			0
@@ -276,6 +276,9 @@ mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミング
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
+- rebuilt with new x264 and ffmpeg
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
 - s/self-build-libmp4v2/libmp4v2/
 - s/self-build-libdvdnav/libdvdnav/

+ 4 - 1
nonfree/self-build-vlc/vlc-vl.spec

@@ -14,7 +14,7 @@
 Summary:	Multi-platform MPEG, DVD, and DivX player
 Name:		vlc
 Version:	1.1.12
-Release:	2%{?_dist_release}
+Release:	3%{?_dist_release}
 License:	GPLv2+
 Group:		Applications/Multimedia
 URL:		http://www.videolan.org/
@@ -482,6 +482,9 @@ fi || :
 
 
 %changelog
+* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
+- rebuilt with new x264 and ffmpeg
+
 * Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
 - s/self-build-libmp4v2/libmp4v2/
 - s/self-build-libdvdnav/libdvdnav/

+ 17 - 9
nonfree/self-build-x264/self-build-x264-vl.spec

@@ -1,12 +1,14 @@
-%define pkgname x264
-%define name	self-build-%{pkgname}
-%define version 0.0.0
-%define date	20110322
-%define time	2245
-%define release	16.%{date}%{?_dist_release}
+%global snapshot_date	20111216
+%global snapshot_time	2245
+%global branch		stable
+
+%global pkgname 	x264
+%global name		self-build-%{pkgname}
+%global version		0.0.0
+%global release		18.%{snapshot_date}%{?_dist_release}
 
 #define sourceurl0	ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
-%define sourceurl0	http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
+%define sourceurl0	http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
 
 Summary:	Package to automatically build %{pkgname} rpm package
 Summary(ja): 	%{pkgname} の rpm パッケージを自動作成するパッケージ
@@ -21,8 +23,8 @@ Source112:	%{pkgname}-nostrip.patch
 License:	GPLv2+
 Group:		Restricted Software
 
-Obsoletes:      x264 < %{version}
-Obsoletes:      self-build-x264 < %{version}
+Obsoletes:      x264 < %{version}-%{release}
+Obsoletes:      self-build-x264 < %{version}-%{release}
 
 Requires(post):		self-build-setup >= 0.9.9
 
@@ -119,6 +121,12 @@ x264 はスクラッチから書かれた H264/AVC ビデオストリームを
 %{_datadir}/%{name}
 
 %changelog
+* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
+- updated source snapshot 20111216 stable branch (ABI 0.119)
+
+* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
+- updated source snapshot 20111013 stable branch (ABI 0.116)
+
 * Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
 - changed to depend on %%{version} for Obsoletes: x264
 - added BuildArch: noarch

+ 21 - 22
nonfree/self-build-x264/x264-vl.spec

@@ -1,25 +1,22 @@
-%define date 20110322
-%define time 2245
+%global snapshot_date	20111216
+%global snapshot_time	2245
+%global branch		stable
 
 Summary: Library for encoding and decoding H264/AVC video streams
 Name: x264
 Version: 0.0.0
-Release: 16.%{date}%{?_dist_release}
+Release: 18.%{snapshot_date}%{?_dist_release}
 License: GPLv2+
 Group: System Environment/Libraries
 URL: http://www.videolan.org/developers/x264.html
-#Source: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
-Source: http://www.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{date}-%{time}.tar.bz2
-Source1: %{name}.desktop
+Source: http://www.videolan.org/pub/videolan/x264/snapshots/%{name}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}.tar.bz2
 # # don't remove config.h and don't re-run version.sh
 # Patch0: x264-nover.patch
-# link with shared libx264
-Patch1: x264-shared.patch
+# # link with shared libx264
+# Patch1: x264-shared.patch
 # don't strip if configured with --enable-debug
-Patch2: x264-nostrip.patch
-%ifarch x86_64 %{ix86}
+# Patch2: x264-nostrip.patch
 BuildRequires: yasm
-%endif
 # gpac-devel package provided by self-build-gpac
 # in self-build-%{name}.spec as PreReq.
 #BuildRequires: gpac-devel
@@ -43,8 +40,6 @@ Summary: Development files for the x264 library
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 Requires: pkgconfig
-# this package is generated by self-build-%{name}
-Requires: self-build-%{name} = %{version}-%{release}
 
 %description devel
 x264 is a free library for encoding H264/AVC video streams, written from
@@ -53,13 +48,10 @@ scratch.
 This package contains the development files.
 
 %prep
-%setup -q -n %{name}-snapshot-%{date}-%{time}
+%setup -q -n %{name}-snapshot-%{snapshot_date}-%{snapshot_time}%{?branch:-%{branch}}
 # %patch0 -p1 -b .nover
-%patch1 -p1 -b .shared
-%patch2 -p1 -b .nostrip
-# AUTHORS file is in iso-8859-1
-iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
-%__mv -f AUTHORS.utf8 AUTHORS
+# %patch1 -p1 -b .shared
+# %patch2 -p1 -b .nostrip
 
 %build
 ./configure \
@@ -72,6 +64,8 @@ iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
     --extra-cflags="$RPM_OPT_FLAGS" \
     \
     %{?_with_visualize:--enable-visualize} \
+    %{!?_with_libavformat:--disable-lavf} \
+    %{!?_with_ffmpegsource:--disable-ffms} \
     --enable-debug \
     --enable-shared \
     --enable-pic \
@@ -101,21 +95,26 @@ iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
 
 %files devel
 %defattr(644, root, root, 0755)
-%doc doc/*.txt
+%doc doc/*
 %{_includedir}/x264.h
 %{_includedir}/x264_config.h
-%exclude %{_libdir}/libx264.a
 %{_libdir}/libx264.so
 %{_libdir}/pkgconfig/%{name}.pc
 
 
 
 %changelog
+* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-18.20111216
+- updated source snapshot 20111216 stable branch (ABI 0.119)
+
+* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-17.20111013
+- updated source snapshot 20111013 stable branch (ABI 0.116)
+
 * Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
 - change release to sync with self-build-x264
 
 * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
-- updated source snapshot 20110322
+- updated source snapshot 20110322 (ABI 0.114)
 
 * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
 - updated source snapshot 20100625